Naprawianie błędu #ARG! w funkcji SUMA.ILOCZYNÓW

W tym temacie opisano najbardziej typowe scenariusze dotyczące błędu #ARG! podczas pracy z funkcją SUMA.ILOCZYNÓW.

Problem: argumenty tablic nie mają takich samych wymiarów

Wszystkie argumenty tablic powinny mieć te same wymiary. Jeśli tak nie jest, jest zwracany błąd #ARG!. Jeśli na przykład tablica 1 odwołuje się do zakresu 3 wierszy i 2 kolumn, wówczas tablica 2 musi też odwoływać się do podobnego zakresu.

Formuła funkcji SUMA.ILOCZYNÓW, która powoduje błąd, to =SUMA.ILOCZYNÓW(D2:D13;E2:E10) — wartość E10 należy zamienić na E13, aby dopasować ją do pierwszego zakresu.
  • =SUMA.ILOCZYNÓW(D2:D13;E2:E10)

Zakończy się niepowodzeniem, ponieważ zakresy objęte odwołaniem nie mają takiej samej liczby wierszy (13 w pierwszym zakresie, ale tylko 10 w drugim).

Rozwiązanie: zmień formułę na:

  • =SUMA.ILOCZYNÓW(D2:D13;E2:E13)

Aby oba zakresy miały te same numery początkowych i końcowych wierszy, i ponownie sprawdź formułę.

Usuwanie błędu #ARG! w danych w celu usunięcia błędu funkcji SUMA.ILOCZYNÓW

Problem: co najmniej jedna komórka w zakresie zawiera tekst

Jeśli co najmniej jedna komórka w zakresie, którego dotyczy odwołanie, zawiera tekst lub jest sformatowana jako typ danych Tekstowe, zostanie zwrócony błąd #ARG!. Tekst może być wynikiem obliczeń z innej formuły lub być może komórka po prostu nie jest poprawnie sformatowana.

Formuła w komórce E15 pokazuje błąd #ARG!, ponieważ w kolumnie E występuje błąd #ARG!.

Rozwiązanie: Wyszukaj wszystkie komórki, które zawierają tekst lub są sformatowane jako tekst, i ustaw poprawny typ danych.

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG!

SUMA.ILOCZYNÓW, funkcja

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×