Naprawianie błędu #ARG! w funkcjach INDEKS/PODAJ.POZYCJĘ

W tym temacie opisano typowe scenariusze występowania błędów #ARG! w przypadku używania formuł z funkcjami INDEKS i PODAJ.POZYCJĘ. Funkcji INDEKS i PODAJ.POZYCJĘ najczęściej używa się łącznie w celu wyszukania wartości w sytuacji, w której nie można użyć do tego celu funkcji WYSZUKAJ.PIONOWO, na przykład wówczas, gdy szukana wartość ma ponad 255 znaków.

Problem: formuła nie została wprowadzona jako formuła tablicowa

Jeśli korzystasz z funkcji INDEKS jako formuły tablicowej wraz z funkcją PODAJ.POZYCJĘ w celu pobrania wartości, konieczne będzie przekonwertowanie formuły na formułę tablicową — w przeciwnym razie zostanie wyświetlony błąd #ARG!.

Rozwiązanie: należy użyć funkcji INDEKS i PODAJ.POZYCJĘ jako formuły tablicowej, co wymaga naciśnięcia klawiszy CTRL+SHIFT+ENTER. Spowoduje to automatyczne umieszczenie formuły w nawiasach klamrowych {}. Jeśli spróbujesz je wprowadzić samodzielnie, program Excel wyświetli formułę jako tekst.

Jeśli korzystasz z funkcji INDEKS/PODAJ.POZYCJĘ do wyszukania wartości mającej więcej niż 255 znaków, konieczne jest wprowadzenie formuły tablicowej.  Komórka F3 zawiera formułę =INDEKS(B2:B4;PODAJ.POZYCJĘ(PRAWDA;A2:A4=F2;0);0), którą należy wprowadzić, naciskając klawisze Ctrl+Shift+Enter
Funkcji INDEKS i PODAJ.POZYCJĘ należy używać jako formuły tablicowej

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG!

INDEKS, funkcja

PODAJ.POZYCJĘ, funkcja

Wyszukiwanie wartości przy użyciu funkcji WYSZUKAJ.PIONOWO, INDEKS lub PODAJ.POZYCJĘ

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×