Naprawianie błędu #ADR!

Naprawianie błędu #ADR!

Błąd #ADR! pojawia się, gdy formuła zawiera odwołanie do komórki, która nie jest prawidłowa. Najczęściej tak się stanie, gdy zostaną usunięte komórki, do których odwołują się formuły, lub zostanie do nich wklejona zawartość.

Przykład — błąd #ADR! spowodowany przez usunięcie kolumny.

W poniższym przykładzie w kolumnie E jest używana formuła: =SUMA(B2;C2;D2).

Formuła używająca jawnego odwołania do komórki, taka jak =SUMA(B2;C2;D2), może powodować błąd #ADR!, jeśli kolumna zostanie usunięta.

Usunięcie kolumn B, C lub D spowodowałoby błąd #ADR!. W takim przypadku usuniemy kolumnę C (Sprzedaż 2007) i formuła teraz ma postać: =SUMA(B2;#ADR!;C2). Gdy są używane jawne odwołania do komórek, tak jak tutaj (gdy występują odwołania do każdej komórki indywidualnie, rozdzielone średnikami), i nastąpi usunięcie objętego odwołaniem wiersza lub kolumny, program Excel nie może rozwiązać tego problemu i zwraca błąd #ADR!. Jest to podstawowy powód, dla którego używanie w funkcjach jawnych odwołań do komórek nie jest zalecane.

Przykład błędu #ADR! spowodowanego przez usunięcie kolumny.

Rozwiązanie

  • W razie przypadkowego usunięcia wierszy lub kolumn możesz od razu kliknąć przycisk Cofnij na pasku narzędzi Szybki dostęp (lub nacisnąć klawisze CTRL+Z), aby je przywrócić.

  • Dopasuj formułę tak, aby używała odwołania do zakresu, a nie do pojedynczych komórek, jak formuła: =SUMA(B2:D2). Teraz możesz usunąć dowolną kolumnę w zakresie funkcji SUMA, a program Excel automatycznie dostosuje formułę. Możesz również użyć formuły: =SUMA(B2:B5) do obliczenia sumy wierszy.

Przykład — funkcja WYSZUKAJ.PIONOWO z odwołaniami do nieprawidłowego zakresu

W poniższym przykładzie formuła =WYSZUKAJ.PIONOWO(A8;A2:D5;5;FAŁSZ) zwróci błąd #ADR!, ponieważ szuka zwracanej wartości w kolumnie 5, ale zakres odwołania to A:D, a więc obejmuje tylko 4 kolumny.

Przykład formuły WYSZUKAJ.PIONOWO z nieprawidłowym zakresem. Formuła ma postać: =WYSZUKAJ.PIONOWO(A8;A2:D5;5;FAŁSZ). W zakresie funkcji WYSZUKAJ.PIONOWO nie ma kolumny piątej, więc 5 powoduje błąd #ADR!.

Rozwiązanie

Dostosuj zakres, powiększając go, lub zmniejsz wartość odnośnika kolumny, aby był zgodny z zakresem odwołania. =WYSZUKAJ.PIONOWO(A8;A2:E5;5;FAŁSZ) będzie prawidłowym zakresem odwołania, tak jak =WYSZUKAJ.PIONOWO(A8;A2:D5;4;FAŁSZ).

Przykład — funkcja INDEKS z nieprawidłowym odwołaniem do wiersza lub kolumny

W tym przykładzie formuła =INDEKS(B2:E5;5;5) zwraca błąd #ADR!, ponieważ zakres funkcji INDEKS to 4 wiersze na 4 kolumny, ale formuła próbuje zwrócić wartość z piątej kolumny i piątego wiersza.

Przykład formuły INDEKS z odwołaniem do nieprawidłowego zakresu. Formuła ma postać: =INDEKS(B2:E5;5;5), ale zakres to tylko 4 wiersze na 4 kolumny.

Rozwiązanie

Dostosuj odwołania wiersza lub kolumny, aby występowały wewnątrz zakresu wyszukiwania funkcji INDEKS. Formuła =INDEKS(B2:E5;4;4) zwróci prawidłowy wynik.

Przykład — odwołanie do zamkniętego skoroszytu za pomocą funkcji ADR.POŚR

W poniższym przykładzie funkcja ADR.POŚR próbuje odwołać się do skoroszytu, który jest zamknięty, co powoduje błąd #ADR!.

Przykład błędu #ADR! spowodowanego przez odwołanie ADR.POŚR do zamkniętego skoroszytu.

Rozwiązanie

Otwórz skoroszyt, do którego występuje odwołanie.

Problemy dotyczące OLE/DDE

Jeśli używasz linku OLE (Object Linking and Embedding, łączenie i osadzanie obiektów), który zwraca błąd #ADR!, uruchom program, który jest wywoływany tym linkiem.

Uwaga: OLE to technologia, która umożliwia współdzielenie informacji między programami.

Jeśli używasz tematu DDE (Dynamic Data Exchange, dynamiczna wymiana danych), który zwraca błąd #ADR!, upewnij się, że odwołujesz się do poprawnego tematu.

Uwaga: DDE to ustalony protokół wymiany danych między programami systemu Microsoft Windows.

Problemy dotyczące makr

Jeśli makro wprowadza w arkuszu funkcję odwołującą się do komórki powyżej funkcji, a komórka zawierająca tę funkcję znajduje się w wierszu 1, funkcja zwróci wartość błędu #ADR!, ponieważ nad wierszem 1 nie ma komórek. Sprawdź, czy funkcja odwołuje się do komórki lub zakresu komórek, które są nieprawidłowe. Może to wymagać edytowania makra w programie Visual Basic Editor (VBE) w celu uwzględnienia tej sytuacji.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Funkcje programu Excel (alfabetycznie)

Funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×