NR.BŁĘDU, funkcja

Ten artykuł zawiera opis składni formuły i zastosowania funkcji NR.BŁĘDU w programie Microsoft Excel.

Opis

Zwraca liczbę odpowiadającą jednej z wartości błędów w programie Microsoft Excel lub zwraca wartość błędu #N/D!, jeśli nie ma błędów. Funkcja NR.BŁĘDU może być stosowana z funkcją JEŻELI do testowania w poszukiwaniu wartości błędu; zwraca ona ciąg tekstowy, taki jak komunikat, zamiast wartości błędu.

Składnia

NR.BŁĘDU(wartość_błędu)

W składni funkcji NR.BŁĘDU występują następujące argumenty:

  • Wartość_błędu    Argument wymagany. Wartość błędu, której numer identyfikacyjny ma zostać odnaleziony. Chociaż argument wartość_błędu może być rzeczywistą wartością błędu, zwykle jest to odwołanie do komórki zawierającej formułę, która ma zostać przetestowana.

Jeśli argument wartość_błędu wynosi

Funkcja NR.BŁĘDU zwraca

#ZERO!

1

#DZIEL/0!

2

#ARG!

3

#ADR!

4

#NAZWA?

5

#LICZBA!

6

#N/D!

7

#POBIERANIE_DANYCH

8

Wszystkie inne

#N/D!

Przykład

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Dane

#ZERO!

#DZIEL/0!

Formuła

Opis

Wynik

=NR.BŁĘDU(A2)

Numer błędu o wartości #ZERO! (1).

1

=JEŻELI(NR.BŁĘDU(A3)<3;WYBIERZ(NR.BŁĘDU(A3);"Zakresy się nie przecinają";"Dzielnik jest równy 0"))

Sprawdza, czy komórka A3 zawiera wartość błędu #ZERO! lub #DZIEL/0!. Jeśli tak, numer wartości błędu jest używany w funkcji arkusza WYBIERZ w celu wyświetlenia jednego z dwóch komunikatów. W innym przypadku jest wyświetlana wartość błędu #N/D!.

Dzielnik jest równy 0

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×