Makiety elementów interfejsu systemu Windows XP

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Szablon Interfejs użytkownika systemu Windows XP umożliwia tworzenie makiet interfejsu użytkownika za pomocą kształtów zgodnych z zasadami określonymi w systemie Microsoft Windows XP. Są to kształty obejmujące elementy często używane w interfejsach, takie jak pusty formularz stanowiący podstawę okna aplikacji, strony kreatora, kształty menu i pasków narzędzi oraz kształty formantów.

Za pomocą tych kształtów nawiązać wszystko od makiety złożonego okna aplikacji lub okna dialogowego z kartami do prostego okna komunikatu lub jeden przycisk.

Co chcesz zrobić?

Tworzenie okna dialogowego

Tworzenie okna dialogowego z kartami

Tworzenie okna aplikacji

Tworzenie menu i pasków narzędzi

Tworzenie okna dialogowego

  1. Z wzornika Okna i okna dialogowe przeciągnij na stronę rysunku kształt Pusty formularz.

  2. Zaznacz kształt i wpisz tytuł okna dialogowego.

  3. Przeciągnij kształt Przycisk okna na prawy koniec paska tytułu i wybierz typ przycisku. Zazwyczaj są tam umieszczane przyciski Pomoc i Zamknij (ułożone od lewej do prawej).

  4. Dodaj przyciski poleceń, takie jak OK, Anuluj i Zastosuj, umieszczając je w prawym dolnym rogu kształtu Pusty formularz.

    how

    1. Z wzornika Formanty standardowe przeciągnij kształty Przycisk polecenia do prawej dolnej krawędzi kształtu Pusty formularz.

    2. Zaznacz po kolei każdy przycisk i wpisz nazwy formantów.

  5. Przeciągnij odpowiednie formanty na kształt Pusty formularz. Kliknij kształty prawym przyciskiem myszy, aby wybrać odpowiednie opcje.

    Aby uzyskać pomoc dotyczącą określonego kształtu formantu, należy kliknąć kształt prawym przyciskiem myszy, a następnie kliknąć polecenie Pomoc.

    Jeśli za pomocą narzędzia Tekst jest tworzony własny tekst na kształcie Pusty formularz, należy sformatować tekst przy użyciu czcionki Tahoma o wielkości 8 punktów.

  6. Połącz polecenia w logiczne grupy.

  7. Przeciągnij kształty Pole grupy i Linia grupy na kształt Pusty formularz, aby w widoczny sposób oddzielić grupy.

    Należy wyrównać formanty za pomocą narzędzia Prowadnice.

    Okno dialogowe Drukuj w menu Plik jest dobrym przykładem okna dialogowego zawierającego wiele często spotykanych elementów.

Początek strony

Tworzenie okna dialogowego z kartami

  1. Z wzornika Okna i okna dialogowe przeciągnij na stronę rysunku kształt Pusty formularz.

  2. Zaznacz kształt i wpisz nazwę okna dialogowego.

  3. Przeciągnij kształt Przycisk okna na prawy koniec paska tytułu i wybierz typ przycisku. Zazwyczaj są tam umieszczane przyciski Pomoc i Zamknij (ułożone od lewej do prawej).

  4. Dodaj przyciski poleceń, takie jak OK, Anuluj i Zastosuj, umieszczając je w prawym dolnym rogu kształtu Pusty formularz.

    how

    1. Z wzornika Formanty standardowe przeciągnij kształty Przycisk polecenia do prawej dolnej krawędzi kształtu Pusty formularz.

    2. Zaznacz po kolei każdy przycisk i wpisz nazwy formantów.

  5. Przeciągnij kształt Formant karty (treść) na kształt Pusty formularz i zmień jego rozmiar tak, aby mieścił się wewnątrz formularza z uwzględnieniem miejsca dla kart.

  6. Przeciągnij kształt Formant karty (karty) i przyklej go do górnej krawędzi kształtu Formant karty (treść).

  7. Zaznacz kształt Formant karty (karty) i wpisz nazwę karty.

  8. Powtórz kroki 6 i 7 dla każdej karty, przyklejając karty do siebie oraz do kształtu Formant karty (treść).

  9. Kliknij prawym przyciskiem myszy kartę, która ma być na wierzchu, kliknij polecenie Karta pierwszoplanowa, a następnie ustaw dla pozostałych kart opcję Karta drugoplanowa.

  10. Przeciągnij odpowiednie formanty na kształt Pusty formularz. Kliknij kształty prawym przyciskiem myszy, aby wybrać odpowiednie opcje.

    Aby uzyskać pomoc dotyczącą określonego kształtu formantu, należy kliknąć kształt prawym przyciskiem myszy, a następnie kliknąć polecenie Pomoc.

    Jeśli za pomocą narzędzia Tekst jest tworzony własny tekst na kształcie Pusty formularz, należy sformatować tekst przy użyciu czcionki Tahoma o wielkości 8 punktów.

  11. Połącz polecenia w logiczne grupy.

  12. Przeciągnij kształty Pole grupy i Linia grupy na kształt Pusty formularz, aby w widoczny sposób oddzielić grupy.

    Należy wyrównać formanty za pomocą narzędzia Prowadnice.

    Okno dialogowe Ustawienia strony w menu Plik jest dobrym przykładem okna dialogowego zawierającego wiele często spotykanych elementów.

Początek strony

Tworzenie okna aplikacji

  1. Z wzornika Okna i okna dialogowe przeciągnij na stronę rysunku kształt Pusty formularz.

  2. Zaznacz kształt i wpisz tytuł okna aplikacji.

  3. Aby dodać ikonę po lewej stronie tekstu na pasku tytułu, kliknij prawym przyciskiem myszy kształt Pusty formularz i zaznacz pole wyboru Miejsce na ikonę.

  4. Przeciągnij kształt Przycisk okna do prawego końca paska tytułu i wybierz typ przycisku. Zazwyczaj znajdują się tam trzy przyciski: Minimalizuj, Maksymalizuj lub Przywróć oraz Zamknij (ułożone od lewej do prawej).

  5. Z wzornika Paski narzędzi i menu przeciągnij na stronę rysunku kształt Pasek menu, umieść go na kształcie Pusty formularz, przyklej go do dolnej części paska tytułu, a następnie dodaj do niego elementy menu.

    how

    1. Przeciągnij na stronę rysunku kształt Element menu najwyższego poziomu i przyklej go do lewej krawędzi kształtu Pasek menu.

      Po lewej stronie pierwszego elementu menu można umieścić ikonę.

    2. Zaznacz kształt i wpisz nazwę. Jeśli element menu ma skrót klawiaturowy, podkreśl odpowiednią literę.

    3. Powtórz kroki 1 i 2, jeśli jest to konieczne.

      Aby uzyskać pomoc dotyczącą kształtu, należy kliknąć kształt prawym przyciskiem myszy i kliknąć polecenie Pomoc.

      Aby ukryć punkty połączeń Obraz punktu połączenia — niebieski znak X , należy w menu Widok kliknąć polecenie Punkty połączeń.

      Wszystkie elementy w kolumnie powinny mieć szerokość najszerszego elementu.

    Aby wyświetlić kropki uchwytu przy lewej krawędzi paska menu, należy kliknąć kształt prawym przyciskiem myszy i wyczyścić pole wyboru Zablokuj pasek menu.

  6. Z wzornika Paski narzędzi i menu przeciągnij na stronę rysunku kształt Pasek narzędzi, umieść go na kształcie Pusty formularz, przyklej go do dolnej części paska menu, a następnie dodaj przyciski paska narzędzi.

    how

    1. Przeciągnij na stronę rysunku jeden z kształtów Przyciski paska narzędzi i przyklej go do lewej krawędzi kształtu Pasek narzędzi.

    2. W oknie dialogowym Dane kształtu wybierz odpowiedni typ przycisku. Aby później zmienić przycisk, kliknij kształt prawym przyciskiem myszy i kliknij polecenie Ustaw typ przycisku w celu ponownego otwarcia okna dialogowego Dane kształtu.

    3. W razie potrzeby przeciągnij na stronę rysunku więcej kształtów Przyciski paska narzędzi oraz Separator przycisków i przyklej je do siebie.

      Aby uzyskać pomoc dotyczącą kształtu, należy kliknąć kształt prawym przyciskiem myszy i kliknąć polecenie Pomoc.

      Aby ukryć punkty połączeń Obraz punktu połączenia — niebieski znak X , należy w menu Widok kliknąć polecenie Punkty połączeń.

    Aby wyświetlić kropki uchwytu przy lewej krawędzi paska narzędzi, należy kliknąć kształt prawym przyciskiem myszy i wyczyścić pole wyboru Zablokuj pasek narzędzi.

  7. W razie potrzeby przeciągnij na stronę rysunku z wzornika Formanty standardowe poziomy i pionowy pasek przewijania i umieść je na prawej i dolnej krawędzi kształtu Pusty formularz.

  8. Kliknij prawym przyciskiem myszy paski przewijania i wybierz polecenie Ustaw rozmiar przycisku przewijania, aby wskazać zakres przewijania okna.

    Jeśli ma być wyświetlany jedynie niewielki fragment dokumentu, należy ustawić mały rozmiar przycisku przewijania, a jeśli prawie cały dokument — duży rozmiar przycisku przewijania.

  9. Przeciągnij na stronę rysunku kształt Pasek stanu, umieść go na dolnej krawędzi okna aplikacji i odpowiednio sformatuj.

    how

    1. Przeciągnij kształt Linia podziału paska stanu na stronę i przyklej go do uchwytu sterującego kształtu Pasek stanu Uchwyt sterujący .

      Punktami, w których kształt Linia podziału paska stanu jest przyklejany do kształtu Pasek stanu lub do innego kształtu Linia podziału paska stanu, są uchwyty sterujące.

      Jeśli kształt Linia podziału paska stanu jest niewidoczny po przyklejeniu go do kształtu Pasek stanu, należy zaznaczyć kształt Pasek stanu, a następnie w menu Kształt wskazać polecenie Kolejność i kliknąć polecenie Przesuń do tyłu.

    2. Przeciągnij na stronę rysunku kształt Zmiana rozmiaru okna i umieść go na prawej krawędzi paska stanu, oznaczając w ten sposób, że rozmiar okna można zmienić.

Początek strony

Tworzenie menu i pasków narzędzi

Za pomocą kształtów systemu Windows XP można budować proste menu, menu rozwijane i paski narzędzi.

Budowanie menu

  1. Z wzornika Paski narzędzi i menu przeciągnij na stronę rysunku kształt Pasek menu. Aby wyświetlić kropki uchwytu przy lewej krawędzi paska menu, kliknij kształt prawym przyciskiem myszy i wyczyść pole wyboru Zablokuj pasek menu.

  2. Przeciągnij kształt Element menu najwyższego poziomu i przyklej go do lewej krawędzi kształtu Pasek menu.

    Porada : Po lewej stronie pierwszego elementu menu można umieścić ikonę.

  3. Zaznacz kształt i wpisz nazwę. Jeśli element menu ma skrót klawiaturowy, podkreśl odpowiednią literę.

  4. Powtórz kroki 2 i 3, jeśli jest to konieczne.

    Aby uzyskać pomoc dotyczącą kształtu, należy kliknąć kształt prawym przyciskiem myszy i kliknąć polecenie Pomoc.

    Aby ukryć punkty połączeń Obraz punktu połączenia — niebieski znak X , należy w menu Widok kliknąć polecenie Punkty połączeń.

    Wszystkie elementy w kolumnie powinny mieć szerokość najszerszego elementu.

Budowanie menu rozwijanego

  1. Przeciągnij na stronę rysunku kształt Element menu najwyższego poziomu.

  2. Zaznacz kształt i wpisz nazwę. Jeśli element menu ma skrót klawiaturowy, podkreśl odpowiednią literę.

  3. Przeciągnij kształt Element menu rozwijanego i przyklej go u dołu kształtu Element menu najwyższego poziomu, a następnie wpisz nazwę.

  4. Powtórz krok 3 dla wszystkich elementów menu rozwijanego w kolumnie.

  5. Zmień rozmiar wszystkich kształtów Element menu rozwijanego tak, aby miały szerokość najszerszego elementu.

  6. Kliknij prawym przyciskiem myszy każdy kształt Element menu rozwijanego, kliknij polecenie Właściwości elementu menu i zaznacz odpowiednie opcje.

    Aby uzyskać pomoc dotyczącą kształtu, należy kliknąć kształt prawym przyciskiem myszy i kliknąć polecenie Pomoc.

    Aby ukryć punkty połączeń Obraz punktu połączenia — niebieski znak X , należy w menu Widok kliknąć polecenie Punkty połączeń.

Budowanie paska narzędzi

  1. Z wzornika Paski narzędzi i menu przeciągnij na stronę rysunku kształt Pasek narzędzi. Aby wyświetlić kropki uchwytu przy lewej krawędzi paska narzędzi, kliknij kształt prawym przyciskiem myszy i wyczyść pole wyboru Zablokuj pasek narzędzi.

  2. Przeciągnij kształt Przycisk paska narzędzi i przyklej go do lewej krawędzi kształtu Pasek narzędzi.

  3. W oknie dialogowym Dane kształtu wybierz odpowiedni typ przycisku. Aby później zmienić przycisk, kliknij kształt prawym przyciskiem myszy i kliknij polecenie Ustaw typ przycisku w celu ponownego otwarcia okna dialogowego Dane kształtu.

  4. Jeśli jest to konieczne, przeciągnij więcej kształtów Przycisk paska narzędzi i Separator przycisków i przyklej je do siebie.

    Aby uzyskać pomoc dotyczącą kształtu, należy kliknąć kształt prawym przyciskiem myszy i kliknąć polecenie Pomoc.

    Aby ukryć punkty połączeń Obraz punktu połączenia — niebieski znak X , należy w menu Widok kliknąć polecenie Punkty połączeń.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×