LUB, funkcja

Użyj funkcji LUB, jednej z funkcji logicznych, aby sprawdzić, czy któryś z warunków w teście ma wartość PRAWDA.

Przykład

Przykłady użycia funkcji LUB.

Funkcja LUB zwraca wartość PRAWDA, jeśli dowolny z jej argumentów ma wartość PRAWDA, lub FAŁSZ, jeśli wszystkie z jej argumentów mają wartość FAŁSZ.

Typowym zastosowaniem funkcji LUB jest rozszerzenie użyteczności innych funkcji służących do wykonywania testów logicznych. Na przykład funkcja JEŻELI wykonuje test logiczny i zwraca jedną wartość, jeśli wynik testu ma wartość PRAWDA, a inną, jeśli wynikiem testu będzie FAŁSZ. Użycie funkcji LUB jako argumentu test_logiczny funkcji JEŻELI umożliwia testowanie wielu różnych warunków zamiast tylko jednego.

Składnia

LUB(wartość_logiczna1; [wartość_logiczna2]; ...)

W składni funkcji LUB występują następujące argumenty:

Argument

Opis

Wartość_logiczna1

Argument wymagany. Pierwszy warunek do sprawdzenia pod kątem PRAWDA czy FAŁSZ.

Wartość_logiczna2; ...

Argumenty opcjonalne. Dodatkowe warunki do sprawdzenia pod kątem PRAWDA czy FAŁSZ (maksymalnie do 255 warunków).

Uwagi

  • Argumenty muszą być wartościami logicznymi, na przykład PRAWDA lub FAŁSZ, bądź tablicami lub odwołaniami zawierającymi wartości logiczne.

  • Jeśli którykolwiek z argumentów tablicowych lub odwołaniowych zawiera tekst lub puste komórki, wartości te są pomijane.

  • Jeśli określony zakres nie zawiera wartości logicznych, funkcja LUB zwraca wartość błędu #ARG!.

  • Formuły tablicowej funkcji LUB można użyć do sprawdzenia, czy dana wartość występuje w tablicy. Aby wprowadzić formułę tablicową, naciśnij klawisze CTRL+SHIFT+ENTER.

Przykłady

Oto kilka ogólnych przykładów użycia samej funkcji LUB, a także w połączeniu z funkcją JEŻELI.

Przykłady użycia funkcji LUB z funkcją JEŻELI.

Formuła

Opis

=LUB(A2>1;A2<100)

Wyświetla wartość PRAWDA, jeśli wartość w komórce A2 jest większa niż 1 LUB mniejsza niż 100. W przeciwnym razie wyświetla wartość FAŁSZ.

=JEŻELI(LUB(A2>1;A2<100);A3;"Wartość jest spoza zakresu")

Wyświetla wartość znajdującą się w komórce A3, jeśli jest ona większa niż 1 LUB mniejsza niż 100. W przeciwnym razie wyświetla komunikat „Wartość jest spoza zakresu”.

=JEŻELI(LUB(A2<0;A2>50);A2;"Wartość jest spoza zakresu")

Wyświetla wartość w komórce A2, jeśli jest ona mniejsza niż 0 LUB większa niż 50. W przeciwnym razie wyświetla komunikat.

Obliczanie prowizji od sprzedaży

Poniżej przedstawiono dość typowy scenariusz, w którym należy sprawdzić, czy sprzedawcy kwalifikują się do uzyskania prowizji, przy użyciu funkcji JEŻELI i LUB.

Przykład użycia funkcji JEŻELI i LUB w celu obliczenia prowizji od sprzedaży.
  • =JEŻELI(LUB(B14>=$B$4;C14>=$B$5);B14*$B$6;0)JEŻELI wartość łącznej sprzedaży jest większa lub równa (>=) wartości docelowej sprzedaży LUB wartość kont jest większa lub równa (>=) wartości docelowej konta, pomnóż wartość łącznej sprzedaży przez % prowizji. W przeciwnym razie zwróć wartość 0.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Tematy pokrewne

Klip wideo: zaawansowane funkcje JEŻELI
Dowiedz się, jak używać zagnieżdżonych funkcji w formule
JEŻELI, funkcja
ORAZ, funkcja
NIE, funkcja
Omówienie formuł w programie Excel
Jak unikać niepoprawnych formuł
Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów
Skróty klawiaturowe w programie Excel 2016 dla systemu Windows
Skróty klawiaturowe w programie Excel 2016 dla komputerów Mac
Funkcje logiczne (informacje)
Funkcje programu Excel (lista alfabetyczna)
Funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×