Krok 4. Udostępnianie makra innym

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Ważną kwestią, którą należy mieć na uwadze w przypadku udostępniania makr, jest fakt, że są one zapisywane w pliku pakietu Office, więc musisz udostępnić ten plik innym osobom. Jeśli makro zostało utworzone w programie Word, musisz udostępnić ten plik jako szablon programu Word z obsługą makr (dotm) lub dokument programu Word z obsługą makr (docm). Jeśli makro zostało utworzone w programie Excel, musisz udostępnić ten plik jako skoroszyt programu Excel z obsługą makr (xlsm) lub szablon programu Excel z obsługą makr (xltm).

Jeśli makro zostało utworzone w programie Word, musisz wykonać kilka dodatkowych kroków, aby udostępnić makro:

Tworzenie pustego szablonu programu Word

  1. Otwórz nowy dokument programu Word.

  2. W menu Plik kliknij polecenie Zapisz jako.

  3. Nadaj plikowi nazwę globalne_makra.dotm.

  4. Z listy rozwijanej Format wybierz pozycję Szablon programu Word z obsługą makr (dotm) jako Format.

  5. Wybierz lokalizację w swojej sieci, w której chcesz przechowywać plik.

  6. Kliknij przycisk Zapisz i zamknij szablon.

Eksportowanie makra programu Word z dokumentu

Używając makra, które zostało zarejestrowane w Kroku 1, wykonaj kolejne kroki opisane poniżej, aby wyeksportować makro:

  1. Otwórz dokument lub szablon zawierający makro, które chcesz wyeksportować.

  2. W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Makra.

  3. Wybierz makro, które chcesz wyeksportować, a następnie kliknij polecenie Edytuj. Wybieranie makra do wyeksportowania

  4. W Edytorze Visual Basic kliknij polecenie Plik > Eksportuj plik.

  5. Zapisz makro w tym samym folderze co szablon z obsługą makr: globalne_makra.dotm.

Importowanie makra programu Word do nowego pustego szablonu

  1. Otwórz plik globalne_makra.dotm, a następnie kliknij polecenie Narzędzia > Makra > Edytor Visual Basic.

  2. Aby zaimportować makro, kliknij polecenie Plik > Importuj plik, przejdź do folderu, do którego wyeksportowano makro, wybierz odpowiedni plik, a następnie kliknij polecenie Otwórz.

  3. Zapisz moduł, zamknij Edytor Visual Basic, a następnie zamknij program Word.

Teraz możesz udostępnić makro innym osobom i udzielić im poniższych instrukcji dotyczących instalacji makra na ich komputerach.

Instalowanie szablonu: konfigurowanie programu Word w celu używania makra

  1. Umieść plik globalne_makra.dotm w następującej lokalizacji:

    • Program Word 2011 dla komputerów Mac: Macintosh HD: Użytkownicy: Nazwa użytkownika: Biblioteka: Application Support: Microsoft: Office: Szablony użytkownika: Moje szablony

    • Program Word 2003 w systemie Windows lub nowszy: C:\Documents and Settings\nazwa_użytkownika\Application Data\Microsoft\Word\STARTUP

      Uwaga :  Nazwa_użytkownika to nazwa logowania użytkownika.

  2. W programie Word kliknij polecenie Word > Preferencje.

Preferencje programu Word

  1. W sekcji Ustawienia osobiste kliknij polecenie Lokalizacje plików

  2. Wybierz pozycję Autostart z listy Lokalizacje plików, a następnie kliknij przycisk Modyfikuj.

Lokalizacja pliku

  1. Sprawdź, czy program Word korzysta z tego samego folderu z plikiem globalne_makra.dotm co folder autostartu.

  2. Kliknij przycisk Wybierz, aby zamknąć okno dialogowe Wybierz folder, a następnie kliknij przycisk OK, aby zamknąć okno dialogowe Lokalizacje plików.

Ostatnim krokiem jest ustawienie pliku globalne_makra.dotm jako pliku używanego w programie Word podczas jego uruchamiania.

  1. W programie Word kliknij polecenie Narzędzia > Szablony i dodatki.

  2. Zaznacz plik globalne_makra.dotm na liście, a następnie kliknij przycisk OK.

    Porada :  Jeśli nie widzisz szablonu na liście, to plik globalne_makra.dotm nie znajduje się w folderze autostartu programu Word. Wróć do kroku 1 w tej sekcji i upewnij się, że folder określony w polu Autostart jest tym samym folderem co folder, do którego skopiowano plik globalne_makra.dotm.

Konfigurowanie szablonu globalnego w programie Word

 Krok 1. Rozpoczynanie pracy z rejestratorem makr

Krok 2. Analizowanie kodu

Krok 3. Poznawanie podstaw programowania

Krok 4. Udostępnianie makra innym

Krok 5. Praktyczne przykłady

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×