Korzystanie z funkcji SUMA.ILOCZYNÓW do sumowania iloczynów odpowiadających sobie wartości w jednej lub wielu tablicach

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Funkcja SUMA.ILOCZYNÓW korzysta z zakresów komórek (lub tablic) jako argumentów (elementów formuły, które umożliwiają jej funkcjonowanie). Za jej pomocą można pomnożyć elementy w tablicach, a następnie zsumować wyniki.

Niniejszy przykład to lista zakupów. Jedna z tablic zawiera cenę poszczególnych pozycji, a druga — liczbę pozycji do kupienia.

Ceny i ilości do pomnożenia, a następnie zsumowania

  1. Aby utworzyć formułę, wpisz ciąg =SUMA.ILOCZYNÓW(B3:B6,C3:C6), a następnie naciśnij klawisz Enter.

Każda komórka w kolumnie B zostanie pomnożona przez odpowiadającą jej komórkę w kolumnie C, a wyniki zostaną zsumowane. Łączna kwota zakupów wynosi 21,60 zł.

  1. Aby napisać dłuższą formułę, która zawiera ten sam wynik, wpisz = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 i naciśnij klawisz Enter.

Po naciśnięciu klawisza Enter uzyskujemy ten sam wynik: 21,60 USD. Komórka B3 jest mnożona przez komórkę C3, a wynik jest dodawany do wyniku mnożenia komórki B4 przez C4 itd. Nietrudno sobie wyobrazić, o ile łatwiej jest skorzystać z funkcji SUMA.ILOCZYNÓW w przypadku tysięcy (czy nawet setek) wierszy.

Uwagi : 

  • Kolumny lub wiersze (tablice) muszą mieć jednakową długość.

  • Jeśli w komórce znajduje się tekst zamiast wartości liczbowej, przyjmowana jest wartość zerowa.

Przykład

Jeśli chcesz poeksperymentować z funkcją SUMA.ILOCZYNÓW i tablicami, skorzystaj ze skoroszytu aplikacji Excel Online zawierającego inne dane.

Skopiuj przykładowe dane do poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

A

B

G

U

3

4

2

7

8

6

6

7

1

9

5

3

Formuła

Wynik

'=SUMA.ILOCZYNÓW(A2:B4;D2:E4)

=SUMA.ILOCZYNÓW(A2:B4;D2:E4)

Mnoży wszystkie składniki dwóch tablic (A2:B4 i D2:E4) i następnie dodaje iloczyny, czyli 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Aby poznać pełne możliwości funkcji, możesz również otworzyć ten skoroszyt w programie Excel. Wystarczy kliknąć ikonę programu Excel w prawym dolnym rogu skoroszytu  Ikona programu Excel w aplikacji Excel Web App , zapisać plik w dogodnym miejscu na komputerze, a następnie otworzyć plik.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×