Konwertowanie dokumentu programu Word na szablon formularza programu InfoPath

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Za pomocą programu Microsoft Office Word można utworzyć dokument przypominający formularz wyglądem i funkcjami, jednak program Word sprawdza się najlepiej jako program do edycji tekstu, a nie jako program do projektowania formularzy. Projektowanie i wypełnianie formularzy elektronicznych jest natomiast podstawową funkcją programu Microsoft Office InfoPath. Do konwertowania istniejących dokumentów na szablony formularzy programu InfoPath można używać Kreatora importu dostępnego w programie InfoPath. Następnie można stosować specjalne funkcje programu InfoPath do projektowania, publikowania i wypełniania formularzy. Można na przykład użyć formatowanie warunkowe, aby w szablonie formularza raportu sprzedaży automatycznie stosować czerwony kolor tła, gdy wartości sprzedaży spadną poniżej prognozowanych kwot. W tym samym szablonie formularza można także użyć reguła, która umożliwi przesyłanie formularzy opartych na tym szablonie formularza jako załączników wiadomości e-mail po kliknięciu odpowiedniego przycisku. Ponadto będzie można udostępniać szablon formularza większej liczbie użytkowników przez utworzenie szablon formularza obsługiwany w przeglądarce.

Szablon formularza utworzony w wyniku przekonwertowania dokumentu programu Word na szablon formularza programu InfoPath odpowiada układowi dokumentu programu Word. Ponadto elementy dokumentu programu Word, które spełniają pewne warunki, są automatycznie konwertowane na odpowiednie formanty umożliwiające użytkownikom wprowadzanie danych. Jeśli na przykład dokument programu Word zawiera nawiasy wokół ciągu spacji, program InfoPath zakłada, że obszar w nawiasach to pole wprowadzania tekstu i formatuje go jako formant typu pole tekstowe w szablonie formularza. Wszystkie pola formularza programu Word są konwertowane na odpowiednie formanty w programie InfoPath.

Do konwertowania dokumentu programu Word na szablon formularza programu InfoPath służą też ustawienia w oknie dialogowym Opcje importowania.

W tym artykule objaśniono podstawową koncepcję i procedurę konwertowania dokumentu programu Word na szablon formularza programu InfoPath, włącznie z funkcjami i ustawieniami, które nie są obsługiwane przez proces konwersji.

W tym artykule

Konwertowanie dokumentu programu Word na szablon formularza programu InfoPath — informacje

Funkcje i ustawienia programu Word, które nie są całkowicie obsługiwane podczas konwersji

Konwertowanie dokumentu programu Word na szablon formularza programu InfoPath

Zmienianie tabeli układu w tabelę powtarzaną

Zmienianie pól wyboru w grupę przycisków opcji

Przeglądanie problemów z konwersją w okienku zadań Sprawdzanie projektu

Konwertowanie dokumentu programu Word na szablon formularza programu InfoPath — informacje

Podczas konwertowania dokumentu programu Word na szablon formularza programu InfoPath dokument stanowi coś w rodzaju planu tworzenia nowego szablonu formularza. Podstawowa struktura dokumentu jest maksymalnie dokładnie odtwarzana w szablonie formularza. W dokumencie programu Word pole formularza jest miejscem przechowywania danych określonego typu, na przykład nazwy lub adresu. Jeśli pola formularza programu Word mają zostać uwzględnione podczas konwertowania dokumentu, do szablonu formularza programu InfoPath są dodawane formanty typu pole tekstowe, pole wyboru i pole listy rozwijanej w miejscach odpowiadających położeniu tych pól w dokumencie. Ponadto program InfoPath automatycznie wykrywa fragmenty dokumentu programu Word, które mogą dobrze działać jako tabele powtarzane i pola tekstu sformatowanego, i konwertuje je na odpowiednie formanty. Jeśli na przykład raport wydatków zawiera pusty podkreślony obszar, w którym użytkownicy mogą wpisywać notatki dotyczące określonego wydatku, program InfoPath konwertuje ten obszar na pole tekstu sformatowanego. Dzięki temu użytkownicy mogą wpisywać w tym polu wiele wierszy tekstu i formatować go stosownie do potrzeb.

Aby lepiej zrozumieć powiązanie dokumentu programu Word, aby konwertować za pomocą Kreatora importu programu InfoPath i wyniku szablon formularza programu InfoPath, załóżmy, że dla kilku ostatnich lat Twoja organizacja korzystała dokument programu Word o nazwie ExpenseReport.doc do zbierania danych z raportu wydatków pracowników. Dział INFORMATYCZNY chce, aby przekonwertować dokument ten szablon formularza programu InfoPath, aby formularza danych można wysłać jako język XML (Extensible Markup) do płatnych konta systemu.

Użycie Kreatora importu powoduje przekonwertowanie pliku Raport_wydatków.doc na szablon formularza o nazwie Raport_wydatków.xsn. W następującym przykładzie tabelę Szczegóły wydatków z dokumentu programu Word przekonwertowano na tabelę powtarzaną w utworzonym szablonie formularza programu InfoPath. Tabela powtarzana umożliwia użytkownikom odpowiednio wstawianie i usuwanie wydatków przez klikanie poleceń w menu skrótów.

Tabela programu Word przekonwertowana na tabelę powtarzaną programu InfoPath

Kiedy dokument programu Word jest konwertowany na szablon formularza programu InfoPath, jego układ i inne elementy są zachowywane. Domyślnie liczba pustych wierszy w tabeli powtarzanej programu InfoPath odpowiada liczbie pustych wierszy w tabeli programu Word. W szablonie formularza można jednak oszczędzić miejsce przez wyświetlanie domyślnie tylko jednego lub dwóch wierszy.

Nowy szablon formularza zawiera elementy podobne do znajdujących się w dokumencie programu Word, na przykład tabelę do zbierania informacji dotyczących wydatków. Ale w utworzonym szablonie formularza niektóre funkcje mogą być inne, zależnie od ustawień wybranych w Kreatorze importu:

  • Używanie Kreatora importu do importowania dokumentu programu Word wyłącznie z zachowaniem układu    Utworzony szablon formularza zawiera tabelę powtarzaną do wprowadzania elementów wierszy w raporcie wydatków. Wszystkie pola formularza w oryginalnym dokumencie, takie jak pole tekstowe Nazwa, lista rozwijana Dział i pola wyboru Oddział, są jednak odrzucane w tworzonym szablonie formularza.

  • Używanie Kreatora importu do importowania dokumentu programu Word z zachowaniem układu oraz konwertowaniem pól formularza programu Word na formanty (domyślne)    Utworzony szablon formularza zawiera tabelę powtarzaną do wprowadzania elementów wierszy w raporcie wydatków. Wszystkie pola formularza z oryginalnego dokumentu, takie jak pole tekstowe Nazwa, lista rozwijana Dział i pola wyboru Oddział, są konwertowane na odpowiednie formanty programu InfoPath.

  • Używanie Kreatora importu do importowania dokumentu programu Word z zachowaniem układu i konwertowaniem pól formularza na formanty (niestandardowe)    Można zdecydować, które dokładnie pola będą konwertowane podczas importu raportu wydatków. Można na przykład wyłączyć opcję konwertowania pustych komórek tabeli w dokumencie na pola tekstowe w szablonie formularza.

Początek strony

Funkcje i ustawienia programu Word, które nie są całkowicie obsługiwane podczas konwersji

Niektóre ustawienia i opcje formatowania dokumentów programu Word nie są obsługiwane w szablonach formularzy programu InfoPath. W przypadku konwertowania dokumentu programu Word zawierającego takie ustawienia tworzony szablon formularza nie będzie zawierać tych funkcji i ustawień. Jeśli na przykład dokument programu Word zawiera znaczniki poprawek, zostaną one odrzucone w szablonie formularza, ponieważ program InfoPath nie obsługuje tej funkcji.

Wszelkie problemy związane z konwersją można znaleźć za pomocą okienka zadań Sprawdzanie projektu w tryb projektowania. Następnie można wykonać odpowiednie działania, aby usunąć te problemy.

Poniżej umieszczono listę funkcji i ustawień, które nie są zachowywane podczas konwertowania dokumentu programu Word na szablon formularza programu InfoPath. W niektórych przypadkach formatowanie jest odrzucane, ale podstawowy tekst zostaje zachowany. Na przykład w przypadku kolumn w stylu biuletynu program InfoPath odrzuci kolumny, ale zawarty w nich tekst zostanie zaimportowany.

  • Zakładki

  • Tekst animowany

  • Motywy

  • Znaki wodne

  • Numerowanie wierszy

  • Obramowania stron

  • Przypisy dolne i przypisy końcowe

  • Układy kolumn w stylu biuletynu

  • Załączniki plików

  • Obiekty połączone i osadzone, takie jak arkusze programu Microsoft Office Excel i rysunki programu Microsoft Office Visio

  • Obiekty rysunkowe (w tym Autokształty, krzywe, linie i obiekty WordArt)

  • Odstępy między znakami (w tym skalowanie, rozstrzelenie lub zagęszczenie, podniesienie i obniżenie tekstu oraz kerning)

  • Formanty ActiveX

  • Komentarze i prześledzone zmiany (w tym wstawienia, usunięcia i zmiany formatowania)

  • Niektóre funkcje, które są specyficzne dla Microsoft Office Word 2007 (w tym bloków konstrukcyjnych i kontrolki zawartości)

  • Niektóre ustawienia wydruku (w tym mieszane formatowanie znaków w nagłówkach i stopkach, różne parzyste i nieparzyste nagłówki i stopki, inne nagłówki i stopki na pierwszej stronie, ustawienia odstępów, ujemne wartości górnego i dolnego marginesu, różne orientacje strony i indywidualne ustawienia sekcji)

Uwaga : Nie można zmodyfikować niektórych dokumentów programu Word bez użycia hasła. Jeśli jest to wielkość liter w dokumencie, nie można pomyślnie zaimportować do programu InfoPath. Aby rozwiązać ten problem, spróbuj usunąć ochronę hasłem z dokumentu przed zaimportowaniem ich. Ponadto niektórych dokumentów ograniczyć użytkowników do niektórych rodzajów czynności, takie jak wprowadzanie danych w polach formularza do edycji. Jeśli jest to wielkość liter w dokumencie, nie można pomyślnie zaimportować do programu InfoPath. Aby rozwiązać ten problem, spróbuj usunąć ograniczenia edycji w dokumencie, zanim zaimportujesz go.

Poniższa lista zawiera objaśnienia funkcji i ustawień, które są częściowo obsługiwane podczas konwertowania dokumentu programu Word na szablon formularza programu InfoPath:

Tekst pionowy    Program InfoPath zachowuje formatowanie tekstu pionowego zastosowane w dokumencie programu Word, jeśli tekst pionowy znajduje się wewnątrz komórki tabeli. Formatowanie tekstu pionowego jest odrzucane w programie InfoPath podczas konwertowania dokumentu programu Word, jeśli tekst pionowy znajduje się poza komórką tabeli, w innej części dokumentu programu Word.

Pola tekstowe    W dokumentach programu Word pola tekstowe to kontenery na tekst, których rozmiar i położenie na stronie można zmieniać. Jeśli dokument programu Word zawiera pole tekstowe, pole to zostanie przekonwertowane na komórkę tabeli w szablonie formularza. Tekst znajdujący się w polu tekstowym będzie w szablonie formularza wyświetlany w komórce tabeli.

Podkreślenie tekstu    Podkreślenie jest obsługiwane w szablonach formularzy programu InfoPath, ale wszelkie dekoracyjne lub podwójne podkreślenia zastosowane w dokumencie programu Word są konwertowane w szablonie formularza na podkreślenie pojedyncze.

Hiperłącza odwołujące się od nieobsługiwanych protokołów    Wszystkie hiperłącza są konwertowane, ale jeśli hiperłącze używa protokołu innego niż HTTP, HTTPS, FILE, FTP lub MAILTO, to hiperłącze nie będzie działać, kiedy użytkownik kliknie łącze w utworzonym szablonie formularza.

Style znaków i efekty tekstowe    Style formatowania, takie jak indeks górny, indeks dolny i pojedyncze przekreślenie, są zachowywane w procesie konwersji. Pozostałe style formatowania i efekty, w tym zakreślony tekst, tekst ukryty i efekty cieni, są w procesie konwersji odrzucane. Tekst z efektami uwypuklenia i wgłębienia jest konwertowany na szary tekst w szablonie formularza.

Ustawienia sekcji    W programie Word sekcje są używane do urozmaicania układu dokumentu na jednej lub wielu stronach. Program InfoPath nie obsługuje sekcji tego typu i są one odrzucane w procesie konwersji. W tworzonym szablonie formularza programu InfoPath są stosowane wszystkie ustawienia zastosowane do pierwszej sekcji dokumentu programu Word.

Formatowanie nagłówka i stopki    Tekst nagłówka i stopki w dokumencie programu Word jest konwertowany na tekst nagłówka i stopki w szablonie formularza programu InfoPath. Część formatowania znaków może zostać odrzucona w procesie konwersji. Jeśli na przykład w nagłówku dokumentu programu Word użyto pogrubienia i kursywy, program InfoPath stosuje w tworzonym szablonie formularza pierwszy napotkany styl formatowania, a odrzuca pozostałe formatowanie. Podobnie wszelkie ustawienia zastosowane wobec nagłówka lub stopki pierwszej sekcji dokumentu w programie Word są stosowane wobec tekstu nagłówka lub stopki w szablonie formularza programu InfoPath.

Konwersja czcionek    Program InfoPath wprawdzie importuje czcionki z dokumentu programu Word podczas tworzenia nowego szablonu formularza, lecz jeśli czcionki w dokumencie nie są dostępne na komputerze używanym do importowania, dla formularza zostaną automatycznie wybrane czcionki alternatywne.

Ujemne marginesy stron    Ujemny górny i dolny margines jest importowany jako margines o wartości 0.

Ujemne ustawienia marginesów, dopełnienia i wcięć    Ujemne ustawienia marginesów, dopełnienia i wcięć są importowane z wartością 0.

Początek strony

Konwertowanie dokumentu programu Word na szablon formularza programu InfoPath

  1. Jeśli dokument programu Word, który chcesz zaimportować, jest otwarty, zamknij go.

  2. W trybie projektowania kliknij polecenie Importuj formularz w menu Plik.

  3. W Kreatorze importu kliknij opcję Importer programu InfoPath dla dokumentów programu Word, a następnie kliknij przycisk Dalej.

  4. Kliknij przycisk Przeglądaj.

  5. Zlokalizuj i kliknij dokument programu Word, który chcesz przekonwertować, a następnie kliknij przycisk Otwórz.

    Uwaga : W przypadku importowania dokumentu programu Word z ograniczonymi uprawnieniami użytkownik musi dysponować dostępem do tego dokumentu na poziomie pełnej kontroli. Jeśli użytkownik ma tylko dostęp do odczytu lub wprowadzania zmian do dokumentu, próba importu poskutkuje wyświetleniem komunikatu o błędzie.

  6. Aby zmienić domyślne zachowanie importu, kliknij przycisk Opcje, a następnie wybierz odpowiednie opcje.

  7. Kliknij przycisk Zakończ.

Początek strony

Zmienianie tabeli układu w tabelę powtarzaną

Jeśli dokument programu Word zawiera tabelę, program InfoPath może ją przekonwertować na tabela układu lub tabelę powtarzaną w szablonie formularza. Wybrany typ tabeli zależy od decyzji dotyczących projektu podjętych przez użytkownika wobec dokumentu programu Word. Poniższa procedura służy do szybkiego zmieniania przekonwertowanej tabeli układu w tabelę powtarzaną.

Za pomocą tabel powtarzanych zapewniająca użytkownikom dodatkowe możliwości elastyczność podczas wypełniania formularzy. Gdy używasz tabele powtarzające szablonu formularza nie jest pokazanie wiele pustych wierszy po pierwszym otwarciu przez użytkownika. Zamiast tego użytkownicy zazwyczaj wyświetlany tylko jeden wiersz i tylko dodać więcej po i jeśli to konieczne. Można zaoszczędzić miejsce w formularzu, a oferuje dodatkowe stopień personalizacji.

  1. W szablonie formularza kliknij prawym przyciskiem myszy wewnątrz tabeli układu, który chcesz przekonwertować.

  2. W menu skrótów wskaż polecenie Zmień na, a następnie kliknij przycisk Tabela powtarzana.

  3. W oknie dialogowym Zmienianie do tabeli powtarzanej wykonaj co najmniej jedną z następujących czynności:

    • Aby określić wiersze nagłówka tabeli powtarzanej, wprowadź wartość w polu Liczba wierszy do zachowania jako nagłówek tabeli. Wiersz nagłówka jest zazwyczaj używane dla nagłówków kolumn.

    • Aby określić wiersze stopki tabeli powtarzanej, wprowadź wartość w polu Liczba wierszy do zachowania w stopce tabeli. Wiele tabel nie powinno obejmować wiersze stopki.

    • Aby określić liczbę wierszy danych za pomocą, wprowadź wartość w polu Liczba powtarzających się wierszy mają zostać uwzględnione podczas wypełniania formularza. Wiersz danych jest wiersz, który można "powtórzenia" w formularzu tyle razy, stosownie do potrzeb

  4. W menu Wstaw kliknij polecenie Więcej formantów lub naciśnij klawisze ALT + I C.

  5. Wstawianie formantów, które mają w komórkach tabeli.

Początek strony

Zmienianie pól wyboru w grupę przycisków opcji

Jeśli w dokumencie programu Word użyto wielu pól wyboru, program InfoPath importuje je jako pola wyboru do szablonu formularza programu InfoPath. Jeśli lepsze wydaje się zastosowanie grupy przycisków opcji, należy wykonać następujące kroki, aby przekonwertować pola wyboru na przyciski opcji w szablonie formularza.

Korzystając z grupę przycisków opcji na szablon formularza programu Microsoft Office InfoPath gdy użytkownicy mają mieć możliwość wyboru jednej z ograniczonym zestawem opcji.

  1. W szablonie formularza kliknij jedno z pól wyboru, które chcesz przekonwertować, a następnie przytrzymaj naciśnięty klawisz CTRL i kliknij każde dodatkowe pole wyboru, które chcesz przekonwertować.

  2. W menu Edycja wskaż polecenie Zmień na, a następnie kliknij Przycisk opcji.

    Grupę przycisków opcji pojawia się teraz w miejscu pola wyboru w szablonie formularza. Każdy przycisk opcji jest związany z tym samym polem w źródle danych. Gdy użytkownik kliknie przycisk opcji, wartość jest skojarzony z tego przycisku opcji znajduje się w polu.

Początek strony

Przeglądanie problemów z konwersją w okienku zadań Sprawdzanie projektu

Czasami elementy oryginalnego dokumentu programu Word nie są wyświetlane w utworzonym szablonie formularza programu InfoPath zgodnie z oczekiwaniami lub są usuwane w procesie konwersji. Program InfoPath nie obsługuje na przykład funkcji WordArt programu Word i w szablonie formularza zastępuje obiekty WordArt obrazami zastępczymi.

Jeśli program InfoPath wykryje w procesie konwersji problemy, po zamknięciu Kreatora importu jest automatycznie otwierane okienko zadań Sprawdzanie projektu. W tym okienku zadań można przejrzeć listę problemów i podjąć kroki niezbędne do ich rozwiązania.

  1. Jeśli okienko zadań Sprawdzanie projektu jest niewidoczne, kliknij polecenie Sprawdzanie projektu w menu Narzędzia.

    Jeśli występują jakiekolwiek problemy dotyczące szablonu formularza, w okienku zadań zostaną wyświetlone komunikaty.

  2. W okienku zadań Sprawdzanie projektu kliknij tekst komunikatu, który chcesz przejrzeć.

    W oknie dialogowym zostaną wyświetlone dodatkowe informacje o problemie.

    Uwaga : Jeśli dokument programu Word zawiera obiekt nieobsługiwany przez program InfoPath, na przykład obiekt rysunkowy programu Word, to program InfoPath dodaje do tworzonego szablonu formularza obraz zastępczy, wskazujący oryginalną lokalizację obiektu w dokumencie programu Word. Aby uzyskać więcej informacji o danym obiekcie, należy kliknąć prawym przyciskiem myszy obraz zastępczy w szablonie formularza, a następnie kliknąć polecenie Więcej szczegółów w menu skrótów.

  3. Jeśli to konieczne, usuń problem w szablonie formularza. Można na przykład usunąć wszystkie obrazy zastępcze, które nie są przeznaczone do używania w uzupełnionym szablonie formularza.

Uwaga : Może się okazać, że okienko zadań Sprawdzanie projektu zawiera przycisk Odśwież. Klikając przycisk Odśwież nie zaktualizuje wiadomości, które są wyświetlane jako wynik importowania dokumentu programu Word do programu InfoPath. Jeśli chcesz usunąć Importowanie wiadomości w okienku zadań Sprawdzanie projektu, należy otworzyć okno dialogowe Pliki zasobów (menuNarzędzia ), a następnie usuń plik o nazwie ImportErrors.xml. Ten plik jest tworzony automatycznie podczas importowania dokumentu programu Word do programu InfoPath. Po usunięciu pliku ImportErrors.xml, kliknij przycisk Odśwież w okienku zadań Sprawdzanie projektu, aby trwale usunąć wiadomości importu. Plik ImportErrors.xml nie jest wymagane dla szablonu formularza do prawidłowego działania. W rzeczywistości ze względów bezpieczeństwa jest zalecane, aby usunąć ten plik przed opublikowaniem szablonu formularza.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×