Klip wideo: widoki przestawne danych w programie Access

Przeglądarka nie obsługuje klipu wideo. Instalowanie dodatku Microsoft Silverlight, Adobe Flash Player lub programu Internet Explorer 9.

Poza widokiem arkusza danych i widokiem formularza w programie Access dostępne są widoki tabeli przestawnej i wykresu przestawnego, które ułatwiają podsumowywanie i wizualizowanie danych. W tym klipie wideo utworzymy widoki przestawne nowej kwerendy, dodamy widok wykresu przestawnego do formularza, a następnie dodamy ten formularz do formularza nawigacji, co ułatwi użytkownikom bazy danych wyświetlanie wykresu przestawnego.

Uwaga:  Widoki tabeli przestawnej i wykresu przestawnego nie są dostępne w bazach danych sieci Web programu Access. Aby uzyskać więcej informacji na temat baz danych sieci Web, zobacz artykuł Tworzenie bazy danych programu Access udostępnianej w sieci Web.

Zawartość klipu wideo

Omówienie

Włączanie widoków tabeli przestawnej i wykresu przestawnego w formularzu

Tworzenie widoku tabeli przestawnej

Wyświetlanie i dostosowywanie widoku wykresu przestawnego

Ustawianie widoku domyślnego obiektu

Wyświetlanie widoku przestawnego formularza lub raportu

Dodawanie formularza lub raportu do formularza nawigacji

Omówienie

Widoki tabeli przestawnej i wykresu przestawnego można tworzyć dla tabel, formularzy i kwerend. Dane dostępne do wyświetlania w widokach tabeli przestawnej i wykresu przestawnego zależą od obiektu, dla którego widok jest tworzony.

  • Po utworzeniu widoku przestawnego formularza mogą w nim być wyświetlane tylko dane ze źródła rekordów tego formularza.

  • Po utworzeniu widoku przestawnego tabeli mogą w nim być wyświetlane tylko dane z tej tabeli.

  • Tworzenie widoków przestawnych dla kwerend zapewnia największe możliwości, ponieważ kwerendy same w sobie są elastyczne i mogą zawierać dane z wielu tabel.

Włączanie widoków tabeli przestawnej i wykresu przestawnego w formularzu

Widoki tabeli przestawnej i wykresu przestawnego są domyślnie wyłączone dla formularzy. Aby je włączyć, wykonaj następujące czynności:

  1. Kliknij prawym przyciskiem myszy formularz w okienku nawigacji, a następnie kliknij polecenie Widok projektu.

  2. Jeśli arkusz właściwości jeszcze nie jest wyświetlany, naciśnij klawisz F4, aby go wyświetlić.

  3. Na karcie Format arkusza ustaw dla właściwości Allow PivotChart View (Zezwalaj na użycie widoku wykresu przestawnego) i Allow PivotTable View (Zezwalaj na użycie widoku tabeli przestawnej) wartość Tak.

Początek strony

Tworzenie widoku tabeli przestawnej

W tym klipie wideo tworzymy kwerendę, a następnie tworzymy dla niej widoki tabeli przestawnej i wykresu przestawnego. Procedura jest jednak taka sama niezależnie od tego, czy dotyczy kwerendy, formularza, czy tabeli. Widoki można tworzyć w dowolnej kolejności, jednak w tym klipie wideo jako pierwszy zostanie utworzony widok tabeli przestawnej.

  1. W okienku nawigacji kliknij dwukrotnie obiekt, dla którego chcesz utworzyć widoki przestawne.

  2. Na karcie Narzędzia główne kliknij przycisk Widok, a następnie kliknij polecenie Widok tabeli przestawnej.

  3. Jeśli okienko Lista pól tabeli przestawnej nie jest jeszcze widoczne, na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij przycisk Lista pól.

  4. Określ, które pola mają być nagłówkami wierszy w tabeli przestawnej, a następnie przeciągnij je z okienka Lista pól tabeli przestawnej do strefy upuszczania Upuść pola wierszy tutaj.

  5. Określ, które pola mają być nagłówkami kolumn w tabeli przestawnej, a następnie przeciągnij je z okienka Lista pól tabeli przestawnej do strefy upuszczania Upuść pola kolumn tutaj.

  6. Aby można było filtrować dane w określonych polach, przeciągnij te pola z okienka Lista pól tabeli przestawnej do strefy upuszczania Upuść pola filtru tutaj.

  7. Następnie określ, dla którego pola chcesz wyświetlać dane szczegółowe lub dane podsumowania, i przeciągnij je do strefy upuszczania Upuść pola sum lub szczegółów tutaj.

Domyślnie w programie Access są wyświetlane rekordy szczegółów, chyba że zostaną utworzone sumy. Aby utworzyć wiersze i kolumny sum:

  1. W tabeli przestawnej kliknij jedną z wartości szczegółów.

  2. Na karcie Projektowanie w grupie Narzędzia kliknij pozycję Autoobliczanie, a następnie wybierz odpowiedni typ sumy.

Aby ukryć komórki szczegółów i wyświetlać tylko sumy:

  1. Kliknij nagłówek kolumny pola szczegółu. Jeśli na przykład komórki szczegółów są oparte na polu Kwota, kliknij nagłówek kolumny Kwota.

  2. Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij pozycję Ukryj szczegóły.

Aby usunąć pole z tabeli przestawnej:

  • Kliknij nagłówek kolumny lub nagłówek wiersza pola, a następnie na karcie Projektowanie w grupie Aktywne pole kliknij pozycję Usuń pole.

Wyświetlanie i dostosowywanie widoku wykresu przestawnego

Podczas tworzenia widoku tabeli przestawnej tworzony jest również widok wykresu przestawnego. Prawdopodobnie jednak widok wykresu przestawnego trzeba dostosować, aby wyświetlane w nim dane były czytelne. Aby wyświetlić wykres przestawny:

  • Na karcie Narzędzia główne kliknij przycisk Widok, a następnie kliknij polecenie Widok wykresu przestawnego.

Wykres należy dostosować przy użyciu narzędzi na karcie Projektowanie. W tym klipie wideo wykonywane są następujące czynności:

  • Przełączanie nagłówków wierszy i kolumn    Na karcie Projektowanie w grupie Aktywne pole kliknij przycisk Przełącz wiersz/kolumnę.

  • Zmienianie typu wykresu    Na karcie Projektowanie w grupie Typ kliknij przycisk Zmień typ wykresu. Wybierz odpowiedni typ wykresu, a następnie zamknij okno dialogowe Właściwości.

  • Wyświetlanie legendy   Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij pozycję Legenda.

  • Ukrywanie stref upuszczania   Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij pozycję Strefy upuszczania.

  • Formatowanie elementów wykresu    Wykres zawiera takie elementy, jak kolor tła i tytuły osi. Wybierz element wykresu, których chcesz zmienić, a następnie na karcie Projektowanie w grupie Narzędzia kliknij pozycję Arkusz właściwości. Wprowadź odpowiednie zmiany i zamknij okno dialogowe Właściwości.

Początek strony

Ustawianie widoku domyślnego obiektu

Po utworzeniu widoków przestawnych obiektu można tak ustawić właściwość Widok domyślny, aby jeden z tych widoków był wyświetlany zawsze po otwarciu obiektu. Dzięki temu widok przestawny będzie wyświetlany po dodaniu obiektu do formularza lub raportu.

  1. Kliknij prawym przyciskiem myszy obiekt w okienku nawigacji, a następnie kliknij polecenie Widok projektu.

  2. Jeśli arkusz właściwości jeszcze nie jest wyświetlany, naciśnij klawisz F4, aby go wyświetlić.

  3. W przypadku pracy z kwerendą kliknij pusty obszar Konstruktora kwerend, tak aby w arkuszu właściwości była wyświetlana pozycja Właściwości kwerendy.

  4. Ustaw dla właściwości Widok domyślny wartość Tabela przestawna lub Wykres przestawny w zależności od tego, który widok ma być wyświetlany.

Początek strony

Wyświetlanie widoku przestawnego formularza lub raportu

  1. W okienku nawigacji kliknij prawym przyciskiem myszy formularz lub raport, do którego chcesz dodać widok przestawny, a następnie kliknij polecenie Widok układu.

  2. Przeciągnij obiekt zawierający widok przestawny z okienka nawigacji do formularza lub raportu.

Uwaga:  Jeśli widok przestawny nie jest wyświetlany, należy się upewnić, że został ustawiony jako domyślny widok obiektu (zobacz poprzednią sekcję).

  1. Zmień rozmiar widoku przestawnego, aby nadać mu odpowiedni wygląd.

  2. Zapisz i zamknij formularz lub raport.

Początek strony

Dodawanie formularza lub raportu do formularza nawigacji

W tym klipie wideo dodaliśmy do formularza widok wykresu przestawnego, a następnie dodaliśmy ten formularz do utworzonego wcześniej formularza nawigacji. Aby uzyskać więcej informacji o tworzeniu formularza nawigacji, zobacz artykuł Tworzenie formularza nawigacji lub klip wideo Tworzenie formularza nawigacji.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×