Tworzenie raportów

Modyfikowanie i drukowanie raportów

Przeglądarka nie obsługuje klipu wideo. Instalowanie dodatku Microsoft Silverlight, Adobe Flash Player lub programu Internet Explorer 9.

Mimo że raport zawiera wszystkie żądane informacje, może nie odzwierciedlać Twojej osobistej marki. Przed wydrukowaniem i udostępnieniem raportu zmień jego wygląd i dodaj logo.

Porada : Jeśli chcesz dokonać zmiany projektu lub formatu raportu, rozpocznij pracę w widoku Układ. Aby tam przejść z karty Narzędzia główne, wybierz pozycję Widok > Widok układu.

  • Aby zmienić rozmiar pola, zaznacz go, a następnie przeciągnij krawędzie.

    Wycinek ekranu przedstawiający produkt w rocznym raporcie sprzedaży

  • Aby przenieść pole, zaznacz to pole, a następnie przeciągnij je w nowe miejsce. Aby przenieść wiele pól, przytrzymaj naciśnięty klawisz Ctrl podczas zaznaczania pól, które chcesz przenieść, a następnie przeciągnij je w nowe miejsce.

  • Aby dodać wizualny motyw do wszystkich raportów i formularzy w bazie danych, na karcie Projekt wybierz pozycję Motywy. Zatrzymaj wskaźnik nad motywem, aby wyświetlić jego podgląd. Aby zmienić wszystkie kolory i czcionki, wybierz motyw.

  • Aby zmienić styl czcionki dla pola, zaznacz pole, które chcesz zmienić. Następnie na karcie Format wybierz czcionkę, rozmiar czcionki, kolor czcionki i wyrównanie.

  • Aby dodać obraz tła do raportu, na karcie Format wybierz pozycję Obraz tła > Przeglądaj. Następnie przejdź do folderu zawierającego obraz, zaznacz go i wybierz pozycję Otwórz.

Uwaga : Program Access nie zapisuje automatycznie zmian w projekcie, dlatego pamiętaj o zapisaniu swojej pracy. Na pasku narzędzi Szybki dostęp wybierz pozycję Zapisz.

Wyróżnianie danych przy użyciu reguły formatowania warunkowego
  1. Zaznacz pola zawierające dane, które chcesz wyróżnić.
    Aby zaznaczyć wiele elementów, podczas zaznaczania pól lub kontrolek przytrzymaj naciśnięty klawisz Ctrl.

  2. Wybierz pozycję Format > Formatowanie warunkowe.

  3. Wybierz pozycję Nowa reguła i wybierz typ reguły.

  4. W polu Edytuj opis reguły wpisz zakres wartości pól, które chcesz wyróżnić.

    Zrzut ekranu przedstawiający interfejs okna dialogowego Nowa reguła formatowania

  5. Na pasku narzędzi formatowania wybierz styl czcionki i kolor tła, jakie mają zostać zastosowane dla wyróżnionych danych.

  6. Aby zastosować regułę do raportu, wybierz przycisk OK.

Dodawanie logo
  1. Na karcie Projektowanie wybierz pozycję Logo.

  2. Aby dodać obraz w górnej części raportu, przejdź do folderu zawierającego obraz, zaznacz go i wybierz pozycję Otwórz.

    • Aby zmienić rozmiar logo, zaznacz uchwyt obrazu i przeciągaj go, dopóki logo nie będzie miało odpowiedniego rozmiaru.

    • Aby przenieść logo, zaznacz je i przeciągnij w wybrane miejsce.

Wyświetlanie podglądu i drukowanie raportu
  1. Wybierz pozycję Plik > Drukuj > Podgląd wydruku.

    • Aby wyświetlić poszczególne strony raportu, użyj strzałek Strona.

    • Aby wyświetlić większy lub mniejszy podgląd, użyj przycisków Powiększanie.

  2. Aby zmienić marginesy, wybierz pozycję Marginesy i wybierz ich rozmiar.

  3. Gdy uzyskasz pożądany wygląd raportu, wybierz pozycję Drukuj, a następnie określ opcje drukowania. W razie potrzeby zmień drukarkę i wybierz liczbę kopii do wydrukowania.

  4. Aby wydrukować raport, wybierz przycisk OK.

Chcesz wiedzieć więcej?

Wprowadzenie do raportów w programie Access

Szkolenia dotyczące programu Excel

Szkolenia dotyczące programu Outlook

Załóżmy, że został utworzony podstawowy raport bazy danych.

Przedstawia on informacje mniej więcej zgodnie z Twoimi oczekiwaniami.

Chcesz jednak nieco go dostosować, a następnie wydrukować dla innych osób.

Aby rozpocząć wprowadzanie podstawowych zmian, wybierz strzałkę pod przyciskiem Widok, a następnie pozycję Widok układu.

Zmiany projektu i formatowania można wprowadzać zarówno w widoku projektu, jak i w widoku układu, ale zmienianie rozmiaru kontrolek będzie prawdopodobnie łatwiejsze w widoku układu, ponieważ widać w nim dane.

Aby zmienić rozmiar kontrolki, zaznacz ją i przeciągnij krawędzie do momentu uzyskania odpowiedniego rozmiaru.

Zwróć uwagę, że zmiana jednej etykiety kontrolki spowoduje zmianę pozostałych etykiet.

Aby przenieść kontrolkę i jej etykiety, zaznacz je i przeciągnij do nowego położenia.

Aby otworzyć menu kontekstowe i wyświetlić więcej opcji formatowania raportu, zaznacz kontrolkę i naciśnij klawisze Shift+F10 lub kliknij ją prawym przyciskiem myszy.

W tym menu możesz zmienić układ, sposób grupowania lub kolejność sortowania, otworzyć arkusz właściwości i nie tylko.

Aby wyświetlić więcej opcji raportu, wybierz pozycję Właściwości.

Arkusz właściwości zawiera wiele opcji, które można dostosować w raporcie.

Możesz też zmienić wyrównanie tekstu w kontrolce.

Ponieważ program Access nie zapisuje automatycznie zmian w projekcie, na pasku narzędzi Szybki dostęp wybierz pozycję Zapisz.

Doskonałym sposobem na wyróżnienie informacji w raporcie jest użycie reguły formatowania warunkowego.

Załóżmy, że chcesz wyróżnić zamówienia zrealizowane od stycznia do marca 2015 roku.

Po otwarciu raportu w widoku układu zaznacz kontrolki, które chcesz wyróżnić.

Aby zaznaczyć wiele elementów, przytrzymaj wciśnięty klawisz Ctrl i zaznacz odpowiednie kontrolki.

Wybierz pozycję Format, a następnie pozycję Formatowanie warunkowe.

W oknie dialogowym wybierz pozycję Nowa reguła.

Zostawimy typ reguły Sprawdź wartości w bieżącym rekordzie lub użyj wyrażenia.

Drugi typ reguły służy do porównywania wartości przy użyciu pasków danych.

Wpiszemy zakres wartości, które chcemy wyróżnić.

Poniżej określimy format tych wartości.

Będzie to pogrubiony tekst z wybranym kolorem tła.

Tutaj widać, jak będą wyglądać wartości z zastosowanym formatowaniem warunkowym. Wybierz przycisk OK.

Program Access zastosuje regułę do raportu.

Aby raport był bardziej atrakcyjny i czytelny, dostosuj kolor i czcionki.

Po otwarciu raportu w widoku układu wybierz pozycję Projekt, a następnie strzałkę pod przyciskiem Motywy.

Wskaż motyw, aby zobaczyć, jak będzie wyglądać w raporcie.

Gdy znajdziesz odpowiedni motyw, wybierz go. Program Access zastosuje go do raportu.

Jeśli chcesz tylko zmienić kolory, wybierz pozycję Kolory, a następnie wybierz odpowiedni schemat kolorów.

Jeśli chcesz tylko zmienić czcionkę, wybierz pozycję Czcionki, a następnie wybierz czcionkę.

Aby uzyskać jeszcze bardziej profesjonalny wygląd, dodaj do nagłówka raportu logo swojej organizacji lub inny obraz.

Po otwarciu raportu w widoku układu wybierz pozycję Projekt, a następnie przycisk Logo.

Przejdź do pliku obrazu i wybierz przycisk OK.

Program Access doda logo do nagłówka raportu.

Jeśli chcesz, zmień rozmiar logo do wybranych wymiarów.

Możesz przenieść logo w inne miejsce w nagłówku.

Możesz też rozważyć dodanie do raportu obrazu tła, na przykład znaku wodnego z logo lub ze zdjęciem sztandarowego produktu.

Jeśli raport został utworzony za pomocą narzędzia Kreator raportów lub Raport, w nagłówku lub stopce znajduje się dzisiejsza data i numer strony.

Jeśli jednak utworzono raport za pomocą narzędzia Projekt raportu lub Pusty raport, nagłówek i stopka nie są zdefiniowane.

Aby dodać lub zmienić numery stron, wybierz pozycję Projekt, a następnie pozycję Numery stron.

Określ format, położenie i wyrównanie numeru strony.

Aby dodać, zmienić lub usunąć datę w nagłówku lub stopce, wybierz pozycję Data i Godzina.

Określ, czy data lub godzina ma być wyświetlana, a jeśli tak, to w jakim formacie.

Przygotowując raport do druku, sprawdź, czy wszystko wygląda właściwie.

Wybierz pozycję Plik, Drukuj, Podgląd wydruku.

Za pomocą poleceń na karcie Podgląd wydruku dopasuj raport do potrzeb.

Możesz powiększyć lub pomniejszyć raport, aby dokładnie go obejrzeć, lub zmienić marginesy albo orientację strony.

Gdy wygląd raportu będzie zgodny z Twoimi oczekiwaniami, wybierz przycisk Drukuj na karcie Podgląd wydruku.

Dostosuj dowolne opcje w oknie dialogowym Drukowanie, na przykład używaną drukarkę i liczbę kopii. Wybierz przycisk OK.

Program Access wydrukuje raport z wprowadzonymi poprawkami.

Masz teraz czytelny, profesjonalny raport, z którego z łatwością skorzystają inne osoby.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×