Jak unikać niepoprawnych formuł

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Zwracanie niezamierzonych wyników lub błędów przez formuły może być bardzo frustrujące, szczególnie gdy nie wiesz, co masz zrobić w danej sytuacji.

Problemy te mogą mieć wiele różnych przyczyn. Formuła może na przykład zawierać niedopasowane nawiasy, błędy pisowni lub odwołania do danych z nieistniejących zakresów. Poniższe najważniejsze wskazówki pozwalają uniknąć typowych błędów podczas tworzenia formuł lub usunąć te błędy, gdy trzeba poprawić formuły.

Skorzystaj z tej najważniejszej wskazówki:

Aby uniknąć tego typowego błędu:

Każda funkcja rozpoczyna się znakiem równości (=)

Wpis, który nie rozpoczyna się znakiem równości, nie jest formułą i nie będzie obliczany — jest to częsty błąd, który można łatwo popełnić.

Na przykład w przypadku wpisania ciągu SUMA(A1:A10) aplikacja Excel Online wyświetli ciąg tekstowy SUMA(A1:A10), a nie wynik formuły. Wpisanie ciągu 11/2 spowoduje wyświetlenie daty, na przykład 2-lis lub 11/02/2009, a nie podzielenie 11 przez 2.

Aby uniknąć tych nieoczekiwanych wyników, zawsze rozpoczynaj formułę od znaku równości. Na przykład wpisz: =SUMA(A1:A10) i =11/2

Liczba wszystkich nawiasów otwierających i zamykających jest zgodna

Upewnij się, że każdy nawias ma nawias do pary. W formule, w której jest używana funkcja, do prawidłowego działania tej funkcji dla każdego nawiasu otwierającego jest wymagany nawias zamykający.

Przykładowa formuła =JEŻELI(B5<0);"Nieprawidłowe";B5*1,05) nie będzie działać, ponieważ ma dwa nawiasy zamykające, ale tylko jeden otwierający.

Poprawna formuła będzie miała następującą postać: =JEŻELI(B5<0;"Nieprawidłowe";B5*1,05).

Wprowadzono wszystkie wymagane argumenty

W przypadku większości funkcji są wymagane argumenty — wartości, które muszą zostać podane, aby funkcja działała. Tylko kilka funkcji (na przykład PI lub DZIŚ) nie ma żadnych argumentów. Sprawdź składnię formuły wyświetlaną po rozpoczęciu wpisywania znaku równości i nazwy funkcji, aby się upewnić, że wprowadzono wszystkie wymagane argumenty — że nie jest ich zbyt mało ani zbyt wiele.

Na przykład funkcja LITERY.WIELKIE przyjmuje jako argument tylko jeden ciąg tekstowy lub odwołanie do komórki: =LITERY.WIELKIE("halo") lub =LITERY.WIELKIE(C2)

Ponadto niektóre funkcje, na przykład SUMA, wymagają tylko argumentów liczbowych, natomiast inne funkcje, na przykład ZASTĄP, wymagają wartości tekstowej dla co najmniej jednego ze swoich argumentów. W przypadku użycia nieprawidłowego typu danych niektóre funkcje mogą zwrócić nieoczekiwane wyniki lub błąd #ARG!.

Liczby w formułach wprowadzono w postaci niesformatowanej

Nie wprowadzaj w formułach liczb sformatowanych za pomocą znaków dolara ($) lub separatorów tysięcy (,), ponieważ znaki dolara oznaczają odwołania bezwzględne, a przecinki są separatorami argumentów (w przypadku używania angielskich formatów; w formułach utworzonych przy użyciu polskich formatów oczywiście można używać przecinków jako separatorów dziesiętnych). Liczby sformatowane nie są używane w obliczeniach formuł. Zamiast wprowadzać $1,000 w formule, wpisz 1000.

W przypadku użycia liczb sformatowanych w argumentach zostaną zwrócone nieoczekiwane wyniki obliczeń, ale może też zostać zwrócony błąd #LICZBA!. Jeśli na przykład wprowadzisz formułę =MODUŁ.LICZBY(-2 134) w celu znalezienia wartości bezwzględnej liczby -2134, aplikacja Excel Online zwróci błąd #LICZBA!, ponieważ funkcja MODUŁ.LICZBY akceptuje tylko pojedyncze argumenty liczbowe bez spacji.

Po wprowadzeniu formuły przy użyciu niesformatowanych liczb wynik jej można sformatować za pomocą separatorów tysięcy i symbolów waluty przez zastosowanie formatu liczby.

Użyto odpowiedniego typu danych komórki

Formuła może zwrócić nieoczekiwane wyniki, jeśli w obliczeniach nie można użyć typu danych komórki.

Jeśli na przykład w komórce sformatowanej jako tekst wpiszesz prostą formułę =2+3, aplikacja Excel Online nie będzie mogła obliczyć wprowadzonych danych. W komórce będzie widoczna wartość =2+3.

Aby rozwiązać ten problem, zmień typ danych komórki z Tekstowe na Ogólne w następujący sposób:

  1. Zaznacz komórkę.

  2. Kliknij pozycję Narzędzia główne > Format liczb i wybierz pozycję Ogólne.

  3. Naciśnij klawisz F2, aby przełączyć komórkę w tryb edycji, i naciśnij klawisz ENTER, aby zaakceptować formułę.

Data wprowadzona w komórce, która ma typ danych Liczbowe, będzie wyświetlana nie jako data, ale jako liczbowa wartość daty. Aby wyświetlić tę liczbę jako datę, w galerii Format liczby wybierz pozycję Data.

Do mnożenia liczb użyto symbolu *

Jako operatora mnożenia w formule czasami odruchowo chcesz użyć znaku x. Zamiast niego należy jednak używać gwiazdki (*).

Gdy użyjesz znaku x w formule, aplikacja Excel Online nie może obliczyć wyniku i zamiast niego wyświetla formułę w komórce, umieszczając wokół niej czerwone obramowanie kropkowane, aby poinformować, że formuła zawiera błąd.

Użyto cudzysłowów wokół tekstu w formułach

W formule zawierającej tekst umieść ten tekst w cudzysłowie.

Na przykład formuła ="Dzisiaj jest " & TEKST(DZIŚ(),"dddd; dd mmmm") łączy tekst "Dzisiaj jest " z wynikami funkcji TEKST i DZIŚ i zwraca w komórce wynik Dzisiaj jest poniedziałek, 30 maj.

W formule tekst „Dzisiaj jest ” zawiera spację przed cudzysłowem zamykającym w celu umieszczenia odstępu między wyrazami Dzisiaj jest i poniedziałek, 30 maja. Ta formuła bez cudzysłowów wokół tekstu zwróci błąd #NAZWA?.

W formule nie użyto więcej niż 64 zagnieżdżonych funkcji

W obrębie formuły można połączyć (zagnieździć) maksymalnie 64 poziomy funkcji.

Na przykład formuła =JEŻELI(PIERWIASTEK(PI())<2;"Mniej niż dwa";"Więcej niż dwa") zawiera 3 poziomy funkcji: funkcję PI zagnieżdżoną w funkcji PIERWIASTEK, która z kolei jest zagnieżdżona w funkcji JEŻELI.

Nie dzielono wartości liczbowych przez zero

Podzielenie komórki przez inną komórkę zawierającą wartość zero (0) lub niezawierającą żadnej wartości powoduje zwrócenie błędu #DZIEL/0!.

Aby uniknąć tego błędu, zagnieźdź swoje operacje dzielenia w funkcji JEŻELI.BŁĄD. Na przykład można wprowadzić do komórek arkusza dwie następujące formuły:

=JEŻELI.BŁĄD(3/0;0)

=JEŻELI.BŁĄD(3/7;0)

W przypadku pierwszej formuły zwrócone zostanie 0, ponieważ funkcja JEŻELI.BŁĄD rozpozna, że dzielenie przez zero powoduje błąd. W przypadku drugiej formuły zwrócona zostanie wartość 3/7 — błędu nie ma, ponieważ dzielenie przez zero nie występuje.

Aby dowiedzieć się więcej na temat tworzenia formuł, zapoznaj się z tymi poradami i wskazówkami dotyczącymi formuł.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×