Jak poprawiać błędy formuł w programie Excel 2016 dla komputerów Mac

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Poniższe informacje mogą pomóc w poprawieniu błędu, jeśli na przykład wystąpi błąd #ARG!, #NAZWA? albo problem z funkcją WYSZUKAJ.PIONOWO.

Funkcja WYSZUKAJ.PIONOWO

Jeśli funkcja WYSZUKAJ.PIONOWO zwróci błędy lub nieoczekiwane wyniki, pobierz podręczną kartę informacyjną z poradami dotyczącymi rozwiązywania problemów z funkcją WYSZUKAJ.PIONOWO.

Błąd #ARG!

Przyczyną tego problemu jest zwykle łączenie wartości liczbowych z wartościami tekstowymi. Aby uzyskać więcej informacji, zobacz Naprawianie błędu #ARG!.

Błąd #NAZWA?

Upewnij się, że nazwy zostały wpisane poprawnie, ujmij wszelki tekst w cudzysłów lub ujmij nazwy arkuszy w pojedynczy cudzysłów ('). Aby poznać inne przyczyny i rozwiązania, zobacz Błąd #NAZWA?.

Błąd #LICZBA!

Ten błąd może wystąpić, jeśli wpisano dodatkowe znaki w formule. Na przykład nie należy wpisywać ciągu 1000 zł w formule. Zamiast tego należy wprowadzić ciąg 1000. Aby poznać inne przyczyny i rozwiązania, zobacz Naprawianie błędu #LICZBA!.

Błąd #N/D!

Jeśli formuła nie może odnaleźć wartości, której dotyczy odwołanie, zwraca błąd #N/D!. Aby uzyskać więcej informacji, zobacz Naprawianie błędu #N/D!.

Błąd #ADR!

Program Excel wyświetla ten błąd, gdy formuła zawiera nieprawidłowe odwołanie do komórki. Aby uzyskać więcej informacji, zobacz Naprawianie błędu #ADR!.

Błąd #DZIEL/0!

Ten błąd występuje, gdy liczba jest dzielona przez zero (0) albo gdy formuła odwołuje się do komórki zawierającej liczbę 0 lub pustej. Aby uzyskać więcej informacji, zobacz Błąd #DZIEL/0!.

Odwoływanie się do innych arkuszy i skoroszytów

Jeśli odwołujesz się do nazwy innego arkusza, wpisz ! po nazwie, a następnie wpisz komórkę lub zakres. Jeśli nazwa arkusza zawiera spacje, ujmij nazwę w pojedynczy cudzysłów. Na przykład: =SUMA('Raport sprzedaży'!A1:A8).

Przy odwoływaniu się do innego skoroszytu zewnętrznego:

  • Ujmij nazwę skoroszytu w nawiasy kwadratowe [ ].

  • Wpisz pełną ścieżkę pliku.

  • Ujmij ścieżkę w pojedynczy cudzysłów (ten znak wstaw na początku ścieżki i po nazwie skoroszytu, przed wykrzyknikiem).

    Przykład: =SUMA('/Użytkownicy/Twoja_nazwa/Pulpit/[Operacje kw2.xlsx]Sprzedaż'!A1:A8)

Inne szybkie rozwiązania, które mogą pomóc

  • Rozpocznij każdą formułę od znaku równości (=). Przykład: =SUMA(A1:A8)

  • Do mnożenia liczb użyj symbolu *, a nie symbolu X. Przykład: =A1*A8

  • Dopasuj wszystkie nawiasy otwierające i zamykające tak, aby występowały w parach. W tym przykładzie występują dwie pary: = JEŻELI(40>50;SUMA(G2:G5);0)

  • Wprowadź wszystkie wymagane argumenty. Może w tym pomóc konstruktor formuł. Aby wyświetlić konstruktora formuł, zacznij wpisywać formułę zawierającą nazwę funkcji, a następnie naciśnij klawisze CONTROL + A.

  • Ujmij tekst w formułach w cudzysłowy. Przykład: =JEŻELI(A2>B2;"Budżet przekroczony";"OK")

  • Zmień typ danych komórki, której dotyczy odwołanie. Naciśnij klawisze COMMAND + 1, a następnie wybierz pozycję Liczba.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×