Jak naprawić błąd #N/D!

Jak naprawić błąd #N/D!

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Błąd #N/D! informuje o tym, że formuła nie może znaleźć szukanego elementu.

Najlepsze rozwiązanie

Najczęstszą przyczyną błędu #N/D! podczas używania funkcji WYSZUKAJ.PIONOWO, WYSZUKAJ.POZIOMO, WYSZUKAJ czy PODAJ.POZYCJĘ jest to, że formuła nie może znaleźć wartości, której dotyczy odwołanie. Na przykład wartość odnośnika nie istnieje w danych źródłowych.

Szukana wartość nie istnieje. Formuła w komórce E2 to =WYSZUKAJ.PIONOWO(D2;$D$6:$E$8;2;FAŁSZ). Nie można odnaleźć wartości „Banan”, więc formuła zwraca błąd #N/D!.
Nie znaleziono elementu w danych źródłowych

W tym przypadku w tabeli odnośników nie ma pozycji „Banan”, więc funkcja WYSZUKAJ.PIONOWO zwraca błąd #N/D!.

Rozwiązanie: Upewnij się, że wartość odnośnika istnieje w danych źródłowych albo użyj w formule funkcji obsługi błędów, takiej jak JEŻELI.BŁĄD. Na przykład =JEŻELI.BŁĄD(FORMUŁA();0), co oznacza:

  • = JEŻELI(wynikiem formuły jest błąd, wyświetl 0, w innym przypadku wyświetl wynik formuły)

Możesz użyć “”, aby nic nie wyświetlać, lub wstawić swój własny tekst: =JEŻELI.BŁĄD(FORMUŁA(),”tekst komunikatu o błędzie”)

Jeśli nie masz pewności, co należy zrobić w tym momencie lub jakiej pomocy potrzebujesz, możesz wyszukać podobne pytania na forum społeczności programu Excel lub zadać własne.

Link do forum społeczności programu Excel

Jeśli chcesz ruszyć z miejsca, poniższa lista kontrolna zawiera kroki rozwiązywania problemów umożliwiające zidentyfikowanie prawdopodobnego błędu w formułach.

Wartość odnośnika i dane źródłowe to różne typy danych. Na przykład próbujesz odwołać się do wartości liczbowej przy użyciu funkcji WYSZUKAJ.PIONOWO, ale dane źródłowe są przechowywane jako tekst.

Niepoprawne typy wartości. Przykład użycia formuły WYSZUKAJ.PIONOWO powodującego błąd #N/D!, ponieważ odnośnik elementu został sformatowany jako liczba, a tabela odnośników została sformatowana jako tekst.
Błąd #N/D! spowodowany przez różne typy danych

Rozwiązanie: Upewnij się, że typy danych są takie same. Możesz sprawdzić formaty komórek, zaznaczając komórkę lub zakres komórek, klikając prawym przyciskiem myszy i wybierając kolejno pozycję Formatuj komórki > Liczbowe (lub naciskając klawisze Ctrl+1), i w razie potrzeby zmienić format liczb.

Okno dialogowe Formatowanie komórek z wyświetloną kartą Liczby i wybraną opcją Tekst.

Porada : Jeśli chcesz wymusić zmianę formatu w całej kolumnie, najpierw zastosuj odpowiedni format, a następnie wybierz pozycję Dane > Tekst jako kolumny > Zakończ.

Przy użyciu funkcji USUŃ.ZBĘDNE.ODSTĘPY możesz usunąć wszystkie spacje początkowe i końcowe. W poniższym przykładzie użyto funkcji USUŃ.ZBĘDNE.ODSTĘPY zagnieżdżonej wewnątrz funkcji WYSZUKAJ.PIONOWO w celu usunięcia spacji początkowych sprzed imion w komórkach A2:A7 i zwrócenia nazwy działu.

Używanie funkcji WYSZUKAJ.PIONOWO oraz USUŃ.ZBĘDNE.ODSTĘPY w formule tablicowej do usuwania spacji wiodących lub końcowych. Formuła w komórce E3 to {=WYSZUKAJ.PIONOWO(D2;USUŃ.ZBĘDNE.ODSTĘPY(A2:B7);2;FAŁSZ)}. Musi ona zostać wprowadzona przez naciśnięcie klawiszy CTRL+SHIFT+ENTER.

{=WYSZUKAJ.PIONOWO(D2;USUŃ.ZBĘDNE.ODSTĘPY(A2:B7);2;FAŁSZ)}

Uwaga : To jest formuła tablicowa i należy ją wprowadzić przy użyciu klawiszy Ctrl+Shift+Enter. Program Excel automatycznie umieści formułę w nawiasach klamrowych {}. Jeśli spróbujesz je wprowadzić samodzielnie, program Excel wyświetli formułę jako tekst.

Domyślnie funkcje, które wyszukują informacje w tabelach, muszą być posortowane w kolejności rosnącej. Jednak funkcje arkusza WYSZUKAJ.PIONOWO i WYSZUKAJ.POZIOMO zawierają argument przeszukiwany_zakres, który nakazuje funkcji znalezienie dokładnego dopasowania nawet wtedy, gdy tabela nie jest posortowana. Aby znaleźć dokładne dopasowanie, dla argumentu przeszukiwany_zakres ustaw wartość FAŁSZ. Pamiętaj, że użycie wartości PRAWDA, która nakazuje funkcji wyszukanie przybliżonego dopasowania, może nie tylko powodować występowanie błędu #N/D!, ale również zwracać błędne wyniki, jak widać w następującym przykładzie.

Przykład użycia funkcji WYSZUKAJ.PIONOWO z argumentem przeszukiwany_zakres o wartości PRAWDA, co może powodować błędne wyniki.
Działanie funkcji WYSZUKAJ.PIONOWO nie powiodło się, ponieważ użyto przybliżonego dopasowania w nieposortowanej tabeli

W tym przykładzie pozycja „Banan” nie tylko zwraca błąd #N/D!, ale pozycja „Gruszka” zwraca błędną cenę. Jest to spowodowane użyciem argumentu PRAWDA, który nakazuje funkcji WYSZUKAJ.PIONOWO wyszukanie przybliżonego dopasowania zamiast dokładnego dopasowania. Bliskie dopasowanie dla pozycji „Banan” nie istnieje, a pozycja „Gruszka” znajduje się przed pozycją „Brzoskwinia” w kolejności alfabetycznej. W tym przypadku użycie funkcji WYSZUKAJ.PIONOWO z argumentem FAŁSZ zwróciłoby prawidłową cenę pozycji „Gruszka”, ale pozycja „Banan” nadal zwróciłaby błąd #N/D!, ponieważ na liście odnośników nie znajduje się odpowiednia pozycja „Banan”.

Jeśli używasz funkcji PODAJ.POZYCJĘ, spróbuj zmienić wartość argumentu typ_porównania, aby określić kolejność sortowania tabeli. Aby znaleźć dokładne dopasowanie, dla argumentu typ_porównania ustaw wartość 0 (zero).

Aby naprawić ten problem, upewnij się, że zakres, do którego odwołuje się formuła tablicowa, ma taką samą liczbę wierszy i kolumn, jak zakres komórek, w którym wprowadzono formułę tablicową, lub wprowadź formułę tablicową do większej lub mniejszej liczby komórek, aby ich liczba odpowiadała zakresowi, do którego odwołuje się formuła.

W tym przykładzie komórka E2 odwołała się do niedopasowanych zakresów:

Przykład formuły tablicowej z odwołaniami do niedopasowanych zakresów, czego skutkiem jest wystąpienie błędu #N/D!. Formuła w komórce E2 to {=SUMA(JEŻELI(A2:A11=D2;B2:B5))}. Musi ona zostać wprowadzona przez naciśnięcie klawiszy CTRL+SHIFT+ENTER.

{= SUMA(JEŻELI(A2:A11=D2;B2:B5))}

Aby formuła poprawnie dokonywała obliczeń, należy wprowadzić zmiany, tak aby oba zakresy odzwierciedlały wiersze 2–11.

{=SUMA(JEŻELI(A2:A11=D2;B2:B11))}

Uwaga : To jest formuła tablicowa i należy ją wprowadzić przy użyciu klawiszy Ctrl+Shift+Enter. Program Excel automatycznie umieści formułę w nawiasach klamrowych {}. Jeśli spróbujesz je wprowadzić samodzielnie, program Excel wyświetli formułę jako tekst.

Przykład błędu #N/D! wprowadzonego do komórek, co uniemożliwia poprawne obliczenie formuły SUMA.

W tym przypadku pozycje Maj–Grudzień mają wartości #N/D!, więc nie można obliczyć sumy i zamiast niej zwracany jest błąd #N/D!.

Aby rozwiązać ten problem, sprawdź składnię użytej funkcji i wprowadź wszystkie wymagane argumenty w formule, która zwraca błąd. W celu sprawdzenia funkcji konieczne może być przejście do Edytora Visual Basic (VBE, Visual Basic Editor). Dostęp do VBE możesz uzyskać z karty Deweloper lub przy użyciu klawiszy ALT+F11.

Aby rozwiązać ten problem, upewnij się, że skoroszyt zawierający funkcję zdefiniowaną przez użytkownika jest otwarty, a funkcja działa poprawnie.

Aby rozwiązać ten problem, upewnij się, że argumenty funkcji są poprawne i znajdują się we właściwych miejscach.

Aby rozwiązać ten problem, naciśnij klawisze Ctr+Alt+F9 w celu ponownego obliczenia arkusza.

Jeśli nie masz pewności co do właściwych argumentów, możesz skorzystać z Kreatora funkcji. Zaznacz komórkę zawierającą odpowiednią formułę, a następnie przejdź do karty Formuły na Wstążce i naciśnij pozycję Wstaw funkcję.

Przycisk Wstaw funkcję.

Program Excel automatycznie załaduje Kreatora.

Przykład okna dialogowego Kreator formuły.

Gdy klikniesz poszczególne argumenty, program Excel przedstawi odpowiednie informacje dotyczące każdego z nich.

Wartość #N/D! może być przydatna. Zwykle wartość #N/D! jest używana podczas pracy nad danymi w wykresach, jak w następującym przykładzie, ponieważ wartości #N/D! nie są przedstawiane na wykresie. Oto przykłady jak wygląda wykres z wartościami 0, a jak z #N/D!.

Przykład wykresu liniowego przedstawiającego wartości 0.

W poprzednim przykładzie wartości 0 są przedstawione jako płaska linia w dolnej części wykresu, która następnie nagle rośnie, przedstawiając sumę. W poniższym przykładzie wartości 0 zastąpiono #N/D!.

Przykład wykresu liniowego nieprzedstawiającego wartości #N/D!.

Aby uzyskać więcej informacji na temat błędu #N/D! wyświetlanego w przypadku użycia konkretnej funkcji, zapoznaj się z poniższymi tematami:

Początek strony

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Zobacz też

Konwertowanie liczb przechowywanych jako tekst na liczby

Wyszukaj.pionowo

Wyszukaj.poziomo, funkcja

Wyszukaj, funkcja

Podaj.pozycję, funkcja

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Używanie funkcji błędów sprawdzania wykrywanie błędów w formułach

Skróty klawiaturowe w programie Excel dla systemu Windows

Skróty klawiaturowe w programie Excel dla komputerów Mac

Funkcje wszystkich programu Excel (lista alfabetyczna)

Funkcje wszystkich programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×