Jak naprawić błąd #ARG! w funkcji LICZ.JEŻELI/LICZ.WARUNKI

W tym temacie wymieniono najbardziej typowe przyczyny błędu #ARG! w przypadku funkcji LICZ.JEŻELI oraz LICZ.WARUNKI.

Problem: formuła odwołuje się do komórek w zamkniętym skoroszycie

Funkcje LICZ.JEŻELI oraz LICZ.WARUNKI odwołujące się do komórki lub zakresu w zamkniętym skoroszycie zwrócą błąd #ARG!.

Uwaga: Jest to znany problem dotyczący też kilku innych funkcji programu Excel, takich jak między innymi SUMA.JEŻELI, SUMA.WARUNKÓW oraz LICZ.PUSTE. Aby uzyskać więcej informacji, zobacz Funkcje SUMA.JEŻELI, LICZ.JEŻELI i LICZ.PUSTE zwracają błąd #ARG!.

Rozwiązanie: Otwórz połączony skoroszyt wskazany w formule i naciśnij klawisz F9, aby odświeżyć formułę.

Ten problem można też objeść przy użyciu połączenia funkcji SUMA i JEŻELI w formule tablicowej. Aby uzyskać więcej informacji, zobacz Funkcje SUMA.JEŻELI, LICZ.JEŻELI i LICZ.PUSTE zwracają błąd #ARG!.

Problem: ciąg ma więcej niż 255 znaków

Rozwiązanie: Skróć ciąg, jeśli to możliwe. Jeśli nie można go skrócić, podziel tę wartość na wiele ciągów za pomocą funkcji ZŁĄCZ.TEKSTY lub operatora &. Na przykład:

  • =LICZ.JEŻELI(B2:B12;"długi ciąg"&"inny długi ciąg")

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG!

LICZ.JEŻELI, funkcja

LICZ.WARUNKI, funkcja

Funkcja JEŻELI — unikanie pułapek związanych z formułami zagnieżdżonymi

Zobacz klip wideo: zaawansowane funkcje JEŻELI

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×