Jak naprawić błąd #ARG! w funkcjach ŚREDNIA i SUMA

Jeśli funkcja ŚREDNIA lub SUMA odwołuje się do komórek zawierających błędy #ARG!, formuła zwróci błąd #ARG!.

Błąd #ARG! w funkcji ŚREDNIA

W celu pominięcia tych wartości błędów skonstruowaliśmy formułę, która ignoruje błędy w zakresie odwołania podczas obliczania średniej z pozostałych „normalnych” wartości.

Aby obejść ten scenariusz, można użyć połączenia funkcji ŚREDNIA i JEŻELI oraz funkcji CZY.BŁĄD w celu ustalenia, czy w określonym zakresie występuje błąd. W tym konkretnym scenariuszu wymagana jest formuła tablicowa:

=ŚREDNIA(JEŻELI(CZY.BŁĄD(B2:D2);"";B2:D2))

Uwaga : Jest to formuła tablicowa, którą należy wprowadzić za pomocą klawiszy CTRL+SHIFT+ENTER. Program Excel automatycznie otoczy formułę nawiasami klamrowymi {}. Jeśli spróbujesz je wprowadzić samodzielnie, program Excel wyświetli formułę jako tekst.

Funkcja tablicowa w funkcji ŚREDNIA na potrzeby naprawienia błędu #ARG!

Uwaga : Powyższa funkcja zadziała nie tylko w przypadku błędu #ARG!, ale też w przypadku błędów #N/D, #ZERO, #DZIEL/0! i innych.

W ten sam sposób można też używać funkcji SUMA:

=SUMA(JEŻELI(CZY.BŁĄD(B2:D2);"";B2:D2))

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG!

ŚREDNIA, funkcja

SUMA, funkcja

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×