JEŻELI, funkcja

Użyj funkcji JEŻELI, jednej z funkcji logicznych, aby zwrócić jedną wartość, jeśli warunek jest prawdziwy, lub inną wartość, jeśli jest fałszywy.

Składnia

JEŻELI(test_logiczny;wartość_jeżeli_prawda;[wartość_jeżeli_fałsz])

Na przykład:

  • =JEŻELI(A2>B2;"Budżet przekroczony";"OK")

  • =JEŻELI(A4=500;B4-A4;"")

Nazwa argumentu

Opis

test_logiczny    (wymagane)

Warunek, który ma zostać sprawdzony.

wartość_jeżeli_prawda    (wymagane)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość PRAWDA.

wartość_jeżeli_fałsz    (opcjonalne)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość FAŁSZ.

Przykłady

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby wyświetlić formułę w komórce formuły, zaznacz komórkę i naciśnij klawisz F2.

Wydatki rzeczywiste

Wydatki przewidywane

1500 zł

900 zł

500 zł

900 zł

500 zł

925 zł

=JEŻELI(A2>B2;"Budżet przekroczony";"OK")

Ponieważ wydatki rzeczywiste o wartości 1500 zł (A2) przekroczyły wydatki przewidywane o wartości 900 zł (B2), jest zwracany wynik Budżet przekroczony.

=JEŻELI(A2<B2;PRAWDA;JEŻELI(A3>B3;"Budżet przekroczony";"OK"))

Wynik pierwszej funkcji JEŻELI to FAŁSZ. Dlatego jest obliczana druga instrukcja JEŻELI, a ponieważ jej wynik to również FAŁSZ, zwracany jest wynik OK.

=JEŻELI(A4=500;B4-A4;"")

Ponieważ komórka A4 zawiera liczbę 500, wydatki rzeczywiste o wartości 500 zł są odejmowane od wydatków przewidywanych o wartości 925 zł w celu obliczenia wartości, o którą przekroczono budżet. Wynik wynosi 425. Jeśli wartość w komórce A4 nie jest równa 500, zostanie zwrócony pusty tekst ("").

=JEŻELI(A2<B2;PRAWDA;JEŻELI(A3>B3;"Budżet przekroczony";"OK"))

Wynik pierwszej funkcji JEŻELI to FAŁSZ. Dlatego jest obliczana druga instrukcja JEŻELI, a ponieważ jej wynik to również FAŁSZ, zwracany jest wynik OK.

Typowe problemy

Problem

Przyczyna

0 (zero) w komórce

Brak argumentu wartość_jeżeli_prawda lub wartość_jeżeli_fałsz. Aby była wyświetlana prawidłowa wartość, dodaj tekst argumentu do obu argumentów lub dodaj wartość PRAWDA lub FAŁSZ do argumentu.

#NAZWA? w komórce

Zazwyczaj oznacza to, że formuła jest błędnie wpisana.

Najważniejsze wskazówki

Czynności do wykonania

Dlaczego

Użycie funkcji JEŻELI w innej funkcji JEŻELI.

W funkcji JEŻELI można zagnieżdżać do 64 funkcji JEŻELI dla argumentów wartość_jeżeli_prawda i wartość_jeżeli_fałsz, aby tworzyć bardziej złożone testy.

Użycie funkcji JEŻELI z tablicami

Jeśli którymkolwiek z argumentów funkcji JEŻELI jest tablica, każdy element tablicy jest oceniany podczas sprawdzania wyrażenia JEŻELI. Dowiedz się, jak utworzyć formułę tablicową.

Powiązane

Dotyczy: Excel for Mac 2011, Excel 2010, Excel 2016 for Mac, Excel Online, Excel Starter, Excel 2013, Excel 2007



Czy te informacje były pomocne?

Tak Nie

Jak możemy to poprawić?

255 pozostało znaków

Aby chronić swoją prywatność, nie dołączaj do opinii informacji o kontakcie. Przejrzyj nasze zasady zachowania poufności informacji.

Dziękujemy za opinię!

Zasoby pomocy technicznej

Zmień język