JEŻELI, funkcja

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Funkcja jeżeli jest jedną z najpopularniejszych funkcji w programie Excel i umożliwia logiczne porównania między wartością i czego można oczekiwać. W postaci najłatwiejszym nosi nazwę funkcji jeżeli:

  • JEŻELI (jakieś wyrażenie jest prawdziwe, to wykonaj określone działanie, a w przeciwnym razie wykonaj inne działanie)

Aby wyrażenia IF może zawierać dwóch wyników. Pierwszy wynik to, jeśli porównania ma wartość PRAWDA, druga, jeśli porównania ma wartość FAŁSZ.

Jeśli chcesz od razu przejść do pracy z wieloma instrukcji Jeżeli, zobacz: Jeżeli zaawansowane funkcje - Praca z formułami zagnieżdżone i unikanie problemów.

Użyj funkcji JEŻELI, jednej z funkcji logicznych, aby zwrócić jedną wartość, jeśli warunek jest prawdziwy, lub inną wartość, jeśli jest fałszywy.

Składnia

JEŻELI(test_logiczny;wartość_jeżeli_prawda;[wartość_jeżeli_fałsz])

Na przykład:

  • =JEŻELI(A2>B2;"Budżet przekroczony";"OK")

  • =JEŻELI(A2=B2;B4-A4;"")

Nazwa argumentu

Opis

test_logiczny    (wymagane)

Warunek, który ma zostać sprawdzony.

wartość_jeżeli_prawda    (wymagane)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość PRAWDA.

wartość_jeżeli_fałsz    (opcjonalne)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość FAŁSZ.

Proste przykłady działania funkcji JEŻELI

Komórka D2 zawiera formułę =JEŻELI(C2="Tak";1;2)
  • =JEŻELI(C2="Tak";1;2)

W powyższym przykładzie działanie formuły w komórce D2 jest następujące: JEŻELI(C2 = Tak, to zwróć wartość 1, a w przeciwnym razie zwróć wartość 2)

Komórka D2 zawiera formułę =JEŻELI(C2=1;"Tak";"Nie")
  • =JEŻELI(C2=1;"Tak";"Nie")

W tym przykładzie działanie formuły w komórce D2 jest następujące: JEŻELI(C2 = 1, to zwróć wartość Tak, a w przeciwnym razie zwróć wartość Nie)

Jak widać, funkcja jeżeli może służyć do oceny tekst i wartości. Ponadto można go ma być obliczona błędy. Nie są ograniczone do tylko sprawdzania, czy jedno jest równa innej i zwraca pojedynczy wynik, można również użyć operatorów matematycznych i obliczeń dodatkowe w zależności od kryteria. Wiele funkcji jeżeli można zagnieżdżać również razem aby można było wykonywać wiele porównania.

Uwaga : Jeśli zamierzasz użyć tekstu w formułach, należy zawinąć tekst w cudzysłowie (np. "tekst"). Jedynym wyjątkiem który korzysta z PRAWDA lub FAŁSZ, który program Excel automatycznie rozumie.

Jak zacząć

Najlepszym sposobem zacznij wpisywać instrukcji jeżeli jest wziąć pod uwagę co chcesz zrobić. Jakie porównania są próbuje nawiązać? Wiele razy, pisania instrukcji jeżeli może być tak proste jak myślenie za pomocą reguł w swojej głowy: "co należy wystąpić, jeśli ten warunek jest spełniony, a co ma się zdarzyć, jeśli nie jest?" Zawsze należy upewnić się, że logiczne postępu wykonaj czynności do wykonania, inaczej formuły nie wykonasz co uważasz, że powinno. Jest to szczególnie ważne, podczas tworzenia złożonych (zagnieżdżonych) instrukcji Jeżeli.

Więcej przykładów działania funkcji JEŻELI

Formuła w komórce D2: =JEŻELI(C2>B2;”Budżet przekroczony”;”W ramach budżetu”)
  • =JEŻELI(C2>B2;”Budżet przekroczony”;”W ramach budżetu”)

W powyższym przykładzie działanie funkcji JEŻELI w komórce D2 jest następujące: JEŻELI(wartość w komórce C2 jest większa niż wartość w komórce B2, to zwróć „Budżet przekroczony”, a w przeciwnym razie zwróć „W ramach budżetu”)

Formuła w komórce E2: =JEŻELI(C2>B2;C2-B2;"")
  • =JEŻELI(C2>B2;C2-B2;0)

Na ilustracji powyżej, zamiast powrócić wyniku tekst chwilę zwraca obliczeń matematycznych. Aby formuły w E2 jest informacją Jeśli (rzeczywista jest większa niż budżetu, a następnie Odejmij kwota budżetu od ilości rzeczywiste, w przeciwnym razie zwraca NIC).

Formuła w komórce F7: JEŻELI(E7="Tak";F5*0,0825;0)
  • =JEŻELI(E7="Tak";F5*0,0825;0)

W tym przykładzie działanie formuły w komórce F7 jest następujące: JEŻELI(E7 = "Tak", to przemnóż wartość łącznej kwoty w komórce F5 przez 8,25%, a w przeciwnym razie zwróć wartość 0, ponieważ podatek od sprzedaży nie jest naliczany)

Najważniejsze wskazówki dotyczące stałych

W ostatnim przykładzie będzie widoczny zarówno "Tak", jak i stawkę podatku od sprzedaży (0.0825) wprowadzona bezpośrednio w formule. Ogólnie nie jest dobrym rozwiązaniem jest umieszczenie literałów stałych (wartości, które trzeba zmienić od czasu do czasu) bezpośrednio w formułach, ponieważ może być trudne do znalezienia i zmienić w przyszłości. Warto znacznie wprowadzenia stałych własnych komórek, gdzie znajdują się w polu Otwórz i łatwo znaleźć i zmienić. W tym przypadku jest przycisk OK, ponieważ istnieje tylko jedna funkcja jeżeli i rzadko zmieni stawkę podatku od sprzedaży. Nawet jeśli tak, będzie ona łatwo zmienić go w formule.

Operatory arytmetyczne

Jeśli chcesz dowiedzieć się więcej na temat różnych operatorów, o których można używać w formułach, (< mniejszą niż większa niż = jest równa ><> nierówne, itp.), zobacz ten artykuł: operatory obliczeń i pierwszeństwo.

Korzystanie z funkcji JEŻELI w celu sprawdzenia, czy komórka jest pusta

Czasami może być konieczne sprawdzenie, czy komórka jest pusta — na ogół wówczas, gdy nie chcesz, by formuła zwracała wynik bez określonych wartości wejściowych.

Formuła w komórce E2: =JEŻELI(D2=1;"Tak";JEŻELI(D2=2;"Nie";"Możliwe"))

W takim przypadku można zastosować funkcję JEŻELI w połączeniu z funkcją CZY.PUSTA:

  • =JEŻELI(CZY.PUSTA(D2);"Pusta";"Niepusta")

Które mówi IF(D2 is blank, then return "Blank", otherwise return "Not Blank"). Równie łatwo można użyć formuły także "Niepuste" warunku. W następnym przykładzie użyto programu "" zamiast czy.pusta. "" Zasadniczo oznacza "nie".

Sprawdzanie, czy komórka jest pusta — formuła w komórce E2: =JEŻELI(CZY.PUSTA(D2);"Pusta";"Niepusta")
  • =JEŻELI(D3="";"Pusta";"Niepusta")

Ta formuła nosi nazwę, Jeśli (D3 nic, a następnie powróć "Puste", inaczej "niepuste"). Oto przykład często metody korzystania z "" Zapobieganie formuły obliczania, jeśli jest puste komórki zależne:

  • =JEŻELI(D3="";"";twoja_formuła())

    JEŻELI(komórka D3 nie zawiera nic, to nic nie zwracaj, a w przeciwnym razie oblicz formułę).

Przykład zagnieżdżonej instrukcji JEŻELI

Prosta funkcja JEŻELI może generować tylko dwa wyniki (Prawda lub Fałsz), natomiast zagnieżdżenie tych funkcji pozwala uzyskać od 3 do 64 wyników.

Używanie cudzysłowów ("") w celu sprawdzenia, czy komórka jest pusta — formuła w komórce E3: =JEŻELI(D3="";"Pusta";"Niepusta")
  • =JEŻELI(D2=1;”Tak”;JEŻELI(D2=2;”Nie”;”Możliwe”))

Na powyższej ilustracji działanie formuły w komórce E2 jest następujące: JEŻELI(D2 ma wartość 1, to zwróć wartość „Tak”, a w przeciwnym razie JEŻELI(D2 ma wartość 2, to zwróć wartość „Nie”, a w przeciwnym razie zwróć wartość „Możliwe”)). Zwróć uwagę na to, że na końcu formuły znajdują się dwa nawiasy zamykające. Są one wymagane do zamknięcia obu funkcji JEŻELI. Próba wprowadzenia formuły bez obu tych nawiasów zamykających spowoduje, że program Excel spróbuje to poprawić.

Przestroga

Gdy program Excel będzie można zagnieździć maksymalnie 64 różne funkcje Jeżeli, w ogóle zalecane jest to zrobić. Dlaczego?

  • Wiele instrukcji jeżeli wymagają dużą myślowych poprawnie je tworzyć i upewnij się, że ich można poprawnie oblicza do każdego warunku Dosunięty do końca. Jeśli użytkownik nie użyto do instrukcji Jeżeli 100% dokładnie w taki sposób, następnie formuły może działać 75% czasu, ale zwracać nieoczekiwane wyniki 25% czasu. Niestety którzy: Przechwytywanie 25% są obsługiwane.

  • Zarządzanie wieloma instrukcjami JEŻELI może okazać się bardzo trudne, zwłaszcza, gdy od ich napisania upłynie trochę czasu lub — co gorsza — wystąpi konieczność przeanalizowania instrukcji utworzonych przez inną osobę.

  • Wiele instrukcji JEŻELI wymaga wielu nawiasów otwierających i zamykających (). Zarządzanie nimi może sprawiać trudności — w zależności od tego, jak złożona jest formuła.

Typowe problemy

Problem

Przyczyna

0 (zero) w komórce

Brak argumentu wartość_jeżeli_prawda lub wartość_jeżeli_fałsz. Aby była wyświetlana prawidłowa wartość, dodaj tekst argumentu do obu argumentów lub dodaj wartość PRAWDA lub FAŁSZ do argumentu.

#NAZWA? w komórce

Zazwyczaj oznacza to, że formuła jest błędnie wpisana.

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Klip wideo: Zaawansowane funkcje Jeżeli

Funkcja IFS (Office 365, programie Excel 2016 lub nowszy)

Jeżeli zaawansowane funkcje - Praca z formułami zagnieżdżone i unikanie problemów

Szkoleniowe klipy wideo: zaawansowane funkcje Jeżeli

Funkcji LICZ będzie zliczanie wartości na podstawie pojedynczej kryteriów

LICZ.warunki, funkcja będzie zliczania wartości na podstawie wielu kryteriów

Funkcja suma.Jeżeli będzie suma wartości na podstawie pojedynczej kryteriów

Funkcja suma.warunków będzie sumowanie wartości na podstawie wielu kryteriów

ORAZ

Funkcja OR

WYSZUKAJ.PIONOWO

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Funkcje logiczne

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×