Formuły i funkcje

JEŻELI, funkcja

JEŻELI, funkcja

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Funkcja jeżeli jest jedną z najpopularniejszych funkcji w programie Excel i umożliwia logiczne porównania między wartością i czego można oczekiwać.

Aby wyrażenia IF może zawierać dwóch wyników. Pierwszy wynik to, jeśli porównania ma wartość PRAWDA, druga, jeśli porównania ma wartość FAŁSZ.

Na przykład działanie formuły =JEŻELI(C2="Tak";1;2) jest następujące: JEŻELI(C2 = Tak, to zwróć wartość 1, a w przeciwnym razie zwróć wartość 2).

Przeglądarka nie obsługuje klipu wideo. Zainstaluj dodatek Microsoft Silverlight, Adobe Flash Player lub program Internet Explorer 9.

Użyj funkcji JEŻELI, jednej z funkcji logicznych, aby zwrócić jedną wartość, jeśli warunek jest prawdziwy, lub inną wartość, jeśli jest fałszywy.

JEŻELI(test_logiczny;wartość_jeżeli_prawda;[wartość_jeżeli_fałsz])

Na przykład:

  • =JEŻELI(A2>B2;"Budżet przekroczony";"OK")

  • =JEŻELI(A2=B2;B4-A4;"")

Nazwa argumentu

Opis

test_logiczny    (wymagane)

Warunek, który ma zostać sprawdzony.

wartość_jeżeli_prawda    (wymagane)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość PRAWDA.

wartość_jeżeli_fałsz    (opcjonalne)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość FAŁSZ.

Proste przykłady działania funkcji JEŻELI

Komórka D2 zawiera formułę =JEŻELI(C2="Tak";1;2)
  • =JEŻELI(C2="Tak";1;2)

W powyższym przykładzie działanie formuły w komórce D2 jest następujące: JEŻELI(C2 = Tak, to zwróć wartość 1, a w przeciwnym razie zwróć wartość 2)

Komórka D2 zawiera formułę =JEŻELI(C2=1;"Tak";"Nie")
  • =JEŻELI(C2=1;"Tak";"Nie")

W tym przykładzie formuła w komórce D2 informacją: IF(C2 = 1, then return Yes, otherwise return No)jak widać, funkcja jeżeli może służyć do oceny tekst i wartości. Ponadto można go ma być obliczona błędy. Nie są ograniczone do tylko sprawdzania, czy jedno jest równa innej i zwraca pojedynczy wynik, można również użyć operatorów matematycznych i obliczeń dodatkowe w zależności od kryteria. Wiele funkcji jeżeli można zagnieżdżać również razem aby można było wykonywać wiele porównania.

Formuła w komórce D2: =JEŻELI(C2>B2;”Budżet przekroczony”;”W ramach budżetu”)
  • =JEŻELI(C2>B2;”Budżet przekroczony”;”W ramach budżetu”)

W powyższym przykładzie działanie funkcji JEŻELI w komórce D2 jest następujące: JEŻELI(wartość w komórce C2 jest większa niż wartość w komórce B2, to zwróć „Budżet przekroczony”, a w przeciwnym razie zwróć „W ramach budżetu”)

Formuła w komórce E2: =JEŻELI(C2>B2;C2-B2;"")
  • =JEŻELI(C2>B2;C2-B2;0)

Na ilustracji powyżej, zamiast powrócić wyniku tekst chwilę zwraca obliczeń matematycznych. Aby formuły w E2 jest informacją Jeśli (rzeczywista jest większa niż budżetu, a następnie Odejmij kwota budżetu od ilości rzeczywiste, w przeciwnym razie zwraca NIC).

Formuła w komórce F7: JEŻELI(E7="Tak";F5*0,0825;0)
  • =JEŻELI(E7="Tak";F5*0,0825;0)

W tym przykładzie działanie formuły w komórce F7 jest następujące: JEŻELI(E7 = "Tak", to przemnóż wartość łącznej kwoty w komórce F5 przez 8,25%, a w przeciwnym razie zwróć wartość 0, ponieważ podatek od sprzedaży nie jest naliczany)

Uwaga: Jeśli zamierzasz użyć tekstu w formułach, należy zawinąć tekst w cudzysłowie (np. "tekst"). Jedynym wyjątkiem który korzysta z PRAWDA lub FAŁSZ, który program Excel automatycznie rozumie.

Typowe problemy

Problem

Przyczyna

0 (zero) w komórce

Brak argumentu wartość_jeżeli_prawda lub wartość_jeżeli_fałsz. Aby była wyświetlana prawidłowa wartość, dodaj tekst argumentu do obu argumentów lub dodaj wartość PRAWDA lub FAŁSZ do argumentu.

#NAZWA? w komórce

Zazwyczaj oznacza to, że formuła jest błędnie wpisana.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Operatory obliczeń i ich hierarchia w programie Excel

Używanie w formule funkcji zagnieżdżonych

Korzystanie z funkcji JEŻELI w celu sprawdzenia, czy komórka jest pusta

Korzystanie z funkcji JEŻELI w celu sprawdzenia, czy komórka jest pusta

Klip wideo: zaawansowane funkcje JEŻELI

Funkcja WARUNKI (usługa Office 365, program Excel 2016 lub nowszy)

Jeżeli zaawansowane funkcje - Praca z formułami zagnieżdżone i unikanie problemów

Szkoleniowe klipy wideo: zaawansowane funkcje Jeżeli

Funkcji LICZ będzie zliczanie wartości na podstawie pojedynczej kryteriów

LICZ.warunki, funkcja będzie zliczania wartości na podstawie wielu kryteriów

Funkcja suma.Jeżeli będzie suma wartości na podstawie pojedynczej kryteriów

Funkcja suma.warunków będzie sumowanie wartości na podstawie wielu kryteriów

ORAZ

LUB

WYSZUKAJ.PIONOWO

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Funkcje logiczne

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×