JEŻELI.BŁĄD, funkcja

Ten artykuł zawiera opis składni formuły i zastosowania funkcji JEŻELI.BŁĄD w programie Microsoft Excel.

Opis

Zwraca określoną wartość, jeśli wynikiem formuły będzie błąd; w przeciwnym razie zwraca wynik formuły. Funkcja JEŻELI.BŁĄD służy do wyłapywania i obsługi błędów w formuła.

Składnia

JEŻELI.BŁĄD(wartość;wartość_jeżeli_błąd)

W składni funkcji JEŻELI.BŁĄD występują następujące argumenty:

  • Wartość    Argument wymagany. Argument sprawdzany w poszukiwaniu błędu.

  • Wartość_jeżeli_błąd    Argument wymagany. Wartość zwracana, jeśli wynikiem formuły jest błąd. Sprawdzane są następujące typy błędów: #N/D!, #ARG!, #ADR!, #DZIEL/0!, #LICZBA!, #NAZWA? i #ZERO!.

Spostrzeżenia

  • Jeśli argument wartość lub wartość_jeżeli_błąd jest pustą komórką, funkcja JEŻELI.BŁĄD traktuje go jako wartość ciągu pustego ("").

  • Jeśli wartość jest formułą tablicową, funkcja JEŻELI.BŁĄD zwraca tablicę wyników dla każdej komórki w zakresie określonym w wartości. Zobacz drugi przykład poniżej.

Przykłady

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Przydział

Liczba sprzedanych sztuk

210

35

55

0

23

Formuła

Opis

Wynik

=JEŻELI.BŁĄD(A2/B2;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie 210 przez 35), nie znajduje błędu, a następnie zwraca wynik formuły.

6

=JEŻELI.BŁĄD(A3/B3;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie 55 przez 0), znajduje błąd dzielenia przez 0, a następnie zwraca wartość argumentu wartość_jeżeli_błąd.

Błąd w obliczeniach

=JEŻELI.BŁĄD(A4/B4;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie "" przez 23), nie znajduje błędu, a następnie zwraca wynik formuły.

0

Przykład 2

Przydział

Liczba sprzedanych sztuk

Stosunek

210

35

6

55

0

Błąd w obliczeniach

23

0

Formuła

Opis

Wynik

=C2

Sprawdza pierwszy argument formuły w pierwszym elemencie tablicy w poszukiwaniu błędu (A2/B2, czyli dzielenie 210 przez 35), nie znajduje błędu, a następnie zwraca wynik formuły.

6

=C3

Sprawdza pierwszy argument formuły w drugim elemencie tablicy w poszukiwaniu błędu (A3/B3, czyli dzielenie 55 przez 0), znajduje błąd dzielenia przez 0, a następnie zwraca wartość argumentu wartość_jeżeli_błąd.

Błąd w obliczeniach

=C4

Sprawdza pierwszy argument formuły w trzecim elemencie tablicy w poszukiwaniu błędu (A4/B4, czyli dzielenie "" przez 23), nie znajduje błędu, a następnie zwraca wynik formuły.

0

Uwaga: formułę podaną w tym przykładzie należy wprowadzić jako formułę tablicową. Po skopiowaniu przykładu do pustego arkusza zaznacz zakres komórek C2:C4, naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×