Hiperlinki w arkuszach

Aby zapewnić szybki dostęp do informacji pokrewnych w innym pliku lub na innej stronie sieci Web, można wstawić hiperlink w komórce arkusza programu Microsoft Excel. Hiperlinki można wstawiać także w określonych elementach wykresu lub obrazach.

Co chcesz zrobić?

Tworzenie hiperlinku do istniejącego pliku lub strony sieci Web

Tworzenie hiperlinku do nowego pliku

Tworzenie hiperlinku do określonej lokalizacji w skoroszycie

Tworzenie lub usuwanie hiperlinku do adresu e-mail

Zaznaczanie hiperlinku bez otwierania linku

Zmienianie lub formatowanie hiperlinku

Kopiowanie lub przenoszenie hiperlinku

Usuwanie hiperlinku

Usuwanie wielu hiperlinków

Wyłączanie automatycznego formatowania hiperlinków

Tworzenie niestandardowego hiperlinku za pomocą funkcji HIPERŁĄCZE

Tworzenie linku odwołania zewnętrznego do danych arkusza w sieci Web

Ustawianie adresu podstawowego hiperlinku w skoroszycie

Informacje o hiperlinkach

Tworzenie hiperlinku do istniejącego pliku lub strony sieci Web

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

    Porada    Można też zaznaczyć obiekt, taki jak obraz czy element wykresu, który ma reprezentować hiperlink.

  2. Wykonaj jedną z następujących czynności:

    • Można też kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie kliknąć polecenie Hiperłącze lub nacisnąć klawisze Ctrl+K.

    • Na karcie Wstawianie w grupie Łącza kliknij przycisk Hiperłącze.

      Hiperlink

  3. W obszarze Połącz z kliknij opcję Istniejący plik lub strona sieci Web.

  4. Wykonaj jedną z następujących czynności:

    • Aby wprowadzić znaną nazwę i lokalizację pliku lub strony sieci Web, do których ma zostać utworzony link, wpisz te informacje w polu Adres.

    • Aby zlokalizować stronę sieci Web, kliknij przycisk Przeglądaj sieć Web Obraz przycisku , otwórz stronę sieci Web, do której ma zostać utworzony link, a następnie przejdź z powrotem do programu Excel, nie zamykając przeglądarki. Możesz też skorzystać ze stron ostatnio używanych dla hiperlinków, klikając pozycję Strony przeglądane, a następnie klikając stronę sieci Web.

    • Aby wybrać plik, kliknij pozycję Bieżący folder, a następnie kliknij plik, do którego ma zostać utworzony link. Możesz też skorzystać z ostatnio używanych plików, klikając pozycję Niedawno używane pliki, a następnie klikając plik.

      Porada    Bieżący folder można zmienić, wybierając inny folder na liście Szukaj w.

  5. Aby utworzyć hiperlink do określonej lokalizacji w pliku lub na stronie sieci Web, kliknij przycisk Zakładka, a następnie kliknij dwukrotnie odpowiednią zakładka.

    Uwaga    Zakładka musi istnieć w pliku lub na stronie sieci Web, do których ma zostać utworzony link.

  6. W polu Tekst do wyświetlenia wpisz tekst, który ma reprezentować hiperlink.

  7. Aby po zatrzymaniu wskaźnika myszy na hiperlinku były wyświetlane pomocne informacje, kliknij przycisk Etykietka ekranowa, wpisz odpowiedni tekst w polu Tekst etykietki ekranowej i kliknij przycisk OK.

Początek strony

Tworzenie hiperlinku do nowego pliku

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

    Porada    Można też zaznaczyć obiekt, taki jak obraz czy element wykresu, który ma reprezentować hiperlink.

  2. Wykonaj jedną z następujących czynności:

    • Można też kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie kliknąć polecenie Hiperłącze lub nacisnąć klawisze Ctrl+K.

    • Na karcie Wstawianie w grupie Łącza kliknij przycisk Hiperłącze.

      Hiperlink

  3. W obszarze Połącz z kliknij przycisk Utwórz nowy dokument.

  4. W polu Nazwa nowego dokumentu wpisz nazwę nowego pliku.

    Porada    Aby określić lokalizację inną niż wyświetlana w obszarze Pełna ścieżka, można wpisać nową lokalizację przed nazwą w polu Nazwa nowego dokumentu. Można też kliknąć przycisk Zmień w celu wybrania odpowiedniej lokalizacji, a następnie kliknąć przycisk OK.

  5. W obszarze Kiedy edytować kliknij opcję Edytuj nowy dokument później lub Edytuj nowy dokument teraz, aby określić, kiedy nowy plik ma zostać otwarty do edycji.

  6. W polu Tekst do wyświetlenia wpisz tekst, który ma reprezentować hiperlink.

  7. Aby po zatrzymaniu wskaźnika myszy na hiperlinku były wyświetlane pomocne informacje, kliknij przycisk Etykietka ekranowa, wpisz odpowiedni tekst w polu Tekst etykietki ekranowej i kliknij przycisk OK.

Początek strony

Tworzenie hiperlinku do określonej lokalizacji w skoroszycie

Aby utworzyć link do określonej lokalizacji w bieżącym lub innym skoroszycie, można albo zdefiniować nazwa komórek miejsce docelowe, albo użyć odwołania do komórki.

Aby posłużyć się nazwą, musisz nadać nazwę komórkom docelowym znajdującym się w skoroszycie docelowym.

Jak nadać nazwę komórce lub zakresowi komórek

  1. Zaznacz komórkę, zakres komórek albo zaznaczenie nieprzylegające, którym chcesz nadać nazwę.

  2. Kliknij pole Nazwa na lewym końcu paska formuły Obraz przycisku .

    Przykładowe pole Nazwa

  3. W polu Nazwa wpisz nazwę dla komórek, a następnie naciśnij klawisz ENTER.

    Uwaga :  Nazwy nie mogą zawierać spacji i muszą zaczynać się od litery.

  4. W arkuszu skoroszytu źródłowego kliknij komórkę, w której chcesz utworzyć hiperlink, a następnie wykonaj jedną z następujących czynności:

    Porady : 

    •  Można też zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować hiperlink.

    • Kliknij prawym przyciskiem myszy komórkę lub grafikę, a następnie kliknij polecenie Hiperłącze lub naciśnij klawisze Ctrl+K.

    • Na karcie Wstawianie w grupie Łącza kliknij przycisk Hiperłącze.

      Hiperlink

  5. W obszarze Połącz z wykonaj jedną z następujących czynności:

    • Aby utworzyć link do lokalizacji w bieżącym skoroszycie, kliknij pozycję Miejsce w tym dokumencie.

    • Aby utworzyć link do lokalizacji w innym skoroszycie, kliknij opcję Istniejący plik lub strona sieci Web, zlokalizuj i zaznacz skoroszyt, do którego chcesz utworzyć hiperlink, a następnie kliknij przycisk Zakładka. Wykonaj jedną z następujących czynności:

      • W polu Lub wybierz miejsce w tym dokumencie w obszarze Adres komórki kliknij arkusz, do którego ma zostać utworzony link, wpisz odwołanie do komórki w polu Wpisz odwołanie do komórki, a następnie kliknij przycisk OK.

      • Na liście w obszarze Nazwy zdefiniowane kliknij nazwę reprezentującą komórki, do których ma zostać utworzony link, a następnie kliknij przycisk OK.

  6. W polu Tekst do wyświetlenia wpisz tekst, który ma reprezentować hiperlink.

  7. Aby po zatrzymaniu wskaźnika myszy na hiperlinku były wyświetlane pomocne informacje, kliknij przycisk Etykietka ekranowa, wpisz odpowiedni tekst w polu Tekst etykietki ekranowej i kliknij przycisk OK.

Początek strony

Tworzenie lub usuwanie hiperlinku do adresu e-mail

Gdy zostanie kliknięty hiperlink do adresu e-mail, automatycznie uruchamia się program poczty e-mail (jeśli tylko jest zainstalowany) i tworzona jest wiadomość e-mail z poprawnym adresem w polu Do.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

    Porada    Można też zaznaczyć obiekt, taki jak obraz czy element wykresu, który ma reprezentować hiperlink.

  2. Wykonaj jedną z następujących czynności:

    • Można też kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie kliknąć polecenie Hiperłącze lub nacisnąć klawisze Ctrl+K.

    • Na karcie Wstawianie w grupie Łącza kliknij przycisk Hiperłącze.

      Hiperlink

  3. W obszarze Połącz z kliknij opcję Adres e-mail.

  4. W polu Adres e-mail wpisz adres e-mail, którego chcesz użyć.

  5. W polu Temat wpisz temat wiadomości poczty e-mail.

    Uwaga    Niektóre przeglądarki sieci Web i programy poczty e-mail mogą nie rozpoznawać wiersza tematu.

  6. W polu Tekst do wyświetlenia wpisz tekst, który ma reprezentować hiperlink.

  7. Aby po zatrzymaniu wskaźnika myszy na hiperlinku były wyświetlane pomocne informacje, kliknij przycisk Etykietka ekranowa, wpisz odpowiedni tekst w polu Tekst etykietki ekranowej i kliknij przycisk OK.

    Porada    Hiperlink do adresu e-mail można też utworzyć przez wpisanie adresu bezpośrednio w komórce. Hiperlink zostanie utworzony automatycznie na przykład po wpisaniu adresu e-mail osoba@example.com.

Usuwanie hiperlinku do adresu e-mail

Jeśli adresy e-mail kontaktów są wyświetlane jako hiperlinki, które można kliknąć, można je dezaktywować, jak w przypadku każdego innego hiperlinku.

  1. W arkuszu kliknij komórkę, z której chcesz usunąć hiperlink.

    Porada    Można też zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować hiperlink.

  2. Kliknij prawym przyciskiem myszy i wybierz polecenie Usuń hiperłącze.

Początek strony

Zaznaczanie hiperlinku bez otwierania linku

Aby zaznaczyć hiperlink bez otwierania hiperlinku do jego miejsce docelowe, wykonaj jedną z następujących czynności:

  • Kliknij komórkę zawierającą hiperlink i przytrzymaj przycisk myszy, aż wskaźnik przybierze kształt krzyżyka Wskaźnik zaznaczenia w programie Excel , a następnie puść przycisk myszy.

  • Zaznacz za pomocą klawiszy strzałek komórkę zawierającą hiperlink.

  • Jeśli hiperlink jest reprezentowany przez grafikę, przytrzymaj naciśnięty klawisz CTRL i kliknij tę grafikę.

Początek strony

Zmienianie lub formatowanie hiperlinku

Istniejący w skoroszycie hiperlink można zmienić, modyfikując jego miejsce docelowe, wygląd lub reprezentujący je tekst albo grafikę.

Zmienianie lokalizacji docelowej hiperlinku

  1. Zaznacz komórkę lub grafikę zawierającą hiperlink, który chcesz zmienić.

    Porada :  Aby zaznaczyć komórkę zawierającą hiperlink bez przechodzenia do miejsca docelowego hiperlinku, kliknij tę komórkę i przytrzymaj przycisk myszy do momentu, aż wskaźnik przybierze kształt krzyżyka Wskaźnik zaznaczenia w programie Excel , a następnie zwolnij przycisk myszy. Komórkę można także zaznaczyć za pomocą klawiszy strzałek. Aby zaznaczyć grafikę, przytrzymaj naciśnięty klawisz CTRL i kliknij grafikę.

  2. Wykonaj jedną z następujących czynności:

    • Kliknij prawym przyciskiem myszy komórkę lub grafikę, a następnie kliknij polecenie Hiperłącze lub naciśnij klawisze Ctrl+K.

    • Na karcie Wstawianie w grupie Łącza kliknij przycisk Hiperłącze.

      Hiperlink

      Uwaga :  Jeśli hiperlink utworzono za pomocą funkcji arkusza HIPERŁĄCZE, należy edytować formułę, aby zmienić miejsce docelowe. Zaznacz komórkę zawierającą hiperlink, a następnie kliknij pasek formuły, aby edytować formułę.

Zmienianie wyglądu tekstu hiperlinku

Wygląd tekstu wszystkich hiperlinków w bieżącym skoroszycie można zmienić, modyfikując styl komórki dla hiperlinków.

  1. Na karcie Narzędzia główne w grupie Style kliknij przycisk Style komórki.

    Przycisk Hiperlink w galerii Style komórki

  2. W obszarze Dane i model wykonaj następujące czynności:

    • Aby zmienić wygląd hiperlinków, które nie zostały kliknięte, kliknij prawym przyciskiem myszy pozycję Hiperłącze, a następnie kliknij polecenie Modyfikuj.

    • Aby zmienić wygląd hiperlinków, które zostały kliknięte, kliknij prawym przyciskiem myszy pozycję Odwiedzone hiperłącze, a następnie kliknij polecenie Modyfikuj.

      Uwaga :  Styl komórki Hiperłącze jest dostępny tylko wtedy, gdy skoroszyt zawiera co najmniej jeden hiperlink. Styl komórki Odwiedzone hiperłącze jest dostępny tylko wtedy, gdy skoroszyt zawiera kliknięty hiperlink.

  3. W oknie dialogowym Styl kliknij przycisk Formatuj.

  4. Na kartach Czcionka i Wypełnienie zaznacz odpowiednie opcje formatowania, a następnie kliknij przycisk OK.

    Uwagi : 

    • Opcje zaznaczone w oknie dialogowym Formatowanie komórek są wyświetlane jako zaznaczone w obszarze Styl zawiera w oknie dialogowym Styl. Można wyczyścić pola wyboru dla opcji, które nie mają być stosowane.

    • Zmiany wprowadzone w stylach komórek Hiperłącze i Odwiedzone hiperłącze są stosowane do wszystkich hiperlinków w bieżącym skoroszycie. Nie można zmienić wyglądu pojedynczych hiperlinków.

Zmienianie tekstu lub grafiki hiperlinku

  1. Zaznacz komórkę lub grafikę zawierającą hiperlink, który chcesz zmienić.

    Porada :  Aby zaznaczyć komórkę zawierającą hiperlink bez przechodzenia do miejsca docelowego hiperlinku, kliknij tę komórkę i przytrzymaj przycisk myszy do momentu, aż wskaźnik przybierze kształt krzyżyka Wskaźnik zaznaczenia w programie Excel , a następnie zwolnij przycisk myszy. Komórkę można także zaznaczyć za pomocą klawiszy strzałek. Aby zaznaczyć grafikę, przytrzymaj naciśnięty klawisz CTRL i kliknij grafikę.

  2. Wykonaj co najmniej jedną z następujących czynności:

    • Aby zmienić tekst hiperlinku, kliknij pasek formuły i edytuj tekst.

    • Aby zmienić format grafiki, kliknij ją prawym przyciskiem myszy, a następnie kliknij opcje formatowania, które chcesz zmienić.

    • Aby zmienić tekst w grafice, kliknij dwukrotnie zaznaczoną grafikę i wprowadź odpowiednie zmiany.

  3. Aby zmienić grafikę przedstawiającą hiperlink, wstaw nową grafikę, zamień ją na hiperlink o tym samym miejscu docelowym, a następnie usuń starą grafikę i hiperlink.

Początek strony

Kopiowanie lub przenoszenie hiperlinku

  1. Kliknij prawym przyciskiem myszy hiperlink, które chcesz skopiować lub przenieść, a następnie kliknij polecenie Kopiuj lub Wytnij.

  2. Kliknij prawym przyciskiem myszy komórkę, do której chcesz skopiować lub przenieść hiperlink, a następnie kliknij polecenie Wklej.

Początek strony

Usuwanie hiperlinku

Aby usunąć hiperlink, wykonaj jedną z następujących czynności:

  • Aby dezaktywować pojedynczy hiperlink, kliknij go prawym przyciskiem i wybierz polecenie Usuń hiperłącze. Adres internetowy pozostanie w komórce, ale nie będzie aktywny ani sformatowany jako hiperlink.

  • Aby usunąć hiperlink i tekst, który je reprezentuje, kliknij prawym przyciskiem myszy komórkę zawierającą hiperlink, a następnie kliknij polecenie Wyczyść zawartość.

Aby usunąć hiperlink i grafikę, która je reprezentuje, przytrzymaj naciśnięty klawisz CTRL i kliknij tę grafikę, a następnie naciśnij klawisz DELETE.

Początek strony

Usuwanie wielu hiperlinków

Aby usunąć (dezaktywować) kilka hiperlinków naraz, wykonaj następujące czynności:

  1. Zaznacz zakres komórek, z których chcesz usunąć hiperlinki. Ten zakres nie musi być ciągły.

    Porada    Aby zaznaczyć komórkę, która zawiera hiperlink, nie przechodząc do miejsca docelowego hiperlinku, należy kliknąć tę komórkę i przytrzymać przycisk myszy naciśnięty do momentu, gdy wskaźnik przybierze kształt krzyżyka Wskaźnik zaznaczenia w programie Excel , a następnie puścić przycisk myszy.

  2. Umieść wskaźnik myszy na dowolnej komórce w zaznaczonym zakresie, kliknij prawym przyciskiem myszy i wybierz polecenie Usuń hiperłącza.

Początek strony

Wyłączanie automatycznego formatowania hiperlinków

Jeśli nie chcesz, aby program Excel automatycznie formatował ścieżki internetowe i sieciowe jako hiperlinki podczas wpisywania, wykonaj następujące czynności:

  1. Wybierz kartę Plik, a następnie wybierz pozycję Opcje.

  2. W oknie dialogowym Opcje programu Excel wybierz pozycję Sprawdzanie, a następnie wybierz pozycję Opcje Autokorekty.

  3. W oknie dialogowym Autokorekta wybierz kartę Autoformatowanie podczas pisania.

  4. Wyczyść pole wyboru Ścieżki internetowe i sieciowe na hiperlinki.

  5. Wybierz przycisk OK, aby zamknąć okno dialogowe Autokorekta.

  6. Wybierz przycisk OK, aby zamknąć okno dialogowe Opcje programu Excel.

Początek strony

Tworzenie niestandardowego hiperlinku za pomocą funkcji HIPERŁĄCZE

Funkcji HIPERŁĄCZE można użyć w celu utworzenia hiperłącza, które otwiera dokument przechowywany na serwerze, w intranet lub w Internecie. Gdy zostanie kliknięta komórka zawierająca funkcję HIPERŁĄCZE, program Excel otworzy plik przechowywany w lokalizacji, do której prowadzi link.

Składnia

=HIPERŁĄCZE(lokalizacja_docelowa_linku;przyjazna_nazwa)

Lokalizacja_docelowa_linku    Ścieżka dostępu i nazwa pliku dokumentu, który ma zostać otwarty jako tekst. Argument lokalizacja_docelowa_linku może się odwoływać do miejsca w dokumencie, na przykład do określonej komórki lub nazwanego zakresu arkusza bądź skoroszytu programu Excel, albo odwoływać się do zakładki w dokumencie programu Microsoft Word. Ścieżka może wskazywać plik przechowywany na dysku twardym, może być ścieżką UNC do lokalizacji na serwerze (w programie Excel) lub może być ścieżką adresu URL w Internecie lub intranecie.

  • Argument lokalizacja_docelowa_linku może być ciągiem tekstowym ujętym w znaki cudzysłowu lub komórką, która zawiera link w postaci ciągu tekstowego.

Jeśli skok określony argumentem lokalizacja_docelowa_linku nie istnieje lub nie można do niego przejść, po kliknięciu komórki wystąpi błąd.

Przyjazna_nazwa    Tekst skoku lub wartość liczbowa wyświetlana w komórce. Argument przyjazna_nazwa jest wyświetlany w postaci podkreślonego tekstu w kolorze niebieskim. Jeśli argument przyjazna_nazwa zostanie pominięty, komórka wyświetli argument lokalizacja_docelowa_linku jako tekst skoku.

  • Argument przyjazna_nazwa może być wartością, ciągiem tekstowym lub komórką, która zawiera tekst skoku lub wartość.

  • Jeśli argument przyjazna_nazwa zwraca wartość błędu (np. #ARG!), to komórka wyświetla błąd zamiast tekstu skoku.

Przykłady

W poniższym przykładzie jest otwierany arkusz noszący nazwę Raport Budżetowy.xlsx, który jest przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report, a także jest wyświetlany tekst „Kliknij, aby wyświetlić raport”:

=HYPERLINK("http://example.microsoft.com/report/budget report.xlsx", "Click for report")

W poniższym przykładzie jest tworzony hiperlink do komórki F10 w arkuszu noszącym nazwę Roczne, w skoroszycie Raport Budżetowy.xlsx, który jest przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report. W komórce arkusza zawierającej hiperlink jest wyświetlana zawartość komórki D1 jako tekst skoku.

=HYPERLINK("[http://example.microsoft.com/report/budget report.xlsx]Annual!F10", D1)

W poniższym przykładzie jest tworzony hiperlink do zakresu noszącego nazwę Dział_ogólnie w arkuszu Pierwszy kwartał, w skoroszycie Raport Budżetowy.xlsx, który jest przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report. W komórce arkusza zawierającej hiperlink jest wyświetlany tekst „Kliknij tutaj, aby zobaczyć podsumowanie pierwszego kwartału dla działu”.

=HYPERLINK("[http://example.microsoft.com/report/budget report.xlsx]First Quarter!DeptTotal", "Click to see First Quarter Department Total")

Aby utworzyć hiperlink do określonego miejsca w dokumencie programu Word, należy za pomocą zakładki określić lokalizację w dokumencie, do której trzeba skoczyć. W poniższym przykładzie jest tworzony hiperlink do zakładki noszącej nazwę Zyski_kwartalne, znajdującej się w dokumencie Raport_roczny.docx, który znajduje się pod adresem example.microsoft.com:

=HYPERLINK("[http://example.microsoft.com/Annual Report.docx]QrtlyProfits", "Quarterly Profit Report")

W poniższym przykładzie w programie Excel jest wyświetlana zawartość komórki D5 jako tekst skoku w komórce, a także jest otwierany plik 1szykw.xlsx, który jest przechowywany w dziale Publikacje na serwerze o nazwie FINANSE. W przykładzie jest używana ścieżka UNC:

=HYPERLINK("\\FINANCE\Statements\1stqtr.xlsx", D5)

W poniższym przykładzie w programie Excel jest otwierany plik 1szykw.xlsx, który jest przechowywany w katalogu o nazwie Finanse na dysku D, a także jest wyświetlana wartość liczbowa przechowywana w komórce H10:

=HYPERLINK("D:\FINANCE\1stqtr.xlsx", H10)

W poniższym przykładzie w programie Excel jest tworzony hiperlink do obszaru o nazwie Sumaryczne zlokalizowanego w innym (zewnętrznym) skoroszycie Mójskoroszyt.xlsx:

=HYPERLINK("[C:\My Documents\Mybook.xlsx]Totals")

Poniższy przykład wyświetla w programie Microsoft Excel dla komputerów Macintosh tekst "Kliknij tutaj" w komórce i otwiera plik o nazwie Pierwszy kwartał, który przechowywany jest w folderze Raporty budżetowe na dysku twardym o nazwie Macintosh HD:

=HYPERLINK("Macintosh HD:Budget Reports:First Quarter", "Click here")

Można utworzyć hiperlink wewnątrz arkusza, aby skoczyć z jednej komórki do drugiej komórki. Na przykład, jeśli arkusz aktywny nosi nazwę "Czerwiec" i znajduje się w skoroszycie o nazwie Budżet, następujący przykład tworzy link do komórki E56. Sam tekst linku to wartość znajdująca się w komórce E56.

=HYPERLINK("[Budget]June!E56", E56)

Aby skoczyć do innego arkusza w tym samym skoroszycie, należy zmienić nazwę arkusza w linku. W poprzednim przykładzie, aby utworzyć link do komórki E56 w arkuszu Wrzesień, należy zmienić słowo "Czerwiec" na słowo "Wrzesień".

Początek strony

Tworzenie linku odwołania zewnętrznego do danych arkusza w sieci Web

Odwołania zewnętrzne (nazywane także linkami) można wstawiać ze skoroszytu do innego skoroszytu w intranet lub Internecie. Skoroszyt nie może zostać zapisany jako plik HTML.

  1. Otwórz źródłowy skoroszyt i zaznacz komórkę lub zakres komórek do skopiowania.

  2. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj.

    Kopiowanie

  3. Przejdź do arkusza, w którym mają zostać umieszczone informacje, a następnie kliknij komórkę, w której te informacje mają być wyświetlane.

  4. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Wklej specjalnie.

  5. Kliknij pozycję Wklej łącze. W programie Excel zostanie utworzony link odwołania zewnętrznego dla zaznaczonej komórki lub wszystkich komórek z zakresu.

    Uwaga :  Można także utworzyć link odwołania zewnętrznego bez otwierania skoroszytu w sieci Web. W tym celu należy kliknąć każdą komórkę w skoroszycie docelowym, w której ma zostać wstawiony link odwołania zewnętrznego, a następnie wpisać znak równości (=), adres URL i lokalizację w skoroszycie. Przykład:

='http://www.czyjas.stronaglowna/[plik.xls]Arkusz1'!A1

='ftp.serwer.gdzies/ plik.xls'!MojaNazwanaKomorka

Początek strony

Ustawianie adresu podstawowego hiperlinku w skoroszycie

Domyślnie nieokreślone ścieżki do plików docelowych hiperlink są definiowane względem lokalizacji aktywnego skoroszytu. Następująca procedura umożliwia ustawienie innej ścieżki domyślnej. Za każdym razem podczas tworzenia hiperlinku do pliku znajdującego się w danej lokalizacji nie trzeba określać ścieżki — wystarczy podać tylko nazwę pliku w oknie dialogowym Wstawianie hiperłącza.

  1. Kliknij pozycję Plik > Informacje.

  2. Kliknij strzałkę Właściwości, a następnie kliknij pozycję Właściwości zaawansowane.

  3. Kliknij kartę Podsumowanie.

  4. W polu Baza hiperłącza wpisz ścieżkę, której chcesz użyć.

    Uwaga :  Można zastąpić adres podstawowy hiperlinku, używając pełnego lub bezwzględnego adresu tego hiperlinku w oknie dialogowym Wstawianie hiperłącza.

Początek strony

Informacje o hiperlinkach

Hiperlink to link z dokumentu, który po kliknięciu otwiera inną stronę lub plik. Miejsce docelowe to najczęściej inna strona sieci Web, ale może też to być obraz, adres e-mail lub program. Hiperlinkiem może być tekst lub obraz.

Gdy użytkownik odwiedzający witrynę klika hiperlink, obiekt docelowy jest pokazywany w przeglądarce sieci Web, otwierany lub uruchamiany, w zależności od typu obiektu. Na przykład hiperlink do strony powoduje wyświetlenie tej strony w przeglądarce sieci Web, a hiperlink do pliku AVI powoduje otwarcie tego pliku w odtwarzaczu multimediów.

Jak korzystać z hiperlinków

Hiperlinków można używać do wykonywania następujących czynności:

  • Przechodzenie do pliku albo strony sieci Web w sieci, intranet lub Internecie

  • Przechodzenie do pliku lub strony sieci Web, która ma zostać utworzona w przyszłości

  • Wysyłanie wiadomości e-mail

  • Uruchamianie transferu pliku, na przykład pobierania pliku z sieci lub sesji protokołu FTP

Po wskazaniu tekstu lub obrazu zawierającego hiperlink wskaźnik myszy przybiera kształt dłoni Wskaźnik w kształcie dłoni , co oznacza, że wskazywany element można kliknąć.

Co to jest i jak działa adres URL

Gdy jest tworzony hiperlink, jego miejsce docelowe jest kodowane jako adres URL, taki jak:

http://example.microsoft.com/wiadomosci.htm

file://NazwaKomputera/FolderUdostepniony/NazwaPliku.htm

Adres URL zawiera protokół, na przykład HTTP, FTP lub FILE, lokalizację serwera sieci Web albo lokalizację sieciową, a także ścieżkę i nazwę pliku. Na poniższej ilustracji określono części adresu URL:

Cztery składniki adresu URL

1. Używany protokół (http, ftp, file)

2. Serwer sieci Web lub lokalizacja sieciowa

3. Ścieżka

4. Nazwa pliku

Hiperlinki bezwzględne i względne

Bezwzględny adres URL zawiera pełny adres, z takimi elementami jak protokół, serwer sieci Web oraz ścieżka i nazwa pliku.

We względnym adresie URL brak jednej lub kilku części. Brakujące informacje są uzyskiwane ze strony zawierającej dany adres URL. Na przykład, gdy brak protokołu i serwera sieci Web, przeglądarka sieci Web używa protokołu i domeny, takiej jak com, org albo edu, bieżącej strony.

W sieci Web powszechne jest używanie względnych adresów URL, które zawierają jedynie częściową ścieżkę i nazwę pliku. Jeśli pliki zostaną przeniesione na inny serwer, wszelkie hiperlinki nadal będą działać, o ile względne lokalizacje stron pozostaną niezmienione. Na przykład hiperlink na stronie sieci Web Produkty.htm wskazuje stronę o nazwie Jablko.htm w folderze o nazwie Jedzenie. Jeśli obie te strony zostaną przeniesione do folderu o nazwie Jedzenie na innym serwerze, adres URL w hiperlinku nadal będzie prawidłowy.

Domyślnie nieokreślone ścieżki do plików docelowych hiperlinków są definiowane względem lokalizacji aktywnego skoroszytu. Można ustawić inny domyślny adres podstawowy, dzięki czemu po każdym utworzeniu hiperlinku do pliku w danej lokalizacji trzeba będzie określić w oknie dialogowym Wstawianie hiperłącza jedynie nazwę pliku, a nie ścieżkę.

Początek strony

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel.

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Funkcje wyszukiwania i adresu

Funkcje programu Excel (alfabetycznie)

Funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×