Formanty tabeli przestawnej i wykresu nie działają w programie Access 2007

Objawy

Gdy baza danych w formacie programu Microsoft Office Access 2003 lub starszej wersji jest otwierana w programie Access 2007, pojawia się jeden z następujących komunikatów:

  • Baza danych lub projekt programu Microsoft Office Access zawiera uszkodzone odwołanie do pliku '0WC10.DLL' wersja 1.0 lub brakuje tego pliku.

  • Baza danych lub projekt programu Microsoft Office Access zawiera uszkodzone odwołanie (lub odwołanie nie istnieje) do pliku '0WC11.DLL' wersja 1.0.

Program Access 2007 otwiera plik bazy danych, ale żadne formanty tabeli przestawnej lub formanty wykresu pakietu Microsoft Office znajdujące się w formularzach, raportach lub stronach dostępu do danych nie działają. Dodatkowo podczas otwierania obiektu, który zawiera formant tabeli przestawnej lub wykresu, program Access może wyświetlić komunikat „W tym formancie nie ma żadnego obiektu”.

Przyczyna

Baza danych zawiera co najmniej jeden formant utworzony przy użyciu składników sieci Web pakietu Microsoft Office 2003 lub starszej wersji. Domyślnie program Access 2007 nie instaluje tych wersji składników sieci Web pakietu Microsoft Office. Dlatego odwołanie do tych plików jest uszkodzone i formanty nie działają.

Uwaga : Problem opisany w tym artykule dotyczy formantów tabeli przestawnej lub wykresu, które można dodawać do formularza, raportu lub strony dostępu do danych. Natomiast widoki tabeli przestawnej i wykresu przestawnego utworzone dla obiektów w programie Access 2003 i starszych wersjach działają w programie Access 2007. Te widoki są dostępne po kliknięciu przycisku Widok na karcie Narzędzia główne i kliknięciu pozycji Widok tabeli przestawnej lub Widok wykresu przestawnego.

Gdy formanty takie jak formant tabeli przestawnej pakietu Microsoft Office są dodawane do formularza, raportu lub strony dostępu do danych, program Access tworzy odwołania do biblioteka dołączana dynamicznie, które obsługują te formanty. Nowsze wersje programu Access mogą nie zawierać wszystkich plików dll potrzebnych dla formantów dodanych podczas pracy z bazą danych w starszych wersjach programu Access. W takim przypadku konieczne jest oddzielne pobranie tych plików dll i zainstalowanie ich, aby można było w dalszym ciągu używać formantów, które zależą od tych bibliotek. Domyślnie program Access 2007 nie instaluje wersji 10.0 ani wersji 11.0 składników sieci Web pakietu Microsoft Office.

Poniższa lista przedstawia przykładowe formanty, których dotyczy ten problem:

  • Wykres Microsoft Office 10.0

  • Wykres Microsoft Office 11.0

  • Tabela przestawna Microsoft Office 10.0

  • Tabela przestawna Microsoft Office 11.0

Rozwiązanie

Aby program Access 2007 poprawnie wyświetlał formanty tabeli przestawnej i wykresu przestawnego w starszej wersji, konieczne jest pobranie i zainstalowanie odpowiednich plików dll. W poniższych procedurach opisano sposób określania potrzebnych plików oraz pobierania i instalowania ich.

Określanie brakujących odwołań

  1. Otwórz bazę danych w programie Access 2007.

  2. Wykonaj jedną z poniższych czynności, aby otworzyć Edytor Visual Basic:

    • Otwórz istniejący moduł, klikając go dwukrotnie w okienku nawigacji.

    • Na karcie Tworzenie w grupie Inne kliknij przycisk Moduł. Jeśli to polecenie jest niedostępne, kliknij strzałkę poniżej przycisku Makro lub Moduł klasy, a następnie kliknij polecenie Moduł.

  3. W Edytorze Visual Basic w menu Tools (Narzędzia) kliknij polecenie References (Odwołania).

  4. W oknie dialogowym References w obszarze Available References (Dostępne odwołania), wyszukaj odwołania z oznaczeniem MISSING (Brakujące).

    • Jeśli brakuje składników sieci Web pakietu Microsoft Office w wersji 10.0 lub 11.0, użyj następującej procedury, aby pobrać i zainstalować wymagany plik dll.

Pobieranie i instalowanie wymaganego pliku

  1. Wyszukaj w witrynie Centrum pobierania firmy Microsoft plik owc10.exe lub owc11.exe zależnie od tego, która wersja została ustalona jako brakująca w poprzedniej procedurze.

  2. Postępuj zgodnie z instrukcjami wyświetlanymi w Centrum pobierania, aby pobrać i zainstalować plik. Zwróć uwagę, że możesz zapisać plik exe na swoim komputerze, a następnie uruchomić go, aby zainstalować plik dll, lub możesz kliknąć przycisk Uruchom, aby zainstalować plik dll bezpośrednio z poziomu Centrum pobierania.

  3. Po zakończeniu instalacji zamknij aplikację bazy danych programu Access i otwórz ją ponownie, aby sprawdzić, czy formanty działają zgodnie z oczekiwaniami.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×