Filtrowanie danych w bazie danych dla komputerów stacjonarnych

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Aby zastosować filtr, kliknij prawym przyciskiem myszy pole lub kontrolkę, dla której ma zostać użyte filtrowanie, a następnie wybierz polecenie filtrowania w dolnej części wyświetlonego menu. W celu użycia konkretnej wartości jako podstawy filtru zaznacz wartość, kliknij ją prawym przyciskiem myszy i wybierz polecenie filtrowania. Dostępne opcje filtrowania zależą od typu danych użytego w danym polu. Poniżej przedstawiono opcje filtrowania dla pola tekstowego o wartości hello world:

Menu kontekstowe zawierające polecenia filtrowania dla pola tekstowego

Filtry umożliwiają wyświetlenie określonych rekordów w formularzu, raporcie, kwerendzie lub arkuszu danych, a także wydrukowanie tylko wybranych rekordów z raportu, tabeli lub kwerendy. Przy użyciu filtru można ograniczyć ilość danych w widoku bez konieczności zmieniania projektu obiektu źródłowego.

W tym artykule wyjaśniono, jak zastosować, zapisywanie i usuwanie filtrów pulpitu bazy danych programu Access. Aby uzyskać informacje na temat filtrowania w aplikacji programu Access zobacz Filtrowanie danych z programu Access 2013wpis w blogu. Aby uzyskać więcej informacji o dostępie aplikacje ogólnie, zobacz artykuł Tworzenie aplikacji programu Access.

W tym artykule

Informacje o filtrowaniu

Różne sposoby filtrowania

Przełączanie się między filtrowanym i niefiltrowanym widokiem danych

Czyszczenie filtru

Zapisywanie i automatyczne stosowanie filtru

Informacje o filtrowaniu

Ograniczanie zakresu wyświetlanych danych to podstawowe zadanie związane z korzystaniem z bazy danych. Jednym ze sposobów jego realizacji jest filtrowanie, jednak niekiedy lepszym rozwiązaniem jest użycie kwerendy. W przypadku podjęcia decyzji o zastosowaniu filtru są dostępne różne możliwości: użycie typowych filtrów, filtrowanie według zaznaczenia i filtrowanie według formularza.

Kiedy należy użyć kwerendy?

W niektórych sytuacjach, gdy zachodzi potrzeba ograniczenia wyświetlanych danych, lepszym rozwiązaniem od filtrowania jest zastosowanie kwerendy. Jej utworzenie wymaga nieco pracy — trzeba otworzyć projektanta kwerend, dodać tabele itd. — jednak wykonanie tych czynności pozwala uzyskać nowe źródło danych, które może być używane w formularzach, raportach, innych kwerendach i dowolnych miejscach pozwalających na korzystanie ze źródeł danych. Użycie kwerendy warto rozważyć w następujących przypadkach:

  • Planowane jest wielokrotne użycie tego samego ograniczonego zestawu danych — również dla więcej niż jednego obiektu. Filtr można zapisać, usunąć i zastosować ponownie, ale nie jest możliwe jego użycie w odniesieniu do obiektu innego niż ten, dla którego został utworzony.

  • Zachodzi konieczność jednoczesnego uwzględnienia wielu możliwości — wielu alternatywnych zestawów kryteriów. Co prawda ten cel można osiągnąć, korzystając z funkcji Filtruj według formularza, jednak w przeciwieństwie do niej kwerenda umożliwia wyświetlenie wszystkich zestawów kryteriów w tym samym czasie zamiast na oddzielnych kartach.

Filtry obsługują różne typy danych

Istnieją różne rodzaje filtrów. Niektóre mają zastosowanie tylko do jednego typu danych, podczas gdy inne mogą być używane z wieloma typami. Rodzaj dostępnych do użycia filtrów zależy od typu i wartości filtrowanego pola. Poniżej przedstawiono ilustrację typowych filtrów dostępnych dla danych typu Data/godzina.

Filtrowanie pola daty

1. Typowe filtry dla danych typu Data/godzina

2. Filtr Wszystkie daty w okresie jest dostępny tylko dla danych typu Data/godzina. Ignoruje on część wartości dat dotyczącą dnia i roku.

Ponowne użycie filtru

Jeśli obiekt zostanie zapisany z zastosowanym filtrem, filtr ten stanie się dostępny po następnym otwarciu obiektu. Właściwość FiltrujPrzyŁadowaniu umożliwia sterowanie stosowaniem filtru podczas otwierania obiektu.

Aby móc ponownie użyć filtru w połączeniu z innymi obiektami bazy danych, możesz go zapisać jako kwerendę.

Początek strony

Różne sposoby filtrowania

Istnieją trzy główne sposoby filtrowania:

  • Typowe filtry    — Zawsze dostępne typowe filtry umożliwiają wybieranie wartości z danych do filtrowania oraz udostępniają zestaw wbudowanych filtrów porównawczych, takich jak filtr Zawiera.

  • Filtrowanie według zaznaczenia    — Ta metoda, również zawsze na wyciągnięcie ręki, sprawdza się dobrze po znalezieniu wartości, która ma zostać użyta jako filtr.

  • Filtrowanie według formularza — W razie potrzeby jednoczesnego zastosowania całego zestawu filtrów funkcja Filtruj według formularza zapewnia dodatkową kontrolę nad tym procesem.

Typowe filtry

Typowe filtry, wbudowane dla większości typów danych, udostępniają podstawowe funkcje filtrowania określonego typu danych. Na przykład podczas filtrowania danych o typie Data/godzina możesz użyć typowego filtru Przed w celu wykluczenia dat równych określonej dacie lub od niej późniejszych.

Uwaga : Typowe filtry działają dla jednego pola naraz. Aby filtrować wiele pól lub kontrolek, można zastosować filtr po kolei dla każdego z nich albo użyć opcji filtru zaawansowanego.

Stosowanie typowego filtru    Kliknij nagłówek pola, które chcesz filtrować. Zostanie wyświetlone menu z typowymi filtrami u dołu.

Typowe filtry dat
Typowe filtry dla danych typu Data/godzina

1. Aby filtrować określone wartości, użyj listy pól wyboru. Zawiera ona wszystkie wartości, które są obecnie przechowywane w polu.

2. Aby filtrować zakres wartości, kliknij filtr porównania i określ wymagane wartości.

Wskazówki dotyczące typowych filtrów

  • Aby filtrować listę wartości na podstawie jednej lub kilku wartości, wyczyść (Zaznacz wszystko) zaznacz pole, a następnie zaznacz żądane wartości.

  • Aby odfiltrować wartości null (wyświetlania rekordów w przypadku, gdy nie ma żadnych danych dla filtrowanego pola), wyczyść (Zaznacz wszystko) zaznacz pole, a następnie zaznacz pole wyboru obok pozycji (puste).

  • W celu zmniejszenia szczegółowości typowego filtru możesz w nim użyć symboli wieloznacznych — na przykład symbol wieloznaczny gwiazdki (*) umożliwia dopasowanie dowolnego ciągu znaków. Korzystając z tego symbolu, można użyć typowego filtru Równa się w polu Imię w celu określenia ciągu filtru T*mek pozwalającego dopasować imiona Tomek i Tymek.

  • Jeśli filtr ma zawierać symbol wieloznaczny pozbawiony opisanego wyżej działania (zwykły znak), należy umieścić ten symbol w nawiasie kwadratowym.

Dlaczego nie widać typowych filtrów?

Typowe filtry nie są dostępne w następujących okolicznościach:

  • Filtry specyficzne dla danych nie są dostępne w przypadku pól typu Tak/Nie, Obiekt OLE i Załącznik.

  • Lista wartości nie jest dostępna w przypadku pól typu Nota.

  • Typowe filtry nie są w ogóle dostępne w widokach innych niż widok arkusza danych, formularza, raportu i układu.

Filtrowanie według zaznaczenia

Aby zastosować filtr oparty na zaznaczonej obecnie wartości, kliknij kartę Narzędzia główne na wstążce, a następnie w grupie Sortowanie i filtrowanie kliknij pozycję Zaznaczenie. Zostanie wyświetlona lista rozwijana zawierająca dostępne opcje filtrowania. Podobnie jak w przypadku typowych filtrów, opcje filtrowania według zaznaczenia zależą od typu danych. W celu filtrowania według zaznaczenia można również kliknąć prawym przyciskiem myszy zaznaczoną wartość.

Menu Filtruj według zaznaczenia

Filtrowanie według formularza

W celu filtrowania na podstawie wypełnianego formularza na karcie Narzędzia główne w grupie Sortowanie i filtrowanie kliknij pozycję Zaawansowane, a następnie kliknij pozycję Filtruj według formularza. Podczas filtrowania według formularza program Access tworzy pusty formularz, który odpowiada filtrowanemu formularzowi i umożliwia wypełnienie dowolnej liczby pól. Po wprowadzeniu żądanych informacji program Access wyszukuje zgodne rekordy. Ta funkcja jest przydatna w przypadku filtrowania na podstawie wartości wielu pól. Poniżej przedstawiono prosty przykład użycia funkcji Filtruj według formularza:

Filtrowanie według formularza

Uwaga : W przypadku użycia funkcji Filtruj według formularza nie można określić wartości pól wielowartościowych ani pól o typie danych Nota, Hiperłącze, Tak/Nie i Obiekt OLE.

Dodawanie alternatywnych wartości filtru według formularza przy użyciu karty Lub

Aby dodać innego zestawu wartości do używania filtrowania, kliknij kartę lub u dołu Filtruj według formularza — zostanie otwarty pusty formularz nowego służących do filtrowania. Zawsze możesz użyć karty lub program Access utworzy inny; istnieje zawsze nieużywane lub tab na Filtruj według formularza. Jeśli znasz wiele zestawów wartości przy użyciu Filtruj według formularza, rekordy, które spełniają dowolny zestaw są uwzględniane. Innymi słowy, tym bardziej lub karty można używać większej ilości danych będzie zawierać filtr.

Filtr/sortowanie zaawansowane

W niektórych sytuacjach może być potrzebny filtr o możliwościach większych niż oferowane przez inne metody filtrowania i pozwalający na samodzielne napisanie kryteriów filtrowania. Możesz wtedy użyć funkcji Filtr/sortowanie zaawansowane — korzystanie z niej przypomina projektowanie kwerendy.

  1. Otwórz tabelę, kwerendę, formularz lub raport w jednym z następujących widoków: Arkusz danych, Formularz, Raport lub Układ.

  2. Upewnij się, że widok nie jest odfiltrowany. Na pasku nawigatora rekordów sprawdź, czy jest wyświetlany wygaszony (niedostępny) przycisk Bez filtru. Jeśli pasek nawigatora rekordów nie jest widoczny, kliknij przycisk Zaawansowane w grupie Sortowanie i filtrowanie na karcie Narzędzia główne, a następnie kliknij polecenie Wyczyść wszystkie filtry. Jeśli polecenie Wyczyść wszystkie filtry jest wygaszone, oznacza to, że nie działają żadne filtry.

  3. Na wstążce kliknij dla użytkowników domowych, następnie w Sortuj i Filtruj kliknij grupę , a następnie kliknij pozycję Zaawansowane;Filtr/sortowanie zaawansowane.

  4. Dodaj do siatki pola, które chcesz filtrować.

  5. W wierszu Kryteria każdego pola określ kryterium. Kryteria są stosowane jako zestaw i wyświetlane są tylko te rekordy, które spełniają wszystkie kryteria w wierszu Kryteria. Aby określić dla jednego pola kryteria alternatywne, wpisz pierwsze kryterium w wierszu Kryteria, a drugie kryterium wpisz w wierszu Lub i tak dalej.

    Porady : 

    • Cały zestaw kryteriów w wierszu Lub jest stosowany jako alternatywa dla zestawu kryteriów w wierszu Kryteria. Kryterium, które powinno być stosowane w obu zestawach, należy wpisać zarówno w wierszu Kryteria, jak i w wierszu Lub. Aby wyświetlić filtrowane wiersze, należy kliknąć przycisk Przełącz filtr.

    • Dobrym sposobem Dowiedz się, jak napisać kryteriów jest stosowanie filtru wspólnego lub filtru opartego na zaznaczeniu, który zwraca wynik, który jest zbliżony szukany element. Następnie, stosując filtr do widoku, wyświetlać karta obiektu filtru

Specjalne polecenia na karcie dokumentu Filtrowanie

Są dwa specjalne polecenia dostępne na karty Filtr dokumentu. Po kliknięciu prawym przyciskiem myszy dowolne miejsce powyżej siatki projektu na karcie Załaduj z kwerendy i polecenia Zapisz jako kwerendę są dostępne w menu skrótów.

Specjalne opcje filtrów

Polecenie Załaduj z kwerendy powoduje załadowanie projektu wybranej kwerendy do siatki. Dzięki temu kryteriów kwerendy można używać jako kryteriów filtru.

Polecenie Zapisz jako kwerendę umożliwia zapisanie ustawień filtru w postaci nowej kwerendy.

Początek strony

Przełączanie się między filtrowanym i niefiltrowanym widokiem danych

Aby przełączyć się do niefiltrowanego widoku danych, kliknij pozycję Filtrowane na pasku nawigatora rekordów.

Przełącznik filtru na pasku nawigatora rekordów

Aby z powrotem przełączyć się do widoku filtrowanego, kliknij pozycję Bez filtrowania na pasku nawigatora rekordów.

Początek strony

Czyszczenie filtru

Wyczyszczenie filtru powoduje usunięcie go i uniemożliwia jego ponowne zastosowanie przez kliknięcie pozycji Bez filtrowania — w tym celu filtr należy utworzyć ponownie. Można wyczyścić jeden filtr z jednego pola lub wszystkie filtry ze wszystkich pól w widoku.

  • Czyszczenie jednego filtru    Kliknij prawym przyciskiem myszy filtrowaną pozycję, a następnie kliknij polecenie Wyczyść filtr z nazwa pola.

  • Czyszczenie wszystkich filtrów    Na dla użytkowników domowych karcie w grupa Sortowanie i filtrowanie, kliknij przycisk Zaawansowane, a następnie kliknij pozycję Wyczyść wszystkie filtry.

Początek strony

Zapisywanie i automatyczne stosowanie filtru

Po zamknięciu tabeli, kwerendy, formularza lub raportu i filtr jest w miejscu filtr jest zapisywany z obiektu. Przy następnym otwarciu obiektu niefiltrowanym dane są wyświetlane, ale zapisany filtr jest dostępny dla stosowanie — po prostu Przełącz do widoku filtrowane, klikając pozycję bez filtrowania na pasku Nawigatora rekordów. Filtr zastosowany po otwarciu obiektu, należy ustawić właściwość FilterOnLoad do Tak.

Uwaga : Ustawienie właściwości FilterOnLoad jest stosowane tylko podczas ładowania obiektu. Ustawienie tej właściwości dla obiektu w widoku projektu, a następnie przełączać się do innego widoku nie spowoduje to ustawienie, które mają być stosowane. Po zamknięciu i ponownym otwarciu obiektu zmian ustawienie właściwości FilterOnLoad została uwzględniona.

Zapisywanie filtru jako kwerendy

Aby zapisać filtr jako kwerendę (i uzyskać możliwość jego zastosowania do innych obiektów), użyj funkcji Filtr/sortowanie zaawansowane: na wstążce kliknij kartę Narzędzia główne, a następnie w grupie Sortowanie i filtrowanie kliknij kolejno pozycję Zaawansowane i pozycję Filtr/sortowanie zaawansowane. Skonfiguruj filtr w żądany sposób, kliknij prawym przyciskiem myszy puste miejsce na karcie Filtr, a następnie kliknij polecenie Zapisz jako kwerendę.

Menu kontekstowe w oknie Filtr/sortowanie zaawansowane

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×