Dodawanie, usuwanie lub aktualizowanie plików zasobów w szablonie formularza

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Plik zasobów to plik służący do wyświetlania dodatkowych informacji w szablonie formularza. Podczas zapisywania lub publikowania szablonu formularza wszystkie pliki zasobów są dołączane do szablonu.

Do szablonu formularza można dodać pliki zasobów następujących typów:

Pliki HTML    Przy użyciu plików HTML można wyświetlać informacje w niestandardowe okienko zadań.

Uwaga : Gdy plik HTML jest dodawany jako plik zasobów do szablonu formularza, należy również dodać wszystkie pliki, których wymaga dodawany plik, na przykład inne pliki HTML, arkusze stylów lub pliki graficzne.

Pliki XML    Przy użyciu plików XML można wypełniać formanty typu pole listy, pole kombi lub pole listy rozwijanej. Jeśli dane w formancie pola listy, pola kombi lub pola listy rozwijanej są stałe, można umieścić te dane w pliku XML i dodać ten plik do szablonu formularza jako plik zasobów, a nie wypełniać tych formantów za pomocą połączenie danych. W przypadku użycia pliku zasobów formularze oparte na danym szablonie formularza są otwierane szybciej niż formularze, w których te formanty są wypełniane za pomocą połączenia danych. Dzieje się tak, ponieważ dane w pliku zasobów są traktowane jako część szablonu formularza i do ich pobrania nie jest potrzebne połączenie danych. Jeśli szablon formularza nie jest skonfigurowany w taki sposób, aby przechowywał dane z zewnętrznego źródła danych, to do pobrania wymaganych danych jest potrzebne połączenie formularza z siecią. Plik zasobów nie wymaga połączenia danych, ponieważ dane są już częścią formularza.

Co chcesz zrobić?

Dodawanie pliku zasobów do szablonu formularza

Usuwanie pliku zasobów z szablonu formularza

Aktualizowanie pliku zasobów w szablonie formularza

Dodawanie pliku zasobów do szablonu formularza

  1. W menu Narzędzia kliknij polecenie Pliki zasobów.

  2. W oknie dialogowym Pliki zasobów kliknij przycisk Dodaj.

  3. W oknie dialogowym Dodawanie pliku zaznacz plik, który chcesz dodać.

Początek strony

Usuwanie pliku zasobów z szablonu formularza

  1. W menu Narzędzia kliknij polecenie Pliki zasobów.

  2. Na liście Pliki zasobów w szablonie formularza w oknie dialogowym Pliki zasobów zaznacz plik zasobów, który chcesz usunąć z szablonu formularza.

  3. Kliknij przycisk Usuń.

Początek strony

Aktualizowanie pliku zasobów w szablonie formularza

Plik zasobów zawarty w szablonie formularza można zaktualizować po opublikowaniu tego szablonu. Może na przykład wystąpić potrzeba dodania nowych elementów lub usunięcia istniejących elementów z pliku zasobów, przy użyciu którego wypełniany jest formant pola listy w szablonie formularza. Aby zaktualizować plik zasobów, należy zmodyfikować kopię tego pliku, a następnie dodać zaktualizowany plik zasobów do szablonu formularza. Dodanie zaktualizowanego pliku zasobów do szablonu formularza powoduje w rzeczywistości zastąpienie istniejącego pliku zasobów. Po dodaniu zaktualizowanego pliku zasobów należy ponownie opublikować szablon formularza. Dzięki temu użytkownicy uzyskają zaktualizowany plik zasobów, gdy odtworzą nowy, pusty formularz oparty na danym szablonie formularza.

  1. Wprowadź wymagane zmiany w lokalnej kopii pliku zasobów.

    Porada : W przypadku braku lokalnej kopii pliku zasobów można ją wyodrębnić z szablonu formularza. Aby uzyskać więcej informacji o wyodrębnianiu plików z szablonu formularza, skorzystaj z łączy dostępnych w sekcji Zobacz też.

  2. W trybie projektowania programu InfoPath otwórz szablon formularza, z którym jest skojarzony plik zasobów.

  3. W menu Narzędzia kliknij polecenie Pliki zasobów.

  4. W oknie dialogowym Pliki zasobów kliknij przycisk Dodaj.

  5. W oknie dialogowym Dodawanie pliku zaznacz zaktualizowany plik, a następnie kliknij przycisk OK.

  6. W oknie dialogowym Microsoft Office InfoPath kliknij pozycję Zastąp istniejący plik, a następnie kliknij przycisk OK.

  7. W oknie dialogowym Pliki zasobów kliknij przycisk OK.

  8. Aby opublikować szablon formularza, w menu Plik kliknij polecenie Publikuj, a następnie postępuj zgodnie z instrukcjami Kreatora publikowania.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×