Dodawanie strony do witryny programu SharePoint

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W tym temacie wyjaśniono, jak za pomocą opcji w oknie dialogowym Nowy Dodawanie strony z istniejącą witryną programu Microsoft SharePoint, a także jak zmienić typ stronie Microsoft Office SharePoint Designer 2007 dodaje domyślnie po kliknięciu pozycji Nowy dokument Obraz przycisku na pasku narzędzi typowych lub naciśnij klawisze CTRL + N.

Dodawanie strony do witryny programu SharePoint wymaga posiadania właściwych uprawnień. Jeżeli dodanie strony do witryny jest niemożliwe, należy skontaktować się z administratorem serwera.

W tym artykule

Jakiego rodzaju strony należy wybrać?

Dodawanie strony do witryny programu SharePoint

Zmienianie domyślnego typu strony

Jakiego typu strony należy użyć?

Przy użyciu technologii Microsoft ASP.NET 2.0 Windows SharePoint Services 3.0 witryny mogą obsługiwać pełni interakcyjnych i wspólnej zawartości (na przykład niestandardowych widoków danych) w sposób tego więcej statyczne witryn HTML, na przykład, nie. Strony można dodać do witryny programu SharePoint, prawie zawsze chcesz dodać na stronie ASP.NET (ASPX), ponieważ stronach ASPX funkcji pełny zakres programu SharePoint. Z tego powodu strona ASPX to ustawienia domyślne dla nowych stron w witrynie programu SharePoint po kliknięciu pozycji Nowy dokument Obraz przycisku na pasku narzędzi typowych lub naciśnij klawisze CTRL + N.

Strony wzorcowe programu ASP.NET także obsługują elementy i funkcje programu SharePoint w sposób, którego nie obsługują strony szablonów oparte na języku HTML (takie jak dynamiczne szablony witryn sieci Web), więc zaleca się używanie stron wzorcowych, jeśli witryna programu SharePoint ma zawierać kilka stron o podobnym wyglądzie i charakterze.

W poniższej tabeli przedstawiono typy stron najczęściej dodawanych podczas pracy z witryną programu SharePoint.

Typ strony

Opis

Strona programu ASP.NET (ASPX)

Pozwala dodać pustą stronę ASPX, która umożliwia wstawianie elementów i dostosowywanie.

Strona wzorcowa

Pozwala dodać stronę programu ASP.NET o rozszerzeniu nazwy pliku master zamiast aspx. Po utworzeniu i zapisaniu nowej strony wzorcowej można użyć opcji Utwórz na podstawie strony wzorcowej w celu dodania stron opartych na tej stronie wzorcowej.

Aby uzyskać więcej informacji na temat stron wzorcowych zobacz artykuł Wprowadzenie do stron wzorcowych ASP.NET.

Strona oparta na istniejącej stronie wzorcowej

Pozwala dodać stronę ASPX opartą na utworzonej wcześniej stronie wzorcowej, która jest aktualizowana na podstawie wszelkich zmian wyglądu i zachowania strony wzorcowej.

Aby uzyskać więcej informacji na temat stron wzorcowych zobacz artykuł Wprowadzenie do stron wzorcowych ASP.NET.

Strona widoku listy

Pozwala dodać stronę ASPX zawierającą nowy widok istniejącej listy lub biblioteki dokumentów. Strona widoku zawiera elementy strony, takie jak paski tytułu, menu i kolumny.

Strona składników Web Part

Pozwala dodać stronę ASPX ze wstępnie zaprojektowanym układem składającym się ze stref składników Web Part, do których można wstawiać składniki Web Part.

Początek strony

Dodawanie strony do witryny programu SharePoint

Istnieje możliwość szybkiego dodania strony domyślnego typu. Można też użyć okna dialogowego Nowy w celu wybrania dowolnego dostępnego typu strony.

Aby dodać stronę do witryny programu SharePoint, użytkownik musi być członkiem grupy witryny z uprawnieniami do dodawania i dostosowywania stron. Te uprawnienia są domyślnie zawarte w uprawnieniach poziomu Pełna kontrola i poziomu Projektant.

Dodawanie strony domyślnego typu

Dla witryny programu SharePoint domyślny typ strony jest strona ASPX. Aby zmienić to ustawienie, zobacz Zmienianie domyślnego typu strony w dalszej części tego artykułu.

  1. Otwórz w programie Office SharePoint Designer 2007 witrynę, do której chcesz dodać nową stronę.

  2. Kliknij przycisk Nowy dokument Obraz przycisku na typowych narzędzi, lub naciśnij klawisze CTRL + N.

    Nowa, niezapisana strona zostanie dodana do bieżącej witryny.

  3. W menu Plik kliknij polecenie Zapisz lub naciśnij klawisze CTRL+S.

  4. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej strony w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.

Dodawanie strony dowolnego typu

  1. Otwórz w programie Office SharePoint Designer 2007 witrynę, do której chcesz dodać nową stronę.

  2. W menu Plik kliknij polecenie Nowy.

    Zostanie otwarte okno dialogowe Nowy.

    Karta Strona w oknie dialogowym Nowy

  3. Na karcie Strona w okienku po lewej kliknij kategorię strony, którą chcesz dodać.

  4. W środkowym okienku kliknij typ strony, którą chcesz dodać.

  5. Wprowadź odpowiednie zmiany w obszarze Opcje.

    Na przykład dla stron programu ASP.NET, takich jak strona ASPX i strona wzorcowa, można zmienić język programowania zawarty w dyrektywie strony.

  6. Kliknij przycisk OK, aby dodać stronę.

    Uwaga : W przypadku niektórych typów stron w tym momencie należy użyć dodatkowego kreatora lub wypełnić okno dialogowe.

    Nowa, niezapisana strona zostanie dodana do bieżącej witryny.

  7. W menu Plik kliknij polecenie Zapisz lub naciśnij klawisze CTRL+S.

  8. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej strony w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.

Początek strony

Zmienianie domyślnego typu strony

Po kliknięciu pozycji Nowy dokument Obraz przycisku na pasku narzędzi typowych lub naciśnij klawisze CTRL + N, możesz dodać nową stronę domyślny typ strony. Możesz zmienić domyślny typ strony, chociaż dla witryn programu SharePoint jest to zalecane zachowanie domyślne: dodawanie nowych stron ASPX, ponieważ takich stron funkcji pełny zakres programu SharePoint.

  1. W menu Narzędzia kliknij polecenie Opcje edytora stron.

    Porada : Podczas dodawania nowej strony można kliknąć łącze Opcje edytora stron w oknie dialogowym Nowy.

  2. W oknie dialogowym Opcje edytora stron kliknij kartę Autorstwo.

  3. W obszarze Domyślne typy dokumentów z listy Domyślny typ dokumentu programu SharePoint kliknij typ dokumentu, który chcesz ustawić jako domyślny.

  4. Kliknij przycisk OK.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×