Dodawanie przycisku przeznaczonego do przełączania widoków

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W programie Microsoft Office InfoPath można tworzyć różne widoki tego samego szablonu formularza. Widok jest alternatywny sposób wyświetlania danych w szablonie formularza. Podczas wypełniania formularzy na podstawie szablonu formularza użytkownicy przełączać się między widokami do wybierz zakres danych, który jest wyświetlany w formularzu. Na przykład w szablonie formularza raportu stanu, możesz zaprojektować widoku podsumowania oprócz szczegółowy widok. Użytkownicy mogą następnie wybrać widok chcą przeglądać w zależności od tego, jakiego rodzaju informacje są potrzebne.

Widoki są często przeznaczona do pracy z regułami. Reguły umożliwiają automatyczne wykonywanie określonych zadań w szablonie formularza w odpowiedzi na zdarzenia lub akcji zainicjowane przez osoby wypełniającej formularz. Na przykład w tym artykule opisano, jak można wstawić przycisk w szablonie formularza, a następnie utwórz regułę, która przełącza widoki, kliknięcie tego przycisku.

W tym artykule

Krok 1: Wstawianie przycisku w każdym widoku

Krok 2: Utwórz regułę, która przełącza widoki

Krok 3: Testowanie środowisko użytkownika

Krok 1: Wstawianie przycisku w każdym widoku

Uwaga : Aby wykonać poniższą procedurę, musisz mieć w dwóch widoków istniejącego szablonu formularza. Łącza do dodatkowych informacji na temat tworzenia widoków w sekcji Zobacz też.

  1. W menu Widok kliknij polecenie Zarządzaj widokami.

  2. W obszarze Wybierz widok kliknij widok, którego chcesz dodać przycisk.

  3. W szablonie formularza umieść kursor w miejscu, w którym chcesz wstawić przycisk.

  4. W menu Wstaw kliknij polecenie Więcej formantów lub naciśnij klawisze ALT + I C.

  5. W obszarze Wstaw kontrolki w okienku zadań formanty, kliknij przycisk.

  6. W szablonie formularza kliknij dwukrotnie wstawiony przycisk.

  7. Kliknij kartę Ogólne.

  8. W polu Etykieta wpisz tekst, który ma być wyświetlany na przycisku, a następnie kliknij przycisk OK.

  9. W menu Widok kliknij polecenie Zarządzaj widokami.

  10. W obszarze Wybierz widok kliknij nazwę drugiego widoku.

  11. Wykonaj kroki od 3 do 8, aby dodać przycisk do drugiego widoku.

Początek strony

Krok 2: Utwórz regułę, która przełącza widoki

Po dodaniu przycisków do każdego widoku w szablonie formularza, należy utworzyć reguły, które przełączanie widoków, gdy użytkownik kliknie tych przycisków.

  1. W menu Widok kliknij polecenie Zarządzaj widokami.

  2. W obszarze Wybierz widok kliknij widok, który chcesz pracować z.

  3. W szablonie formularza kliknij dwukrotnie przycisk wstawiony w poprzedniej procedurze.

  4. Kliknij kartę Ogólne.

  5. Na liście Akcja kliknij pozycję Reguły i kod niestandardowy.

  6. Kliknij przycisk Reguły.

  7. W oknie dialogowym Reguły kliknij przycisk Dodaj.

  8. W polu Nazwa wpisz nazwę dla reguły, takich jak Przełącz do widoku 2. Ta nazwa zostanie wyświetlona podczas pracy w widoku w trybie projektowania. Jednak nazwy nie są widoczne dla osoby wypełniającej formularz.

  9. Kliknij przycisk Dodaj akcję.

  10. Na liście Akcja kliknij pozycję Przełącz widoki.

  11. Na liście Widok kliknij widok, na który chcesz się przełączyć, a następnie kliknij przycisk OK.

  12. Kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

  13. W okienku zadań Widoki w obszarze Wybierz widok, kliknij drugi widok.

  14. Wykonaj kroki od 3 do 12, aby utworzyć regułę dla przycisku w drugim widoku.

Początek strony

Krok 3: Testowanie środowisko użytkownika

Po dodaniu przycisków widoków i niezbędne reguły utworzone, jest dobrym pomysłem, aby przetestować szablon formularza, aby upewnić się, że działa on zgodnie z oczekiwaniami.

  1. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

    Uwaga : Widok, który pracy w większości ostatnio jest widok, który będzie wyświetlany w oknie podglądu.

  2. Aby sprawdzić, czy przyciski służące do przełączania widoków działają poprawnie, kliknij przyciski utworzoną w poprzedniej procedurze.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×