Dodawanie połączenia danych za pomocą ustawień w bibliotece połączeń

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W tym artykule

Omówienie

Przed rozpoczęciem

Dodawanie połączenia danych kwerendy

Dodawanie połączenia przesyłania danych

Omówienie

Jeśli projektujesz kilka szablonów certyfikatów zawierających podobne połączenia danych, rozważ użycie plik połączenia danych zamiast tworzenia połączenia danych z zewnętrznego źródła danych dla każdego szablonu formularza. Dzięki temu musisz zaktualizować tylko jeden plik połączenia danych, gdy informacje o połączeniu danych dla zestaw szablonów powiązanym formularzu. Na przykład po przeniesieniu do sieci produkcyjnej szablonów formularzy z sieci test, należy zaktualizować dane ustawienia połączenia tylko raz w bibliotece połączeń zamiast aktualizowanie połączenia danych w szablonie formularza. Gdy formularz oparty na szablonie formularza, który używa plik połączenia danych jest używany połączenia danych, połączenia danych jest automatycznie zaktualizowane przy użyciu nowych ustawień.

Plik połączenia danych jest plikiem XML z rozszerzeniem pliku XML lub udcx, zawierający informacje o połączeniu dla pojedynczego zewnętrznego źródła danych. Ten plik jest przechowywany w bibliotece połączeń danych na serwerze z systemem Microsoft Office SharePoint Server 2007. Plik połączenia danych zostanie utworzony przez dewelopera lub konwertując połączenia danych w istniejącego szablonu formularza do pliku połączenia danych, klikając przycisk Konwertuj, w oknie dialogowym Połączenia danych (menuNarzędzia ).

Zalety korzystania z plikami połączeń danych obejmują:

  • Wiele formularzy można użyć tego samego pliku połączenia danych, dlatego nie trzeba utworzyć połączenie danych od podstaw dla każdego szablonu formularza.

  • W przypadku zmiany lokalizacji zewnętrznego źródła danych lub ustawień połączenia z tym źródłem wystarczy zaktualizować dane w pliku — nie jest wymagane modyfikowanie ustawień szablonu

  • Plik połączenia danych może zawierać informacje uwierzytelniające alternatywnego, który może być używany przez serwer, gdy użytkownik wypełnia formularza za pomocą przeglądarki sieci Web.

  • Formularze na podstawie szablonu formularza zgodnego z przeglądarkami, które są wypełnione w przeglądarce można nawiązać serwerów w innej domeny tylko w przypadku połączeń danych za pomocą plików połączenia danych.

Uwaga : Program Microsoft Office InfoPath używa plików połączeń danych, występujące po tym formacie plików 2.0 wersji uniwersalny połączenia danych. Ta wersja jest podzbiorem wersji 1.0 format używany przez program Microsoft Office FrontPage i Microsoft Office Excel. Program InfoPath nie można używać plików połączenia danych w wersji 1.0 formacie.

Gdy połączenie danych zostanie dodane do szablonu formularza za pomocą ustawień dostępnych w bibliotece połączeń danych, ma ono charakter pomocniczy. Różni się ono od głównego połączenia danych tworzonego na etapie projektowania szablonu formularza opartego na strukturze bazy danych czy usługi sieci Web albo na ustawieniach zdefiniowanych w bibliotece połączeń danych. Pomocnicze połączenie danych należy dodać tylko w przypadku, gdy nie udaje się przesyłanie albo pobieranie danych za pośrednictwem połączenia głównego.

Początek strony

Przed rozpoczęciem

Aby do szablonu formularza dodać połączenie danych za pomocą ustawień zapisanych w bibliotece połączeń danych, należy zwrócić się do administratora witryny o podanie następujących informacji:

  • Lokalizacja serwera z programem Microsoft Office SharePoint Server 2007, na którym znajduje się witryna zawierająca bibliotekę połączeń danych.

  • Nazwa należącego do biblioteki pliku połączenia danych, którego chcesz używać.

  • Informacja, czy plik połączenia danych zawiera ustawienia połączenia danych kwerendy lub połączenia przesyłania danych.

  • Informacja, czy w przypadku, gdy ustawienia dotyczą połączenia danych kwerendy, w szablonie formularza można skonfigurować opcje bezpiecznego przechowywania wyników tych kwerend w celu korzystania z nich w trybie offline.

Początek strony

Dodawanie połączenia danych kwerendy

Aby do szablonu formularza dodać połączenie danych za pomocą ustawień zapisanych w bibliotece połączeń, należy wykonać następującą procedurę:

  1. Dodanie pomocniczego połączenia danych do szablonu formularza

  2. Powiązanie formantów z kwerendą i polami danych w pomocniczym źródle danych

  3. Skonfigurowanie w szablonie formularza opcji używania połączenia danych za pomocą reguły lub przycisku

Krok 1: Dodawanie pomocniczego połączenia danych

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Wyszukaj połączenia na serwerze Microsoft Office SharePoint Server, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora na liście Witryna kliknij nazwę witryny znajdującej się na serwerze z programem Office SharePoint Server 2007 zawierającej bibliotekę połączeń.

    Mojej witryny nie ma na liście

    Aby dodać witrynę do listy, należy wykonać następujące czynności:

    1. Kliknij przycisk Zarządzaj witrynami.

    2. W oknie dialogowym Zarządzanie witrynami kliknij przycisk Dodaj.

    3. W polu adres URL wpisz lokalizację biblioteki połączeń danych.

    4. W polu Nazwa wyświetlana wpisz nazwę biblioteki połączeń danych. Ta nazwa będzie wyświetlana na liście w Kreatorze połączenia danych.

    5. Kliknij przycisk OK.

    6. Kliknij przycisk Zamknij.

  5. Kliknij nazwę biblioteki połączeń danych, aby wyświetlić listę plików połączeń danych, kliknij nazwę pliku połączenia danych, który ma być używany dla tego połączenia danych, a następnie kliknij przycisk Dalej.

  6. Zależnie od ustawień istniejących w pliku połączenia danych na następnej stronie kreatora może się pojawić monit o podanie przykładowych wartości dla wszystkich parametrów.

    Jak wprowadzić przykładowe wartości?

    1. Wybierz parametr w tabeli Parametry, a następnie kliknij Ustaw przykładową wartość.

    2. W polu wartość próbki wpisz wartość, że użytkownika może użyć dla tego pola, a następnie kliknij przycisk OK.

    3. Powtórz te czynności dla każdego parametru w tabeli Parametry, a następnie kliknij przycisk Dalej.

    Uwaga techniczna

    Po skonfigurowaniu połączenia danych z usługi sieci Web w Kreatorze połączenia danych programu Microsoft Office InfoPath nawiązuje połączenie z usługą sieci Web i żąda pliku Web Service Description Language (WSDL). Plik języka WSDL zawiera schematu używane przez usługę sieci Web. Usługa sieci Web odpowiada na żądanie, wysyłając ten plik do programu InfoPath. Program InfoPath używa informacji w tym pliku dodać odpowiednie pola i grupy do pomocnicze źródło danych w szablonie formularza. Jeśli program InfoPath znajdzie typu nieznany element w pliku WSDL, InfoPath używa przykładowych danych w celu określenia definicji typu nieznany element i następnie dodaje odpowiednich pól i grup pomocnicze źródło danych.

  7. Jeżeli wyniki kwerendy mają być dostępne w czasie, gdy formularz nie jest połączony z siecią, należy zaznaczyć pole wyboru Przechowuj kopię danych w szablonie formularza.

    Uwaga dotycząca zabezpieczeń : Zaznaczenie tego pola wyboru przechowuje wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, jest dostępny w formularzach, które wypełniania przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli występują poufne dane z tego połączenia danych, można wyłączyć tę funkcję w celu ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież.

  8. Kliknij przycisk Dalej.

    Następna strona kreatora będzie zawierała zestawienie ustawień połączenia danych.

  9. Wprowadź opisową nazwę połączenia danych. Będzie ona wyświetlana w okienku zadań Źródło danych na liście Źródło danych.

  10. Jeśli formularze oparte na szablonie po otwarciu mają używać tego połączenia danych, zaznacz pole wyboru Automatycznie pobierz dane podczas otwierania formularza.

Początek strony

Krok 2: Dodawanie formantu, w którym dane będą wyświetlane użytkownikom

  1. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  2. Przeciągnij formant na szablon formularza.

  3. W oknie dialogowym Powiązanie formantu Formant zaznacz pole, z którym chcesz powiązać formant, a następnie kliknij przycisk OK.

Krok 3: Konfigurowanie w ustawieniach szablonu formularza opcji korzystania z nowo utworzonego połączenia

Jeśli po otwarciu formularza użytkownicy powinni mieć możliwość pobrania do niego danych za pomocą utworzonego połączenia danych, można zastosować jeden z dwóch sposobów: do ustawień szablonu dodać regułę powodującą użycie połączenia pod określonymi warunkami lub na stronie szablonu umieścić przycisk, za pomocą którego użytkownicy będą sami inicjowali połączenie danych.

Dodawanie reguły

W ustawieniach szablonu formularza można dodać regułę, która w przypadku spełnienia określonego w niej warunku będzie powodowała zainicjowanie połączenia danych kwerendy. W opisanej poniżej procedurze założono, że takie połączenie zostało już utworzone, a w szablonie umieszczono formant służący do wyświetlania danych przesyłanych za pomocą połączenia danych.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Kliknij dwukrotnie formant, do którego chcesz dodać regułę.

  3. Kliknij kartę Dane.

  4. W obszarze Sprawdzanie poprawności i reguły kliknij przycisk Reguły.

  5. W oknie dialogowym Reguły kliknij przycisk Dodaj.

  6. W polu Nazwa wpisz nazwę reguły.

  7. Aby określić warunek, kiedy będzie uruchamiane reguły, kliknij przycisk Ustaw warunek, a następnie wprowadź warunek. Reguła zostanie uruchomiona, gdy wystąpi warunek. Jeśli warunek nie jest ustawiona, reguła zostanie uruchomiona, gdy użytkownik zmieni się wartość w formancie i przenosi własnego kursor poza tego formantu.

  8. Kliknij przycisk Dodaj akcję.

  9. Na liście Akcja kliknij pozycję Kwerenda przy użyciu połączenia danych.

  10. Na liście Połączenie danych kliknij połączenie danych kwerendy, którego chcesz użyć, a następnie kliknij przycisk OK, aby zamknąć wszystkie okna dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Dodawanie przycisku inicjującego połączenie danych kwerendy

Do szablonu formularza można dodać przycisk. Gdy użytkownik, który utworzył formularz oparty na tym szablonie, kliknie przycisk, do formularza zostaną pobrane informacje za pośrednictwem zdefiniowanego połączenia danych kwerendy.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  3. Przeciągnij formant przycisku na szablon formularza.

  4. Kliknij dwukrotnie format przycisku dodanego przed chwilą do szablonu formularza.

  5. Kliknij kartę Ogólne.

  6. Na liście Akcja kliknij polecenie Odśwież.

  7. W polu Etykieta wpisz nazwę, która ma być wyświetlana na przycisku na szablonie formularza.

  8. Kliknij przycisk Ustawienia.

  9. W oknie dialogowym Odświeżanie kliknij opcję Jedno pomocnicze źródło danych.

  10. Na liście Wybierz pomocnicze źródło danych kliknij pomocnicze źródło danych, które jest skojarzone z połączeniem danych kwerendy.

  11. Kliknij przycisk OK, aby zamknąć każde otwarte okno dialogowe.

  12. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Początek strony

Dodawanie połączenia przesyłania danych

Jeśli plik połączenia danych zawiera ustawienia połączenia przesyłania danych, można skonfigurować opcje szablonu formularza umożliwiające użytkownikom przesyłanie zawartości formularza przez to połączenie. Gdy opcje zostaną skonfigurowane, program InfoPath doda przycisk Prześlij na pasku narzędzi Standardowy oraz polecenie Prześlij w menu Plik. Opcje przesyłania danych z szablonu należy konfigurować w oknie dialogowym Opcje przesyłania (menu Narzędzia). Procedura definiowania tych opcji przebiega tak samo jak dodawanie pomocniczego połączenia przesyłania danych. W sekcji Zobacz też znajdują się łącza do dodatkowych informacji na temat dodawania do szablonu formularza połączenia przesyłania danych.

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Wyszukaj połączenia na serwerze Microsoft Office SharePoint Server, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora na liście Witryna kliknij nazwę witryny zawierającej bibliotekę połączeń.

    Mojej witryny nie ma na liście

    Aby dodać witrynę do listy, należy wykonać następujące czynności:

    1. Kliknij przycisk Zarządzaj witrynami.

    2. W oknie dialogowym Zarządzanie witrynami kliknij przycisk Dodaj.

    3. W polu adres URL wpisz lokalizację biblioteki połączeń danych.

    4. W polu Nazwa wyświetlana wpisz nazwę biblioteki połączeń danych. Ta nazwa będzie wyświetlana na liście w Kreatorze połączenia danych.

    5. Kliknij przycisk OK.

    6. Kliknij przycisk Zamknij.

  5. Kliknij nazwę biblioteki połączeń danych. Spowoduje to wyświetlenie listy plików połączeń danych. Na liście kliknij nazwę pliku połączenia danych, który ma być używany dla tego połączenia przesyłania danych, a następnie kliknij przycisk Dalej.

  6. Jeśli ustawienia zawarte w pliku dotyczą połączenia przesyłania danych do usługi sieci Web, program InfoPath może ustalić, do których parametrów w usłudze te informacje mają być kierowane. W ustawieniach połączenia można skonfigurować opcje przesyłania wszystkich danych formularza lub tylko ich części.

    Jak?

    1. Na liście Parametry kliknij parametr, do którego będą przesyłane dane z formularza.

    2. Aby do parametru były przesyłane wszystkie dane z formularza, w tym element główny i wszelkie instrukcje przetwarzania, należy wykonać następujące czynności:

      1. Kliknij opcję Cały formularz (dokument XML włącznie z instrukcjami przetwarzania).

      2. Aby przesłać dane w formie ciągu tekstowego, zaznacz pole wyboru Prześlij dane jako ciąg. Zazwyczaj w tej postaci przesyła się dane podpisane elektronicznie, dlatego w większości przypadków pole należy pozostawić niezaznaczone.

    3. Aby wskazać pole lub grupę danych dla tego parametru, należy wykonać następujące czynności:

      1. W obszarze Opcje parametru kliknij pozycję Pole lub grupa.

      2. Kliknij przycisk Modyfikuj Obraz przycisku .

      3. W oknie dialogowym Wybieranie pola lub grupy kliknij pole lub grupę, których dane chcesz przesyłać, a następnie kliknij przycisk OK.

      4. Na liście Dołącz kliknij pozycję Tylko tekst i elementy podrzędne, aby była przesyłana tylko zawartość pola lub grupy, lub pozycję Poddrzewo XML, włącznie z zaznaczonym elementem, jeśli chcesz przesyłać zarówno wartość, jak i atrybuty konfiguracyjne wybranej grupy lub pola.

    4. Powtórz te czynności dla każdego parametru.

  7. Kliknij przycisk Dalej.

  8. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×