Dodawanie połączenia danych z bazą danych programu Microsoft SQL Server

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Do szablonu formularza można dodać pomocnicze połączenie danych, które będzie służyło do wykonywania kwerend w bazie danych programu Microsoft SQL Server. Nie można natomiast dodać połączenia, za pomocą którego dane będą przesyłane do bazy. Aby umożliwić przesyłanie danych do bazy, należy utworzyć pomocnicze połączenie danych prowadzące do usługi sieci Web współpracującej z tą bazą. W sekcji Zobacz też znajdują się łącza do materiałów poświęconych tworzeniu takich łączy.

Aby utworzyć pomocnicze połączenie z bazą danych, należy wykonać następujące czynności:

Krok 1: Dodawanie pomocniczego połączenia danych do szablonu formularza    Operacja spowoduje utworzenie pomocniczego źródła danych zawierającego pola i grupy odpowiadające strukturze przechowywania danych w bazie. Ponadto w ustawieniach szablonu można skonfigurować automatyczne inicjowanie połączenia z chwilą otwarcia formularza.

Krok 2: Konfigurowanie w ustawieniach szablonu formularza opcji korzystania z nowo utworzonego połączenia    Jeśli chcesz, aby po otwarciu formularza użytkownicy mogli korzystać z tego połączenia danych, dodaj odpowiednią regułę lub przycisk.

W tym artykule

Omówienie

Przed rozpoczęciem

Krok 1: Dodawanie pomocniczego połączenia danych

Krok 2: Konfigurowanie szablonu formularza do używania połączenia danych

Omówienie

Przy tworzeniu szablonu formularza opartym na zewnętrznym źródle danych program Microsoft Office InfoPath tworzy główne połączenie danych prowadzące do tego źródła. Następnie program generuje dla tego szablonu główne źródło danych uwzględniające sposób przechowywania danych w źródle zewnętrznym. Zdarza się jednak, że zewnętrzne źródło danych używane w głównym połączeniu danych nie zawiera wartości, które powinny się pojawić w formantach szablonu. Wartości te mogą istnieć w innym zewnętrznym źródle, na przykład innej bazie danych programu SQL Server. Aby były one pobierane, można dodać do szablonu pomocnicze połączenie danych.

Pomocnicze połączenie danych to połączenie danych dodawane do szablonu formularza przez użytkownika. Mogą to być połączenia danych kwerendy lub połączenia przesyłania danych. Połączenie danych kwerendy może pełnić rolę wyłącznie pomocniczego połączenia danych z bazą danych programu SQL Server. Należy je dodawać wyłącznie w sytuacji, gdy istnieje konieczność pozyskiwania danych z zewnętrznego źródła innego niż źródło ustawione w podstawowym połączeniu danych. Połączenie przesyłania danych nie może pełnić roli pomocniczego połączenia z bazą programu SQL Server.

Po dodaniu połączenia danych kwerendy do bazy danych programu InfoPath tworzy pomocniczej źródło danych z pól i grup, które odpowiadają w sposób przechowywania danych w bazie danych. Struktura danych w pomocnicze źródło danych musi być zgodna tak, że dane są przechowywane w tabelach bazy danych, nie można zmodyfikować pola lub grupy w pomocnicze źródło danych. Możesz skonfigurować każdego połączenia danych zapytania, aby zapisać wyniki, tak aby użytkownicy mają dostęp do danych, gdy ich formularza nie jest połączony z siecią. W zależności od rodzaju danych można wyświetlić wyniki kwerendy tylko wtedy, gdy użytkownicy są połączeni z siecią.

Uwaga dotycząca zabezpieczeń : Jeśli korzystasz z pomocniczego połączenia danych do pobierania danych poufnych z zewnętrznego źródła danych, można wyłączyć tę funkcję w celu ochrony danych przed nieautoryzowanym użyciem w przypadku, gdy komputer jest utraconych lub kradzież. Jeśli wyłączysz tę funkcję, dane będą dostępne tylko wtedy, gdy użytkownik jest połączony z siecią.

W przypadku dodania do szablonu formularza połączenia danych kwerendy formularze oparte na tym szablonie domyślnie używają tego połączenia danych, gdy są otwierane przez użytkownika. Można również skonfigurować szablon formularza tak, aby używać połączenia danych kwerendy w jeden z następujących sposobów:

  • Dodawanie reguły    Można skonfigurować regułę przy każdym wystąpieniu warunku w regule za pomocą połączenia danych kwerendy.

  • Przycisk Dodaj    Możesz dodać przycisk do szablonu formularza, który można kliknąć, aby pobrać dane przy użyciu kwerendy połączenia danych.

  • Używanie kodu niestandardowego    Jeśli nie możesz dodawać reguły lub przycisku, możesz za pomocą kodu niestandardowego pobieranie danych przy użyciu kwerendy połączenia danych. Za pomocą kodu niestandardowego wymaga dewelopera utworzyć niestandardowy kod.

Początek strony

Przed rozpoczęciem

Zanim do szablonu formularza będzie można dodać pomocnicze połączenie z bazą danych programu SQL Server, należy się zwrócić do administratora bazy o podanie następujących informacji:

  • Nazwa serwera zawierającego bazę danych, który będzie używany z tym szablonem formularza.

  • Nazwa bazy danych, która będzie używana z tym szablonem formularza.

  • Uwierzytelnianie wymagane przez bazę danych. Do określenia sposobu uzyskiwania przez użytkowników dostępu do bazy danych może ona stosować uwierzytelnianie systemu Microsoft Windows lub uwierzytelnianie serwera SQL Server.

  • Nazwa tabeli zawierającej dane, które chcesz wysłać do formularza. Jest to tabela podstawowa. Jeśli zamierzasz używać więcej niż jednej tabeli z bazy, będą potrzebne nazwy tych tabel podrzędnych. Należy również ustalić nazwy pól w tabelach podrzędnych, które są powiązane z polami w tabeli podstawowej.

  • Czy wyniki kwerendy można bezpiecznie przechowywać w formularzu w celu umożliwienia dostępu do nich w trybie offline.

Początek strony

Krok 1: Dodawanie pomocniczego połączenia danych

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Baza danych (tylko programu Microsoft SQL Server lub Microsoft Office Access), a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora kliknij przycisk Wybierz bazę danych.

  6. W oknie dialogowym Wybierz źródło danych kliknij przycisk Nowe źródło.

  7. Na liście Z jakim rodzajem źródła danych chcesz się połączyć? kliknij opcję Microsoft SQL Server, a następnie kliknij przycisk Dalej.

  8. W polu Nazwa serwera wpisz nazwę serwera zawierającego bazę danych.

  9. W obszarze Poświadczenia logowania wykonaj jedną z następujących czynności:

    • Jeżeli baza danych określa dostęp użytkowników na podstawie poświadczeń stosowanych w sieci Microsoft Windows, kliknij opcję Użyj uwierzytelniania systemu Windows.

    • Jeżeli baza danych określa dostęp użytkowników na podstawie podanej przez administratora określonej nazwy użytkownika i hasła, kliknij opcję Użyj następującej nazwy użytkownika i hasła, a następnie wpisz nazwę użytkownika i hasło w polach Nazwa użytkownika i Hasło.

  10. Kliknij przycisk Dalej.

  11. Na następnej stronie kreatora na liście Wybierz bazę danych, która zawiera dane, które chcesz kliknij bazę danych, którą chcesz użyć, zaznacz pole wyboru Połącz z określonej tabeli, kliknij nazwę tabeli podstawowej i kliknij przycisk Dalej.

  12. Na następnej stronie kreatora, w polu Nazwa pliku wpisz nazwę pliku, w którym przechowywane są informacje o połączeniu danych.

  13. Aby zapisać wprowadzone ustawienia, kliknij przycisk Zakończ.

  14. Dodaj inne dowolne tabele, których chcesz używać w połączeniu danych kwerendy.

    Jak to zrobić?

    1. Kliknij przycisk Dodaj tabelę.

    2. W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij nazwę tabeli podrzędnej, a następnie kliknij przycisk Dalej. Program InfoPath próbuje ustawić relacje dopasowując nazwy pól w obu tabelach. Jeśli nie chcesz używać sugerowane relacji, wybierz relację, a następnie kliknij Usuwanie relacji. Aby dodać relację, kliknij pozycję Dodaj relację. W oknie dialogowym Dodaj relację kliknij nazwę każdego pola pokrewne w odpowiedniej kolumnie, a następnie kliknij przycisk OK.

    3. Kliknij przycisk Zakończ.

    4. W celu dodania kolejnych tabel podrzędnych powtórz wszystkie kroki.

  15. Kliknij przycisk Dalej.

  16. Aby wyniki sesji połączenia danych kwerendy były dostępne w czasie, gdy formularz nie jest połączony z siecią, zaznacz pole wyboru Przechowuj kopię danych w szablonie formularza.

    Uwaga dotycząca zabezpieczeń : Zaznaczenie tego pola wyboru spowoduje, że w czasie, gdy formularz łączy się z siecią przy użyciu tego połączenia danych, dane zwracane przez kwerendę będą zapisywane na komputerze użytkownika. Jeśli w ten sposób do formularza trafiają informacje poufne, lepiej wyłączyć tę opcję, ponieważ w razie kradzieży czy zagubienia komputera mogą się one dostać w ręce niepowołanych osób.

  17. Kliknij przycisk Dalej.

  18. Na następnej stronie kreatora wprowadź opisową nazwę tego pomocniczego połączenia danych. Jeśli chcesz, aby dane były automatycznie pobrane podczas otwierania formularza, zaznacz pole wyboru Automatycznie pobierz dane podczas otwierania formularza.

Początek strony

Krok 2: Konfigurowanie w ustawieniach szablonu formularza opcji korzystania z nowo utworzonego połączenia

Jeśli formularze oparte na szablonie mają po otwarciu przez użytkownika korzystać z tego połączenia danych, można zastosować jeden z dwóch sposobów: do ustawień szablonu dodać regułę powodującą użycie połączenia pod określonymi warunkami lub na stronie szablonu umieścić przycisk, za pomocą którego użytkownicy będą samodzielnie inicjowali połączenie danych.

Dodawanie reguły

Możliwe jest dodanie do szablonu formularza reguły powodującej pobranie danych z połączenia danych kwerendy za każdym razem, gdy reguła zostanie spełniona. Następująca procedura zakłada, że utworzone zostało połączenie danych kwerendy dla szablonu formularza i że został skonfigurowany na szablonie formularza formant wyświetlający dane z tego połączenia danych.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Kliknij dwukrotnie formant, do którego chcesz dodać regułę.

  3. Kliknij kartę Dane.

  4. W obszarze Sprawdzanie poprawności i reguły kliknij przycisk Reguły.

  5. W oknie dialogowym Reguły kliknij przycisk Dodaj.

  6. W polu Nazwa wpisz nazwę reguły.

  7. Aby określić warunek, kiedy będzie uruchamiane reguły, kliknij przycisk Ustaw warunek, a następnie wprowadź warunek. Reguła zostanie uruchomiona, gdy wystąpi warunek. Jeśli warunek nie jest ustawiona, reguła zostanie uruchomiona, gdy użytkownik zmieni się wartość w formancie i przenosi własnego kursora w kierunku od tego formantu.

  8. Kliknij przycisk Dodaj akcję.

  9. Na liście Akcja kliknij opcję Kwerenda przy użyciu połączenia danych.

  10. Na liście Połączenie danych kliknij połączenie danych kwerendy, którego chcesz używać, a następnie kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Dodawanie przycisku

Do szablonu formularza można dodać przycisk, którego kliknięcie będzie powodowało pobranie danych za pomocą połączenia danych kwerendy.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  3. Przeciągnij formant przycisku na szablon formularza.

  4. Kliknij dwukrotnie przycisk dodany do szablonu formularza.

  5. Kliknij kartę Ogólne.

  6. Na liście Akcja kliknij polecenie Odśwież.

  7. W polu Etykieta wpisz nazwę, która ma być wyświetlana na przycisku na szablonie formularza.

  8. Kliknij przycisk Ustawienia.

  9. W oknie dialogowym Odświeżanie kliknij opcję Jedno pomocnicze źródło danych.

  10. Na liście Wybierz pomocnicze źródło danych kliknij pomocnicze źródło danych, które jest skojarzone z połączeniem danych kwerendy.

  11. Kliknij przycisk OK, aby zamknąć każde otwarte okno dialogowe.

  12. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×