Dodawanie połączenia danych do biblioteki lub listy dokumentów programu SharePoint

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Można dodać jedno lub więcej połączeń pomocniczego do szablonu formularza, który można dane kwerendy z biblioteki dokumentów lub listy lub przesyłanie danych do biblioteki dokumentów na serwerze z programem Microsoft Windows SharePoint Services.

W tym artykule

Omówienie

Przed rozpoczęciem

Dodawanie połączenia danych kwerendy

Dodawanie połączenia przesyłania danych

Omówienie

Pomocniczego połączenia danych jest wszystkie połączenia danych z zewnętrznego źródła danych dodany do szablonu formularza. To połączenie danych różni się od głównego połączenia danych utworzony podczas projektowania szablonu formularza na podstawie bazy danych, usługi sieci Web lub ustawień w bibliotece połączeń. Możesz dodać pomocniczego połączenia danych tylko wtedy, gdy nie można kwerendy lub przesyłania danych głównego połączenia danych.

Po dodaniu pomocniczego połączenia danych do szablonu formularza danych kwerendy, program Microsoft Office InfoPath tworzy pomocniczej źródło danych z pola danych oraz grupy odpowiadający sposób przechowywania danych w bibliotece dokumentów lub listy. Relacja między z zewnętrznym źródłem danych i źródła danych w szablonie formularza.

Struktura danych w pomocnicze źródło danych musi być zgodna tak, że dane są przechowywane w bibliotece dokumentów lub listy, nie można zmodyfikować istniejące pola lub grupy w pomocnicze źródło danych.

Połączenie danych, że kwerendy danych z programu SharePoint w bibliotece dokumentów lub listy automatycznie zwraca wszystkie elementy w tej biblioteki dokumentów lub listy. Jeśli korzystasz z połączenia danych kwerendy do wypełnienia listy pola, pole listy rozwijanej lub formant pola kombi i formant zawiera zbyt wiele elementów lub mają być wyświetlane tylko te elementy, które spełniają określone kryteria, w formancie można zastosować filtr, aby ograniczyć liczbę elementów. Łącza do dodatkowych informacji na temat filtrowania danych wyświetlanych w formancie w sekcji Zobacz też.

W ustawieniach każdego połączenia danych kwerendy można także skonfigurować opcję zapisywania wyników kwerendy, dzięki czemu użytkownicy zachowają dostęp do danych mimo braku połączenia między formularzem a siecią. Jeśli wymaga tego charakter danych, można określić, aby wyniki kwerendy były prezentowane wyłącznie użytkownikom pracującym w sieci.

Uwaga dotycząca zabezpieczeń : Jeśli korzystasz z pomocniczego połączenia danych do pobierania danych poufnych z zewnętrznego źródła danych, można wyłączyć tę funkcję w celu ochrony danych przed nieautoryzowanym użyciem w przypadku, gdy komputer jest utraconych lub kradzież. Jeśli wyłączysz tę funkcję, dane będą dostępne tylko wtedy, gdy użytkownik jest połączony z siecią.

W przypadku dodania do szablonu formularza połączenia danych kwerendy formularze oparte na tym szablonie domyślnie używają tego połączenia danych, gdy są otwierane przez użytkownika. Można również skonfigurować szablon formularza tak, aby używać połączenia danych kwerendy w jeden z następujących sposobów:

  • Dodawanie reguły    Można skonfigurować regułę przy każdym wystąpieniu warunku w regule za pomocą połączenia danych kwerendy.

  • Przycisk Dodaj    Możesz dodać przycisk do szablonu formularza, który można kliknąć, aby pobrać dane przy użyciu kwerendy połączenia danych.

  • Używanie kodu niestandardowego    Jeśli nie możesz dodawać reguły lub przycisku, możesz za pomocą kodu niestandardowego pobieranie danych przy użyciu kwerendy połączenia danych. Za pomocą kodu niestandardowego wymaga dewelopera utworzyć niestandardowy kod.

Gdy do szablonu formularza zostanie dodane połączenie przesyłania danych, w ustawieniach szablonu można skonfigurować opcje pozwalające użytkownikom na przesyłanie danych wprowadzanych przez nich do formularza. Dodatkowo można określić ustawienia przesyłania dla formularzy utworzonych na podstawie szablonu.

Początek strony

Przed rozpoczęciem

Przed dodaniem pomocniczego połączenia danych do szablonu formularza należy zwrócić się do administratora witryny o podanie następujących informacji:

  • Lokalizacja witryny programu SharePoint i uprawnienia potrzebne w celu uzyskania dostępu do tej witryny.

  • Potwierdzenie, że witryna jest skonfigurowana tak, aby użytkownicy mieli możliwość pobierania danych z biblioteki lub listy dokumentów.

  • Potwierdzenie możliwości przechowywania danych pochodzących z biblioteki lub listy dokumentów, które znajdują się na komputerach użytkowników w celu korzystania z nich w trybie offline.

Początek strony

Dodawanie połączenia danych kwerendy

Aby umożliwić użytkownikom przesyłanie kwerendy dotyczącej danych zawartych w bibliotece lub na liście dokumentów umieszczonej na serwerze z programem Microsoft Windows SharePoint Services, należy wykonać następujące czynności w szablonie formularza:

  1. Dodawanie pomocniczego połączenia danych.

  2. Konfigurowanie szablonu formularza do korzystania z pomocniczego połączenia danych.

Krok 1: Dodawanie pomocniczego połączenia danych

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Biblioteka lub lista programu SharePoint, a następnie kliknij przycisk Dalej.

    Strona w Kreatorze połączenia danych, aby określić witryny programu SharePoint jako źródła danych.

  5. Na następnej stronie kreatora wpisz adres URL witryny programu SharePoint z biblioteki dokumentów lub listy, a następnie kliknij przycisk Dalej. Na przykład aby użyć listy dokumentów w witrynie programu SharePoint przy użyciu adresu URL http://www.adventureworks.com/EmployeeList, należy wpisać http://www.adventureworks.com/EmployeeList.

  6. Na następnej stronie kreatora na liście Wybierz listę lub bibliotekę kliknij listę lub bibliotekę, której chcesz używać, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora zaznacz pola wyboru obok wartości, które chcesz otrzymywać. Jeśli szablon formularza będzie publikowany w bibliotece dokumentów, a chcesz, aby formularze oparte na tym szablonie używały metadanych formularza bazowego, zaznacz pole wyboru Uwzględnij tylko dane dla aktywnego formularza.

  8. Kliknij przycisk Dalej.

  9. Jeśli chcesz przechowywać wyniki kwerendy z szablonem, zaznacz pole wyboru Przechowaj kopię danych w szablonie formularza. Zaznaczenie tego pola wyboru przechowuje wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, dane są niedostępne w formularzach, które wypełniania przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią.

    Uwaga dotycząca zabezpieczeń : Zaznaczenie tego pola wyboru przechowuje wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, jest dostępny w formularzach, które wypełniania przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli występują poufne dane z tego połączenia danych, można wyłączyć tę funkcję w celu ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież.

  10. Kliknij przycisk Dalej.

  11. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego połączenia danych pomocniczą. To nazwa wyświetlana na liście źródła danych w okienku zadań źródło danych. Jeśli chcesz, aby ta kwerenda uruchamiane automatycznie przy każdym otwarciu formularza przez użytkownika, zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza.

Krok 2: Konfigurowanie szablonu formularza do korzystania z pomocniczego połączenia danych

Jeśli chcesz formularzy opartych na szablonie formularza dla tego połączenia danych po otwarciu formularza, można dodać regułę do szablonu formularza, który używa tego połączenia danych w określonych warunkach lub można dodać przycisk do szablonu formularza, który można kliknąć, aby użyć tego połączenia danych.

Dodawanie reguły

Możliwe jest dodanie do szablonu formularza reguły powodującej pobranie danych z połączenia danych kwerendy za każdym razem, gdy reguła zostanie spełniona. Następująca procedura zakłada, że utworzone zostało połączenie danych kwerendy dla szablonu formularza i że został skonfigurowany na szablonie formularza formant wyświetlający dane z tego połączenia danych.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Kliknij dwukrotnie formant, w którym mają być wyświetlane wyniki kwerendy.

  3. Kliknij kartę Dane.

  4. W obszarze Sprawdzanie poprawności i reguły kliknij przycisk Reguły.

  5. W oknie dialogowym Reguły kliknij przycisk Dodaj.

  6. W polu Nazwa wpisz nazwę reguły.

  7. Aby określić warunek, kiedy będzie uruchamiane reguły, kliknij przycisk Ustaw warunek, a następnie wprowadź warunek. Reguła zostanie uruchomiona, gdy wystąpi warunek. Jeśli warunek nie jest ustawiona, reguła zostanie uruchomiona, gdy użytkownik zmieni się wartość w formancie i przenosi własnego kursor poza tego formantu.

  8. Kliknij przycisk Dodaj akcję.

  9. Na liście Akcja kliknij opcję Kwerenda przy użyciu połączenia danych.

  10. Na liście Połączenie danych kliknij połączenie danych kwerendy, którego chcesz używać, a następnie kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Dodawanie przycisku

Do szablonu formularza można dodać przycisk, którego kliknięcie będzie powodowało użycie wybranego połączenia danych kwerendy. W opisanej poniżej procedurze założono, że takie połączenie zostało już utworzone.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  3. Przeciągnij formant przycisku na szablon formularza.

  4. Kliknij dwukrotnie format przycisku dodanego przed chwilą do szablonu formularza.

  5. Kliknij kartę Ogólne.

  6. Na liście Akcja kliknij polecenie Odśwież.

  7. W polu Etykieta wpisz nazwę, która ma być wyświetlana na przycisku na szablonie formularza.

  8. Kliknij przycisk Ustawienia.

  9. W oknie dialogowym Odświeżanie kliknij opcję Jedno pomocnicze źródło danych.

  10. Na liście Wybierz pomocnicze źródło danych kliknij pomocnicze źródło danych, które jest skojarzone z połączeniem danych kwerendy, a następnie kliknij przycisk OK, aby zamknąć każde otwarte okno dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Początek strony

Dodawanie połączenia przesyłania danych

Aby umożliwić użytkownikom przesyłanie danych z formularzy opartych na szablonie formularza do biblioteki dokumentów, należy wykonać następujące czynności:

  1. Dodanie do szablonu formularza pomocniczego połączenia danych powodującego przesyłanie danych.

  2. Skonfigurowanie w ustawieniach szablonu formularza opcji zezwalania użytkownikom na przesyłanie danych wprowadzanych przez nich do formularza do biblioteki dokumentów.

Krok 1: Dodawanie pomocniczego połączenia danych

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Prześlij dane, a następnie kliknij przycisk Dalej.

  4. W obszarze W jaki sposób chcesz przesłać dane kliknij opcję Do biblioteki dokumentów w witrynie programu SharePoint, a następnie kliknij przycisk Dalej.

  5. W Kreatorze połączenia danych w polu Biblioteka dokumentów wpisz adres URL biblioteki dokumentów programu SharePoint.

  6. W polu Nazwa pliku wpisz nazwę, która będzie służyć do identyfikowania formularza w bibliotece dokumentów.

    Porada : Aby zagwarantować, że każda nazwa formularza będzie unikatowa, można użyć formuły.

    Jak?

    1. Kliknij przycisk Wstaw formułę Obraz przycisku .

    2. W oknie dialogowym Wstawianie formuły wykonaj jedną z następujących czynności:

      • Aby użyć pola w formule, kliknij przycisk Wstaw pole lub grupę, w oknie dialogowym Wybieranie pola lub grupy kliknij pole, którego chcesz użyć, a następnie kliknij przycisk OK.

      • Aby użyć funkcji w formule, kliknij przycisk Wstaw funkcję, w oknie dialogowym Wstawianie funkcji wybierz funkcję, której chcesz użyć, a następnie kliknij przycisk OK.

        Porada : Jeśli funkcja wymaga parametrów, wybierz funkcję w oknie dialogowym Wstawianie funkcji, kliknij przycisk OK, a następnie w polu Formuła w oknie dialogowym Wstawianie formuły, kliknij dwukrotnie funkcję dodanego, a kliknij pola lub grupy. Łącza do dodatkowych informacji na temat funkcji można znaleźć w sekcji Zobacz też.

      • Aby wstawić wartość lub operator matematyczny w formule, w polu Formuła wpisz wartość lub symbol operacji matematycznej.

    Operacja

    Symbol

    Dodawanie

    +

    Odejmowanie

    -

    Mnożenie

    *

    Dzielenie

    /

    • Uwaga : Jeśli formuła używa operatora dzielenia (/), upewnij się, że jest znak spacji przed i po operatora dzielenia. Jeśli operatora dzielenia bez spacji przed i po nim, mogą interpretować programu InfoPath "/" jako separator XPath lokalizacji instrukcje, a nie jako operatora dzielenia.

    • Aby sprawdzić, czy formuła ma poprawną składnię, kliknij przycisk Weryfikuj formułę w oknie dialogowym Wstawianie formuły.

      W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o formułach.

  7. Jeśli nowe formularze mają zastępować formularze o takich samych nazwach już istniejące w bibliotece dokumentów, zaznacz pole wyboru Zezwalaj na zastąpienie, jeżeli plik istnieje.

  8. Kliknij przycisk Dalej.

  9. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

Po dodaniu pomocniczego połączenia przesyłania danych konieczne jest skonfigurowanie szablonu formularza w celu umożliwienia użytkownikom przesyłania danych za pomocą połączenia przesyłania danych.

Krok 2: Włączanie przesyłania na szablonie formularza

Gdy w szablonie formularza zostaną skonfigurowane opcje pozwalające użytkownikom na przesyłanie danych wprowadzanych przez nich do formularza, program InfoPath doda przycisk Prześlij do paska narzędzi Standardowy oraz polecenie Prześlij do menu Plik w oknie formularza. Ponadto można wszechstronnie dostosowywać opcje przesyłania:

  • zmieniając tekst wyświetlany na przycisku Prześlij;

  • zmieniając skrót klawiaturowy przycisku Prześlij;

  • tworząc niestandardowe komunikaty wyświetlane, gdy użytkownicy przesyłają formularze;

  • określając, czy po przesłaniu formularza ma on pozostać otwarty, zostać zamknięty czy ma zostać otwarty kolejny pusty formularz.

  • W menu Narzędzia kliknij polecenie Opcje przesyłania.

  • W oknie dialogowym Opcje przesyłania zaznacz pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza, kliknij przycisk Wyślij danych formularza do jednego miejsca docelowego, a następnie, na liście kliknij biblioteki dokumentów programu SharePoint.

  • Na liście Wybierz połączenie danych dla przesyłania kliknij nazwę połączenia przesyłania danych z biblioteką programu SharePoint.

    1. Aby zmienić nazwę przycisk Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w oknie dialogowym Opcje przesyłania.

      Porada : Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  • Jeśli nie chcesz używać polecenia Prześlij lub przycisk Zatwierdź na pasku narzędzi Standardowy, podczas wypełniania formularza użytkownicy, wyczyść pole wyboru Pokaż polecenie Prześlij i przycisk Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      • Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      • Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Porada : Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      • Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×