Dodawanie połączenia danych bazy danych programu Microsoft Access

Ważne: Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Jeśli użytkownicy muszą danych z bazy danych Microsoft Office Access 2007 (accdb) lub z bazy danych programu Access zapisany w starszej wersji (format MDB), aby wypełnić formularz oparty na szablonie formularza programu Microsoft Office InfoPath, możesz dodać pomocniczego połączenia danych do szablonu formularza, który wykonuje kwerendę bazy danych programu Access.

Możesz dodać pomocniczego połączenia danych, ale to połączenie danych można tylko kwerendy bazy danych programu Access. Nie możesz dodać połączenie danych pomocniczej przesyła danych formularza do bazy danych programu Access.

Jeśli chcesz, aby użytkownicy mogli przesyłanie ich danych formularza do bazy danych programu Access, projektowanie szablonu formularza, który jest oparty na bazie danych programu Access, a następnie Włącz przesyłanie połączenia danych w głównego połączenia danych. Możesz także dodać pomocniczego połączenia danych do usługi sieci Web, z którymi współpracuje z bazy danych programu Access.

Łącza do dodatkowych informacji o projektowaniu szablonów formularzy, które są oparte na bazę danych programu Access i dodawanie pomocniczego połączenia danych usługi sieci Web, w sekcji Zobacz też.

W tym artykule

Omówienie

Informacje dotyczące zgodności

Przed rozpoczęciem

Krok 1: Dodawanie pomocniczego połączenia danych

Krok 2: Konfigurowanie szablonu formularza do używania połączenia danych

Omówienie

Pomocnicza połączenie danych to połączenie danych, które możesz dodać do szablonu formularza. Pomocniczego połączenia danych różni się od głównego połączenia danych, które można tworzyć podczas projektowania nowego szablonu formularza, który jest oparty na bazy danych lub usługi sieci Web. Szablon formularza głównego połączenia z danymi mógł pobierać dane z zewnętrznego źródła danych i można także przesyłanie danych formularza do zewnętrznego źródła danych. Jednak szablonu formularza może mieć tylko jeden głównego połączenia z danymi.

Możesz dodać dowolną liczbę pomocniczych połączeń danych w szablonie formularza zgodnie z oczekiwaniami. Załóżmy, że masz bazy danych programu Access zawierającą tabelę, której są magazynowane dane pracowników i innej tabeli, w którym są przechowywane dane klienta. Możesz dodać pomocniczego połączenia danych pobierającego dane z tabeli pracowników, a można również dodać innego pomocniczego połączenia danych pobierającego dane z tabeli klienta w tej samej bazy danych programu Access.

Mimo że pomocniczego połączenia danych można dodać do szablonu formularza, który można przesyłanie danych formularza do zewnętrznego źródła danych, takich jak usługi sieci Web lub w bibliotece programu Windows SharePoint Services, pomocniczych połączeń danych można używać tylko do pobierania danych z bazy danych programu Access. Nie możesz dodać połączenie danych pomocniczej przesyła danych formularza do bazy danych programu Access.

Po dodaniu połączenia danych kwerendy do bazy danych programu InfoPath tworzy pomocniczej źródło danych, która zawiera pola danych oraz grupy, które odpowiadają w sposób przechowywania danych w bazie danych. Struktura danych w pomocnicze źródło danych musi być zgodna tak, że dane są przechowywane w tabelach bazy danych, nie można zmodyfikować pola lub grupy w pomocnicze źródło danych.

Możesz skonfigurować każdego połączenia danych kwerendy można zapisać jego wyniki, tak aby użytkownicy mają dostęp do danych, gdy ich formularz nie jest połączony z siecią. W zależności od rodzaju danych można wyświetlić wyniki kwerendy tylko wtedy, gdy użytkownicy są połączeni z siecią.

Uwaga dotycząca zabezpieczeń: Jeśli korzystasz z pomocniczego połączenia danych do pobierania danych poufnych z zewnętrznego źródła danych, można wyłączyć tę funkcję w celu ochrony danych przed nieautoryzowanym użyciem w przypadku, gdy komputer jest utraconych lub kradzież. Jeśli wyłączysz tę funkcję, dane będą dostępne tylko wtedy, gdy użytkownik jest połączony z siecią.

W przypadku dodania do szablonu formularza połączenia danych kwerendy formularze oparte na tym szablonie domyślnie używają tego połączenia danych, gdy są otwierane przez użytkownika. Można również skonfigurować szablon formularza tak, aby używać połączenia danych kwerendy w jeden z następujących sposobów:

  • Dodawanie reguły    Można skonfigurować regułę przy każdym wystąpieniu warunku w regule za pomocą połączenia danych kwerendy.

  • Przycisk Dodaj    Możesz dodać przycisk do szablonu formularza, który można kliknąć, aby pobrać dane przy użyciu kwerendy połączenia danych.

  • Używanie kodu niestandardowego    Jeśli nie możesz dodawać reguły lub przycisku, możesz za pomocą kodu niestandardowego pobieranie danych przy użyciu kwerendy połączenia danych. Za pomocą kodu niestandardowego wymaga dewelopera utworzyć niestandardowy kod.

Początek strony

Zgodność

Nie możesz dodać połączenie danych do bazy danych programu Access szablon formularza zgodny z przeglądarką.

Początek strony

Przed rozpoczęciem

Przed dodaniem pomocniczego połączenia danych do bazy danych programu Access do szablonu formularza jest potrzebny następujące informacje:

  • Nazwa i lokalizacja bazy danych.

    Uwaga: Jeśli baza danych programu Access jest przechowywany w lokalizacji sieciowej, upewnij się, że baza danych jest dostępne dla użytkowników.

  • Nazwa tabeli lub kwerendy, które będzie dostarczać dane do formularzy opartych na tym szablonie formularza. Tej tabeli lub kwerendy jako podstawowej tabeli lub kwerendy zostanie użyty podczas konfigurowania kwerendy połączenia danych.

  • Nazwy innych tabel i kwerend, które dostarczają dodatkowe dane do podstawowej tabeli lub kwerendy. W większości przypadków relacji między tabelami są już ustalone w bazie danych. Jeśli masz ręcznie ustanawiać relacje pomiędzy podstawowej tabeli lub kwerendy, a innej tabeli lub kwerendy, konieczne będzie nazwy pól powiązanych tabel lub kwerend.

Początek strony

Krok 1: Dodawanie pomocniczego połączenia danych

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Baza danych (tylko programu Microsoft SQL Server lub Microsoft Office Access), a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora kliknij przycisk Wybierz bazę danych.

  6. W oknie dialogowym Wybieranie źródła danych przejdź do lokalizacji bazy danych.

    Uwaga: Jeśli bazy danych jest przechowywany w lokalizacji sieciowej, przejdź do nazewnictwa uniwersalna konwencja nazewnicza (UNC) ścieżkę do lokalizacji. Nie przejdź do lokalizacji sieciowej za pośrednictwem mapowanego dysku sieciowego. Jeśli używasz mapowanego dysku sieciowego, użytkownicy, którzy tworzą formularzy opartych na tym szablonie formularza spowoduje wyszukanie bazy danych na serwerze sieciowym zamapowane. Jeśli użytkownik nie ma na dysku sieciowym zamapowane, formularz nie znajdzie bazy danych.

  7. Kliknij nazwę bazy danych, a następnie kliknij przycisk Otwórz.

  8. W oknie dialogowym Wybieranie tabeli kliknij podstawowego tabelę lub kwerendę, której chcesz użyć, a następnie kliknij przycisk OK.

  9. Na następnej stronie kreatora zaznacz pole wyboru Pokaż kolumny w tabeli.

    Domyślnie wszystkie pola z tabeli lub kwerendy są dodawane do głównego źródła danych szablonu formularza.

  10. Wyczyść pola wyboru dla pola, które chcesz uwzględnić w pomocnicze źródło danych.

    Dodawanie dodatkowych tabel lub kwerend do połączenia danych.

    Jak to zrobić?

    1. Kliknij przycisk Dodaj tabelę.

    2. W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij nazwę tabeli podrzędnej, a następnie kliknij przycisk Dalej. Program InfoPath próbuje ustawić relacje dopasowując nazwy pól w obu tabelach. Jeśli nie chcesz używać sugerowane relacji, wybierz relację, a następnie kliknij Usuwanie relacji. Aby dodać relację, kliknij pozycję Dodaj relację. W oknie dialogowym Dodaj relację kliknij nazwę każdego pola pokrewne w odpowiedniej kolumnie, a następnie kliknij przycisk OK.

    3. Kliknij przycisk Zakończ.

    4. W celu dodania kolejnych tabel podrzędnych powtórz wszystkie kroki.

  11. Kliknij przycisk Dalej.

  12. Aby wyniki sesji połączenia danych kwerendy były dostępne w czasie, gdy formularz nie jest połączony z siecią, zaznacz pole wyboru Przechowuj kopię danych w szablonie formularza.

    Uwaga dotycząca zabezpieczeń: Zaznaczenie tego pola wyboru przechowuje dane na komputerze użytkownika, gdy formularz używa tego połączenia danych. Jeśli formularz pobiera poufne dane z tego połączenia danych, można wyłączyć tę funkcję w celu ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież.

  13. Kliknij przycisk Dalej.

  14. Na następnej stronie kreatora wpisz opisową nazwę dla tego połączenia danych pomocniczej, a następnie sprawdź, czy informacje w sekcji Podsumowanie są poprawne.

  15. Aby skonfigurować formularza w celu odbioru danych automatycznie, gdy formularz jest otwarty, zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza.

Początek strony

Krok 2: Konfigurowanie w ustawieniach szablonu formularza opcji korzystania z nowo utworzonego połączenia

Jeśli chcesz, aby formularze, które są oparte na tym szablonie formularza, aby użyć tego połączenia danych po otwarciu formularza, reguła można dodać do szablonu formularza, który używa tego połączenia danych warunkowe lub można dodać przycisk do szablonu formularza, który użytkownicy mogą kliknij, aby użyć tego połączenia danych.

Dodawanie reguły

Szablon formularza, który służy do pobierania danych z kwerendy połączenia danych, gdy spełnienia warunku reguły można dodać regułę. Na przykład można dodać pole tekstowe do szablonu formularza, który użytkownik mogą wypełniać uzyskiwania określone dane z zewnętrznego źródła danych. Następnie można dodać regułę, która korzysta z połączenia danych, gdy użytkownik wprowadza dane w polu tekstowym.

W poniższej procedurze przyjęto w szablonie formularza, aby wyświetlić dane z tego połączenia danych dla szablonu formularza utworzono połączenie danych kwerendy i skonfigurowano formantu (innych niż przycisk).

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Kliknij dwukrotnie formant, do którego chcesz dodać regułę.

  3. Kliknij kartę Dane.

  4. W obszarze Sprawdzanie poprawności i reguły kliknij przycisk Reguły.

  5. W oknie dialogowym Reguły kliknij przycisk Dodaj.

  6. W polu Nazwa wpisz nazwę reguły.

  7. Aby określić warunek, kiedy będzie uruchamiane reguły, kliknij przycisk Ustaw warunek, a następnie wprowadź warunek. Reguła zostanie uruchomiona, gdy wystąpi warunek. Jeśli warunek nie jest ustawiona, reguła zostanie uruchomiona, gdy użytkownik zmieni się wartość w formancie i przenosi własnego kursora w kierunku od tego formantu.

  8. Kliknij przycisk Dodaj akcję.

  9. Na liście Akcja kliknij opcję Kwerenda przy użyciu połączenia danych.

  10. Na liście Połączenie danych kliknij połączenie danych kwerendy, którego chcesz używać, a następnie kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Dodawanie przycisku

Do szablonu formularza można dodać przycisk, którego kliknięcie będzie powodowało pobranie danych za pomocą połączenia danych kwerendy.

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  3. Przeciągnij formant przycisku na szablon formularza.

  4. Kliknij dwukrotnie przycisk dodany do szablonu formularza.

  5. Kliknij kartę Ogólne.

  6. Na liście Akcja kliknij polecenie Odśwież.

  7. W polu Etykieta wpisz nazwę, która ma być wyświetlana na przycisku na szablonie formularza.

  8. Kliknij przycisk Ustawienia.

  9. W oknie dialogowym odświeżanie wykonaj jedną z następujących czynności:

    • Aby uzyskać najnowsze dane ze wszystkich źródeł danych zewnętrznych z pomocniczych połączeń danych do tego szablonu formularza, kliknij pozycję wszystkie pomocnicze źródła danych.

    • Aby skonfigurować ten przycisk, aby otrzymywać aktualne dane z jednego źródła danych zewnętrznych z pomocniczego połączenia danych do szablonu formularza, kliknij jeden pomocniczego połączenia danych, a następnie kliknij pomocnicze źródło danych na liście Wybierz pomocnicze źródło danych.

  10. Kliknij przycisk OK, aby zamknąć każde otwarte okno dialogowe.

  11. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Początek strony

Uwaga: Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×