Dodawanie nowego formularza do narzędzia niestandardowego Listy

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Formularze dodaje się do narzędzia niestandardowego Listy, importując pliki rozwiązania szablonu formularza (xsn) zaprojektowane w programie Microsoft Office InfoPath.

Projektanci mogą importować dowolne rozwiązanie szablonu formularza utworzone w programie InfoPath. Jednak najlepszym sposobem na utworzenie nowego szablonu formularza jest skorzystanie z Projektanta narzędzia Listy w programie SharePoint Workspace, ponieważ wszystkie nowe szablony formularzy utworzone w Projektancie narzędzia Listy mają następujące wbudowane funkcje przeznaczone do pracy z programem SharePoint Workspace:

  • Ustawienie Opcje przesyłania ma wartość Prześlij do hosta.

  • Ustawienie Zabezpieczenia i zaufanie w opcjach formularza ma wartość Domena (formularz nie może uzyskać dostępu do zawartości znajdującej się poza formularzem).

  • Pola systemowe _Created, _CreatedBy, _Modified i ModifiedBy są już obecne na liście pól.

  • <konfigurowanie pola odnośnika ... potrzeba więcej informacji>

Te funkcje trzeba dodać ręcznie w innych rozwiązaniach szablonów formularzy programu InfoPath.

  1. Otwórz Projektanta narzędzia Listy.

  2. Na karcie Narzędzia główne kliknij pozycję Nowy formularz.

    Program Microsoft Office InfoPath otwiera nowy pusty formularz w programie InfoPath Designer.

  3. Dodaj pola i inne funkcje projektowe, które chcesz umieścić w szablonie Formularz w programie InfoPath.

    Pomoc dotyczącą tworzenia układu szablonów formularzy w programie InfoPath można znaleźć w Pomocy online dotyczącej programu InfoPath.

  4. Zapisz szablon Formularz na dysku jako plik szablonu formularza programu SharePoint Workspace (xsn).

    Porada : Szablon formularza można szybko zapisać w folderze Dokumenty. W tym celu należy kliknąć kartę Plik, kliknąć pozycję Publikuj, a następnie kliknąć pozycję SharePoint Workspace, aby otworzyć okno dialogowe systemu Windows Zapisywanie jako.

  5. Wróć do Projektanta narzędzia Listy w programie SharePoint Workspace.

  6. Na karcie Narzędzia główne kliknij pozycję Importuj formularz.

  7. Przejdź do pliku szablonu formularza zapisanego na dysku, a następnie kliknij przycisk Otwórz.

    Jeśli nie wykryto żadnych problemów dotyczących szablonu formularza, formularz zostaje dodany do projektu narzędzia Listy. Zostaje także utworzony odpowiedni widok dla nowego formularza.

    Jeśli program SharePoint Workspace wykryje problemy z szablonem formularza, jest wyświetlane okno dialogowe Błędy importu. W oknie dialogowym Błędy importu określone problemy mogą być zgłoszone jako ostrzeżenia, a inne jako błędy. Zwykle ostrzeżenia dotyczą nieobsługiwanych funkcji, takich jak okienka zadań, menu i paski narzędzi, które nie zostaną wyświetlone w zaimportowanym formularzu. Takie ostrzeżenia można zignorować. Jednak błędy oznaczają problemy, które uniemożliwiają zaimportowanie formularza. Na przykład nie można zaimportować szablonu formularza, jeśli są w nim używane podpisy dokumentów.

    Jeśli komunikat Błędy importu zawiera błędy, trzeba je naprawić w szablonie formularza przed jego zaimportowaniem.

    Skuteczną metodą unikania błędów w szablonie formularza jest utworzenie nowego formularza bezpośrednio w Projektancie narzędzia Listy (jak już wspomniano w tym temacie).

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×