Dodawanie łączników między kształtami w programie Visio

Dodawanie łączników między kształtami w programie Visio

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Program Visio ułatwia łączenie kształtów na rysunku. Za pomocą funkcji autołączenia możesz łączyć kształty podczas ich dodawania, a istniejące kształty możesz łączyć przy użyciu narzędzia Łącznik.

Typy połączeń

Istnieją dwa rodzaje połączeń, które łącznik może mieć z kształtem: połączenie punktowe i połączenie dynamiczne. Połączenie punktowe sprawia, że łącznik jest przyklejony do konkretnego punktu na kształcie, nawet w przypadku przesunięcia lub obrotu tego kształtu. Połączenie dynamiczne pozwala łącznikowi na zmianę położenia na kształcie, dzięki czemu w przypadku przesunięcia lub obrotu kształtu łącznik przesuwa się do punktu połączenia, który znajduje się najbliżej miejsca pochodzenia łącznika.

Na poniższym diagramie kształt A ma punkt połączenia z kształtem C, a przy każdym ruchu kształtu C łącznik z A pozostaje połączony z tym samym punktem na C. Z kolei kształt B ma połączenie dynamiczne z C, a łącznik z B przesuwa się do takiego punktu połączenia, który jest najbliżej C.

Kształt A ma połączenie punktowe z kształtem C, ale kształt B ma połączenie dynamiczne z kształtem C.

Możesz mieć obu typów połączenia na jednym z końców łącznika. Jeśli łączenie kształtów za pomocą funkcji autołączenia obydwa końce ma połączenie dynamiczne. Jeśli wybierzesz ręcznie, którego łącznik jest podłączony do kształtu, można określić typ używanego połączenia.

Automatyczne łączenie kształtu podczas jego dodawania

Jednym ze sposobów łączenia kształtów jest automatyczne łączenie w programie Visio podczas dodawania kształtów do rysunku. Ta opcja jest szczególnie przydatna podczas tworzenia schematu blokowego.

Poniższa procedura umożliwia dodanie do rysunku kształtu, który następnie program Visio automatycznie łączy z istniejącym kształtem.

Uwaga : Aby skorzystać z poniższej procedury, upewnij się, że aktywny jest tryb autołączenia. Na karcie Widok w grupie Ułatwienia wizualne upewnij się, że wybrana jest pozycja Autołączenie.

Aby dodać kształt i automatycznie połączyć go z istniejący kształt

  1. Jeśli na stronie nie ma jeszcze kształtów, przeciągnij kształt z okna Kształty na stronę.

  2. Przytrzymaj wskaźnik myszy na kształcie początkowym, aż wokół kształtu pojawią się strzałki autołączenia.

    Gdy autołączenie jest aktywne, umieść wskaźnik myszy na kształcie, aby wyświetlić strzałki połączenia.

    Jeśli nie widzisz strzałek autołączenia, sprawdź, czy na karcie Widok jest zaznaczona pozycja Autołączenie.

  3. Przytrzymaj wskaźnik na strzałce w kierunku, który chcesz dodać do kształtu.

    Umieszczenie wskaźnika myszy na strzałce autołączenia spowoduje wyświetlenie paska narzędzi z kształtami, które można dodać.

    Zostanie wyświetlony minipasek narzędzi zawierający pierwsze cztery szybkie kształty, które znajdują się obecnie we wzorniku Szybkie kształty. Gdy wskażesz kształt na pasku narzędzi, program Visio wyświetli podgląd tego kształtu na stronie.

  4. Kliknij kształt, który chcesz dodać.

  5. Jeśli chcesz kontynuować, wskaż strzałkę autołączenia na nowo dodanym kształcie w celu dodania innego kształtu, który również zostanie automatycznie połączony.

    Umieszczenie wskaźnika myszy na nowo dodanym kształcie spowoduje wyświetlenie strzałek autołączenia służących do dodawania kolejnego kształtu.

Uwaga : Jeśli chcesz, aby inny kształt niż przedstawione na minipasku narzędzi, przeciągnij kształt, który chcesz z okna Kształty w odpowiednim miejscu na stronie. Aby połączyć kształt, użyj metody opisane w następnej sekcji.

Łączenie kształtów znajdujących się już na stronie

Kształty, które znajdują się już na rysunku, można łączyć za pomocą autołączenia lub za pomocą narzędzia Łącznik.

Po połączeniu kształtów, możesz to zrobić z połączenia dwóch typów: punktu połączenia lub połączenie dynamiczne. Aby uzyskać więcej informacji na temat tych typów połączeń zobacz typy połączeńpowyżej.

Aby utworzyć połączenie punktowe, dzięki któremu łącznik będzie przyklejony do określonego punktu na kształcie, przeciągnij wskaźnik od punktu połączenia na pierwszym kształcie do punktu połączenia na drugim kształcie. Po połączeniu kształtów punkty końcowe łącznika zmienią kolor na zielony.

Przyklej łącznik do określonego punktu w kształcie, aby przymocować łącznik do tego punktu.
Przyklej łącznik do określonego punktu w kształcie, aby przymocować łącznik do tego punktu.

Aby utworzyć połączenie dynamiczne, dzięki któremu łącznik będzie automatycznie przesuwany do bliższych punktów na kształcie, umieść narzędzie Łącznik na środku pierwszego kształtu i przytrzymaj je tam, aż wokół kształtu pojawi się zielona ramka. Naciśnij i przytrzymaj przycisk myszy i przeciągnij wskaźnik do środka drugiego kształtu. Kiedy wokół drugiego kształtu zostanie wyświetlona zielona ramka, zwolnij przycisk myszy.

Przyklej łącznik do kształtu, aby umożliwić dynamiczne przenoszenie łącznika do punktów w kształcie.
Przyklej łącznik do kształtu, aby umożliwić dynamiczne przenoszenie łącznika do punktów w kształcie.

Łączenie kształtów za pomocą funkcji autołączenia

  1. Przytrzymaj wskaźnik myszy na kształcie, aż wokół niego pojawią się strzałki autołączenia.

    Gdy autołączenie jest aktywne, umieść wskaźnik myszy na kształcie, aby wyświetlić strzałki połączenia.
  2. Kliknij i przeciągnij uchwyt strzałki autołączenia do innego kształtu, upuść punkt końcowy łącznika na środku kształtu, aby uzyskać połączenie dynamiczne, albo na konkretnym punkcie połączenia na kształcie, aby uzyskać połączenie punktowe.

    Gdy przytrzymasz wskaźnik myszy na strzałce autołączenia, zostanie wyświetlony podgląd kształtu, ale kształt można zignorować — zniknie po przesunięciu łącznika do jego miejsca docelowego.

Łączenie kształtów za pomocą narzędzia Łącznik

  1. Na karcie Narzędzia główne w grupie Narzędzia kliknij przycisk Łącznik.

    Narzędzie Łącznik umożliwia łączenie kształtów połączeniem punktowym po obu końcach.
  2. Kliknij dowolny kształt i przeciągnij łącznik do innego kształtu.

  3. Po zakończeniu kliknij pozycję Wskaźnik — narzędzie na karcie Narzędzia główne w grupie Narzędzia.

Szybkie zadania

Zadanie

Akcja

Zmiana typu łącznika na łącznik z kątem prostym, łącznik prostoliniowy lub zakrzywiony.

Kliknij prawym przyciskiem myszy łącznik, a następnie kliknij typ łącznika w menu skrótów: z kątem prostym, łącznik prostoliniowy lub zakrzywiony.

Wyrównanie i rozłożenie kształtów w celu uzyskania przejrzystych łączników.

Zaznacz kształty, które chcesz wyrównać, a następnie na karcie Narzędzia główne w grupie Rozmieszczanie kliknij pozycje Wyrównaj > Automatyczne wyrównanie lub Położenie > Automatyczny odstęp. Wiele kształtów można zaznaczyć, naciskając klawisz Ctrl podczas klikania wielu kształtów lub używając jednej z opcji Zaznacz w grupie Edytowanie na karcie Narzędzia główne.

Zmiana połączenia z dynamicznego na punktowe lub odwrotnie.

Zaznacz łącznik i przeciągnij punkt końcowy łącznika, odsuwając go od kształtu. Następnie upuść łącznik na konkretnym punkcie połączenia, aby uzyskać połączenie punktowe, lub na środku kształtu, aby uzyskać połączenie dynamiczne.

Włączanie i wyłączanie autołączenia

Autołączenie można włączać i wyłączać we wszystkich rysunkach Visio lub tylko w aktywnym rysunku.

Włączanie i wyłączanie autołączenia dla aktywnego diagramu

  • Na karcie Widok w grupie Ułatwienia wizualne zaznacz lub wyczyść zaznaczenie pola wyboru Autołączenie.

    Zaznacz lub wyczyść pole wyboru Autołączenie na karcie Widok, aby aktywować lub dezaktywować autołączenie.

Uwaga : Jeśli pole wyboru Autołączenie jest niedostępne, sprawdź, czy funkcja autołączenia została wyłączona dla wszystkich diagramów, wykonując poniższą procedurę.

Włączanie i wyłączanie autołączenia dla wszystkich diagramów

  1. Kliknij kartę Plik, a następnie kliknij pozycję Opcje.

  2. W obszarze Opcje programu Visio kliknij pozycję Zaawansowane.

  3. W obszarze Opcje edycji wybierz pozycję Włącz autołączenie, aby włączyć autołączenie. Aby wyłączyć autołączenie, wyczyść pole wyboru Autołączenie.

    Zaznacz lub wyczyść pole wyboru Włącz autołączenie, aby aktywować lub dezaktywować autołączenie dla wszystkich diagramów i rysunków.
  4. Kliknij przycisk OK.

Zobacz też

Dodawanie strzałek, punktów lub innych końców linii do łącznika

Dodawanie, przenoszenie i usuwanie punktów połączeń przy użyciu narzędzia punkt połączenia

Automatyczne łączenie kształtu podczas jego dodawania

Jednym ze sposobów łączenia kształtów jest automatyczne łączenie w programie Visio podczas dodawania kształtów do rysunku. Ta opcja jest szczególnie przydatna podczas tworzenia schematu blokowego.

Poniższa procedura umożliwia dodanie do rysunku kształtu, który następnie program Visio automatycznie łączy z istniejącym kształtem.

  1. Jeśli na stronie nie ma jeszcze kształtów, przeciągnij kształt początkowy z okna Kształty na stronę.

  2. Przytrzymaj wskaźnik myszy na kształcie początkowym, aż wokół kształtu pojawią się niebieskie strzałki autołączenia.

  3. Przytrzymaj wskaźnik na strzałce w kierunku, który chcesz dodać do kształtu.

    Pojawi się minipasek narzędzi, zawierający pierwsze cztery szybkie kształty, które znajdują się obecnie we wzorniku Szybkie kształty. Na stronie zostanie wyświetlony podgląd na żywo kształtu wybranego we wzorniku.

  4. Ustawiając wskaźnik na jednym z czterech kształtów na minipasku narzędzi, można zobaczyć, jak każdy z nich będzie wyglądał na stronie.

  5. Kliknij kształt, który chcesz dodać.

Aby użyć innego kształtu, należy zabrać wskaźnik ze strzałki autołączenia (podgląd nie będzie wyświetlany). Następnie można przeciągnąć żądany kształt z okna Kształty.

Szybkie zadania

Zadanie

Akcja

Zmienianie szybkich kształtów dla wzornika.

Otwórz wzornik i przeciągnij szybkie kształty w wybranej kolejności. Kształty można przeciągać do i z obszaru Szybkie kształty.

Zmienianie kształtów znajdujących się na minipasku narzędzi.

We wzorniku Szybkie kształty w grupie Szybkie kształty zaznacz kształt, który ma występować na minipasku narzędzi. Grupa z zaznaczonymi kształtami pojawi się na pasku narzędzi.

Można też przeciągnąć wzornik zawierający kształty, które mają być pierwsze, i upuścić go tuż poniżej paska tytułu Szybkie kształty. Kolejność wzorników można zmieniać, przeciągając je wyżej lub niżej w oknie Kształty — we wzorniku Szybkie kształty występują one w tej samej kolejności.

Łączenie kształtów znajdujących się już na stronie

Umożliwia nawiązanie połączenia kształtów znajdujących się już na rysunku za pomocą autołączenia lub za pomocą narzędzia Łącznik.

Łączenie kształtów za pomocą autołączenia

  1. Przytrzymaj wskaźnik myszy na kształcie, aż wokół kształtu pojawią się niebieskie strzałki autołączenia.

  2. Kliknij i przeciągnij uchwyt strzałki autołączenia do innego kształtu, upuść punkt końcowy łącznika na środku kształtu, aby uzyskać połączenie dynamiczne, albo na konkretnym punkcie połączenia, aby uzyskać połączenie punktowe.

    Po przytrzymaniu wskaźnika myszy na niebieskiej strzałce zostanie wyświetlony podgląd na żywo kształtu, ale kształt można zignorować — zniknie po zabraniu wskaźnika.

Łączenie kształtów za pomocą narzędzia Łącznik

  1. Na karcie Narzędzia główne w grupie Narzędzia kliknij przycisk Łącznik.

  2. Kliknij dowolny kształt i przeciągnij łącznik do innego kształtu.

Aby przykleić łącznik do określonego punktu na kształcie, przeciągnij wskaźnik od punktu połączenia na pierwszym kształcie do punktu połączenia na drugim kształcie. Po połączeniu kształtów punkty końcowe łącznika zmienią kolor na czerwony. Jest to tak zwane połączenie punktowe.

Aby umożliwić przenoszenie punktu połączenia w dowolne miejsce kształtu podczas przenoszenia kształtu, umieść narzędzie Łącznik na środku pierwszego kształtu. Naciśnij i przytrzymaj przycisk myszy i przeciągnij wskaźnik do środka drugiego kształtu. Kiedy wokół drugiego kształtu zostanie wyświetlona czerwona ramka, zwolnij przycisk myszy. Jest to tak zwane połączenie dynamiczne.

Szybkie zadania

Zadanie

Akcja

Zmiana typu łącznika na łącznik z kątem prostym, łącznik prostoliniowy lub zakrzywiony.

Kliknij prawym przyciskiem myszy łącznik, a następnie kliknij typ łącznika w menu skrótów.

Wyrównanie i rozłożenie kształtów w celu uzyskania przejrzystych łączników.

Zaznacz wszystkie kształty, które chcesz wyrównać, a następnie na karcie Narzędzia główne kliknij Automatyczne wyrównanie i odstępy. Czy Zaznaczanie wielu kształtów, naciskając klawisz CTRL podczas klikania wszystkich lub przy użyciu jednej z opcji Wybierz pozycję.

Zmiana połączenia z dynamicznego na punktowe lub odwrotnie.

Zaznacz łącznik i przeciągnij punkt końcowy łącznika, odsuwając go od kształtu. Następnie upuść łącznik na konkretnym punkcie połączenia, aby uzyskać połączenie punktowe, lub na środku kształtu, aby uzyskać połączenie dynamiczne.

Włączanie i wyłączanie autołączenia

Autołączenie można włączać i wyłączać dla wszystkich rysunków lub tylko dla aktywnego rysunku.

Włączanie i wyłączanie autołączenia dla aktywnego diagramu

  • Na karcie Widok w grupie Ułatwienia wizualne zaznacz lub wyczyść pole wyboru Autołączenie.

Jeśli pole wyboru Autołączenie jest niedostępne, należy sprawdzić, czy funkcja autołączenia nie została wyłączona dla wszystkich diagramów, wykonując poniższą procedurę.

Włączanie i wyłączanie autołączenia dla wszystkich diagramów

  1. Kliknij pozycję Plik > Opcje.

  2. Kliknij kategorię Zaawansowane.

  3. W obszarze Opcje edycji zaznacz pole wyboru Włącz autołączenie, aby włączyć autołączenie. Wyczyść to pole wyboru, aby wyłączyć autołączenie.

Zobacz też

Dodawanie strzałek, punktów lub innych końców linii do łącznika

Dodawanie, przenoszenie i usuwanie punktów połączeń

Łączenie kształtów za pomocą funkcji autołączenia

Jednym ze sposobów łączenia kształtów jest automatyczne łączenie w programie Visio podczas dodawania kształtów do rysunku. Ta opcja jest szczególnie przydatna podczas tworzenia schematu blokowego.

Poniższa procedura umożliwia dodanie do rysunku kształtu, który następnie program Visio automatycznie łączy z istniejącym kształtem.

Używanie funkcji autołączenia podczas przeciągania kształtów na stronie

  1. Przeciągnij kształt ze wzornika na stronę rysunku i umieść go w pobliżu innego kształtu.

    Kształt umieszczony w pobliżu innego kształtu

  2. Trzymając naciśnięty przycisk myszy, umieść wskaźnik myszy na jednym z niebieskim trójkącie. Trójkąt zmieni ciemny niebieski.

    Wskaźnik ustawiony na niebieskim trójkącie

  3. Zwolnij przycisk myszy. Kształt umieszczony na stronie rysunku, a zostanie dodany łącznik i przyklejony do obydwu kształtów.

    Po kliknięciu niebieskiego trójkąta do obu kształtów zostaną dodane i przyklejone łączniki.

Porada : Jeśli nie podoba, przeciągając kształty, można uzyskać ten sam efekt przy pierwszym Zaznaczanie kształtu we wzorniku, umieszczając wskaźnik na kształcie na rysunku, a następnie klikając jeden z niebieskim trójkącie, które pojawiają się obok tego kształtu.

Używanie funkcji autołączenia z kształtami już na stronie

  1. Umieść wskaźnik myszy na kształt, do którego chcesz się połączyć z.

    Wskaźnik ustawiony na kształcie, z którego jest tworzone połączenie

  2. Umieść wskaźnik na niebieskim trójkącie znajdującym się najbliżej kształt, do którego chcesz się połączyć.

    Wskaźnik umieszczony nad niebieskim trójkątem najbliższym kształtowi, do którego połączenie ma zostać utworzone.

    Trójkąt zmieni ciemny niebieski, a zostanie wyświetlona czerwona ramka wokół kształtu, który chcesz nawiązać połączenie.

    Uwaga : Jeśli nie ma czerwona ramka wokół kształtu, który chcesz nawiązać połączenie, kształt może być zbyt daleko. Przenoszenie kształtu bliżej i spróbuj ponownie lub za pomocą narzędzia Łącznik.

  3. Kliknij niebieski trójkąt. I dodany łącznik przyklejony do obydwu kształtów.

    Po kliknięciu niebieskiego trójkąta do obu kształtów zostaną dodane i przyklejone łączniki.

Włączanie lub wyłączanie funkcji autołączenia

Można włączyć lub wyłączyć funkcję autołączenia wszystkich rysunków lub tylko na bieżącym rysunku. Dla wszystkich rysunków:

  1. W menu Narzędzia kliknij polecenie Opcje.

  2. Kliknij kartę Ogólne.

  3. W obszarze Opcje okna rysunku zaznacz pole wyboru Włącz autołączenie.

Dla bieżącego tylko rysunku:

  • Na pasku narzędzi Standardowy kliknij narzędzie autołączenia.

    Uwaga : Jeśli kliknięciem narzędzia autołączenia nie obsługuje funkcji autołączenia, upewnij się, że jest zaznaczone pole wyboru Włącz autołączenie, w oknie dialogowym Opcje.

Łączenie kształtów za pomocą narzędzia Łącznik

Jedną z najbardziej elastyczna sposoby Dodawanie i przyklejanie łączników jest narysowanie go za pomocą narzędzia Łącznik Obraz przycisku na pasku narzędzi Standardowy.

  1. Kliknij narzędzie Łącznik Obraz przycisku na pasku narzędzi Standardowy.

  2. Wykonaj jedną z następujących czynności:

    • Aby zachować łącznik przyklejony do określonego punktu na kształcie, przeciągnij z punktu połączenia Obraz punktu połączenia — niebieski znak X pierwszego kształtu do punktu połączenia drugiego kształtu. Czerwony punkty końcowe łącznika, gdy kształty są połączone. Jest to połączenie typu punkt-punkt. Połączenie typu punkt-punkt łącznik pozostaje przyklejony do tych samych punktów połączenia po umieszczeniu w jednym z kształtów.

    • Aby zezwolić na łącznik powoduje przejście do najbliższego dostępnego punktu połączenia, ustaw narzędzia Łącznik nad Centrum pierwszego kształtu, aż wokół kształtu zostanie wyświetlona czerwona ramka. Przytrzymaj naciśnięty przycisk myszy i przeciągnij do środka drugiego kształtu. Kiedy wokół drugiego kształtu zostanie wyświetlona czerwona ramka, zwolnij przycisk myszy. Jest to połączenie kształt kształt. Połączenie kształt kształt łącznik pozostaje przyklejony do każdego kształtu, przenosząc do najbliższego dostępnego punktu połączenia po umieszczeniu jeden z kształtów. Jeśli istnieją nie punktów połączeń, łącznik powoduje przejście do najbliższego boku kształtu.

      Uwaga : Można także tworzyć połączenia między kształtami, gdzie jeden koniec łącznika jest podłączone do punktu połączenia, a drugi koniec łącznika jest połączony z kształtem (i odwrotnie).

  3. Kliknij narzędzie Wskaźnik Przycisk wskaźnika na pasku narzędzi Standardowy, aby wrócić do normalnego edytowania.

    Uwagi : 

    • Aby dodać łącznik z jednego kształtu do wielu kształtów, należy dodać wiele łączników; nie ma żadnych "rozgałęziania" kształtu łącznik.

    • Jeśli chcesz utworzyć połączenie typu punkt-punkt i o czasie trudne, przyklejanie łącznika dokładnie w żądanym miejscu wypróbować różne Przyciąganie i przyklejanie ustawienia:

    • W menu Narzędzia kliknij polecenie Przyciąganie i przyklejanie, a następnie na karcie Ogólne wybierz odpowiednie opcje.

      Jeśli przyklejony do geometrii kształtu, uchwytu kształtu lub wierzchołka kształtu punktu połączenia jest automatycznie dodawany, jeśli jeszcze nie istnieje.

Zobacz też

Dodawanie strzałek, punktów lub innych końców linii do łącznika

Dodawanie, przesuwanie i usuwanie punktów połączeń

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×