Cyfrowe podpisywanie projektu makra

W tym artykule opisano sposób, w jaki można cyfrowo podpisać projekt makra, wykorzystując certyfikat. Jeśli nie masz jeszcze certyfikatu cyfrowego, musisz go uzyskać. Aby przetestować projekty makra na własnym komputerze, możesz utworzyć certyfikat z podpisem własnym, korzystając z narzędzia Selfcert.exe.

Certyfikat cyfrowy można uzyskać od komercyjnego urzędu certyfikacji, od administratora zabezpieczeń wewnętrznych lub od informatyka.

Aby dowiedzieć się więcej o urzędach certyfikacji oferujących usługi związane z produktami firmy Microsoft, zobacz listę urzędów certyfikacji uwzględnionych w programie Microsoft Root Certificate Program.

Początek strony

Ponieważ certyfikat cyfrowy utworzony samodzielnie przez użytkownika nie jest wydany przez zaufany urząd certyfikacji, podpisane w ten sposób projekty makr są określane jako projekty z podpisem własnym. Pakiet Microsoft Office uznaje certyfikat z podpisem własnym za zaufany tylko na tych komputerach, na których taki certyfikat dodano do folderu Zaufane główne urzędy certyfikacji w magazynie Certyfikaty — bieżący użytkownik.

Aby dowiedzieć się, jak utworzyć certyfikat z podpisem własnym, zobacz następną sekcję.

  1. Przejdź do lokalizacji C:\Program Files (x86)\Microsoft Office\root\.

  2. Kliknij pozycję SelfCert.exe. Zostanie wyświetlone okno Tworzenie certyfikatu cyfrowego.

  3. W polu Nazwa certyfikatu wpisz opisową nazwę certyfikatu.

  4. Kliknij przycisk OK.

  5. Gdy zostanie wyświetlony komunikat o tym, że działanie programu SelfCert zakończyło się pomyślnie, kliknij przycisk OK.

  1. Przejdź do lokalizacji CC:\Program Files\Microsoft Office\<wersja pakietu Office>\.

  2. Kliknij pozycję SelfCert.exe. Zostanie wyświetlone okno Tworzenie certyfikatu cyfrowego.

  3. W polu Nazwa certyfikatu wpisz opisową nazwę certyfikatu.

  4. Kliknij przycisk OK.

  5. Gdy zostanie wyświetlony komunikat o tym, że działanie programu SelfCert zakończyło się pomyślnie, kliknij przycisk OK.

  1. Kliknij przycisk Start, wskaż polecenie Wszystkie programy, kliknij polecenie Microsoft Office, kliknij polecenie Narzędzia Microsoft Office, a następnie kliknij polecenie Certyfikat cyfrowy dla projektów VBA.
    Zostanie wyświetlone okno Tworzenie certyfikatu cyfrowego.

  2. W polu Nazwa certyfikatu wpisz opisową nazwę certyfikatu.

  3. Kliknij przycisk OK.

  4. Gdy zostanie wyświetlony komunikat o tym, że działanie programu SelfCert zakończyło się pomyślnie, kliknij przycisk OK.

Okno dialogowe Tworzenie podpisu cyfrowego

Aby wyświetlić certyfikat znajdujący się w magazynie certyfikatów osobistych, wykonaj następujące czynności:

  1. Uruchom program Internet Explorer.

  2. W menu Narzędzia kliknij polecenie Opcje internetowe, a następnie kliknij kartę Zawartość.

  3. Kliknij przycisk Certyfikaty, a następnie kliknij kartę Osobisty.

Początek strony

  1. Otwórz plik zawierający projekt makra, który chcesz podpisać.

  2. Na karcie Deweloper w grupie Kod kliknij przycisk Visual Basic.

    Uwaga : Jeśli karta Deweloper nie jest dostępna, kliknij kartę Plik, kliknij pozycję Opcje, a następnie pozycję Dostosowywanie Wstążki. Na liście Dostosuj Wstążkę zaznacz pozycję Deweloper, a następnie kliknij przycisk OK.

  3. W oknie Visual Basic w menu Tools (Narzędzia) kliknij polecenie Digital Signature (Podpis cyfrowy).

  4. Zostanie wyświetlone okno dialogowe Podpis cyfrowy.

  5. Wybierz certyfikat i kliknij przycisk OK.

    Uwaga : Jeśli po raz pierwszy używasz certyfikatu cyfrowego lub chcesz użyć innego certyfikatu, kliknij przycisk Choose (Wybierz), wybierz certyfikat, a następnie kliknij przycisk OK.

    Uwagi : 

    • Zalecane jest podpisywanie makr wyłącznie po przetestowaniu rozwiązania i przygotowaniu go do rozpowszechnienia, ponieważ każda zmiana kodu w podpisanym projekcie makra powoduje usunięcie podpisu cyfrowego tego makra. Jeśli jednak na komputerze istnieje prawidłowy certyfikat cyfrowy, który został poprzednio użyty do podpisania projektu, projekt makra jest automatycznie podpisywany ponownie podczas zapisywania.

    • Aby zapobiec przypadkowej zmianie projektu makra przez użytkowników, co unieważniłoby podpis, przed podpisaniem projektu makra należy go zablokować. Podpis cyfrowy oznacza, że właściciel podpisu gwarantuje, iż projekt nie był modyfikowany od czasu jego podpisania. Nie jest natomiast dowodem, że właściciel podpisu jest autorem projektu. Zablokowanie projektu makra nie pozbawia zatem innego użytkownika możliwości zamiany bieżącego podpisu cyfrowego na inny podpis. Administratorzy w firmach mogą podpisywać od nowa szablony i dodatki, aby kontrolować, co użytkownicy mogą uruchamiać na swoich komputerach.

    • W przypadku tworzenia dodatku, który dodaje kod do projektu makra, nowy kod powinien stwierdzać, czy projekt jest podpisany cyfrowo, i powiadamiać użytkownika o konsekwencjach modyfikowania podpisanego projektu, zanim pozwoli mu przejść dalej.

    • Podczas cyfrowego podpisywania makr ważne jest utworzenie sygnatury czasowej, aby inni użytkownicy mogli zweryfikować podpis nawet po wygaśnięciu lub odwołaniu jego certyfikatu. Podpisanie makra bez sygnatury czasowej powoduje, że podpis jest prawidłowy tylko przez okres ważności certyfikatu.

Początek strony

Certyfikat cyfrowy można uzyskać od komercyjnego urzędu certyfikacji (CA) lub od administratora zabezpieczeń.

Aby dowiedzieć się więcej o urzędach certyfikacji oferujących usługi związane z produktami firmy Microsoft, zobacz listę urzędów certyfikacji uwzględnionych w programie Microsoft Root Certificate Program.

Początek strony

Ponieważ certyfikat cyfrowy utworzony samodzielnie przez Ciebie nie jest wydany przez oficjalny urząd certyfikacji, podpisane w ten sposób projekty makr są nazywane projektami z podpisem własnym. Pakiet Microsoft Office uznaje certyfikat z podpisem własnym za zaufany tylko na komputerze mającym ten certyfikat w magazynie certyfikatów osobistych użytkownika.

  1. Kliknij przycisk Start, wskaż polecenie Wszystkie programy, kliknij polecenie Microsoft Office, kliknij polecenie Narzędzia Microsoft Office, a następnie kliknij polecenie Certyfikat cyfrowy dla projektów VBA. W polu Nazwa certyfikatu wpisz opisową nazwę certyfikatu.

  2. Gdy zostanie wyświetlony komunikat z potwierdzeniem certyfikatu, kliknij przycisk OK.

Aby wyświetlić certyfikat znajdujący się w magazynie certyfikatów osobistych, wykonaj następujące czynności:

  1. Uruchom program Internet Explorer.

  2. W menu Narzędzia kliknij polecenie Opcje internetowe, a następnie kliknij kartę Zawartość.

  3. Kliknij przycisk Certyfikaty, a następnie kliknij kartę Osobisty.

Początek strony

  1. Kliknij przycisk Start, wskaż polecenie Wszystkie programy, wskaż polecenie Microsoft Office, wskaż polecenie Narzędzia Microsoft Office, a następnie kliknij polecenie Certyfikat cyfrowy dla projektów VBA. W polu Nazwa certyfikatu wpisz opisową nazwę certyfikatu.

  2. Gdy zostanie wyświetlony komunikat z potwierdzeniem certyfikatu, kliknij przycisk OK.

Aby wyświetlić certyfikat znajdujący się w magazynie certyfikatów osobistych, wykonaj następujące czynności:

  1. Otwórz program Windows Internet Explorer.

  2. W menu Narzędzia kliknij polecenie Opcje internetowe, a następnie kliknij kartę Zawartość.

  3. Kliknij przycisk Certyfikaty, a następnie kliknij kartę Osobisty.

Początek strony

  1. Otwórz plik zawierający projekt makra, który chcesz podpisać.

    • Na karcie Deweloper w grupie Kod kliknij przycisk Visual Basic.

      Jeśli karta Deweloper nie jest dostępna, kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Excel. Kliknij pozycję Popularne, a następnie zaznacz pole wyboru Pokaż kartę Deweloper na Wstążce.

      Uwaga : Wstążka to jeden z elementów, które zawiera interfejs użytkownika Microsoft Office Fluent.

  2. W Eksploratorze projektów języka Visual Basic wybierz projekt, który chcesz podpisać.

  3. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat cyfrowy nie był wcześniej wybierany lub chcesz użyć innego certyfikatu, kliknij przycisk Choose (Wybierz), wybierz certyfikat, a następnie dwukrotnie kliknij przycisk OK.

    • Aby użyć bieżącego certyfikatu, kliknij przycisk OK.

      Uwagi : 

      • Podpisuj makra wyłącznie po przetestowaniu rozwiązania i przygotowaniu go do rozpowszechnienia, ponieważ każda zmiana kodu w podpisanym projekcie makra powoduje usunięcie podpisu cyfrowego tego makra. Jeśli jednak na komputerze istnieje prawidłowy certyfikat cyfrowy, który został poprzednio użyty do podpisania projektu, projekt makra jest automatycznie podpisywany ponownie podczas zapisywania.

      • Aby zapobiec przypadkowej zmianie projektu makra przez użytkowników, co unieważniłoby podpis, przed podpisaniem projektu makra należy go zablokować. Podpis cyfrowy oznacza jedynie, że właściciel podpisu gwarantuje, iż projekt nie był modyfikowany od czasu jego podpisania. Nie jest natomiast dowodem, że właściciel podpisu jest autorem projektu. Zablokowanie projektu makra nie pozbawia zatem innego użytkownika możliwości zamiany bieżącego podpisu cyfrowego na inny podpis. Administratorzy w firmach mogą podpisywać od nowa szablony i dodatki, aby kontrolować, co użytkownicy mogą uruchamiać na swoich komputerach.

      • W przypadku tworzenia dodatku, który dodaje kod do projektu makra, nowy kod powinien stwierdzać, czy projekt jest podpisany cyfrowo, i powiadamiać użytkownika o konsekwencjach modyfikowania podpisanego projektu, zanim pozwoli mu przejść dalej.

      • Podczas cyfrowego podpisywania makr ważne jest utworzenie sygnatury czasowej, aby inni użytkownicy mogli zweryfikować podpis nawet po wygaśnięciu jego certyfikatu. Podpisanie makra bez sygnatury czasowej powoduje, że podpis jest prawidłowy tylko przez okres ważności certyfikatu.

  1. Otwórz plik zawierający projekt makra, który chcesz podpisać.

    • W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Edytor Visual Basic.

  2. W Eksploratorze projektów języka Visual Basic wybierz projekt, który chcesz podpisać.

  3. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat cyfrowy nie był wcześniej wybierany lub chcesz użyć innego certyfikatu, kliknij przycisk Choose (Wybierz), wybierz certyfikat, a następnie dwukrotnie kliknij przycisk OK.

    • Aby użyć bieżącego certyfikatu, kliknij przycisk OK.

      Uwagi : 

      • Podpisuj makra wyłącznie po przetestowaniu rozwiązania i przygotowaniu go do rozpowszechnienia, ponieważ każda zmiana kodu w podpisanym projekcie makra powoduje usunięcie podpisu cyfrowego tego makra. Jeśli jednak na komputerze istnieje prawidłowy certyfikat cyfrowy, który został poprzednio użyty do podpisania projektu, projekt makra jest automatycznie podpisywany ponownie podczas zapisywania.

      • Aby zapobiec przypadkowej zmianie projektu makra przez użytkowników, co unieważniłoby podpis, przed podpisaniem projektu makra należy go zablokować. Podpis cyfrowy oznacza jedynie, że właściciel podpisu gwarantuje, iż projekt nie był modyfikowany od czasu jego podpisania. Nie jest natomiast dowodem, że właściciel podpisu jest autorem projektu. Zablokowanie projektu makra nie pozbawia zatem innego użytkownika możliwości zamiany bieżącego podpisu cyfrowego na inny podpis. Administratorzy w firmach mogą podpisywać od nowa szablony i dodatki, aby kontrolować, co użytkownicy mogą uruchamiać na swoich komputerach.

      • W przypadku tworzenia dodatku, który dodaje kod do projektu makra, nowy kod powinien stwierdzać, czy projekt jest podpisany cyfrowo, i powiadamiać użytkownika o konsekwencjach modyfikowania podpisanego projektu, zanim pozwoli mu przejść dalej.

      • Podczas cyfrowego podpisywania makr ważne jest utworzenie sygnatury czasowej, aby inni użytkownicy mogli zweryfikować podpis nawet po wygaśnięciu jego certyfikatu. Podpisanie makra bez sygnatury czasowej powoduje, że podpis jest prawidłowy tylko przez okres ważności certyfikatu.

Początek strony

  1. Otwórz plik zawierający projekt makra, który chcesz podpisać.

    • Na karcie Deweloper w grupie Kod kliknij przycisk Visual Basic.

      Jeśli karta Deweloper nie jest dostępna, kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu PowerPoint. Kliknij pozycję Popularne, a następnie zaznacz pole wyboru Pokaż kartę Deweloper na Wstążce.

      Uwaga : Wstążka to jeden z elementów, które zawiera interfejs użytkownika Microsoft Office Fluent.

  2. W Eksploratorze projektów języka Visual Basic wybierz projekt, który chcesz podpisać.

  3. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat cyfrowy nie był wcześniej wybierany lub chcesz użyć innego certyfikatu, kliknij przycisk Choose (Wybierz), wybierz certyfikat, a następnie dwukrotnie kliknij przycisk OK.

    • Aby użyć bieżącego certyfikatu, kliknij przycisk OK.

      Uwagi : 

      • Podpisuj makra wyłącznie po przetestowaniu rozwiązania i przygotowaniu go do rozpowszechnienia, ponieważ każda zmiana kodu w podpisanym projekcie makra powoduje usunięcie podpisu cyfrowego tego makra. Jeśli jednak na komputerze istnieje prawidłowy certyfikat cyfrowy, który został poprzednio użyty do podpisania projektu, projekt makra jest automatycznie podpisywany ponownie podczas zapisywania.

      • Aby zapobiec przypadkowej zmianie projektu makra przez użytkowników, co unieważniłoby podpis, przed podpisaniem projektu makra należy go zablokować. Podpis cyfrowy oznacza jedynie, że właściciel podpisu gwarantuje, iż projekt nie był modyfikowany od czasu jego podpisania. Nie jest natomiast dowodem, że właściciel podpisu jest autorem projektu. Zablokowanie projektu makra nie pozbawia zatem innego użytkownika możliwości zamiany bieżącego podpisu cyfrowego na inny podpis. Administratorzy w firmach mogą podpisywać od nowa szablony i dodatki, aby kontrolować, co użytkownicy mogą uruchamiać na swoich komputerach.

      • W przypadku tworzenia dodatku, który dodaje kod do projektu makra, nowy kod powinien stwierdzać, czy projekt jest podpisany cyfrowo, i powiadamiać użytkownika o konsekwencjach modyfikowania podpisanego projektu, zanim pozwoli mu przejść dalej.

      • Podczas cyfrowego podpisywania makr ważne jest utworzenie sygnatury czasowej, aby inni użytkownicy mogli zweryfikować podpis nawet po wygaśnięciu jego certyfikatu. Podpisanie makra bez sygnatury czasowej powoduje, że podpis jest prawidłowy tylko przez okres ważności certyfikatu.

Początek strony

  1. Otwórz plik zawierający projekt makra, który chcesz podpisać.

    • W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Edytor Visual Basic.

  2. W Eksploratorze projektów języka Visual Basic wybierz projekt, który chcesz podpisać.

  3. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat cyfrowy nie był wcześniej wybierany lub chcesz użyć innego certyfikatu, kliknij przycisk Choose (Wybierz), wybierz certyfikat, a następnie dwukrotnie kliknij przycisk OK.

    • Aby użyć bieżącego certyfikatu, kliknij przycisk OK.

      Uwagi : 

      • Podpisuj makra wyłącznie po przetestowaniu rozwiązania i przygotowaniu go do rozpowszechnienia, ponieważ każda zmiana kodu w podpisanym projekcie makra powoduje usunięcie podpisu cyfrowego tego makra. Jeśli jednak na komputerze istnieje prawidłowy certyfikat cyfrowy, który został poprzednio użyty do podpisania projektu, projekt makra jest automatycznie podpisywany ponownie podczas zapisywania.

      • Aby zapobiec przypadkowej zmianie projektu makra przez użytkowników, co unieważniłoby podpis, przed podpisaniem projektu makra należy go zablokować. Podpis cyfrowy oznacza jedynie, że właściciel podpisu gwarantuje, iż projekt nie był modyfikowany od czasu jego podpisania. Nie jest natomiast dowodem, że właściciel podpisu jest autorem projektu. Zablokowanie projektu makra nie pozbawia zatem innego użytkownika możliwości zamiany bieżącego podpisu cyfrowego na inny podpis. Administratorzy w firmach mogą podpisywać od nowa szablony i dodatki, aby kontrolować, co użytkownicy mogą uruchamiać na swoich komputerach.

      • W przypadku tworzenia dodatku, który dodaje kod do projektu makra, nowy kod powinien stwierdzać, czy projekt jest podpisany cyfrowo, i powiadamiać użytkownika o konsekwencjach modyfikowania podpisanego projektu, zanim pozwoli mu przejść dalej.

      • Podczas cyfrowego podpisywania makr ważne jest utworzenie sygnatury czasowej, aby inni użytkownicy mogli zweryfikować podpis nawet po wygaśnięciu jego certyfikatu. Podpisanie makra bez sygnatury czasowej powoduje, że podpis jest prawidłowy tylko przez okres ważności certyfikatu.

Początek strony

  1. Otwórz plik zawierający projekt makra, który chcesz podpisać.

    • W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Edytor Visual Basic.

  2. W Eksploratorze projektów języka Visual Basic wybierz projekt, który chcesz podpisać.

  3. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat cyfrowy nie był wcześniej wybierany lub chcesz użyć innego certyfikatu, kliknij przycisk Choose (Wybierz), wybierz certyfikat, a następnie dwukrotnie kliknij przycisk OK.

    • Aby użyć bieżącego certyfikatu, kliknij przycisk OK.

      Uwagi : 

      • Podpisuj makra wyłącznie po przetestowaniu rozwiązania i przygotowaniu go do rozpowszechnienia, ponieważ każda zmiana kodu w podpisanym projekcie makra powoduje usunięcie podpisu cyfrowego tego makra. Jeśli jednak na komputerze istnieje prawidłowy certyfikat cyfrowy, który został poprzednio użyty do podpisania projektu, projekt makra jest automatycznie podpisywany ponownie podczas zapisywania.

      • Aby zapobiec przypadkowej zmianie projektu makra przez użytkowników, co unieważniłoby podpis, przed podpisaniem projektu makra należy go zablokować. Podpis cyfrowy oznacza jedynie, że właściciel podpisu gwarantuje, iż projekt nie był modyfikowany od czasu jego podpisania. Nie jest natomiast dowodem, że właściciel podpisu jest autorem projektu. Zablokowanie projektu makra nie pozbawia zatem innego użytkownika możliwości zamiany bieżącego podpisu cyfrowego na inny podpis. Administratorzy w firmach mogą podpisywać od nowa szablony i dodatki, aby kontrolować, co użytkownicy mogą uruchamiać na swoich komputerach.

      • W przypadku tworzenia dodatku, który dodaje kod do projektu makra, nowy kod powinien stwierdzać, czy projekt jest podpisany cyfrowo, i powiadamiać użytkownika o konsekwencjach modyfikowania podpisanego projektu, zanim pozwoli mu przejść dalej.

      • Podczas cyfrowego podpisywania makr ważne jest utworzenie sygnatury czasowej, aby inni użytkownicy mogli zweryfikować podpis nawet po wygaśnięciu jego certyfikatu. Podpisanie makra bez sygnatury czasowej powoduje, że podpis jest prawidłowy tylko przez okres ważności certyfikatu.

  1. Otwórz plik zawierający projekt makra, który chcesz podpisać.

    • Na karcie Deweloper w grupie Kod kliknij przycisk Visual Basic.

      Jeśli karta Deweloper nie jest dostępna, kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Word. Kliknij pozycję Popularne, a następnie zaznacz pole wyboru Pokaż kartę Deweloper na Wstążce.

      Uwaga : Wstążka to jeden z elementów, które zawiera interfejs użytkownika Microsoft Office Fluent.

  2. W Eksploratorze projektów języka Visual Basic wybierz projekt, który chcesz podpisać.

  3. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat cyfrowy nie był wcześniej wybierany lub chcesz użyć innego certyfikatu, kliknij przycisk Choose (Wybierz), wybierz certyfikat, a następnie dwukrotnie kliknij przycisk OK.

    • Aby użyć bieżącego certyfikatu, kliknij przycisk OK.

      Uwagi : 

      • Podpisuj makra wyłącznie po przetestowaniu rozwiązania i przygotowaniu go do rozpowszechnienia, ponieważ każda zmiana kodu w podpisanym projekcie makra powoduje usunięcie podpisu cyfrowego tego makra. Jeśli jednak na komputerze istnieje prawidłowy certyfikat cyfrowy, który został poprzednio użyty do podpisania projektu, projekt makra jest automatycznie podpisywany ponownie podczas zapisywania.

      • Aby zapobiec przypadkowej zmianie projektu makra przez użytkowników, co unieważniłoby podpis, przed podpisaniem projektu makra należy go zablokować. Podpis cyfrowy oznacza jedynie, że właściciel podpisu gwarantuje, iż projekt nie był modyfikowany od czasu jego podpisania. Nie jest natomiast dowodem, że właściciel podpisu jest autorem projektu. Zablokowanie projektu makra nie pozbawia zatem innego użytkownika możliwości zamiany bieżącego podpisu cyfrowego na inny podpis. Administratorzy w firmach mogą podpisywać od nowa szablony i dodatki, aby kontrolować, co użytkownicy mogą uruchamiać na swoich komputerach.

      • W przypadku tworzenia dodatku, który dodaje kod do projektu makra, nowy kod powinien stwierdzać, czy projekt jest podpisany cyfrowo, i powiadamiać użytkownika o konsekwencjach modyfikowania podpisanego projektu, zanim pozwoli mu przejść dalej.

      • Podczas cyfrowego podpisywania makr ważne jest utworzenie sygnatury czasowej, aby inni użytkownicy mogli zweryfikować podpis nawet po wygaśnięciu jego certyfikatu. Podpisanie makra bez sygnatury czasowej powoduje, że podpis jest prawidłowy tylko przez okres ważności certyfikatu.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×