Automatyzacja zdarzeń uruchamiania przy użyciu makra

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Jeśli chcesz uruchomić określonych akcji każdym otwarciu bazy danych programu Access lub aplikacji sieci web programu Access, należy utworzyć makro AutoExec w bazie danych pulpitu lub makra przy uruchamianiu w aplikacji sieci web programu Access. Na przykład w bazie danych pulpitu makra AutoExec może automatycznie maksymalizowanie okna aplikacji, blokowanie okienko nawigacji i otworzyć określony raport zawsze podczas otwierania bazy danych.

W tym temacie

Tworzenie makra AutoExec w bazie danych pulpitu

Tworzenie makra przy uruchamianiu w aplikacji sieci web programu Access

Tworzenie makra AutoExec w bazie danych dla komputerów stacjonarnych

Uruchamia makro AutoExec (makro nadawanie nazwy AutoExec) przed innymi makr i modułów w bazie danych. Jeśli masz już utworzony makro, które ma ma nastąpić po uruchomieniu bazy danych, po prostu zmienić nazwę makra AutoExeci będzie działać przy następnym otwarciu bazy danych. W przeciwnym razie wykonaj poniższe czynności, aby utworzyć makro:

  1. Kliknij przycisk Utwórz > makra.

    Przycisk Makro na karcie Tworzenie.

  2. Z listy rozwijanej u góry Konstruktora makr wybierz akcję, którą chcesz wykonać. Jeśli trzeba, wpisz odpowiednie wartości w polach argumentów.

    • Jeśli nie możesz znaleźć akcji, które mają, upewnij się, że na karcie Projektowanie wybrano opcję Pokaż wszystkie akcje. Można je rozwinąć listę akcji, które są dostępne, ale lista będzie zawierać niektóre akcje, które będą tylko zaufane Uruchom udzielenie bazy danych. Aby uzyskać więcej informacji zobacz podjęcie decyzji o zaufaniu bazie danych.

  3. Powtórz krok 2 dla każdej dodatkowej akcji, którą chcesz wywoływać. Akcje możesz też wyszukać w wykazie akcji, a następnie kliknąć dwukrotnie lub przeciągnąć do makra.

  4. Kliknij przycisk Zapisz, a następnie w oknie dialogowym Zapisywanie jako wpisz AutoExec.

  5. Kliknij przycisk OK, a następnie zamknij Konstruktora makr. Makro będzie od tej pory uruchamiane przy każdym otwarciu bazy danych.

Aby uzyskać więcej informacji na temat tworzenia makr zobacz artykuł Tworzenie makra interfejsu użytkownika (UI).

Uwaga : 

Początek strony

Tworzenie makra przy uruchamianiu w aplikacji sieci web programu Access

Makra przy uruchamianiu w aplikacjach sieci web programu Access wykonuje jest taka sama funkcja jako makra AutoExec w bazie danych pulpitu, ale nie jest wyświetlana w okienku nawigacji jako nazwane makro. Ponadto zamiast uruchamiania podczas otwierania bazy danych w kliencie programu Access, jest uruchamiane podczas otwierania aplikacji sieci web w przeglądarce. Nie można pomijać logiczny makra zdefiniowane w makra przy uruchamianiu podczas otwierania aplikacji sieci web w przeglądarce.

Oto jak utworzyć takie makro:

  1. Otwórz aplikację sieci web w programie Access. Jeśli wyświetlasz go w przeglądarce, kliknij pozycję Ustawienia > Dostosuj w programie Access.

  2. Kliknij kartę Narzędzia główne > Zaawansowane > na początku makra.

    Polecenie Makro Przy uruchamianiu na wstążce

    Program Access otworzy projektanta makr. Jeśli makra przy uruchamianiu już istnieje, program Access wyświetli ją. W przeciwnym razie zostanie wyświetlona makra puste miejsce, w którym można rozpocząć dodawanie akcji.

  3. Wybierz akcje z rozwijane Dodawanie nowej akcji, Znajdź akcje w wykazie akcji i kliknij dwukrotnie lub przeciągnij je do makra.

    Porada :  Wykaz akcji zawiera krótkie opisy poszczególnych akcji, co pozwala poznać ich przeznaczenie.

  4. Jeśli trzeba, wpisz odpowiednie wartości w polach argumentów dodawanych akcji.

  5. Kliknij pozycję Plik > Zamknij.

  6. Kliknij kartę Narzędzia główne > Uruchom aplikację, a na Start uruchomienie makra po otwarciu aplikacji sieci web w przeglądarce.

Aby uzyskać więcej informacji o tworzeniu makr w aplikacji sieci web programu Access zobacz Dostosowywanie widoku przez utworzenie użytkownika interfejsu makra.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×