Automatyczne wypełnianie danych w komórkach arkusza

Automatyczne wypełnianie danych w komórkach arkusza

Zamiast ręcznie wprowadzać dane w arkuszu, można wypełnić komórki danymi zgodnymi z określonym wzorcem lub bazującymi na danych w innych komórkach — za pomocą funkcji Autowypełnianie.

W tym artykule nie wyjaśniono, jak ręcznie wprowadzać dane ani jak wprowadzać dane jednocześnie w wielu arkuszach. Aby uzyskać informacje o ręcznym wprowadzaniu danych, zobacz artykuł Ręczne wprowadzanie danych w komórkach arkusza.

Automatyczne powtarzanie wartości już istniejących w kolumnie

Jeśli pierwsze kilka znaków wpisanych w komórce odpowiada istniejącemu wpisowi w tej samej kolumnie, program Excel automatycznie wprowadza pozostałe znaki. Automatyczne uzupełnianie dotyczy tylko wpisów zawierających tekst lub połączenia tekstu i liczb. Wpisy zawierające tylko liczby, daty lub godziny nie są automatycznie uzupełniane.

Po uzupełnieniu przez program Excel wpisywanej wartości, wykonaj jedną z następujących czynności:

  • Aby zaakceptować proponowany wpis, naciśnij klawisz Enter.

    Uzupełniony wpis ma układ wielkich i małych liter odpowiadający układowi w istniejącym wpisie.

  • Aby zamienić automatycznie wprowadzone znaki, kontynuuj wpisywanie.

  • Aby usunąć automatycznie wprowadzone znaki, naciśnij klawisz Backspace.

Uwaga : 

  • Program Excel uzupełnia wpis tylko wtedy, gdy kursor jest na końcu zawartości bieżącej komórki.

  • Program Excel określa listę możliwych wpisów funkcji Autouzupełnianie na podstawie kolumny zawierającej komórka aktywna. Wpisy powtarzające się w wierszu nie są automatycznie uzupełniane.

Włączanie i wyłączanie automatycznego uzupełniania wartości komórek

Jeśli program Excel nie powinien automatycznie uzupełniać wartości komórek, można wyłączyć tę funkcję.

  1. Kliknij kartę Plik, a następnie kliknij pozycję Opcje.

  2. Kliknij przycisk Zaawansowane, a następnie w obszarze Opcje edycji zaznacz lub usuń zaznaczenie pola wyboru Włącz Autouzupełnianie wartości komórek, aby wyłączyć lub włączyć automatyczne uzupełnianie wartości komórek.

Wypełnianie danych w przylegających komórkach za pomocą uchwytu wypełniania

Aby szybko wypełnić komórki seriami danych kilku typów, można zaznaczyć komórki i przeciągnąć uchwyt wypełniania Uchwyt wypełniania . W celu użycia uchwytu wypełniania należy zaznaczyć komórki, na podstawie których mają zostać wypełnione dodatkowe komórki, a następnie przeciągnąć uchwyt wypełniania w poziomie albo w dół wzdłuż komórek do wypełnienia.

Uchwyt wypełniania jest domyślnie wyświetlany, ale można go ukryć albo pokazać, jeśli został ukryty.

Po przeciągnięciu uchwytu wypełniania pojawi się przycisk Opcje Autowypełniania. Jeśli przycisk Opcje Autowypełniania nie ma być wyświetlany po każdym przeciągnięciu uchwytu wypełniania, można go wyłączyć. Podobnie jeśli przycisk Opcje Autowypełniania nie jest wyświetlany po przeciągnięciu uchwytu wypełniania, można go bez problemu włączyć.

Ukrywanie i wyświetlanie uchwytu wypełniania

  1. Kliknij kartę Plik, a następnie kliknij pozycję Opcje.

  2. Kliknij kategorię Zaawansowane, a następnie w obszarze Opcje edycji zaznacz lub usuń zaznaczenie pola wyboru Włącz uchwyt wypełniania oraz przeciąganie i upuszczanie komórek, aby pokazać lub ukryć uchwyt wypełniania.

  3. Aby uniknąć zamieniania istniejących danych podczas przeciągania uchwytu wypełniania, należy się upewnić, że jest zaznaczone pole wyboru Ostrzegaj przy zastępowaniu komórek. Aby uniknąć wyświetlania komunikatu dotyczącego zastępowania niepustych komórek, można wyczyścić to pole wyboru.

Wypełnianie danych w przylegających komórkach przez przeciągnięcie uchwytu wypełniania

  1. Zaznacz komórki zawierające dane, którymi chcesz wypełnić przylegające komórki.

  2. Przeciągnij uchwyt wypełniania przez komórki, które chcesz wypełnić.

  3. Aby zmienić sposób wypełniania zaznaczenia, kliknij przycisk Opcje Autowypełniania Obraz przycisku , a następnie kliknij wybraną opcję.

    Można na przykład wybrać wypełnianie samymi formatami komórek, klikając opcję Wypełnij tylko formatami, a można też wybrać wypełnianie samą zawartością komórek, klikając opcję Wypełnij bez formatowania.

Uwaga : Przeciągnięcie uchwytu wypełniania w górę lub na lewo od zaznaczenia i zatrzymanie uchwytu w obszarze zaznaczonych komórek bez przechodzenia przez pierwszą kolumnę lub pierwszy wiersz zaznaczenia spowoduje, że program Excel usunie dane objęte zaznaczeniem. Przed zwolnieniem przycisku myszy należy przeciągnąć uchwyt wypełniania poza zaznaczony obszar.

Włączanie i wyłączanie przycisku Opcje Autowypełniania

  1. Kliknij kartę Plik, a następnie kliknij pozycję Opcje.

  2. Kliknij kategorię Zaawansowane, a następnie w obszarze Wycinanie, kopiowanie i wklejanie zaznacz lub wyczyść pole wyboru Pokaż przycisk opcji wklejania po wklejeniu zawartości, aby włączyć lub wyłączyć tę opcję.

Wypełnianie danych w przylegających komórkach za pomocą polecenia Wypełnij

Za pomocą polecenia Wypełnij można wypełnić aktywną komórkę lub aktywny zakres komórek zawartością przylegającej komórki lub przylegającego zakresu komórek.

  1. Wykonaj jedną z następujących czynności:

    • Aby wypełnić aktywną komórkę zawartością sąsiedniej komórki, zaznacz pustą komórkę poniżej, z prawej strony, powyżej lub z lewej strony komórki, która zawiera dane, na podstawie których ma zostać wypełniona zaznaczona komórka.

    • Aby wypełnić wiele przylegających komórek, zaznacz komórkę zawierającą dane do skopiowania oraz komórki, które chcesz wypełnić.

  2. Na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Wypełnij, a następnie kliknij polecenie W dół, W prawo, W górę lub W lewo.

Obraz Wstążki programu Excel

Skrót klawiaturowy    Aby szybko wypełnić komórkę zawartością komórki przylegającej, można nacisnąć klawisze Ctrl+D w celu wypełnienia jej na podstawie komórki powyżej albo klawisze Ctrl+R w celu wypełnienia jej na podstawie komórki z lewej strony.

Wypełnianie formuł w przylegających komórkach

  1. Zaznacz komórkę zawierającą formułę, którą chcesz wypełnić przylegające komórki.

  2. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

  3. Aby wybrać sposób wypełnienia zaznaczenia, kliknij przycisk Opcje Autowypełniania Obraz przycisku , a następnie kliknij żądaną opcję.

    Uwaga : Jeśli nie jest włączone automatyczne obliczanie skoroszytu, formuły nie wykonują ponownie obliczeń po wypełnieniu komórek. Aby sprawdzić opcje obliczania skoroszytu, należy wykonać następujące czynności:

  4. Kliknij kartę Plik.

  5. W obszarze programu Excel kliknij pozycję Opcje, a następnie kliknij kategorię Formuły.

  6. W obszarze Opcje obliczania sprawdź obszar Obliczanie skoroszytu.

    • Automatycznie    Formuły są obliczane automatycznie.

    • Automatycznie, z wyjątkiem tabel danych    Formuły są obliczane automatycznie, chyba że daną formułę zawiera tabela danych.

    • Ręcznie    Formuły nie są obliczane automatycznie.

    • Oblicz ponownie skoroszyt przed zapisaniem    Ta opcja jest dostępna tylko wtedy, gdy dla opcji Obliczanie skoroszytu ustawiono wartość Ręcznie. Jeśli to pole wyboru jest zaznaczone, formuły nie są obliczane automatycznie, dopóki skoroszyt nie zostanie zapisany. Należy zauważyć, że kilka innych akcji może spowodować zapisanie skoroszytu, na przykład użycie polecenia Wyślij do.

      Uwagi : 

      • Można też wypełnić aktywną komórkę formułą z przylegającej komórki, używając polecenia Wypełnij (na karcie Narzędzia główne w grupie Edytowanie) albo naciskając klawisze Ctrl+D lub Ctrl+R, aby wypełnić komórkę odpowiednio poniżej lub po prawej stronie komórki zawierającej formułę.

      • Można automatycznie wypełnić formułą wszystkie przylegające komórki poniżej, których ta formuła dotyczy, klikając dwukrotnie uchwyt wypełniania pierwszej komórki zawierającej formułę. Załóżmy na przykład, że komórki A1:A15 i B1:B15 zawierają liczby, a w komórce C1 wpisano formułę =A1+B1. Aby skopiować tę formułę do komórek C2:C15, należy zaznaczyć komórkę C1 i kliknąć dwukrotnie uchwyt wypełniania.

Wypełnianie serią liczb, dat lub innych wbudowanych elementów

Za pomocą uchwytu wypełniania lub polecenia Wypełnij można szybko wypełniać komórki w zakresie seriami liczb lub dat albo wbudowanymi seriami dni, dni tygodnia, miesięcy lub lat.

Wypełnianie komórek serią liczb za pomocą uchwytu wypełniania

  1. Zaznacz pierwszą komórkę w zakresie, który chcesz wypełnić.

  2. Wprowadź wartość początkową serii.

  3. Wprowadź wartość w następnej komórce, aby ustalić wzorzec.

    Jeśli na przykład jest potrzebna seria 1, 2, 3, 4, 5,..., należy wprowadzić do pierwszych dwóch komórek wartości 1 i 2. Jeśli jest potrzebna seria 2, 4, 6, 8,..., należy wprowadzić wartości 2 i 4. Jeśli seria ma mieć wartości 2, 2, 2, 2,..., można zostawić drugą komórkę pustą.

  4. Zaznacz komórkę lub komórki zawierające wartości początkowe.

  5. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez zakres, który chcesz wypełnić.

    Aby wypełnić zakres w kolejności rosnącej, przeciągnij uchwyt w dół lub w prawo. Aby wypełnić zakres w kolejności malejącej, przeciągnij uchwyt w górę lub w lewo.

    Uwaga : 

  6. Można określić typ serii, przeciągając uchwyt wypełniania prawym przyciskiem myszy przez zakres komórek, a następnie klikając odpowiednie polecenie w menu skrótów. Jeśli na przykład wartością początkową jest data sty-2007, w celu uzyskania serii lut-2007, mar-2007 itd. należy kliknąć polecenie Wypełnij miesiącami, a w celu uzyskania serii sty-2007, sty-2008 itd. należy kliknąć polecenie Wypełnij latami.

  7. Jeśli zaznaczenie zawiera liczby, można wybrać typ serii, która ma zostać utworzona.

  8. Można pominąć Autowypełnianie serią, przytrzymując naciśnięty klawisz Ctrl podczas przeciągania uchwytu wypełniania dla zaznaczenia obejmującego co najmniej dwie komórki. Zaznaczone wartości zostaną skopiowane do przylegających komórek, a program Excel nie rozwinie serii.

Wypełnianie komórek serią liczb za pomocą polecenia Wypełnij

  1. Zaznacz pierwszą komórkę w zakresie, który chcesz wypełnić.

  2. Wprowadź wartość początkową serii.

  3. Na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Wypełnienie, a następnie kliknij polecenie Seria danych.

    Obraz Wstążki programu Excel

  4. W obszarze Typ kliknij jedną z następujących opcji:

    • Liniowy    Tworzy serię obliczaną przez dodawanie wartości pola Wartość kroku do każdej kolejnej wartości komórki.

    • Wzrost    Tworzy serię obliczaną przez mnożenie wartości pola Wartość kroku przez każdą kolejną wartość komórki.

    • Data    Tworzy serię dat rosnących zgodnie z wartością pola Wartość kroku i zależnych od jednostki określonej w polu Jednostka daty.

    • Autowypełnianie    Tworzy serię dającą wyniki odpowiadające przeciągnięciu uchwytu wypełniania.

  5. Aby ustalić wzór wypełnienia dla serii, w polach Wartość kroku i Wartość końcowa wpisz wybrane wartości.

Więcej przykładów wypełniania seriami

Przy wypełnianiu serią zaznaczenia są rozszerzane w sposób pokazany w poniższej tabeli. W tej tabeli elementy rozdzielone przecinkami są zawarte w osobnych przylegających komórkach w arkuszu.

Wartości początkowe

Rozwinięta seria

1, 2, 3

4, 5, 6,...

09:00:00

10:00, 11:00, 12:00,...

pn

wt, śr, cz,...

poniedziałek

wtorek, środa, czwartek,...

sty

lut, mar, kwi,...

sty, kwi

lip, paź, sty,...

7-sty, 7-kwi

7-lip, 7-paź, 8-sty,...

15-sty, 15-kwi

15-lip, 15-paź,...

2007, 2008

2009, 2010, 2011,...

1-sty, 1-mar

1-maj, 1-lip, 1-wrz,...

kwa3 (albo k3 lub kwartał3)

kwa4, kwa1, kwa2,...

tekst1, tekstA

tekst2, tekstA, tekst3, tekstA,...

1. okres

2. okres, 3. okres,...

Produkt 1

Produkt 2, Produkt 3,...

Wypełnianie danych za pomocą serii niestandardowej

Można uprościć wprowadzanie określonej sekwencji danych (na przykład listy nazwisk lub regionów sprzedaży) za pomocą wypełnienia serią niestandardową. Seria niestandardowa może zostać utworzona na podstawie listy istniejących elementów arkusza lub listy wpisanej przez użytkownika. Nie można edytować ani usuwać wbudowanych serii (na przykład serii miesięcy i dni), ale można edytować lub usuwać serie niestandardowe.

Uwaga : Lista niestandardowa może zawierać tylko tekst lub tekst razem z liczbami.

Używanie serii niestandardowej opartej na istniejącej liście elementów

  1. Zaznacz w arkuszu listę elementów, których chcesz użyć w serii.

  2. Kliknij kartę Plik, a następnie kliknij pozycję Opcje.

  3. Kliknij kategorię Zaawansowane, a następnie w obszarze Ogólne kliknij przycisk Edytuj listy niestandardowe.

  4. Sprawdź, czy odwołanie do komórek zawierających zaznaczoną listę elementów jest wyświetlane w polu Importuj listę z komórek, a następnie kliknij przycisk Importuj.

    Elementy zaznaczonej listy zostaną dodane do pola Listy niestandardowe.

  5. Kliknij przycisk OK dwa razy.

  6. Kliknij komórkę w arkuszu, a następnie wprowadź element serii niestandardowej, który ma być użyty jako pierwszy element listy.

  7. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

Używanie serii niestandardowej opartej na nowej liście elementów

  1. Kliknij kartę Plik, a następnie kliknij pozycję Opcje.

  2. Kliknij kategorię Zaawansowane, a następnie w obszarze Ogólne kliknij przycisk Edytuj listy niestandardowe.

  3. W polu Listy niestandardowe kliknij opcję NOWA LISTA, a następnie wpisz elementy w polu Lista wpisów, zaczynając od pierwszego wpisu.

  4. Po wprowadzeniu każdego wpisu naciśnij klawisz Enter.

  5. Po wpisaniu całej listy kliknij przycisk Dodaj, a następnie kliknij przycisk OK dwa razy.

  6. Kliknij komórkę w arkuszu, a następnie wprowadź element niestandardowej serii wypełniania, który ma być użyty jako pierwszy element listy.

  7. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

Edytowanie lub usuwanie niestandardowej serii wypełniania

  1. Kliknij kartę Plik, a następnie kliknij pozycję Opcje.

  2. Kliknij kategorię Zaawansowane, a następnie w obszarze Ogólne kliknij przycisk Edytuj listy niestandardowe.

  3. W polu Listy niestandardowe zaznacz listę, którą chcesz edytować lub usunąć, a następnie wykonaj jedną z następujących czynności:

    • Aby edytować serię wypełniania, wprowadź żądane zmiany w polu Lista wpisów, a następnie kliknij przycisk Dodaj.

    • Aby usunąć serię wypełniania, kliknij przycisk Usuń.

W tym artykule nie wyjaśniono, jak ręcznie wprowadzać dane ani jak wprowadzać dane jednocześnie w wielu arkuszach. Aby uzyskać informacje o ręcznym wprowadzaniu danych, zobacz artykuł Ręczne wprowadzanie danych w komórkach arkusza.

Automatyczne powtarzanie wartości już istniejących w kolumnie

Jeśli pierwsze kilka znaków wpisanych w komórce odpowiada istniejącemu wpisowi w tej samej kolumnie, program Excel automatycznie wprowadza pozostałe znaki. Automatyczne uzupełnianie dotyczy tylko wpisów zawierających tekst lub połączenia tekstu i liczb. Wpisy zawierające tylko liczby, daty lub godziny nie są automatycznie uzupełniane.

Po uzupełnieniu przez program Excel wpisywanej wartości, wykonaj jedną z następujących czynności:

  • Aby zaakceptować proponowany wpis, naciśnij klawisz ENTER.

    Uzupełniony wpis ma układ wielkich i małych liter odpowiadający układowi w istniejącym wpisie.

  • Aby zamienić automatycznie wprowadzone znaki, kontynuuj wpisywanie.

  • Aby usunąć automatycznie wprowadzone znaki, naciśnij klawisz BACKSPACE.

Uwagi : 

  • Program Excel uzupełnia wpis tylko wtedy, gdy kursor jest na końcu zawartości bieżącej komórki.

  • Program Excel określa listę możliwych wpisów funkcji Autouzupełnianie na podstawie kolumny zawierającej komórka aktywna. Wpisy powtarzające się w wierszu nie są automatycznie uzupełniane.

Wyłączanie automatycznego uzupełniania wartości komórek

Jeśli program Excel nie powinien automatycznie uzupełniać wartości komórek, można wyłączyć tę funkcję.

  1. Kliknij kartę Plik.

  2. W obszarze Excel kliknij pozycję Opcje.

  3. Kliknij przycisk Zaawansowane, a następnie w obszarze Opcje edycji zaznacz lub usuń zaznaczenie pola wyboru Włącz Autouzupełnianie wartości komórek, aby włączyć lub wyłączyć automatyczne uzupełnianie wartości komórek.

Wypełnianie danych za pomocą uchwytu wypełniania

Aby szybko wypełnić komórki seriami danych kilku typów, można zaznaczyć komórki i przeciągnąć uchwyt wypełniania Uchwyt wypełniania . W celu użycia uchwytu wypełniania należy zaznaczyć komórki, na podstawie których mają zostać wypełnione dodatkowe komórki, a następnie przeciągnąć uchwyt wypełniania w poziomie albo w dół wzdłuż komórek do wypełnienia.

Ukrywanie lub wyświetlanie uchwytu wypełniania

Uchwyt wypełniania jest domyślnie wyświetlany, ale można go ukryć albo pokazać, jeśli został ukryty.

  1. Kliknij kartę Plik.

  2. W obszarze Excel kliknij pozycję Opcje.

  3. Kliknij kategorię Zaawansowane, a następnie w obszarze Opcje edycji zaznacz lub usuń zaznaczenie pola wyboru Włącz uchwyt wypełniania oraz przeciąganie i upuszczanie komórek, aby pokazać lub ukryć uchwyt wypełniania.

  4. Aby uniknąć zamieniania istniejących danych podczas przeciągania uchwytu wypełniania, należy się upewnić, że jest zaznaczone pole wyboru Ostrzegaj przy zastępowaniu komórek. Aby uniknąć wyświetlania komunikatu dotyczącego zastępowania niepustych komórek, można wyczyścić to pole wyboru.

Zmienianie sposobu wypełniania wybranego elementu za pomocą przycisku Opcje Autowypełniania

Po przeciągnięciu uchwytu wypełniania zostaje wyświetlony przycisk Opcje Autowypełniania Obraz przycisku umożliwiający zmianę sposobu wypełnienia wybranego elementu. Można na przykład wybrać wypełnianie samymi formatami komórek, klikając opcję Wypełnij tylko formatami, a można też wybrać wypełnianie samą zawartością komórek, klikając opcję Wypełnij bez formatowania.

Włączanie i wyłączanie przycisku Opcje Autowypełniania

Jeśli przycisk Opcje Autowypełniania nie ma być wyświetlany po każdym przeciągnięciu uchwytu wypełniania, można go wyłączyć. Podobnie jeśli przycisk Opcje Autowypełniania nie jest wyświetlany po przeciągnięciu uchwytu wypełniania, można go bez problemu włączyć.

  1. Kliknij kartę Plik.

  2. W obszarze Excel kliknij pozycję Opcje.

  3. Kliknij kategorię Zaawansowane, a następnie w obszarze Wycinanie, kopiowanie i wklejanie wyczyść pole wyboru Pokaż przycisk opcji wklejania po wklejeniu zawartości.

Wypełnianie danych w przylegających komórkach za pomocą polecenia Wypełnij

Za pomocą polecenia Wypełnij można wypełnić aktywną komórkę lub aktywny zakres komórek zawartością przylegającej komórki lub przylegającego zakresu komórek. Przylegające komórki można również szybko wypełnić, przeciągając uchwyt wypełniania Uchwyt wypełniania .

Wypełnianie aktywnej komórki zawartością przylegającej komórki

  1. Zaznacz pustą komórkę poniżej, z prawej strony, powyżej lub z lewej strony komórki, która zawiera dane, na podstawie których ma zostać wypełniona zaznaczona komórka.

  2. Na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Wypełnij, a następnie kliknij polecenie W dół, W prawo, W górę lub W lewo.

Obraz Wstążki programu Excel

Porada : Aby szybko wypełnić komórkę zawartością przylegającej komórki, można nacisnąć klawisze CTRL+D w celu wypełnienia jej na podstawie komórki powyżej albo klawisze CTRL+R w celu wypełnienia jej na podstawie komórki z lewej strony. Aby wypełnić komórkę zawartością komórki znajdującej się poniżej (czyli wypełnić komórki w górę), na karcie Narzędzia główne w grupie Edycja kliknij pozycję Wypełnienie, a następnie kliknij pozycję W górę. Aby wypełnić komórkę zawartością komórki znajdującej się z prawej strony (czyli wypełnić w lewo), na karcie Narzędzia główne w grupie Edycja kliknij pozycję Wypełnienie, a następnie kliknij pozycję W lewo.

Wypełnianie danych w przylegających komórkach przez przeciągnięcie uchwytu wypełniania

  1. Zaznacz komórki zawierające dane, którymi chcesz wypełnić przylegające komórki.

  2. Przeciągnij uchwyt wypełniania przez komórki, które chcesz wypełnić.

  3. Aby zmienić sposób wypełniania zaznaczenia, kliknij przycisk Opcje Autowypełniania Obraz przycisku , a następnie kliknij wybraną opcję.

Uwaga : Przeciągnięcie uchwytu wypełniania w górę lub na lewo od zaznaczenia i zatrzymanie uchwytu w obszarze zaznaczonych komórek bez przechodzenia przez pierwszą kolumnę lub pierwszy wiersz zaznaczenia spowoduje, że program Excel usunie dane objęte zaznaczeniem. Przed zwolnieniem przycisku myszy należy przeciągnąć uchwyt wypełniania poza zaznaczony obszar.

Wypełnianie formuł w przylegających komórkach

  1. Zaznacz komórkę zawierającą formułę, którą chcesz wypełnić przylegające komórki.

  2. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

  3. Aby wybrać sposób wypełnienia zaznaczenia, kliknij przycisk Opcje Autowypełniania Obraz przycisku , a następnie kliknij żądaną opcję.

    Uwaga : Jeśli nie jest włączone automatyczne obliczanie skoroszytu, formuły nie wykonują ponownie obliczeń po wypełnieniu komórek. Aby sprawdzić opcje obliczania skoroszytu, należy wykonać następujące czynności:

  4. Kliknij kartę Plik.

  5. W obszarze programu Excel kliknij pozycję Opcje, a następnie kliknij kategorię Formuły.

  6. W obszarze Opcje obliczania sprawdź obszar Obliczanie skoroszytu.

    • Automatycznie    Formuły są obliczane automatycznie.

    • Automatycznie, z wyjątkiem tabel danych    Formuły są obliczane automatycznie, chyba że daną formułę zawiera tabela danych.

    • Ręcznie    Formuły nie są obliczane automatycznie.

    • Oblicz ponownie skoroszyt przed zapisaniem    Ta opcja jest dostępna tylko wtedy, gdy dla opcji Obliczanie skoroszytu ustawiono wartość Ręcznie. Jeśli to pole wyboru jest zaznaczone, formuły nie są obliczane automatycznie, dopóki skoroszyt nie zostanie zapisany. Należy zauważyć, że kilka innych akcji może spowodować zapisanie skoroszytu, na przykład użycie polecenia Wyślij do.

Porady

  • Można też wypełnić aktywną komórkę formułą z przylegającej komórki, używając polecenia Wypełnij (na karcie Narzędzia główne w grupie Edycja) albo naciskając klawisze CTRL+D lub CTRL+R, aby wypełnić komórkę odpowiednio poniżej lub po prawej stronie komórki zawierającej formułę.

  • Można automatycznie wypełnić formułą wszystkie przylegające komórki poniżej, których ta formuła dotyczy, klikając dwukrotnie uchwyt wypełniania pierwszej komórki zawierającej formułę. Załóżmy na przykład, że komórki A1:A15 i B1:B15 zawierają liczby, a w komórce C1 wpisano formułę =A1+B1. Aby skopiować tę formułę do komórek C2:C15, należy zaznaczyć komórkę C1 i kliknąć dwukrotnie uchwyt wypełniania.

Wypełnianie serią liczb, dat lub innych wbudowanych elementów

Za pomocą uchwytu wypełniania można szybko wypełniać komórki w zakresie seriami liczb lub dat albo wbudowanymi seriami dni, dni tygodnia, miesięcy lub lat.

  1. Zaznacz pierwszą komórkę w zakresie, który chcesz wypełnić.

  2. Wprowadź wartość początkową serii.

  3. Wprowadź wartość w następnej komórce, aby ustalić wzorzec.

    Jeśli na przykład jest potrzebna seria 1, 2, 3, 4, 5,..., należy wprowadzić do pierwszych dwóch komórek wartości 1 i 2. Jeśli jest potrzebna seria 2, 4, 6, 8,..., należy wprowadzić wartości 2 i 4. Jeśli seria ma mieć wartości 2, 2, 2, 2,..., można zostawić drugą komórkę pustą.

Więcej przykładów wypełniania seriami

Przy wypełnianiu serią zaznaczenia są rozszerzane w sposób pokazany w poniższej tabeli. W tej tabeli elementy rozdzielone przecinkami są zawarte w osobnych przylegających komórkach w arkuszu.

Wartości początkowe

Rozwinięta seria

1, 2, 3

4, 5, 6,...

09:00:00

10:00, 11:00, 12:00,...

pn

wt, śr, cz,...

poniedziałek

wtorek, środa, czwartek,...

sty

lut, mar, kwi,...

sty, kwi

lip, paź, sty,...

7-sty, 7-kwi

7-lip, 7-paź, 8-sty,...

15-sty, 15-kwi

15-lip, 15-paź,...

2007, 2008

2009, 2010, 2011,...

1-sty, 1-mar

1-maj, 1-lip, 1-wrz,...

kwa3 (albo k3 lub kwartał3)

kwa4, kwa1, kwa2,...

tekst1, tekstA

tekst2, tekstA, tekst3, tekstA,...

1. okres

2. okres, 3. okres,...

Produkt 1

Produkt 2, Produkt 3,...

  1. Zaznacz komórkę lub komórki zawierające wartości początkowe.

  2. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez zakres, który chcesz wypełnić.

    Aby wypełnić zakres w kolejności rosnącej, przeciągnij uchwyt w dół lub w prawo. Aby wypełnić zakres w kolejności malejącej, przeciągnij uchwyt w górę lub w lewo.

Porady

  • Można określić typ serii, przeciągając uchwyt wypełniania prawym przyciskiem myszy przez zakres komórek, a następnie klikając odpowiednie polecenie w menu skrótów. Jeśli na przykład wartością początkową jest data sty-2007, w celu uzyskania serii lut-2007, mar-2007 itd. należy kliknąć polecenie Wypełnij miesiącami, a w celu uzyskania serii sty-2007, sty-2008 itd. należy kliknąć polecenie Wypełnij latami.

  • Jeśli zaznaczenie zawiera liczby, można wybrać typ serii, która ma zostać utworzona.

Wypełnianie komórek serią liczb

  1. Na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Wypełnienie, a następnie kliknij polecenie Seria danych.

    Obraz Wstążki programu Excel

  2. W obszarze Typ kliknij jedną z następujących opcji:

    • Liniowy    Tworzy serię obliczaną przez dodawanie wartości pola Wartość kroku do każdej kolejnej wartości komórki.

    • Wzrost    Tworzy serię obliczaną przez mnożenie wartości pola Wartość kroku przez każdą kolejną wartość komórki.

    • Data    Tworzy serię dat rosnących zgodnie z wartością pola Wartość kroku i zależnych od jednostki określonej w polu Jednostka daty.

    • Autowypełnianie    Tworzy serię dającą wyniki odpowiadające przeciągnięciu uchwytu wypełniania.

  3. Można pominąć Autowypełnianie serią, przytrzymując naciśnięty klawisz CTRL podczas przeciągania uchwytu wypełniania dla zaznaczenia obejmującego co najmniej dwie komórki. Zaznaczone wartości zostaną skopiowane do przylegających komórek, a program Excel nie rozwinie serii.

Wypełnianie danych za pomocą serii niestandardowej

Można uprościć wprowadzanie określonej sekwencji danych (na przykład listy nazwisk lub regionów sprzedaży) za pomocą wypełnienia serią niestandardową. Seria niestandardowa może zostać utworzona na podstawie listy istniejących elementów arkusza lub listy wpisanej przez użytkownika. Nie można edytować ani usuwać wbudowanych serii (na przykład serii miesięcy i dni), ale można edytować lub usuwać serie niestandardowe.

Uwaga : Lista niestandardowa może zawierać tylko tekst lub tekst razem z liczbami. Aby utworzyć listę niestandardową zawierającą tylko liczby, na przykład od 0 do 100, najpierw należy utworzyć listę liczb sformatowanych jako tekst.

Formatowanie liczb jako tekstu

  1. Zaznacz wystarczająco dużo komórek dla listy liczb, które chcesz sformatować jako tekst.

  2. Na karcie Narzędzia główne w grupie Liczba kliknij strzałkę w polu Format liczb, a następnie kliknij pozycję Tekst.

Obraz Wstążki programu Excel

Porada : Aby wyświetlić na liście format Tekst, może być konieczne kliknięcie pozycji Więcej formatów liczb.

  1. W sformatowanych komórkach wpisz listę liczb.

Używanie serii niestandardowej opartej na istniejącej liście elementów

  1. Zaznacz w arkuszu listę elementów, których chcesz użyć w serii.

  2. Kliknij kartę Plik.

  3. W obszarze Excel kliknij pozycję Opcje.

  4. Kliknij kategorię Zaawansowane, a następnie w obszarze Ogólne kliknij przycisk Edytuj listy niestandardowe.

  5. Sprawdź, czy odwołanie do komórek zawierających zaznaczoną listę elementów jest wyświetlane w polu Importuj listę z komórek, a następnie kliknij przycisk Importuj.

    Elementy zaznaczonej listy zostaną dodane do pola Listy niestandardowe.

  6. Kliknij przycisk OK dwa razy.

  7. Kliknij komórkę w arkuszu, a następnie wprowadź element serii niestandardowej, który ma być użyty jako pierwszy element listy.

  8. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

Używanie serii niestandardowej opartej na nowej liście elementów

  1. Kliknij kartę Plik.

  2. W obszarze Excel kliknij pozycję Opcje.

  3. Kliknij kategorię Zaawansowane, a następnie w obszarze Ogólne kliknij przycisk Edytuj listy niestandardowe.

  4. W polu Listy niestandardowe kliknij opcję NOWA LISTA, a następnie wpisz elementy w polu Lista wpisów, zaczynając od pierwszego wpisu.

  5. Po wprowadzeniu każdego wpisu naciśnij klawisz ENTER.

  6. Po wpisaniu całej listy kliknij przycisk Dodaj, a następnie kliknij przycisk OK dwa razy.

  7. Kliknij komórkę w arkuszu, a następnie wprowadź element niestandardowej serii wypełniania, który ma być użyty jako pierwszy element listy.

  8. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

Edytowanie lub usuwanie niestandardowej serii wypełniania

  1. Kliknij kartę Plik.

  2. W obszarze Excel kliknij pozycję Opcje.

  3. Kliknij kategorię Zaawansowane, a następnie w obszarze Ogólne kliknij przycisk Edytuj listy niestandardowe.

  4. W polu Listy niestandardowe zaznacz listę, którą chcesz edytować lub usunąć, a następnie wykonaj jedną z następujących czynności:

    • Aby edytować serię wypełniania, wprowadź żądane zmiany w polu Lista wpisów, a następnie kliknij przycisk Dodaj.

    • Aby usunąć serię wypełniania, kliknij przycisk Usuń.

Początek strony

Zamiast ręcznie wprowadzać dane w arkuszu, można wypełnić komórki danymi zgodnymi z określonym wzorcem lub bazującymi na danych w innych komórkach — za pomocą funkcji Autowypełnianie. W tym artykule nie wyjaśniono, jak ręcznie wprowadzać dane ani jak wprowadzać dane jednocześnie w wielu arkuszach. Aby dowiedzieć się, jak ręcznie wprowadzać dane, zobacz artykuł Ręczne wprowadzanie danych.

Automatyczne powtarzanie wartości już istniejących w kolumnie

Jeśli pierwsze kilka znaków wpisanych w komórce odpowiada istniejącemu wpisowi w tej samej kolumnie, program Excel automatycznie wprowadza pozostałe znaki. Automatyczne uzupełnianie dotyczy tylko wpisów zawierających tekst lub połączenia tekstu i liczb. Wpisy zawierające tylko liczby, daty lub godziny nie są automatycznie uzupełniane.

Po uzupełnieniu przez program Excel wpisywanej wartości, wykonaj jedną z następujących czynności:

  • Aby zaakceptować proponowany wpis, naciśnij klawisz ENTER.

    Uzupełniony wpis ma układ wielkich i małych liter odpowiadający układowi w istniejącym wpisie.

  • Aby zamienić automatycznie wprowadzone znaki, kontynuuj wpisywanie.

  • Aby usunąć automatycznie wprowadzone znaki, naciśnij klawisz BACKSPACE.

Uwagi : 

  • Program Excel uzupełnia wpis tylko wtedy, gdy kursor jest na końcu zawartości bieżącej komórki.

  • Program Excel określa listę możliwych wpisów funkcji Autouzupełnianie na podstawie kolumny zawierającej komórka aktywna. Wpisy powtarzające się w wierszu nie są automatycznie uzupełniane.

Wyłączanie automatycznego uzupełniania wartości komórek

Jeśli program Excel nie powinien automatycznie uzupełniać wartości komórek, można wyłączyć tę funkcję.

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

  2. Kliknij przycisk Zaawansowane, a następnie w obszarze Opcje edycji zaznacz lub usuń zaznaczenie pola wyboru Włącz Autouzupełnianie wartości komórek, aby włączyć lub wyłączyć automatyczne uzupełnianie wartości komórek.

Wypełnianie danych za pomocą uchwytu wypełniania

Aby szybko wypełnić komórki seriami danych kilku typów, można zaznaczyć komórki i przeciągnąć uchwyt wypełniania Uchwyt wypełniania . W celu użycia uchwytu wypełniania należy zaznaczyć komórki, na podstawie których mają zostać wypełnione dodatkowe komórki, a następnie przeciągnąć uchwyt wypełniania w poziomie albo w dół wzdłuż komórek do wypełnienia.

Ukrywanie lub wyświetlanie uchwytu wypełniania

Uchwyt wypełniania jest domyślnie wyświetlany, ale można go ukryć albo pokazać, jeśli został ukryty.

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

  2. Kliknij kategorię Zaawansowane, a następnie w obszarze Opcje edycji zaznacz lub usuń zaznaczenie pola wyboru Włącz uchwyt wypełniania oraz przeciąganie i upuszczanie komórek, aby pokazać lub ukryć uchwyt wypełniania.

  3. Aby uniknąć zamieniania istniejących danych podczas przeciągania uchwytu wypełniania, należy się upewnić, że jest zaznaczone pole wyboru Ostrzegaj przy zastępowaniu komórek. Aby uniknąć wyświetlania komunikatu dotyczącego zastępowania niepustych komórek, można wyczyścić to pole wyboru.

Zmienianie sposobu wypełniania wybranego elementu za pomocą przycisku Opcje Autowypełniania

Po przeciągnięciu uchwytu wypełniania zostaje wyświetlony przycisk Opcje Autowypełniania Obraz przycisku umożliwiający zmianę sposobu wypełnienia wybranego elementu. Można na przykład wybrać wypełnianie samymi formatami komórek, klikając opcję Wypełnij tylko formatami, a można też wybrać wypełnianie samą zawartością komórek, klikając opcję Wypełnij bez formatowania.

Włączanie i wyłączanie przycisku Opcje Autowypełniania

Jeśli przycisk Opcje Autowypełniania nie ma być wyświetlany po każdym przeciągnięciu uchwytu wypełniania, można go wyłączyć. Podobnie jeśli przycisk Opcje Autowypełniania nie jest wyświetlany po przeciągnięciu uchwytu wypełniania, można go bez problemu włączyć.

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

  2. Kliknij kategorię Zaawansowane, a następnie w obszarze Wycinanie, kopiowanie i wklejanie wyczyść pole wyboru Pokaż przyciski opcji wklejania.

Wypełnianie danych w przylegających komórkach za pomocą polecenia Wypełnij

Za pomocą polecenia Wypełnij można wypełnić aktywną komórkę lub aktywny zakres komórek zawartością przylegającej komórki lub przylegającego zakresu komórek. Przylegające komórki można również szybko wypełnić, przeciągając uchwyt wypełniania Uchwyt wypełniania .

Wypełnianie aktywnej komórki zawartością przylegającej komórki

  1. Zaznacz pustą komórkę poniżej, z prawej strony, powyżej lub z lewej strony komórki, która zawiera dane, na podstawie których ma zostać wypełniona zaznaczona komórka.

  2. Na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Wypełnij, a następnie kliknij polecenie W dół, W prawo, W górę lub W lewo.

    Obraz Wstążki programu Excel

Porada : Aby szybko wypełnić komórkę zawartością przylegającej komórki, można nacisnąć klawisze CTRL+D w celu wypełnienia jej na podstawie komórki powyżej albo klawisze CTRL+R w celu wypełnienia jej na podstawie komórki z lewej strony. Aby wypełnić komórkę zawartością komórki znajdującej się poniżej (czyli wypełnić komórki w górę), na karcie Narzędzia główne w grupie Edycja kliknij pozycję Wypełnienie, a następnie kliknij pozycję W górę. Aby wypełnić komórkę zawartością komórki znajdującej się z prawej strony (czyli wypełnić w lewo), na karcie Narzędzia główne w grupie Edycja kliknij pozycję Wypełnienie, a następnie kliknij pozycję W lewo.

Wypełnianie danych w przylegających komórkach przez przeciągnięcie uchwytu wypełniania

  1. Zaznacz komórki zawierające dane, którymi chcesz wypełnić przylegające komórki.

  2. Przeciągnij uchwyt wypełniania przez komórki, które chcesz wypełnić.

  3. Aby zmienić sposób wypełniania zaznaczenia, kliknij przycisk Opcje Autowypełniania Obraz przycisku , a następnie kliknij wybraną opcję.

Uwaga : Przeciągnięcie uchwytu wypełniania w górę lub na lewo od zaznaczenia i zatrzymanie uchwytu w obszarze zaznaczonych komórek bez przechodzenia przez pierwszą kolumnę lub pierwszy wiersz zaznaczenia spowoduje, że program Excel usunie dane objęte zaznaczeniem. Przed zwolnieniem przycisku myszy należy przeciągnąć uchwyt wypełniania poza zaznaczony obszar.

Wypełnianie formuł w przylegających komórkach

  1. Zaznacz komórkę zawierającą formułę, którą chcesz wypełnić przylegające komórki.

  2. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

  3. Aby wybrać sposób wypełnienia zaznaczenia, kliknij przycisk Opcje Autowypełniania Obraz przycisku , a następnie kliknij żądaną opcję.

Uwaga : Jeśli nie jest włączone automatyczne obliczanie skoroszytu, formuły nie wykonują ponownie obliczeń po wypełnieniu komórek. Aby sprawdzić opcje obliczania skoroszytu, należy wykonać następujące czynności:

  1. Kliknij przycisk Microsoft Office Obraz przycisku pakietu Office , przycisk Opcje programu Excel, a następnie kategorię Formuły.

  2. W obszarze Opcje obliczania sprawdź obszar Obliczanie skoroszytu.

    • Automatycznie    Formuły są obliczane automatycznie.

    • Automatycznie, z wyjątkiem tabel danych    Formuły są obliczane automatycznie, chyba że daną formułę zawiera tabela danych.

    • Ręcznie    Formuły nie są obliczane automatycznie.

    • Oblicz ponownie skoroszyt przed zapisaniem    Ta opcja jest dostępna tylko wtedy, gdy dla opcji Obliczanie skoroszytu ustawiono wartość Ręcznie. Jeśli to pole wyboru jest zaznaczone, formuły nie są obliczane automatycznie, dopóki skoroszyt nie zostanie zapisany. Należy zauważyć, że kilka innych akcji może spowodować zapisanie skoroszytu, na przykład użycie polecenia Wyślij do.

Porady

  • Można też wypełnić aktywną komórkę formułą z przylegającej komórki, używając polecenia Wypełnij (na karcie Narzędzia główne w grupie Edycja) albo naciskając klawisze CTRL+D lub CTRL+R, aby wypełnić komórkę odpowiednio poniżej lub po prawej stronie komórki zawierającej formułę.

  • Można automatycznie wypełnić formułą wszystkie przylegające komórki poniżej, których ta formuła dotyczy, klikając dwukrotnie uchwyt wypełniania pierwszej komórki zawierającej formułę. Załóżmy na przykład, że komórki A1:A15 i B1:B15 zawierają liczby, a w komórce C1 wpisano formułę =A1+B1. Aby skopiować tę formułę do komórek C2:C15, należy zaznaczyć komórkę C1 i kliknąć dwukrotnie uchwyt wypełniania.

Wypełnianie serią liczb, dat lub innych wbudowanych elementów

Za pomocą uchwytu wypełniania można szybko wypełniać komórki w zakresie seriami liczb lub dat albo wbudowanymi seriami dni, dni tygodnia, miesięcy lub lat.

  1. Zaznacz pierwszą komórkę w zakresie, który chcesz wypełnić.

  2. Wprowadź wartość początkową serii.

  3. Wprowadź wartość w następnej komórce, aby ustalić wzorzec.

    Jeśli na przykład jest potrzebna seria 1, 2, 3, 4, 5,..., należy wprowadzić do pierwszych dwóch komórek wartości 1 i 2. Jeśli jest potrzebna seria 2, 4, 6, 8,..., należy wprowadzić wartości 2 i 4. Jeśli seria ma mieć wartości 2, 2, 2, 2,..., można zostawić drugą komórkę pustą.

    Więcej przykładów wypełniania seriami

    Przy wypełnianiu serią zaznaczenia są rozszerzane w sposób pokazany w poniższej tabeli. W tej tabeli elementy rozdzielone przecinkami są zawarte w osobnych przylegających komórkach w arkuszu.

Wartości początkowe

Rozwinięta seria

1, 2, 3

4, 5, 6,...

09:00:00

10:00, 11:00, 12:00,...

pn

wt, śr, cz,...

poniedziałek

wtorek, środa, czwartek,...

sty

lut, mar, kwi,...

sty, kwi

lip, paź, sty,...

7-sty, 7-kwi

7-lip, 7-paź, 8-sty,...

15-sty, 15-kwi

15-lip, 15-paź,...

2007, 2008

2009, 2010, 2011,...

1-sty, 1-mar

1-maj, 1-lip, 1-wrz,...

kwa3 (albo k3 lub kwartał3)

kwa4, kwa1, kwa2,...

tekst1, tekstA

tekst2, tekstA, tekst3, tekstA,...

1. okres

2. okres, 3. okres,...

Produkt 1

Produkt 2, Produkt 3,...

  1. Zaznacz komórkę lub komórki zawierające wartości początkowe.

  2. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez zakres, który chcesz wypełnić.

    Aby wypełnić zakres w kolejności rosnącej, przeciągnij uchwyt w dół lub w prawo. Aby wypełnić zakres w kolejności malejącej, przeciągnij uchwyt w górę lub w lewo.

Porady

  • Można określić typ serii, przeciągając uchwyt wypełniania prawym przyciskiem myszy przez zakres komórek, a następnie klikając odpowiednie polecenie w menu skrótów. Jeśli na przykład wartością początkową jest data sty-2007, w celu uzyskania serii lut-2007, mar-2007 itd. należy kliknąć polecenie Wypełnij miesiącami, a w celu uzyskania serii sty-2007, sty-2008 itd. należy kliknąć polecenie Wypełnij latami.

  • Jeśli zaznaczenie zawiera liczby, można wybrać typ serii, która ma zostać utworzona.

    Wypełnianie komórek serią liczb

    1. Na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Wypełnienie, a następnie kliknij polecenie Seria danych.

      Obraz Wstążki programu Excel

    2. W obszarze Typ kliknij jedną z następujących opcji:

      • Liniowy    Tworzy serię obliczaną przez dodawanie wartości pola Wartość kroku do każdej kolejnej wartości komórki.

      • Wzrost    Tworzy serię obliczaną przez mnożenie wartości pola Wartość kroku przez każdą kolejną wartość komórki.

      • Data    Tworzy serię dat rosnących zgodnie z wartością pola Wartość kroku i zależnych od jednostki określonej w polu Jednostka daty.

      • Autowypełnianie    Tworzy serię dającą wyniki odpowiadające przeciągnięciu uchwytu wypełniania.

  • Można pominąć Autowypełnianie serią, przytrzymując naciśnięty klawisz CTRL podczas przeciągania uchwytu wypełniania dla zaznaczenia obejmującego co najmniej dwie komórki. Zaznaczone wartości zostaną skopiowane do przylegających komórek, a program Excel nie rozwinie serii.

Wypełnianie danych za pomocą serii niestandardowej

Można uprościć wprowadzanie określonej sekwencji danych (na przykład listy nazwisk lub regionów sprzedaży) za pomocą wypełnienia serią niestandardową. Seria niestandardowa może zostać utworzona na podstawie listy istniejących elementów arkusza lub listy wpisanej przez użytkownika. Nie można edytować ani usuwać wbudowanych serii (na przykład serii miesięcy i dni), ale można edytować lub usuwać serie niestandardowe.

Uwaga : Lista niestandardowa może zawierać tylko tekst lub tekst razem z liczbami. Aby utworzyć listę niestandardową zawierającą tylko liczby, na przykład od 0 do 100, najpierw należy utworzyć listę liczb sformatowanych jako tekst.

Formatowanie liczb jako tekstu

  1. Zaznacz wystarczająco dużo komórek dla listy liczb, które chcesz sformatować jako tekst.

  2. Na karcie Narzędzia główne w grupie Liczba kliknij strzałkę w polu Format liczb, a następnie kliknij pozycję Tekst.

    Obraz Wstążki programu Excel

    Porada : Aby wyświetlić na liście format Tekst, może być konieczne kliknięcie pozycji Więcej.

  3. W sformatowanych komórkach wpisz listę liczb.

Używanie serii niestandardowej opartej na istniejącej liście elementów

  1. Zaznacz w arkuszu listę elementów, których chcesz użyć w serii.

  2. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

  3. Kliknij kategorię Popularne, a następnie w obszarze Najczęściej używane opcje w pracy z programem Excel kliknij pozycję Edytuj listy niestandardowe.

  4. Sprawdź, czy odwołanie do komórek zawierających zaznaczoną listę elementów jest wyświetlane w polu Importuj listę z komórek, a następnie kliknij przycisk Importuj.

    Elementy zaznaczonej listy zostaną dodane do pola Listy niestandardowe.

  5. Kliknij przycisk OK dwa razy.

  6. Kliknij komórkę w arkuszu, a następnie wprowadź element serii niestandardowej, który ma być użyty jako pierwszy element listy.

  7. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

Używanie serii niestandardowej opartej na nowej liście elementów

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

  2. Kliknij kategorię Popularne, a następnie w obszarze Najczęściej używane opcje w pracy z programem Excel kliknij pozycję Edytuj listy niestandardowe.

  3. W polu Listy niestandardowe kliknij opcję NOWA LISTA, a następnie wpisz elementy w polu Lista wpisów, zaczynając od pierwszego wpisu.

    Po wprowadzeniu każdego wpisu naciśnij klawisz ENTER.

  4. Po wpisaniu całej listy kliknij przycisk Dodaj, a następnie kliknij przycisk OK dwa razy.

  5. Kliknij komórkę w arkuszu, a następnie wprowadź element niestandardowej serii wypełniania, który ma być użyty jako pierwszy element listy.

  6. Przeciągnij uchwyt wypełniania Uchwyt wypełniania przez komórki, które chcesz wypełnić.

Edytowanie lub usuwanie niestandardowej serii wypełniania

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

  2. Kliknij kategorię Popularne, a następnie w obszarze Najczęściej używane opcje w pracy z programem Excel kliknij pozycję Edytuj listy niestandardowe.

  3. W polu Listy niestandardowe zaznacz listę, którą chcesz edytować lub usunąć, a następnie wykonaj jedną z następujących czynności:

    • Aby edytować serię wypełniania, wprowadź żądane zmiany w polu Lista wpisów, a następnie kliknij przycisk Dodaj.

    • Aby usunąć serię wypełniania, kliknij przycisk Usuń.

Początek strony

Czy wiesz?

Jeśli nie masz subskrypcji usługi Office 365 ani najnowszej wersji pakietu Office, możesz ją teraz wypróbować:

Wypróbuj usługę Office 365 lub najnowszą wersję programu Excel

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomóż w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×