Aktualizowanie danych w istniejącym wykresie

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Po utworzeniu wykresu, może być konieczne zmiany w danych źródłowych na arkusz. Aby wprowadzić te zmiany na wykresie, Microsoft Office Excel zawiera aktualizowanie wykresu na różne sposoby. Możesz natychmiast zaktualizować wykresu ze zmienionymi wartościami lub można dynamicznie zmieniać źródła danych. Wykres można także zaktualizować przez dodanie, zmiana lub usunięcie danych.

Zmienianie danych źródłowych, na podstawie wykresu

Podczas aktualizacji danych źródłowych wykresu dane i wygląd wykresu powoduje także. Zakres tych zmian zależy od tego, jak zdefiniować źródła danych wykresu. Można automatycznie aktualizować arkusza zmienione wartości na wykresie lub można użyć sposoby dynamicznego zmieniania źródła danych źródłowych wykresu.

Automatyczne aktualizowanie wartości w arkuszu zmienione istniejącego wykresu

Wartości na wykresie są połączone z danych arkusza, który posłużył do utworzenia wykresu. Opcje obliczania ustawienia automatycznie (kartaformuły, grupa obliczenia, przycisk Opcje obliczania ) zmiany wprowadzone do danych arkusza automatycznie są wyświetlane na wykresie.

Uwaga : W Excel 2007, kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office > Opcje programu Excel > formuły > obliczenia > Opcje obliczania.

  1. Otwórz arkusz zawierający dane wykreślone na wykresie.

  2. W komórce, która zawiera wartość, która ma zostać zmieniony wpisz nową wartość.

  3. Naciśnij klawisz ENTER.

Dynamiczne Zmienianie źródła danych istniejącego wykresu

Jeśli źródło danych wykresu, aby dynamicznie powiększanie, istnieją dwie metody, które można wykonać. Danych znajdujących się w tabeli programu Excel można utworzyć wykres lub oparte na zdefiniowanej nazwy.

Wykres opiera się na tabeli programu Excel

Po utworzeniu wykresu na podstawie zakresu komórek aktualizacje do danych w zakresie oryginalny zostaną uwzględnione na wykresie. Jednak aby powiększyć rozmiar zakresu, dodawania wierszy i kolumn, a zmiana danych i wyglądu wykresu, należy ręcznie zmienić oryginalne źródło danych na wykresie, zmieniając zakres komórek, na podstawie wykresu.

Jeśli chcesz zmienić dane i wygląd wykresu w przypadku powiększa się ze źródłem danych, można użyć tabeli programu Excel jako źródła danych.

  1. Kliknij wykres, dla którego chcesz zmienić zakres komórek zawierających dane źródłowe.

    Zostanie wyświetlony widok Narzędzia wykresów oraz karty Projektowanie, Układ i Formatowanie.

  2. Na karcie Projektowanie w grupie Dane kliknij przycisk Zaznacz dane.

    Obraz Wstążki programu Excel

  3. W oknie dialogowym Wybieranie źródła danych Zanotuj lokalizację zakres danych, a następnie kliknij przycisk OK.

  4. Przejdź do lokalizacji zakres danych, a następnie kliknij dowolną komórkę w zakresie danych.

  5. Na karcie Wstawianie w grupie Tabele kliknij przycisk Tabela.

    Obraz Wstążki programu Excel

    Skrót klawiaturowy: naciśnij klawisze CTRL + L lub CTRL + T.

Wykres opiera się na zdefiniowanej nazwy

Innym sposobem dynamicznie Zmienianie danych i wygląd wykresu po powiększa się ze źródłem danych jest zdefiniowana nazwa za pomocą funkcji przesunięcie i funkcji. Ta metoda jest przydatna, gdy potrzebne rozwiązanie, które ma zastosowanie również w poprzednich wersjach programu Excel.

Aby uzyskać więcej informacji zobacz jak za pomocą zdefiniowanych nazw, aby automatycznie zaktualizować zakres wykresu w programie Excel.

Dodawanie danych do istniejącego wykresu

Można użyć jednej z kilku sposobów zawiera dodatkowe źródła danych w istniejącym wykresie. Możesz szybko dodać innego seria danych, przeciągnij uchwyty zmiany rozmiaru zakresy, które będą zawierać dane na wykresie, który jest wbudowany w tym samym arkuszu lub kopię nowego arkusza danych do wykresu osadzonego lub do oddzielnych arkusz wykresu.

Dodawanie serii danych do wykresu

  1. Kliknij wykres, do którego chcesz dodać innego serii danych.

    Zostanie wyświetlony widok Narzędzia wykresów oraz karty Projektowanie, Układ i Formatowanie.

  2. Na karcie Projektowanie w grupie Dane kliknij przycisk Zaznacz dane.

    Obraz Wstążki programu Excel

  3. W oknie dialogowym Wybieranie źródła danych w obszarze Wpisy legendy (serie danych), kliknij przycisk Dodaj.

  4. W oknie dialogowym Edytuj serię wykonaj następujące czynności:

    • W polu Nazwa serii wpisz nazwę, której chcesz użyć w serii, lub wybierz nazwę arkusza.

    • W polu serii wartości wpisz odwołanie do zakresu danych w serii danych, którą chcesz dodać, lub zaznacz zakres w arkuszu.

      Czy kliknij przycisk Zwiń okno dialogowe przycisk Przycisk Zwiń , po prawej stronie pola Nazwa serii lub serii wartości, a następnie wybierz zakres, który ma być używany dla tabeli w arkuszu. Gdy skończysz, kliknij przycisk Zwiń okno dialogowe ponownie, aby wyświetlić całe okno dialogowe.

      Umieść wskaźnik myszy do wpisz odwołanie do za pomocą klawiszy strzałek, po naciśnięciu F2, aby upewnić się, że jesteś w trybie edycji. Ponownie nacisnąć klawisz F2 przełączy się do trybu punktu. Można sprawdzić bieżący tryb na pasku stanu.

Przeciągnij uchwyty zmiany rozmiaru zakresy, aby dodać dane do wykresu osadzonego

Jeśli wykres osadzony został utworzony z sąsiadujących komórek arkusza, można dodać dane, przeciągając uchwyty zmiany rozmiaru zakresy danych źródłowych. Wykres musi być na tym samym arkuszu jako dane, które zostało użyte do utworzenia wykresu.

  1. W arkuszu wpisz dane i etykiety, które chcesz dodać do wykresu w komórkach, które przylegają do istniejących danych arkusza.

  2. Kliknij wykres, aby wyświetlić uchwyty zmiany rozmiaru wokół danych źródłowych w arkuszu.

  3. W arkuszu wykonaj jedną z następujących czynności:

    • Aby dodać nowe kategorie i serii danych do wykresu, przeciągnij uchwyt zmiany rozmiaru niebieski, aby uwzględnić nowe dane i etykiety w prostokąt.

    • Dodawanie nowych danych serii, przeciągnij uchwyt zmiany rozmiaru zielony, aby uwzględnić nowe dane i etykiety w prostokąt.

    • Aby dodać nowe kategorie i punkty danych, przeciągnij uchwyt zmiany rozmiaru fioletowy, aby uwzględnić nowe dane i kategorii w prostokąt.

Kopiowanie arkusza danych do wykresu

Jeśli został utworzony wykres osadzony z nieprzylegające lub wykres znajduje się w oddzielnym arkuszu wykresu, możesz skopiować dodatkowe arkusza danych do wykresu.

  1. W arkuszu zaznacz komórki zawierające dane, które chcesz dodać do wykresu.

    Aby na wykresie została wyświetlona etykieta kolumny lub wiersza nowych danych, zaznacz również komórkę zawierającą etykietę.

  2. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj Obraz przycisku .

    Grupa Schowek na karcie Narzędzia główne

    Skrót klawiaturowy: naciśnij klawisze CTRL+C.

  3. Kliknij arkusz wykresu lub wykres osadzony, do którego chcesz wkleić skopiowane dane.

  4. Wykonaj jedną z następujących czynności:

    • Aby wkleić dane na wykresie, na karcie Narzędzia główne w grupie Schowek kliknij przycisk Wklej Obraz przycisku .

      Skrót klawiaturowy: naciśnij klawisze CTRL + V.

    • Aby określić, jak skopiowane dane powinny być na wykresie, na karcie Narzędzia główne w grupie Schowek kliknij strzałkę na przycisku Wklej, kliknij polecenie Wklej specjalnie, a następnie wybierz odpowiednie opcje.

Zmienianie danych w istniejącym wykresie

Istniejącego wykresu można zmienić przez zmianę zakres komórek, na podstawie wykresu lub edytowania poszczególnych serii danych wyświetlanych na wykresie. Możesz również zmienić etykiety osi na osi poziomej (kategorii).

Zmienianie zakresu komórek, na podstawie wykresu

  1. Kliknij wykres, dla którego chcesz zmienić zakres komórek zawierających dane źródłowe.

    Zostanie wyświetlony widok Narzędzia wykresów oraz karty Projektowanie, Układ i Formatowanie.

  2. Na karcie Projektowanie w grupie Dane kliknij przycisk Zaznacz dane.

    Obraz Wstążki programu Excel

  3. W oknie dialogowym Wybieranie źródła danych upewnij się, że jest zaznaczona opcja całego odwołanie w polu zakres danych wykresu.

    Można kliknij przycisk Zwiń okno dialogowe przycisk Przycisk Zwiń , po prawej stronie pola zakres danych wykresu, a następnie wybierz zakres, który ma być używany dla tabeli w arkuszu. Gdy skończysz, kliknij przycisk Zwiń okno dialogowe ponownie, aby wyświetlić całe okno dialogowe.

  4. W arkuszu zaznacz komórki zawierające dane, które mają być wyświetlane na wykresie.

    Jeżeli chcesz, aby etykiety kolumn lub wierszy pojawiły się na wykresie, zaznacz komórki, w których są one zawarte.

    Umieść wskaźnik myszy do wpisz odwołanie do za pomocą klawiszy strzałek, po naciśnięciu F2, aby upewnić się, że jesteś w trybie edycji. Ponownie nacisnąć klawisz F2 przełączy się do trybu punktu. Można sprawdzić bieżący tryb na pasku stanu.

Zmienianie nazwy lub edytowanie serii danych, który jest wyświetlany na wykresie

Bez wpływu na dane w arkuszu, można modyfikować nazwę i wartości istniejących serii danych.

  1. Kliknij wykres, który zawiera serię danych, którą chcesz zmienić.

    Zostanie wyświetlony widok Narzędzia wykresów oraz karty Projektowanie, Układ i Formatowanie.

  2. Na karcie Projektowanie w grupie Dane kliknij przycisk Zaznacz dane.

    Obraz Wstążki programu Excel

  3. W oknie dialogowym Wybieranie źródła danych, w obszarze Wpisy legendy (serie danych) wybierz serię danych, którą chcesz zmienić, a następnie kliknij przycisk Edytuj.

  4. Aby zmienić serię danych, w polu Nazwa serii wpisz nazwę, której chcesz użyć w serii, lub wybierz nazwę arkusza. Nazwa wyświetlana w legendzie wykresu, ale nie są dodawane do arkusza.

  5. Aby zmienić zakres danych dla serii danych, w polu wartości serii wpisz odwołanie do zakresu danych w serii danych, którą chcesz dodać, zaznacz zakres w arkuszu lub wprowadź wartości w polach. Wpisywane wartości nie są dodawane do arkusza.

    Wykres jest xy (punktowy), pola wartości X serii i wartości Y serii są wyświetlane w celu zmiany zakresu danych dla tych wartości. Wykres znajduje się na wykresie bąbelkowym, co umożliwia zmianę zakresu danych dla wartości te są wyświetlane pola wartości X serii, wartości serii Y i rozmiary bąbelków serii.

Dla każdego z pól serii możesz kliknij przycisk Zwiń okno dialogowe przycisk Przycisk Zwiń , po prawej stronie pola Nazwa serii lub serii wartości, a następnie wybierz zakres, który ma być używany dla tabeli w arkuszu. Gdy skończysz, kliknij przycisk Zwiń okno dialogowe ponownie, aby wyświetlić całe okno dialogowe.

Umieść wskaźnik myszy do wpisz odwołanie do za pomocą klawiszy strzałek, po naciśnięciu F2, aby upewnić się, że jesteś w trybie edycji. Ponownie nacisnąć klawisz F2 przełączy się do trybu punktu. Można sprawdzić bieżący tryb na pasku stanu.

Zmienianie kolejności serii danych

  1. Kliknij wykres, który zawiera serię danych, którą chcesz zmienić.

    Zostanie wyświetlony widok Narzędzia wykresów oraz karty Projektowanie, Układ i Formatowanie.

  2. Na karcie Projektowanie w grupie Dane kliknij przycisk Zaznacz dane.

    Obraz Wstążki programu Excel

  3. W oknie dialogowym Wybieranie źródła danych w obszarze Wpisy legendy (serie danych) wybierz serię danych, którą chcesz przenieść w inne miejsce w sekwencji.

  4. Kliknij strzałki Przenieś w górę lub Przenieś w dół, aby przenieść serię danych.

  5. Powtórz krok 3 i 4 dla wszystkich serii danych, które chcesz przenieść.

Zmienianie osi poziomej (kategorii) etykiety osi

Gdy zmienisz osi poziomej (kategorii) zostanie zmieniona etykiet osi, wszystkie etykiety osi poziomej. Nie można zmienić etykiety osi pojedynczych, poziomej.

  1. Kliknij wykres, który zawiera etykiety osi poziomej, które chcesz zmienić.

    Zostanie wyświetlony widok Narzędzia wykresów oraz karty Projektowanie, Układ i Formatowanie.

  2. Na karcie Projektowanie w grupie Dane kliknij przycisk Zaznacz dane.

    Obraz Wstążki programu Excel

  3. W obszarze Etykiety osi poziomej (kategorii) kliknij przycisk Edytuj.

  4. W polu zakres etykiet osi wpisz odwołanie do zakresu danych w serii danych, która ma być używany dla etykiet osi poziomej, lub zaznacz zakres w arkuszu.

    Czy kliknij przycisk Zwiń okno dialogowe przycisk Przycisk Zwiń , po prawej stronie pola Nazwa serii lub serii wartości, a następnie wybierz zakres, który ma być używany dla tabeli w arkuszu. Gdy skończysz, kliknij przycisk Zwiń okno dialogowe ponownie, aby wyświetlić całe okno dialogowe.

    Umieść wskaźnik myszy do wpisz odwołanie do za pomocą klawiszy strzałek, po naciśnięciu F2, aby upewnić się, że jesteś w trybie edycji. Ponownie nacisnąć klawisz F2 przełączy się do trybu punktu. Można sprawdzić bieżący tryb na pasku stanu.

Usuwanie danych z wykresu

Opcje obliczania ustawienia automatycznie zostaną automatycznie usunięte z wykresu dane, które zostanie usunięty z arkusza. Można też usunąć dane z wykresu bez zmieniania danych źródłowych w arkuszu.

Usuwanie źródła danych w arkuszu

  • W arkuszu zaznacz komórkę lub zakres komórek zawierający dane, które chcesz usunąć z wykresu, a następnie naciśnij klawisz DELETE.

    • Po usunięciu danych z zaznaczonych komórek pustych komórek są wykreślane na wykresie. Możesz zmienić sposób kreślenia pustych komórek przez kliknięcie prawym przyciskiem myszy wykres, a następnie wybierając ukryte i puste komórki.

    • Po usunięciu kolumny serii danych całego zostanie usunięta z wykresu. Jeśli usuniesz wiersz, może zostać wyświetlony komunikat o błędzie. Po kliknięciu przycisku OK wykres może być wyświetlany jeden lub więcej punktów danych w serii danych, która została usunięta. Czy kliknij punktów danych, a następnie naciśnij klawisz DELETE.

Usuwanie serii danych z wykresu

  1. Kliknij wykres lub serię danych, którą chcesz usunąć, lub wykonaj poniższe czynności, aby wybrać serii danych lub wykresu z listy elementów wykresu:

    1. Kliknij wykres.

      Zostanie wyświetlony widok Narzędzia wykresów oraz karty Projektowanie, Układ i Formatowanie.

    2. Na karcie Formatowanie w grupie Bieżące zaznaczenie kliknij strzałkę obok pola Obszar wykresu, a następnie kliknij element wykresu, który ma być używany.

      Grupa Bieżące zaznaczenie na karcie Układ (Narzędzia wykresów)

  2. Wykonaj jedną z następujących czynności:

    1. Jeśli wybrano wykres, wykonaj następujące czynności:

      1. Na karcie Projektowanie w grupie Dane kliknij przycisk Zaznacz dane.

        Obraz Wstążki programu Excel

      2. W oknie dialogowym Wybieranie źródła danych, w obszarze Wpisy legendy (serie danych) wybierz serię danych, którą chcesz usunąć, a następnie kliknij przycisk Usuń.

    2. Jeśli wybrano serii danych na wykresie, naciśnij klawisz DELETE.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać ekspertem w Społeczności użytkowników programu Excel Techuzyskiwanie pomocy technicznej w społeczności Answerslub proponowanie nowej funkcji lub poprawiony Głosu użytkownika programu Excel.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×