ŚREDNIA, funkcja

Ten artykuł zawiera opis składni formuły i zastosowania funkcji średnia w programie Microsoft Excel.

Opis

Zwraca średnią (średnią arytmetyczną) argumentów. Jeśli na przykład zakres a1: A20 zawiera liczby, formuła =średnia (a1: A20) zwraca wartość średnią tych liczb.

Składnia

ŚREDNIA(liczba1;[liczba2];...)

W składni funkcji ŚREDNIA występują następujące argumenty:

  • Liczba1    Argument wymagany. Pierwsza liczba, odwołanie do komórki lub zakres, dla którego ma zostać obliczona średnia.

  • Liczba2; ...    Argument opcjonalny. Dodatkowe liczby, odwołania do komórek lub zakresy (maksymalnie 255), dla których ma zostać wyznaczona średnia.

Spostrzeżenia

  • Argumentami mogą być liczby, nazwy, zakresy lub odwołania do komórek, które zawierają liczby.

  • Wartości logiczne i tekstowe reprezentacje liczb wpisane bezpośrednio na liście argumentów nie są liczone.

  • Jeśli argument zakresu lub odwołania do komórki zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak uwzględniane w obliczeniach.

  • Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić w cyfry, powodują błędy.

  • Aby uwzględnić wartości logiczne i tekstowe reprezentacje liczb w odwołaniu jako część obliczeń, należy użyć funkcji ŚREDNIA.A.

  • Aby obliczyć średnią tylko dla wartości spełniających określone kryteria, należy użyć funkcji ŚREDNIA.JEŻELI lub funkcji ŚREDNIA.WARUNKÓW.

Uwaga: Funkcja ŚREDNIA sprawdza tendencję centralną, którą jest lokalizacja środka zbioru liczb w rozkładzie statystycznym. Trzy najczęściej używane miary tendencji centralnej to:

  • Średnia — średnia arytmetyczna, obliczana jako suma zbioru wartości podzielona przez ich liczbę. Na przykład średnią liczb 2, 3, 3, 5, 7 i 10 jest wartość 30 podzielona przez 6, czyli 5.

  • Mediana — środkowa liczba w zbiorze wartości (połowa liczb jest większa lub równa medianie, a połowa liczb jest mniejsza lub równa medianie). Na przykład medianą zbioru 2, 3, 3, 5, 7 i 10 jest 4.

  • Wyst.najczęściej — najczęściej występująca wartość w zbiorze (dominanta). Na przykład dominantą zbioru 2, 3, 3, 5, 7 i 10 jest 3.

W przypadku symetrycznego rozkładu zbioru liczb wszystkie trzy miary tendencji centralnej są takie same. W przypadku skośnego rozkładu zbioru liczb miary mogą być różne.

Porada: Podczas obliczania średniej komórek należy pamiętać o różnicy między komórkami pustymi a komórkami zawierającymi wartości zerowe, szczególnie jeśli zostało wyczyszczone pole wyboru Pokaż zero w komórkach o zerowej wartości w oknie dialogowym Opcje programu Excel w aplikacji komputerowej programu Excel. Jeśli ta opcja jest zaznaczona, w obliczeniach są uwzględniane wartości zerowe, ale nie są uwzględniane puste komórki.

Aby znaleźć pole wyboru Pokaż zero w komórkach o zerowej wartości:

  • Na karcie Plik kliknij pozycję Opcje, a następnie w kategorii Zaawansowane zlokalizuj obszar Opcje wyświetlania dla tego arkusza.

Przykład

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Dane

10

15

32

7

9

27

2

Formuła

Opis

Wynik

=ŚREDNIA(A2:A6)

Średnia liczb z komórek od A2 do A6.

11

=ŚREDNIA(A2:A6;5)

Średnia liczb z komórek od A2 do A6 i liczby 5.

10

=ŚREDNIA(A2:C2)

Średnia liczb z komórek od A2 do C2.

19

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×