Łączenie dwóch widoków danych

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Użytkownicy programu Microsoft Office SharePoint Designer 2007 prawdopodobnie są przyzwyczajeni do tworzenia aplikacji, w których w szerokim zakresie używane są źródła danych i widoki danych. Łącząc widoki danych, które zostały wstawione jako widoki lub formularze, można tworzyć połączenia między nimi. Wówczas wykonanie akcji w jednym widoku danych powoduje zmianę zawartości drugiego widoku danych. Łączenie widoków danych jest szybkim i jednocześnie funkcjonalnym sposobem dodawania elementów interaktywnych do witryny lub aplikacji.

Uwaga : Widoki danych to rodzaj składników Web Part, więc koncepcje i procedury opisane w tym artykule można równie dobrze zastosować do dowolnych dwóch możliwych do połączenia składników Web Part.

W tym artykule przedstawiono sposób tworzenia dwóch widoków danych i połączenia ich przy użyciu Kreatora połączeń składników Web Part.

Aby dowiedzieć się więcej na temat widoków danych, zobacz Tworzenie widoku danych.

W tym artykule

Dlaczego połączenia składników Web Part?

Tworzenie pierwszego widoku danych przy użyciu plik produkty.XML

Tworzenie pliku XML jako źródła danych przykładowych

Tworzenie widoku danych przy użyciu Suppliers.xml

Łączenie składników Web Part

Testowanie połączenia składników Web Part

Usuwanie połączenia składnika Web Part

Dlaczego warto łączyć składniki Web Part?

Połączenie dwóch składników Web Part umożliwia przekazywanie danych między nimi i zsynchronizowanie ich zachowania. Można na przykład połączyć składnik Web Part widoku listy, w którym wyświetlana jest lista pracowników, ze składnikiem Web Part obrazu. W przypadku połączenia tych dwóch składników Web Part po każdym kliknięciu nazwiska pracownika w składniku Web Part widoku listy w składniku Web Part obrazu wyświetlane będzie zdjęcie wybranego pracownika.

Proste połączenie składników Web Part można ustanowić przy użyciu przeglądarki. Można na przykład połączyć ze sobą dwa składniki Web Part znajdujące się na tej samej stronie składników Web Part. Jednak korzystając z programu Office SharePoint Designer 2007, można rozszerzyć funkcjonalność połączenia. Można na przykład użyć składnika Web Part formularza do filtrowania danych w innym składniku Web Part lub ustanowić połączenie między dwoma składnikami Web Part na dwóch różnych stronach składników Web Part w tej samej witrynie sieci Web najwyższego poziomu. Do obu tych akcji wymagany jest program Office SharePoint Designer 2007 i nie można ich wykonać przy użyciu przeglądarki.

Początek strony

Tworzenie pierwszego widoku danych przy użyciu pliku produkty.xml

Firma Northwind Traders, która zajmuje się dystrybucją wyszukanych potraw, prowadzi ewidencję swoich zapasów w pliku xml o nazwie produkty.xml, a dane z tego pliku są wyświetlane w widoku danych. Ten widok danych został wstawiony jako formularz, dzięki czemu zespół może aktualizować zapasy za pomocą przeglądarki, zapisując zmiany w pliku produkty.xml. Kiedy zapas jest niski, członek zespołu dzwoni do dostawcy danego produktu i składa zamówienie, a następnie aktualizuje zapas przy użyciu widoku danych. Ale za każdym razem, gdy członek zespołu składa zamówienie, musi poszukać informacji kontaktowych dostawcy.

W takim przypadku warto wstawić drugi widok danych, w którym będą wyświetlane informacje kontaktowe dostawców, a następnie utworzyć połączenie między tymi dwoma składnikami Web Part. Dzięki temu, kiedy członek zespołu będzie chciał złożyć zamówienie, będzie mógł dla każdego produktu wyświetlić zarówno dane o zapasach, jak i informacje kontaktowe dostawcy, klikając jedno hiperłącze.

Wykonanie poniższych procedur wymaga przy użyciu dwóch plików XML jako źródła danych i tworzenia widoku danych z każdego z tych źródeł danych. Aby obserwować w przykładzie, Utwórz widok danych z pierwszego z plik produkty.XML wykonując procedurę opisaną w artykule Wstawianie widoku danych jako formularza. Następnie wróć do tego artykułu, aby utworzyć drugi widok danych z Suppliers.xml.

Początek strony

Tworzenie pliku XML jako przykładowego źródła danych

Firma Northwind Traders przechowuje informacje kontaktowe dotyczące swoich dostawców w pliku xml o nazwie dostawcy.xml.

Tworzenie pliku dostawcy.xml

  1. W menu Plik kliknij polecenie Otwórz witrynę.

  2. W oknie dialogowym Otwieranie witryny przejdź do odpowiedniej witryny i zaznacz ją, a następnie kliknij przycisk Otwórz.

  3. Gdy zostanie wyświetlony monit, w oknie dialogowym Łączenie z wpisz nazwę użytkownika i hasło, a następnie kliknij przycisk OK.

  4. W menu Plik kliknij polecenie Nowy.

  5. W oknie dialogowym Nowy kliknij dwukrotnie pozycję Plik tekstowy.

    W witrynie zostanie otworzony nowy plik tekstowy.

  6. Skopiuj poniższe wiersze kodu, zaznaczając je, a następnie naciskając klawisze CTRL+C.

    <?xml version="1.0" encoding="utf-8"?>
    <SuppliersRoot>
    <Suppliers>
    <SupplierID>1</SupplierID>
    <CompanyName>Exotic Liquids</CompanyName>
    <ContactName>Charlotte Cooper</ContactName>
    <ContactTitle>Purchasing Manager</ContactTitle>
    <Address>49 Gilbert St.</Address>
    <City>London</City>
    <PostalCode>EC1 4SD</PostalCode>
    <Country>UK</Country>
    <Phone>(171) 555-2222</Phone>
    </Suppliers>
    <Suppliers>
    <SupplierID>2</SupplierID>
    <CompanyName>New Orleans Cajun Delights</CompanyName>
    <ContactName>Shelley Burke</ContactName>
    <ContactTitle>Order Administrator</ContactTitle>
    <Address>P.O. Box 78934</Address>
    <City>New Orleans</City>
    <Region>LA</Region>
    <PostalCode>70117</PostalCode>
    <Country>USA</Country>
    <Phone>(100) 555-4822</Phone>
    <HomePage>#CAJUN.HTM#</HomePage>
    </Suppliers>
    </SuppliersRoot>
  7. W programie Office SharePoint Designer 2007 umieść punkt wstawiania u góry strony, a następnie naciśnij klawisze CTRL+V, aby wkleić skopiowany kod na stronie.

  8. W menu Plik kliknij polecenie Zapisz jako.

  9. W oknie dialogowym Zapisywanie jako w polu Nazwa pliku wpisz suppliers.xml.

  10. Na liście Zapisz jako typ kliknij pozycję XML, a następnie kliknij przycisk Zapisz.

Początek strony

Tworzenie widoku danych przy użyciu pliku dostawcy.xml

  1. Otwórz stronę zawierającą widok danych pierwszy utworzony w artykule Wstawianie widoku danych jako formularza.

    Chociaż nie jest konieczne, aby oba widoki danych znajdowały się na jednej stronie, jednak w tym przypadku chcemy, aby zespół miał możliwość zobaczenia informacji kontaktowych dostawcy od razu po kliknięciu produktu.

    Wybrane dane wyświetlone w postaci formularza

  2. Wybierz pierwszy widok danych, a następnie naciśnij dwa razy klawisz STRZAŁKA W PRAWO, aby umieścić kursor poniżej widoku danych.

  3. W menu Widok danych kliknij polecenie Wstaw widok danych.

    Poniżej pierwszego widoku danych zostanie wyświetlony pusty widok danych i zostanie otwarte okienko zadań Biblioteka źródeł danych.

    Pusty widok danych

  4. W okienku zadań Biblioteka źródeł danych zlokalizuj źródło danych, kliknij je, a następnie kliknij przycisk Pokaż dane.

    W tym przykładzie w obszarze Pliki XML kliknij pozycję dostawcy.xml, a następnie kliknij przycisk Pokaż dane. Jeśli nagłówek Pliki XML jest zwinięty, kliknij znak plus (+), aby go rozwinąć.

  5. W okienku zadań Szczegóły źródła danych kliknij pola, które chcesz wstawić w widoku danych.

    Porada : Aby zaznaczyć wiele pól, podczas ich klikania przytrzymaj wciśnięty klawisz CTRL.

    W tym przykładzie w folderze SuppliersRoot w obszarze Suppliers kliknij pozycję CompanyName. Naciśnij i przytrzymaj klawisz CTRL podczas klikania pozycji ContactName, Country i Phone.

  6. Kliknij przycisk Wstaw wybrane pola jako, a następnie kliknij polecenie Widok jednego elementu, aby wstawić zaznaczone dane do widoku danych.

    Wybrano wyświetlanie tylko jednego elementu w widoku danych, ponieważ chcemy, aby jednorazowo wyświetlane były informacje kontaktowe tylko dla jednego dostawcy.

    Pola wybrane w okienku zadań Szczegóły źródła danych teraz są wyświetlane w drugim widoku danych poniżej pierwszego.

    Widok danych dostawców wyświetlany poniżej widoku danych produktów
    Dane widoku z Suppliers.xml (opisane w kolorze czerwonym) jest wyświetlany poniżej widoku danych plik produkty.XML.

Początek strony

Łączenie składników Web Part

Pliki dostawcy.xml i produkty.xml są powiązane przez wspólne pole o nazwie SupplierID. Przy użyciu Kreatora połączeń składników Web Part należy połączyć składniki Web Part, tworząc połączenie pola SupplierID w pliku produkty.xml z polem SupplierID w pliku dostawcy.xml.

Po utworzeniu dwóch widoków danych należy obok każdego produktu w widoku danych pliku produkty.xml dodać tekst, który będzie hiperłączem do widoku danych pliku dostawcy.xml. Po kliknięciu hiperłącza dla produktu w pierwszym widoku danych w drugim widoku danych będą wyświetlane informacje kontaktowe dotyczące dostawcy tego produktu.

Widok danych pliku produkty.xml jest źródłowym składnikiem Web Part, a widok danych pliku dostawcy.xml jest docelowym składnikiem Web Part. Ponieważ pracujemy z widokiem danych wstawionym jako formularz, hiperłącze tekstowe należy utworzyć poza polem formularza. Po wpisaniu tekstu należy go zaznaczyć i użyć Kreatora połączeń składników Web Part, aby w pliku produkty.xml utworzyć hiperłącze do widoku danych pliku dostawcy.xml.

  1. Widok danych utworzony na podstawie plik produkty.XML umieść kursor po prawej stronie pola tekstowego, które zawiera nazwę produktu, naciśnij klawisz SPACJA, a następnie wpisz kolejności. Ponieważ widoku danych rozdzielanych XSLT, tekst "zamówienia" jest dodawany do wszystkich pól produktu na liście.

    Zamówienie jest wyświetlane w kolumnie ProductName dla każdego produktu na liście

  2. W widoku danych zaznacz tekst „zamówienie”, kliknij go prawym przyciskiem myszy, a następnie kliknij polecenie Połączenia składników Web Part w menu skrótów.

    Zostanie otwarty Kreator połączeń składników Web Part.

  3. Na liście Wybierz akcję w źródłowym składniku Web Part do użycia dla tego połączenia kliknij pozycję Wyślij wiersz danych do, a następnie kliknij przycisk Dalej.

    Strona w Kreatorze połączeń składników Web Part

  4. W sekcji Wybierz stronę zawierającą składnik Web Part dla połączenia kliknij opcję Połącz ze składnikiem Web Part na tej stronie, a następnie kliknij przycisk Dalej.

    Strona w Kreatorze połączeń składników Web Part

  5. Na liście Docelowy składnik Web Part kliknij pozycję dostawcy.xml.

  6. Ponieważ chcesz filtrować dane z pliku dostawcy.xml, aby pasowały do pola SupplierID określonego produktu w pierwszym widoku danych, to na liście Akcja docelowa kliknij pozycję Pobierz wartości filtrów z, a następnie kliknij przycisk Dalej.

    Strona w Kreatorze połączeń składników Web Part

  7. W kolumnie Dane wejściowe składnika dostawcy.xml przewijaj listę w dół do momentu wyświetlenia pola SupplierID. Po lewej stronie od pola SupplierID na liście w kolumnie Kolumny w składniku produkty.xml kliknij komórkę, kliknij strzałkę, a następnie kliknij pozycję SupplierID na liście. Kliknij przycisk Dalej.

    Strona w Kreatorze połączeń składników Web Part

  8. Na liście Utwórz hiperłącze w kliknij pozycję [ Bieżące zaznaczenie ], a następnie kliknij przycisk Dalej.

    Strona w Kreatorze połączeń składników Web Part

  9. Kliknij przycisk Zakończ.

  10. Kliknij polecenie Zapisz w menu Plik lub naciśnij klawisze CTRL+S.

Tekst „zamówienie” jest teraz hiperłączem i połączenie składników Web Part zostało skonfigurowane.

Początek strony

Testowanie połączenia składników Web Part

Teraz po skonfigurowaniu połączenia składników Web Part można przetestować połączenie, wyświetlając podgląd strony w przeglądarce.

  • Aby wyświetlić podgląd pliku w przeglądarce, kliknij przycisk Podgląd na pasku narzędzi Typowe lub naciśnij klawisz F12.

Oba składniki Web Part są wyświetlane na stronie w przeglądarce. Aby wyświetlić dostawcę określonego produktu, należy w pierwszym widoku danych kliknąć hiperłącze zamówienie obok odpowiedniego produktu w kolumnie ProductName. Informacje kontaktowe tego dostawcy zostaną wyświetlone w drugim widoku danych poniżej.

Dwa połączone widoki danych na stronie

Uwaga : Firma Exotic Liquids jest dostawcą produktów Chai, Chang i Aniseed Syrup. Firma New Orleans Cajun Delights jest dostawcą produktów Chef Anton’s Cajun Seasoning oraz Chef Anton’s Gumbo Mix.

Początek strony

Usuwanie połączenia składników Web Part

Możliwe jest także usunięcie połączenia składników Web Part, tak aby nie były już ze sobą połączone. Podczas łączenia składników Web Part każdy składnik Web Part dodaje to połączenie do listy, więc możliwe jest usunięcie połączenia podczas pracy ze źródłowym lub docelowym składnikiem Web Part. Usunięcie połączenia ze źródłowego składnika Web Part powoduje także usuniecie połączenia z docelowego składnika Web Part.

  1. Kliknij prawym przyciskiem myszy jeden z widoków danych, a następnie kliknij polecenie Połączenia składników Web Part w menu skrótów.

  2. W oknie dialogowym Połączenia składników Web Part kliknij połączenie, które chcesz usunąć, a następnie kliknij przycisk Usuń.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×