Unieke waarden onder duplicaten tellen

Opmerking:  We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

Stel dat u wilt weten hoeveel unieke tekst- of numerieke waarden in een bereik zijn. Bijvoorbeeld als een kolom bevat de tekstwaarden Bradley, Doyle, Doyle, Doyle, er zijn twee unieke waarden, Bradley en Doyle. Als het bereik de getallen 5, 6, 7 en 6bevat, zijn de unieke waarden 5, 6 en 7.

Als u alleen unieke waarden wilt tellen, gebruikt u een combinatie van de volgende functies, zoals in het onderstaande voorbeeldwerkblad:

  • Gebruik de functie als de waarde 1 toewijzen aan elke voorwaarde die waar is.

  • Gebruik de functie SOM om alle unieke waarden te tellen.

  • Gebruik de functie interval om het aantal unieke waarden te tellen. Deze functie worden genegeerd tekst en nulwaarden. Voor het eerste exemplaar van een bepaalde waarde wordt een getal gelijk is aan het aantal exemplaren van die waarde. Elk exemplaar van die dezelfde waarde na de eerste retourneert deze functie de waarde 0.

  • De functie vergelijken gebruiken om de positie van een tekenreeks in een bereik te retourneren. De functie interval wordt de resulterende waarde gebruikt de bijbehorende tekstwaarden wordt berekend.

  • Gebruik de functie lengte om lege cellen. Lege cellen hebben een lengte (aantal tekens) van 0.

Voorbeeld

Kopieer de tabel naar cel A1 in een leeg werkblad in Excel om te werken met deze voorbeelden van formules waarin functies worden gebruikt.

Gegevens

Gegevens

986

Bradley

Doyle

563

67

789

235

Bradley

Doyle

689

789

Doyle

143

56

237

67

235

Formule

Beschrijving (resultaat)

=SOM(ALS(INTERVAL(A2:A10,A2:A10)>0,1))

Hiermee wordt het aantal unieke getalwaarden geteld in de cellen A2:A10, maar lege cellen of tekstwaarden worden niet meegeteld (4)

=SOM(ALS(INTERVAL(MATCH(B2:B10,B2:B10,0),MATCH(B2:B10,B2:B10,0))>0,1))

Hiermee wordt het aantal unieke tekst- en getalwaarden geteld in de cellen B2:B10 (die geen lege cellen mogen bevatten) (7)

=SOM(ALS(INTERVAL(ALS(LENGTE(A2:A10)>0,MATCH(A2:A10,A2:A10,0),""), ALS(LENGTE(A2:A10)>0,MATCH(A2:A10,A2:A10,0),""))>0,1))

Hiermee wordt het aantal unieke tekst- en getalwaarden geteld in de cellen A2:A10 , maar lege cellen of tekstwaarden worden niet meegeteld (6)

Notities: 

  • De formules in dit voorbeeld moeten als matrixformules worden ingevoerd. Selecteer alle cellen met een formule, drukt u op F2 en druk op Ctrl + Shift + Enter.

  • Als u wilt zien hoe een functie stap voor stap wordt geëvalueerd, selecteert u de cel met de formule en klikt u op het tabblad Formules in de groep Formules controleren op Formule evalueren.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×