Unieke waarden onder duplicaten tellen

Belangrijk : Dit artikel is automatisch vertaald, bekijk de disclaimer. De Engelse versie van dit artikel vindt u hier voor referentiedoeleinden.

Stel dat u wilt weten hoeveel unieke tekst- of numerieke waarden in een bereik zijn. Bijvoorbeeld als een kolom bevat de tekstwaarden Bradley, Doyle, Doyle, Doyle, er zijn twee unieke waarden, Bradley en Doyle. Als het bereik de getallen 5, 6, 7 en 6bevat, zijn de unieke waarden 5, 6 en 7.

Als u alleen unieke waarden wilt tellen, gebruikt u een combinatie van de volgende functies, zoals in het onderstaande voorbeeldwerkblad:

  • Gebruik de functie ALS om de waarde 1 toe te wijzen aan elke voorwaarde die WAAR is.

  • Gebruik de functie SOM om alle unieke waarden op te tellen.

  • Gebruik de functie INTERVAL om het aantal unieke waarden te tellen. De functie negeert tekst- en nulwaarden. Voor de eerste keer dat een bepaalde waarde voorkomt, retourneert deze functie een getal dat gelijk is aan het aantal keren dat deze waarde voorkomt. Voor elk keer dat diezelfde waarde voorkomt na de eerste keer retourneert deze functie de waarde nul.

  • Gebruik de functie VERGELIJKEN om de positie van een tekstwaarde in een bereik te retourneren. De functie INTERVAL gebruikt de resulterende waarde om de bijbehorende tekstwaarden te evalueren.

  • Gebruik de functie LENGTE om lege cellen te vinden. Lege cellen hebben de lengte (aantal tekens) 0.

Voorbeeld

Kopieer de tabel naar cel A1 in een leeg werkblad in Excel om te werken met deze voorbeelden van formules waarin functies worden gebruikt.

Gegevens

Gegevens

986

Bradley

Doyle

563

67

789

235

Bradley

Doyle

689

789

Doyle

143

56

237

67

235

Formule

Beschrijving (resultaat)

=SOM(ALS(INTERVAL(A2:A10,A2:A10)>0,1))

Hiermee wordt het aantal unieke getalwaarden geteld in de cellen A2:A10, maar lege cellen of tekstwaarden worden niet meegeteld (4)

=SOM(ALS(INTERVAL(MATCH(B2:B10,B2:B10,0),MATCH(B2:B10,B2:B10,0))>0,1))

Hiermee wordt het aantal unieke tekst- en getalwaarden geteld in de cellen B2:B10 (die geen lege cellen mogen bevatten) (7)

=SOM(ALS(INTERVAL(ALS(LENGTE(A2:A10)>0,MATCH(A2:A10,A2:A10,0),""), ALS(LENGTE(A2:A10)>0,MATCH(A2:A10,A2:A10,0),""))>0,1))

Hiermee wordt het aantal unieke tekst- en getalwaarden geteld in de cellen A2:A10 , maar lege cellen of tekstwaarden worden niet meegeteld (6)

Notities : 

  • De formules in dit voorbeeld moeten als matrixformules worden ingevoerd. Selecteer alle cellen met een formule, drukt u op F2 en druk op Ctrl + Shift + Enter.

  • Als u wilt zien hoe een functie stap voor stap wordt geëvalueerd, selecteert u de cel met de formule en klikt u op het tabblad Formules in de groep Formules controleren op Formule evalueren.

Opmerking : Disclaimer voor automatische vertaling: Dit artikel is vertaald door een computersysteem zonder menselijke tussenkomst. Microsoft biedt deze automatische vertalingen aan om niet-Engels sprekende gebruikers te helpen de inhoud over producten, services en technologieën van Microsoft te raadplegen. Omdat het artikel automatisch is vertaald, bevat het mogelijk fouten in grammatica, woordenschat en syntaxis.

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×