TYPE.FOUT, functie

In dit artikel worden de syntaxis van de formule en het gebruik van de functie TYPE.FOUT in Microsoft Excel beschreven.

Beschrijving

Geeft als resultaat een nummer dat overeenkomt met een van de foutwaarden van Microsoft Excel, of de foutwaarde #N/B als er geen fout is. U kunt TYPE.FOUT toepassen in een functie ALS om te zoeken naar een foutwaarde en een tekenreeks, zoals een bericht, als resultaat te geven in plaats van de foutwaarde.

Syntaxis

TYPE.FOUT(foutwaarde)

De syntaxis van de functie TYPE.FOUT heeft de volgende argumenten:

  • foutwaarde    Vereist. De foutwaarde waarvan u het nummer wilt weten. Hoewel foutwaarde zelf de foutwaarde kan zijn, zal foutwaarde over het algemeen verwijzen naar een cel die een formule bevat die moet worden getest.

Als foutwaarde is

Resulteert TYPE.FOUT in

#LEEG!

1

#DEEL/0!

2

#WAARDE!

3

#VERW!

4

#NAAM?

5

#GETAL!

6

#N/B

7

#GEGEVENS_OPHALEN

8

Anders

#N/B

Voorbeeld

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Om resultaten van formules weer te geven, selecteert u deze, drukt u op F2 en drukt u vervolgens op Enter. Indien nodig kunt u de kolombreedten aanpassen als u alle gegevens wilt zien.

Gegevens

#LEEG!

#DEEL/0!

Formule

Beschrijving

Resultaat

=TYPE.FOUT(A2)

Het nummer van de fout #LEEG!.

1

=ALS(TYPE.FOUT(A3)<3;KIEZEN(TYPE.FOUT(A3);"Bereiken overlappen elkaar niet";"De deler is nul"))

Hiermee wordt gecontroleerd of de cel A3 de foutwaarde #LEEG! of #DEEL/0! bevat. Als dit het geval is, wordt het nummer van de foutwaarde gebruikt in de functie KIEZEN om een van twee berichten weer te geven. Als dit niet het geval is, wordt de foutwaarde #N/B als resultaat gegeven.

De deler is nul

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×