SOMPRODUCT gebruiken om bijbehorende waarden in één of meer matrices berekenen

Opmerking:  We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

SOMPRODUCT gebruikt cellenbereiken (of matrices) als de argumenten (de onderdelen van de formule waarmee de software werken). Vermenigvuldigd samen de items in de matrices, en klik vervolgens onder het resultaat opgeteld.

Dit voorbeeld is een boodschappenlijst met één matrix waarin de kosten van elk artikel staan en één matrix waarin staat hoeveel artikelen zullen worden gekocht.

Prijzen en aantallen die moeten worden vermenigvuldigd en daarna moeten worden opgeteld

  1. U maakt de formule door =SOMPRODUCT(B3:B6;C3:C6) en druk op Enter.

Elke cel in kolom B wordt vermenigvuldigd met de bijbehorende cel in dezelfde rij in kolom C en de resultaten worden opgeteld. Het totaalbedrag voor de boodschappen bedraagt € 21,60.

  1. Een langere formule schrijven die hetzelfde resultaat oplevert, type = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 en druk op Enter.

Nadat u op Enter hebt gedrukt, is het resultaat hetzelfde: € 21,60. Cel B3 wordt vermenigvuldigd met C3 en het resultaat wordt toegevoegd aan het resultaat van cel B4 vermenigvuldigd met cel C4, enzovoort. U kunt zich voorstellen dat wanneer u duizenden (of zelfs honderden) rijen hebt, het veel gemakkelijk is om SOMPRODUCT te gebruiken.

Notities: 

  • De kolommen of rijen (matrices) moeten dezelfde lengte hebben.

  • Als een cel tekst in plaats van een getal bevat, wordt de cel als nul beschouwd.

Voorbeeld

Als u experimenteren met SOMPRODUCT en matrices wilt, volgt een werkmap Excel Online met andere gegevens dan die in dit artikel worden gebruikt.

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van het nieuwe Excel-werkblad. Resultaten van formules worden weergegeven door ze te selecteren en op F2 en vervolgens op Enter te drukken. Als u wilt, kunt u de kolombreedte wijzigen om alle gegevens te zien.

A

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Formule

Resultaat

'=SOMPRODUCT(A2:B4;D2:E4)

=SOMPRODUCT(A2:B4;D2:E4)

Deze formule vermenigvuldigt alle elementen van de twee matrices (A2:B4 en D2:E4) en telt vervolgens de producten op, dat wil zeggen 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

Voor een uitgebreidere ervaring, kunt u ook deze werkmap openen in Excel. Klikt u op het Excel-pictogram in de rechterbenedenhoek van de werkmap Excel-pictogram in Excel Web App , sla het bestand op een handige locatie op uw computer en deze vervolgens openen.

Naar boven

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×