Office
Aanmelden

SOMPRODUCT, functie

In dit artikel worden de syntaxis van de formule en het gebruik van de functie SOMPRODUCT in Microsoft Excel beschreven.

Beschrijving

Vermenigvuldigt corresponderende elementen in de opgegeven matrices en geeft als resultaat de som van het product daarvan.

Syntaxis

SOMPRODUCT(matrix1;[matrix2];[matrix3];...)

De syntaxis van de functie SOMPRODUCT heeft de volgende argumenten:

  • matrix1     Vereist. Het eerste matrixargument waarvan u de elementen wilt vermenigvuldigen en vervolgens wilt optellen.

  • matrix2; matrix3, ...     Optioneel. Matrixargumenten 2 tot en met 255 waarvan u de elementen wilt vermenigvuldigen en vervolgens wilt optellen.

Opmerkingen

  • De opgegeven matrices moeten dezelfde dimensie hebben. Als dat niet het geval is, geeft SOMPRODUCT de foutwaarde #WAARDE! als resultaat.

  • Met SOMPRODUCT worden niet-numerieke matrixgegevens als nullen beschouwd.

Voorbeeld

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Om resultaten van formules weer te geven, selecteert u deze, drukt u op F2 en drukt u vervolgens op Enter. Indien nodig kunt u de kolombreedten aanpassen als u alle gegevens wilt zien.

Matrix 1

Matrix 2

3

4

2

7

8

6

6

7

1

9

5

3

Formule

Beschrijving

Resultaat

=SOMPRODUCT(A2:B4; D2:E4)

Vermenigvuldigt alle elementen van de twee matrices en telt vervolgens de producten op, dat wil zeggen 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

156

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×