Formules en functies

Functie SOM

SOM, functie

Met de functie som worden waarden opgeteld. U kunt afzonderlijke waarden, celverwijzingen, celbereiken of een combinatie van deze drie optellen.

Bijvoorbeeld:

  • =SOM(A2:A10) Hiermee worden de waarden in de cellen A2:10 opgeteld.

  • =SOM(A2:A10;C2:C10) Hiermee worden de waarden in de cellen A2:10 opgeteld en ook cellen C2: C10.

Uw browser biedt geen ondersteuning voor video. Installeer Microsoft Silverlight, Adobe Flash Player of Internet Explorer 9.

SOM(getal1;[getal2];...)

Naam argument

Beschrijving

getal1   

Vereist

Het eerste getal dat u wilt optellen. Het getal kan een cijfer zijn zoals 4, een celverwijzing zoals B6 of een celbereik zoals B2:B8.

getal2-255   

Optioneel

Dit is het tweede getal dat u wilt optellen. U kunt op deze manier maximaal 255 getallen opgeven.

In deze sectie worden enkele aanbevolen procedures behandeld voor het werken met de functie SOM. Veel van deze procedures gelden ook voor andere functies.

De methode =1+2 of =A+B. Hoewel =1+2+3 of =A1+B1+C2 in veel gevallen het juiste resultaat zal opleveren, zijn deze methoden om verschillende redenen foutgevoelig:

  1. Typfouten. Stel dat u meer en/of langere waarden moet invoeren zoals deze:

    • =14598,93+65437,90+78496,23

    Vervolgens moet u controleren of de invoer juist is. Het is veel gemakkelijker om deze waarden in afzonderlijke cellen te zetten en vervolgens SOM te gebruiken. Bovendien kunt u de waarden opmaken als ze in cellen staan, zodat ze veel beter leesbaar zijn dan in een formule.

    Gebruik de functie SOM in plaats van letterlijke waarden op te nemen in formules.  Formule in cel D5 is =SOM(D2:D4)
  2. De fout #WAARDE! omdat er wordt verwezen naar tekst in plaats van getallen

    Stel dat u deze formule gebruikt:

    • =A1+B1+C1 of =A1+A2+A3

    Voorbeeld van een slechte formule.  Formule in cel D2 is =A2+B2+C2

    De formule kan breken als er niet-numerieke waarden (tekst) in de cellen staan waarnaar wordt verwezen, met de fout #WAARDE! als gevolg. Met de functie SOM worden tekstwaarden gewoon genegeerd en krijgt u de som van alleen de numerieke waarden.

    Juiste samenstelling van formule.  In plaats van =A2+B2+C2, is de formule van cel D2 =SOM(A2:C2)
  3. De fout #VERW! door het verwijderen van rijen of kolommen

    #VERW! fout veroorzaakt doordat er een kolom is verwijderd.  Formule is gewijzigd in =A2+#VERW!+B2

    Als u een rij of kolom verwijdert, wordt de formule niet automatisch bijgewerkt, met als gevolg dat de fout #VERW! wordt geretourneerd, waarbij een functie SOM automatisch wordt bijgewerkt.

    In de functie SOM wordt automatisch rekening gehouden met ingevoegde of verwijderde rijen en kolommen
  4. Verwijzingen in formules worden niet bijgewerkt als u rijen of kolommen invoegt

    Formules met =A+B+C worden niet bijgewerkt als u rijen toevoegt

    Als u een rij of kolom invoegt, wordt de formule niet automatisch aangepast. Dit gebeurt wel als u de functie SOM gebruikt (maar alleen als u zich binnen het bereik bevindt waarnaar wordt verwezen in de formule). Dit is vooral belangrijk als u verwacht dat de formule wordt bijgewerkt en dit niet het geval is. De kans bestaat dan namelijk dat u zonder dat u het weet met onvolledige resultaten werkt.

    In het voorbeeld ziet u een formule met SOM die automatisch wordt uitgebreid van =SOM(A2:C2) naar =SOM(A2:D2) als er een kolom wordt ingevoegd
  5. De functie SOM gebruiken met afzonderlijke celverwijzingen of bereiken

    Stel dat u deze formule gebruikt:

    • =SOM(A1;A2;A3;B1;B2;B3)

    De kans op fouten is dan om dezelfde redenen even groot wanneer u rijen invoegt of verwijdert in het bereik waarnaar wordt verwezen. Het is veel beter om afzonderlijke bereiken te gebruiken, zoals:

    • =SOM(A1:A3;B1:B3)

    Deze worden namelijk bijgewerkt als u rijen toevoegt of verwijdert.

  1. Ik wil alleen getallen optellen/aftrekken/vermenigvuldigen/delen Bekijk deze videoreeks over het uitvoeren van basisberekeningen in Excel of gebruik van Excel als rekenmachine.

  2. Hoe kan ik meer/minder decimalen weergeven? U kunt de getalnotatie wijzigen. Selecteer de cel of het celbereik en gebruik Ctrl+1 om het dialoogvenster Celeigenschappen weer te geven. Klik op het tabblad Getal en selecteer de gewenste notatie. Geef het gewenste aantal decimalen op.

  3. Hoe kan ik tijd optellen of aftrekken? U kunt tijden op verschillende manieren toevoegen en aftrekken. Als u bijvoorbeeld het verschil wilt uitrekenen tussen 8:00 AM - 12:00 PM voor loonadministratiedoeleinden, gebruikt u: = ("12:00 PM"-"8:00 AM")*24, waarbij de eindtijd minus de starttijd wordt gebruikt. Omdat tijden in Excel als dagdeel worden berekend, moet u de waarde vermenigvuldigen met 24 om het totaal aantal uren als resultaat weer te geven. In het eerste voorbeeld gebruiken we =((B2-A2)+(D2-C2))*24 om de som van het aantal uren van het begin tot het einde als resultaat weer te geven, minus de lunchpauzw (8,5 uur in totaal).

    Als u alleen uren en minuten wilt optellen en op die manier wilt weergeven, hoeft u niet met 24 te vermenigvuldigen. In het tweede voorbeeld gebruiken we daarom =SOM(A6:C6) omdat we alleen het totaal aantal uren en minuten willen voor toegewezen taken (5:36, ofwel 5 uren, 36 minuten).

    Tijden berekenen

    Zie voor meer informatie: Tijden optellen of aftrekken.

  4. Hoe kan ik het verschil tussen datums weergeven? U kunt net als bij tijden datums optellen en aftrekken. Hier volgt een zeer gangbaar voorbeeld van het tellen van het aantal dagen tussen twee datums. De functie is zeer eenvoudig: =B2-A2. Het belangrijkste voor het werken met datums en tijden is dat u begint met de einddatum/eindtijd en vervolgens de begindatum/begintijd hiervan aftrekt.

    Verschillen tussen datums berekenen

    Zie het volgende artikel voor meer informatie over het werken met datums: Het aantal dagen tussen twee datums berekenen.

  5. Hoe ik alleen zichtbare cellen optellen? Soms wanneer u handmatig rijen verbergt of AutoFilter gebruikt om alleen bepaalde gegevens weer te geven, wilt u ook alleen de zichtbare cellen optellen. U kunt daarvoor de functie SUBTOTAAL gebruiken. Als u een rij met totalen in een Excel-tabel gebruikt, wordt een functie die u in de vervolgkeuzelijst Totalen selecteert automatisch ingevoerd als een subtotaal. Zie meer informatie over het optellen van gegevens in een Excel-tabel.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Meer informatie over SOM

Met de functie SOM.ALS worden alleen de waarden opgeteld die voldoen aan één criterium

Met de functie SOMMEN.ALS worden alleen de waarden opgeteld die voldoen aan meerdere criteria

Met de functie AANTAL.ALS worden alleen de waarden opgeteld die voldoen aan één criterium

Met de functie AANTALLEN.ALS worden alleen de waarden opgeteld die voldoen aan meerdere criteria

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten in formules zoeken en verbeteren

Veelvoorkomende problemen met formules en hoe u ze kunt oplossen

Wiskundige en trigonometrische functies

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Opmerking:  Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor je is. Wil je ons laten weten of deze informatie nuttig is? Hier is het Engelstalige artikel ter referentie.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×