OF, functie

Gebruik de functie OF, een van de logische functies, om te bepalen of een van de voorwaarden in een test WAAR zijn.

Voorbeeld

Voorbeelden van het gebruik van de functie OF.

De functie OF resulteert in WAAR als het resultaat van een van de argumenten WAAR is en resulteert in ONWAAR als het resultaat van alle argumenten ONWAAR is.

De functie OF wordt vaak gebruikt om andere functies die logische tests uitvoeren uit te breiden. Met de functie ALS wordt bijvoorbeeld een logische test uitgevoerd en een bepaalde waarde geretourneerd als het resultaat van de test WAAR is en een andere waarde als het resultaat van de test ONWAAR is. Als u de functie OF gebruikt als het argument logische-test van de functie ALS, kunt u in plaats van één voorwaarde verschillende voorwaarden testen.

Syntaxis

OF(logisch1; [logisch2]; ...)

De syntaxis van de functie OF heeft de volgende argumenten:

Argument

Beschrijving

logisch1

Vereist. De eerste voorwaarde die u wilt testen en waarvan het resultaat WAAR of ONWAAR kan zijn.

Logisch2, ...

Optioneel. Maximaal 255 extra voorwaarden die u wilt testen en waarvan het resultaat WAAR of ONWAAR kan zijn.

Opmerkingen

  • De argumenten moeten als resultaat logische waarden geven, zoals WAAR of ONWAAR, of matrices of verwijzingen die logische waarden bevatten.

  • Als een matrix- of verwijzingsargument tekst of lege cellen bevat, worden deze waarden genegeerd.

  • Als het opgegeven bereik geen logische waarden bevat, geeft OF de fout #WAARDE! als resultaat.

  • U kunt een OF-matrixformule gebruiken om te controleren of een waarde in een matrix voorkomt. Als u een matrixformule wilt invoeren, drukt u op Ctrl+Shift+Enter.

Voorbeelden

Hier volgen enkele algemene voorbeelden van het gebruik van OF op zichzelf en in combinatie met ALS.

Voorbeelden van het gebruik van de functie OF met de functie ALS.

Formule

Beschrijving

= OF(A2>1;A2<100)

Resulteert in WAAR als A2 groter is dan 1 OF kleiner is dan 100. Anders wordt ONWAAR weergegeven.

=ALS(OF(A2>1;A2<100);A3;"De waarde ligt buiten het bereik.")

Geeft de waarde in cel A3 weer als deze groter is dan 1 OF kleiner is dan 100. Anders wordt het bericht 'De waarde ligt buiten het bereik.' weergegeven.

=ALS(OF(A2<0;A2>50);A2;"De waarde ligt buiten het bereik.")

Geeft de waarde in cel A2 weer als deze kleiner is dan 0 OF groter is dan 50. Anders wordt het bericht 'De waarde ligt buiten het bereik.' weergegeven.

Berekening van verkoopprovisie

Hier volgt een veelvoorkomend scenario waarbij met ALS en OF wordt berekend of verkopers in aanmerking komen voor een provisie.

Voorbeeld van het gebruik van ALS en OF om de verkoopprovisie te berekenen.
  • =ALS(OF(B14>=$B$4;C14>=$B$5);B14*$B$6;0) - ALS de totale verkoop groter is dan of gelijk aan (> =) het verkoopdoel OF het aantal accounts is groter dan of gelijk aan (> =) het accountdoel, vermenigvuldig dan de totale verkoop met het provisiepercentage. Geef in andere gevallen het cijfer 0 als resultaat.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Verwante onderwerpen

Video: geavanceerde ALS-functies
Learn how to use nested functions in a formula (Geneste functies in een formule gebruiken)
ALS, functie
EN, functie
NIET, functie
Overzicht van formules in Excel
Niet-werkende formules voorkomen
Veelvoorkomende fouten in formules corrigeren met foutencontrole
Toetsenbordsneltoetsen in Excel 2016 voor Windows
Sneltoetsen in Excel 2016 voor Mac
Logische functies (overzicht)
Excel-functies (alfabetisch)
Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×