Office
Aanmelden

NIET, functie

Gebruik de functie NIET, een van de logische functies, als u zeker wilt zijn dat een waarde niet gelijk is aan een andere.

Voorbeeld

Voorbeelden van de functie NIET om argumenten om te keren.  BIJVOORBEELD =NIET(1+1=2)

De functie NIET keert de waarde van het argument om.

De functie NIET wordt vaak gebruikt om andere functies die logische tests uitvoeren uit te breiden. Met de functie ALS wordt bijvoorbeeld een logische test uitgevoerd en een bepaalde waarde geretourneerd als het resultaat van de test WAAR is en een andere waarde als het resultaat van de test ONWAAR is. Als u de functie NIET gebruikt als het argument logische-test van de functie ALS, kunt u in plaats van één voorwaarde verschillende voorwaarden testen.

Syntaxis

NIET(logisch)

De syntaxis van de functie NIET heeft de volgende argumenten:

  • logisch    Vereist. Een waarde of expressie die WAAR of ONWAAR kan zijn.

Opmerkingen

Als logisch ONWAAR is, geeft NIET de waarde WAAR als resultaat. Als logisch WAAR is, geeft NIET de waarde ONWAAR als resultaat.

Voorbeelden

Hier volgen enkele algemene voorbeelden van het gebruik van NIET op zichzelf en in combinatie met ALS, EN en OF.

Voorbeelden van NIET met functies ALS, EN en OF

Formule

Beschrijving

= NIET(A2>100)

A2 is NIET groter dan 100

=ALS(EN(NIET(A2>1),NIET(A2<100)),A2,"De waarde ligt buiten het bereik")

50 is groter is dan 1 (WAAR), EN 50 is kleiner dan 100 (WAAR), dus NIET keert beide argumenten om tot ONWAAR. EN vereist dat beide argumenten WAAR zijn, zodat deze het resultaat retourneert indien ze ONWAAR zijn.

=ALS(OF(NIET(A3<0),NIET(A3>50)),A3,"De waarde ligt buiten het bereik")

100 is niet kleiner dan 0 (ONWAAR) en 100 is groter dan 50 (WAAR), zodat NIET de argumenten omkeert naar WAAR/ONWAAR. OF vereist slechts één argument dat WAAR is, zodat deze het resultaat retourneert als de waarde WAAR is.

Berekening van verkoopprovisie

Hier volgt een veelvoorkomend scenario, waar we met NIET met ALS en EN moeten berekenen of verkopers in aanmerking komen voor een bonus.

Voorbeeld van een berekening van een verkoopbonus met ALS, EN en NIET.  Formule in cel E14 is =ALS(EN(NIET(B14<$B$7),NIET(C14<$B$5)),B14*$B$8,0)
  • =ALS(EN(NIET(B14<$B$7),NIET(C14<$B$5)),B14*$B$8,0)- ALS Totale verkoop NIET kleiner is dan het Verkoopdoel EN Accounts NIET kleiner is dan het Accountdoel, dan moet Totale verkoop worden vermenigvuldigd met het Commissiepercentage of anders 0 retourneren.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Verwante onderwerpen

Video: geavanceerde ALS-functies
Learn how to use nested functions in a formula (Geneste functies in een formule gebruiken)
ALS, functie
EN, functie
OF, functie
Overzicht van formules in Excel
Niet-werkende formules voorkomen
Veelvoorkomende fouten in formules corrigeren met foutencontrole
Toetsenbordsneltoetsen in Excel 2016 voor Windows
Sneltoetsen in Excel 2016 voor Mac
Logische functies (overzicht)
Excel-functies (alfabetisch)
Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×