Macro's maken of uitvoeren

In Word kunt u veelgebruikte taken automatiseren door macro's te maken en uit te voeren. Een macro is een reeks opdrachten en instructies die u als één opdracht groepeert om een bepaalde taak automatisch uit te voeren.

Als u bepaalde taken regelmatig uitvoert, kunt u tijd besparen door de stappen op te nemen in een macro. Hiervoor moet u de macro eerst opnemen. Vervolgens kunt u de macro uitvoeren door te klikken op een knop op de werkbalk Snelle toegang of een combinatie van toetsen in te drukken. U geeft zelf aan hoe u de macro wilt afspelen.

  1. Klik op Beeld > Macro's > Macro opnemen.

    de opdracht macro opnemen

  2. Typ een naam voor de macro.

    het vak macronaam

  3. Als u deze macro wilt gebruiken in nieuwe documenten die u maakt, moet in het vak Macro opslaan in de optie Alle documenten (Normal.dotm) worden weergegeven.

    Vak voor het kiezen van de opslaglocatie van een macro

  4. Als u de macro wilt uitvoeren door op een knop te klikken, selecteert u Knop.

    selecteren om de macro toe te wijzen aan een knop

  5. Klik op de nieuwe macro (deze heeft een naam met de notatie Normal.NewMacros.<macronaam>) en klik op Toevoegen.

    De macro en de knop Toevoegen

  6. Klik op Wijzigen.

    De knop Wijzigen in het vak De werkbalk Snelle toegang aanpassen

  7. Kies een knopafbeelding, typ de gewenste naam en klik tweemaal op OK.

    Knopopties in het vak Knop wijzigen

  8. Nu kunt u de stappen gaan opnemen. Klik op de gewenste opdrachten of druk de toetsen in voor elke taak in de taak. De muisklikken en toetsaanslagen worden ongewijzigd opgeslagen door Word.

    Opmerking: Gebruik het toetsenbord om tekst te selecteren tijdens het opnemen van de macro. Selecties met de muis worden namelijk niet opgenomen.

  9. Als u de opname wilt stoppen, klikt u op Beeld > Macro's > Opname stoppen.

    de opdracht opname stoppen

De knop voor de macro wordt weergegeven op de werkbalk Snelle toegang.

De knop Macro op de werkbalk Snelle toegang

Klik op de knop om de macro uit te voeren.

  1. Klik op Beeld > Macro's > Macro opnemen.

    de opdracht macro opnemen

  2. Typ een naam voor de macro.

    het vak macronaam

  3. Als u deze macro wilt gebruiken in nieuwe documenten die u maakt, moet in het vak Macro opslaan in de optie Alle documenten (Normal.dotm) worden weergegeven.

    Vak voor het kiezen van de opslaglocatie van een macro

  4. Als u de macro wilt uitvoeren door op een sneltoets te drukken, selecteert u Toetsenbord.

    selecteren om de macro toe te wijzen aan een sneltoets

  5. Druk in het vak Druk op nieuwe sneltoets op de gewenste combinatie van toetsen.

  6. Kijk of de toetsencombinatie misschien al in gebruik is. Als dat het geval is, probeert u een andere combinatie.

  7. Als u deze sneltoets wilt gebruiken in nieuwe documenten die u maakt, moet in het vak Wijzigingen opslaan in de optie Normal.dotm worden weergegeven.

  8. Klik op Toewijzen.

  9. Nu kunt u de stappen gaan opnemen. Klik op de gewenste opdrachten of druk de toetsen in voor elke taak in de taak. De muisklikken en toetsaanslagen worden ongewijzigd opgeslagen door Word.

    Opmerking: Gebruik het toetsenbord om tekst te selecteren tijdens het opnemen van de macro. Selecties met de muis worden namelijk niet opgenomen.

  10. Als u de opname wilt stoppen, klikt u op Beeld > Macro's > Opname stoppen.

    de opdracht opname stoppen

U kunt de macro uitvoeren door op de toegewezen toetsen te drukken.

Wanneer u een macro wilt uitvoeren, klikt u op de knop op de werkbalk Snelle toegang, drukt u op de sneltoets op het toetsenbord of gebruikt u de lijst Macro's.

  1. Klik op Beeld > Macro's > Macro's weergeven.

    De opdracht Macro's weergeven

  2. Klik in de lijst onder Macronaam op de naam van de macro die u wilt uitvoeren.

  3. Klik op Uitvoeren.

Als u een macro in een document beschikbaar wilt maken voor alle nieuwe documenten, voegt u de macro toe aan de sjabloon Normal.dotm.

  1. Open het document met de macro.

  2. Klik op Beeld > Macro's > Macro's weergeven.

    De opdracht Macro's weergeven

  3. Klik op Beheer.

    De knop Beheer in het vak Macro's weergeven

  4. Klik op de macro die u wilt toevoegen aan de sjabloon Normal.dotm en klik op Kopiëren.

  1. Klik op Bestand > Opties > Lint aanpassen.

  2. Klik onder Kies opdrachten uit op Macro's.

  3. Klik op de gewenste macro.

  4. Klik onder Het lint aanpassen op het tabblad en de aangepaste groep waaraan u de macro wilt toevoegen.

Als er geen aangepaste groep beschikbaar is, klikt u op Nieuwe groep. Klik vervolgens op Naam wijzigen en typ een naam voor de aangepaste groep.

  1. Klik op Toevoegen.

  2. Klik op Naam wijzigen om een afbeelding te kiezen voor de macro en typ de gewenste naam.

  3. Klik tweemaal op OK.

  1. Klik op het tabblad Ontwikkelaars in de groep Programmacode op Macro's.

  2. Typ in het vak Macronaam een naam voor de macro.

    Opmerking: Als u een nieuwe macro dezelfde naam geeft als een ingebouwde macro in Word, wordt de ingebouwde macro vervangen door de nieuwe macro. Als u een lijst met ingebouwde macro's wilt weergeven, klikt u op Word-opdrachten in de lijst Macro's in.

  3. Klik in de lijst Macro's in op de sjabloon of het document waarin u de macro wilt opslaan.

    Klik op Normal.dotm als u de macro in alle documenten wilt kunnen gebruiken.

  4. Klik op Maken om Visual Basic Editor te openen.

Als u Visual Basic Editor hebt geopend, wilt u mogelijk meer informatie over het werken met Visual Basic for Applications. Klik voor meer informatie op Microsoft Visual Basic Help in het menu Help menu of druk op F1.

U kunt een reeks acties opnemen of u kunt een geheel nieuwe macro schrijven door VBA-code (Visual Basic for Applications) in te voeren in de Visual Basic Editor.

Opmerking: Als u in Office Word 2007 met macro's wilt werken, geeft u het tabblad Ontwikkelaars weer.

  1. Klik op de Microsoft Office-knop afbeelding office-knop en klik vervolgens op Opties voor Word.

  2. Klik op Populair.

  3. Schakel onder De belangrijkste opties voor het werken met Word het selectievakje Tabblad Ontwikkelaars op het lint weergeven in.

    Opmerking: Het lint maakt deel uit van de Microsoft Office Fluent-gebruikersinterface.

  1. Ga naar het tabblad Ontwikkelaars en klik in de groep Programmacode op Macro opnemen.

    Codegroep op het tabblad Ontwikkelaars
  2. Typ in het vak Macronaam een naam voor de macro.

    Opmerking: Als u een nieuwe macro dezelfde naam geeft als een ingebouwde macro in Office Word 2007, wordt de ingebouwde macro vervangen door de nieuwe macro. Als u een lijst met ingebouwde macro's wilt weergeven, klikt u op het tabblad Ontwikkelaars in de groep Programmacode op Macro's. Klik op Word-opdrachten in de lijst Macro's in.

  3. Klik in het vak Macro opslaan in op de sjabloon of het document waarin u de macro wilt opslaan.

    Belangrijk: Klik op Normal.dotm als u de macro voor alle documenten wilt kunnen gebruiken.

  4. Typ een beschrijving van de macro in het vak Beschrijving.

  5. Ga op een van de volgende manieren te werk:

    • Beginnen met opnemen    Als u een macro wilt opnemen zonder dat u deze eerst aan een knop op de werkbalk Snelle toegang of aan een sneltoets toewijst, klikt u op OK.

    • Een knop maken    Als u de macro aan een knop op de werkbalk Snelle toegang wilt toewijzen, gaat u als volgt te werk:

      1. Klik op Knop.

      2. Selecteer onder Werkbalk Snelle toegang aanpassen het document (of alle documenten) waarvoor u de macro aan de werkbalk Snelle toegang wilt toewijzen.

        Belangrijk: Klik op Normal.dotm als u de macro voor alle documenten wilt kunnen gebruiken.

      3. Klik in het dialoogvenster Kies opdrachten uit op de macro die u wilt opnemen en klik vervolgens op Toevoegen.

      4. Klik op Wijzigen om de knop aan te passen.

      5. Klik onder Symbool op het symbool dat u voor de knop wilt gebruiken.

      6. Typ in het vak Weergavenaam de macronaam die u wilt weergeven.

      7. Klik tweemaal op OK om te beginnen met het opnemen van de macro.

        Het symbool dat u kiest, wordt weergegeven op de werkbalk Snelle toegang. De naam die u typt, wordt weergegeven wanneer u het symbool aanwijst.

    • Een sneltoets toewijzen    Als u de macro aan een sneltoets wilt toewijzen, gaat u als volgt te werk:

      1. Klik op Toetsenbord.

      2. Klik in het vak Opdrachten op de macro die u wilt opnemen.

      3. Typ de gewenste toetsencombinatie in het vak Druk op nieuwe sneltoets en klik vervolgens op Toewijzen.

      4. Klik op Sluiten om te beginnen met het opnemen van de macro.

  6. Voer de acties uit die u in de macro wilt opnemen.

    Opmerking: Als u een macro opneemt, kunt u de muis gebruiken om op opdrachten en opties te klikken, maar niet om tekst te selecteren. U moet het toetsenbord gebruiken om tekst te selecteren. Zie Tekst selecteren voor meer informatie over het selecteren van tekst met het toetsenbord.

  7. Als u het opnemen van uw acties wilt beëindigen, klikt u op Opname stoppen in de groep Programmacode.

De sneltoets voor een macro wijzigen

  1. Klik op de Microsoft Office-knop afbeelding office-knop en klik vervolgens op Opties voor Word.

  2. Klik op Aanpassen.

  3. Klik naast Sneltoetsen op Aanpassen.

  4. Klik in de lijst Categorieën op Macro's.

  5. Klik in het vak Macro's op de macro die u wilt wijzigen.

  6. Typ in het vak Druk op nieuwe sneltoets de toetsencombinatie die u wilt gebruiken.

  7. Kijk in het vak Gebruikte toetsen om te controleren dat u geen toetsencombinatie toewijst die u al gebruikt voor een andere taak.

  8. Klik in de lijst Wijzigingen opslaan in op de optie die overeenkomt met waar u de macro wilt uitvoeren.

    Belangrijk: Klik op Normal.dotm als u de macro voor alle documenten wilt kunnen gebruiken.

  9. Klik op Sluiten.

  1. Ga naar het tabblad Ontwikkelaars en klik in de groep Programmacode op Macro's.

    Codegroep op het tabblad Ontwikkelaars

  2. Klik in de lijst onder Macronaam op de macro die u wilt uitvoeren.

  3. Klik op Uitvoeren.

  1. Klik op het tabblad Ontwikkelaars in de groep Programmacode op Macro's.

    Codegroep op het tabblad Ontwikkelaars

  2. Typ in het vak Macronaam een naam voor de macro.

    Opmerking: Als u een nieuwe macro dezelfde naam geeft als een ingebouwde macro in Office Word 2007, wordt de ingebouwde macro vervangen door de nieuwe macro. Als u een lijst met ingebouwde macro's wilt weergeven, klikt u op Word-opdrachten in de lijst Macro's in.

  3. Klik in de lijst Macro's in op de sjabloon of het document waarin u de macro wilt opslaan.

    Klik op Normal.dotm als u de macro voor alle documenten wilt kunnen gebruiken.

  4. Klik op Maken om Visual Basic Editor te openen.

Als u Visual Basic Editor hebt geopend, wilt u mogelijk meer informatie over het werken met Visual Basic for Applications. Klik voor meer informatie op Microsoft Visual Basic Help in het menu Help menu of druk op F1.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×