KIEZEN, functie

In dit artikel worden de syntaxis en het gebruik van de functie KIEZEN in Microsoft Excel beschreven.

Beschrijving

Gebruikt index_getal om een waarde uit de lijst met waarde-argumenten te leveren. Met KIEZEN kunt u één van de maximaal 254 opgegeven waarden op basis van het indexnummer selecteren. Als waarde1 tot waarde7 bijvoorbeeld de dagen van de week zijn, geeft KIEZEN als resultaat de dag van de week die hoort bij het getal tussen 1 en 7 dat u opgeeft voor index_getal.

Syntaxis

KIEZEN(index_getal;waarde1;[waarde2];...)

De syntaxis van de functie KIEZEN heeft de volgende argumenten:

  • index_getal    Vereist. Geeft aan welk waardeargument is geselecteerd. index_getal moet een getal zijn tussen 1 en 254, of een formule of verwijzing naar een cel die een getal tussen 1 en 254 bevat.

    • Als index_getal 1 is, geeft KIEZEN waarde1. Als index_getal 2 is, geeft KIEZEN waarde2; enz.

    • Als index_getal kleiner is dan 1 of groter dan het getal van de laatste waarde in de lijst, geeft KIEZEN de foutwaarde #WAARDE! als resultaat.

    • Als index_getal een breuk is, wordt deze eerst afgekapt tot het laagste gehele getal.

  • waarde1, waarde2,...     waarde 1 is vereist, de volgende waarden zijn optioneel. Maximaal 254 waardeargumenten waaruit de functie KIEZEN een waarde of een te verrichten bewerking kiest op basis van index_getal. Geldige argumenten zijn getallen, celverwijzingen, gedefinieerde namen, formules, functies of tekst.

Opmerkingen

  • Als index_getal een matrix is, wordt elke waarde geëvalueerd als KIEZEN wordt geëvalueerd.

  • De waarde-argumenten van KIEZEN kunnen zowel verwijzingen naar een bereik zijn als afzonderlijke waarden.

    Zo is de formule:

=SOM(KIEZEN(2;A1:A10;B1:B10;C1:C10))

gelijk aan:

=SOM(B1:B10)

die vervolgens resulteert in de waarde die is gebaseerd op de waarden in het bereik B1:B10.

De functie KIEZEN wordt als eerste geëvalueerd en geeft de verwijzing B1:B10 als resultaat. Vervolgens wordt de functie SOM geëvalueerd met als argument het resultaat van de functie KIEZEN, namelijk B1:B10.

Voorbeelden

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Om resultaten van formules weer te geven, selecteert u deze, drukt u op F2 en drukt u vervolgens op Enter. Indien nodig kunt u de kolombreedten aanpassen als u alle gegevens wilt zien.

Gegevens

 

1ste

Spijkers

2de

Schroeven

3de

Moeren

Gereed

Bouten

Formule

Beschrijving

Resultaat

=KIEZEN(2;A2;A3;A4;A5)

De waarde van het tweede argument in de lijst (waarde van cel A3).

2de

=KIEZEN(4;B2;B3;B4;B5)

De waarde van het vierde argument in de lijst (waarde van cel B5).

Bouten

=KIEZEN(3;"Wereld";115;"wijd";8)

De waarde van het derde argument in de lijst.

wijd

Voorbeeld 2

Gegevens

23

45

12

10

Formule

Beschrijving (resultaat)

Resultaat

=SOM(A2:KIEZEN(2;A3;A4;A5))

Berekent het totaal van de reeks A2:A4. Met de functie KIEZEN wordt A4 geretourneerd als tweede deel van het bereik voor de functie SOM.

80

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×