Hyperlinks wijzigen en repareren

Belangrijk : Dit artikel is automatisch vertaald, bekijk de disclaimer. De Engelse versie van dit artikel vindt u hier voor referentiedoeleinden.

U kunt het uiterlijk en de bestemming van een hyperlink wijzigen. Wanneer een hyperlink niet werkt, moet u het probleem vaststellen en het adres voor de bestemming van de koppeling repareren.

Opmerking : Als u de tekst of volgorde van hyperlinks op een navigatiebalk wilt wijzigen, klikt u op de navigatiebalk en vervolgens op Eigenschappen van de navigatiebalk in het menu Opmaak.

Wat wilt u doen?

Het uiterlijk van een hyperlink wijzigen

De bestemming van een hyperlink wijzigen

Een hyperlink wijzigen in normale tekst

Hyperlinks testen voordat u ze naar uw website publiceert

Hyperlinks repareren die niet werken

Het uiterlijk van een hyperlink wijzigen

De weergavetekst van een hyperlink wijzigen

  1. Klik op de hyperlinktekst die u wilt wijzigen.

  2. Typ de nieuwe tekst en verwijder de oorspronkelijke tekens afzonderlijk door op Delete of Backspace te drukken.

De onderstreping van hyperlinktekst verwijderen

  1. Selecteer de hyperlinktekst.

    Als u alleen de onderstreepte tekens wilt selecteren, klikt u na het laatste onderstreepte teken en sleept u de aanwijzer naar het eerste teken.

  2. Op de werkbalk Standaard klikt u op Onderstrepen Knopafbeelding .

De afbeelding wijzigen die u voor een hyperlink gebruikt

  1. Selecteer de afbeelding die een koppeling bevat.

  2. Klik met de rechtermuisknop op de afbeelding, wijs Afbeelding wijzigen aan en klik op de locatie van de nieuwe afbeelding die u wilt gebruiken. Klik bijvoorbeeld op Uit bestand als u een afbeelding wilt gebruiken die op uw computer is opgeslagen.

  3. Selecteer de nieuwe afbeelding die u wilt gebruiken.

Naar boven

De bestemming van een hyperlink wijzigen

  1. Klik met de rechtermuisknop op de hyperlink die u wilt wijzigen, en klik vervolgens op Hyperlink bewerken.

    Opmerking : Als het snelmenu alleen opdrachten voor spelling bevat, klikt u op Alles negeren en klikt u nogmaals met de rechtermuisknop op de hyperlink.

  2. In het dialoogvenster Hyperlink bewerken voert u de nieuwe bestemming van de hyperlink in het vakje Adres in.

Naar boven

Een hyperlink wijzigen in normale tekst

  • Met de rechtermuisknop op de hyperlink en klik vervolgens op Hyperlink verwijderen.

Naar boven

Hyperlinks testen voordat u ze naar uw website publiceert

U kunt een hyperlink testen om ervoor te zorgen dat deze goed werkt voordat u deze naar uw website publiceert. Voer een van de volgende handelingen uit:

  • Houd Ctrl ingedrukt terwijl u op de tekst of afbeelding van de hyperlink klikt, om een hyperlink vanuit uw webpublicatie te volgen alvorens u deze naar het web publiceert.

  • In het menu Bestand klikt u op Voorbeeld van webpagina weergeven en vervolgens op een hyperlink in het voorbeeld van de website om naar de bestemming te gaan.

    Opmerking : U kunt in het voorbeeld van de website geen koppelingen naar externe bestanden testen.

  • Publiceer uw website naar een lokale server om de hyperlinks te testen.

    1. Klik in het menu Bestand op Publiceren op het web.

    2. Als u een vak met informatie over een service voor webhosting ziet, klikt u op OK.

    3. Zoek in het dialoogvenster Publiceren op het web naar de lokale server waarop u de website wilt testen en klik op Opslaan.

Naar boven

Hyperlinks repareren die niet werken

Hieronder volgen enkele algemene reparaties voor hyperlinks die niet werken.

Hyperlinks repareren die naar andere pagina's op uw Publisher-website gaan

  • Wanneer één koppeling niet werkt    Wanneer een pagina is verplaatst, werkt Microsoft Office Publisher hyperlinks automatisch bij met de juiste pagina. Als een hyperlink echter niet werkt, controleert u dat de koppeling niet naar een bladwijzer verwijst die is verplaatst of verwijderd. U repareert de hyperlink als volgt:

    1. Klik met de rechtermuisknop op de hyperlink en klik vervolgens op Hyperlink bewerken.

    2. In het dialoogvenster Hyperlink bewerken klikt u op Plaats in dit document en vervolgens op de pagina en bladwijzer waarnaar u wilt verwijzen.

      Als de bladwijzer is verwijderd, klikt u op Annuleren. Ga naar de pagina waarnaar u wilt verwijzen en voeg een bladwijzer in. Vervolgens gaat u terug naar de hyperlink die u wilt repareren en bewerkt u die hyperlink.

  • Wanneer vele hyperlinks niet werken    Als meerdere hyperlinks niet werken, is een aantal van uw bestanden misschien niet gepubliceerd. Wanneer u een website publiceert, uploadt Publisher standaard een submap met de naam index_files naar de opgegeven bestandslocatie. Deze map bevat alle bestanden die aan uw website zijn gekoppeld, behalve de eerste pagina van de publicatie (de introductiepagina van de website), die naar de submap met bijbehorende pagina's verwijst. Als de map niet beschikbaar is, werken hyperlinks naar andere pagina's in uw publicatie niet. Als u een programma van een derde partij gebruikt om uw website te uploaden, wordt de submap misschien niet automatisch naar de webserver geladen. In dat geval moet u de submap handmatig uploaden.

    Opmerking : U kunt de instellingen zo wijzigen dat Publisher de volgende keer dat u uw website publiceert, niet de map index_files maakt en alle bestanden voor uw website naar één map publiceert. Klik in uw webpublicatie in het menu Extra op Opties, klik op het tabblad Web en schakel het selectievakje Ondersteunende bestanden in een map indelen uit.

Hyperlinks die naar andere websites gaan

Als een hyperlink naar een andere website niet werkt, gaat u naar de bestemming waarnaar u wilt verwijzen. Als het bestemmingsbestand op het internet staat, zoekt u ernaar in uw webbrowser. Als het bestand op uw vaste schijf of een netwerk staat, zoekt u ernaar in Microsoft Windows Verkenner. Vervolgens controleert u in uw Publisher-webpublicatie het volgende:

  • De bestemming is misschien verplaatst of bestaat niet meer    Klik met de rechtermuisknop op de hyperlink en klik vervolgens op Hyperlink bewerken. In het dialoogvenster Hyperlink bewerken verifieert u dat het pad naar de bestemmingspagina goed is.

  • De tekst waarvan u denkt dat het een hyperlink is, ziet er alleen maar uit als een hyperlink    Selecteer de tekst en klik op Hyperlink invoegen Knopafbeelding op de werkbalk Standaard om ervoor te zorgen dat de tekst een hyperlink is.

    Tip : Zorg dat u één hyperlink selecteert voordat u op Hyperlink invoegen klikt. Als u meer dan een hyperlink of een hyperlink op een navigatiebalk selecteert, is Hyperlink invoegen mogelijk niet beschikbaar.

  • U hebt misschien geen toegang tot de bestemming    Als de bestemming op het internet staat, moet u zorgen dat u een verbinding met het internet hebt. Als de bestemming op een netwerk staat, neemt u contact op met uw netwerkbeheerder om ervoor te zorgen dat u toegang tot het doelbestand hebt.

Hyperlinks repareren waarmee externe bestanden worden geopend

Wanneer u een hyperlink maakt op een webpagina waarmee een extern bestand wordt geopend, zoals een Microsoft Office Word-document, een Microsoft Office Excel-werkblad of een PDF-bestand, moet u rekening houden met het volgende:

Bestandsnamen

Bestandsnamen voor externe bestanden waarnaar u verwijst, kunnen beter geen spaties bevatten en moeten in kleine letters zijn.

Als u naar een bestand koppelt met een spatie in de naam en u kunt de naam niet wijzigen, controleert u of Publisher de spatie in het hyperlinkadres heeft vervangen met %20. Als de bestandsnaam bijvoorbeeld mijn bestand.docx is, moet het hyperlinkadres mijn%20bestand.docx zijn.

Testen

U kunt een koppeling naar een extern bestand niet testen in Webvoorbeeld, maar u kunt een hyperlink wel testen vanuit uw publicatie door Ctrl ingedrukt te houden terwijl u op de gekoppelde tekst of afbeelding klikt. U kunt uw website ook naar een lokale server publiceren om de hyperlinks naar externe bestanden te testen.

Belangrijk : Als u koppelingen naar externe bestanden op een lokale server test, moet u de externe bestanden naar die lokale server kopiëren.

Uploaden

Wanneer u uw website publiceert, moet u het externe bestand handmatig uploaden; Publisher doet dit niet voor u. Het pad wordt bepaald door de plaats van het externe bestand op de webserver, bijvoorbeeld:

  • Als u van de startpagina verwijst naar een bestand dat in dezelfde map op de webserver staat, kan het pad uit alleen de bestandsnaam bestaan (bijvoorbeeld mijnbestand.docx).

  • Als het bestand in een andere map staat dan de introductiepagina, moet de mapnaam worden opgenomen in het pad (bijvoorbeeld index_bestanden/mijnbestand.docx).

U moet dit pad vaststellen en in het dialoogvenster Hyperlink invoegen typen voordat u naar het web publiceert. Selecteer de tekst of afbeelding waarop bezoekers aan uw website moeten klikken om het externe bestand te openen. Klik in het menu Invoegen op Hyperlink. In het dialoogvenster Hyperlink invoegen typt u in het vak Adres het pad naar het externe bestand.

Opmerking : Als u een hyperlinkpad in het vakje Adres invoegt door ernaartoe te navigeren, kunt u het pad wijzigen door alleen de bestandsnaam te typen of de map en bestandsnaam, zoals hierboven genoemd.

Het koppelingspad repareren naar een bestand dat op een schijf staat

Misschien wilt u de bestanden voor uw website op een schijf zetten, zoals een cd of dvd, zodat uw website op een andere computer kan worden weergegeven voordat u de site naar het web publiceert. Als u uw webpublicatiebestanden naar een schijf kopieert, zullen de koppelingen niet werken. In plaats daarvan moet u de website rechtstreeks naar de schijf publiceren. Zo gaat u te werk:

In Windows Vista

  1. Klik in het menu Bestand op Publiceren op het web.

  2. In de adresbalk klikt u op het station voor de schijf waarop u uw website wilt publiceren, zoals D:\mijnwebsite.

    Als u de website wilt toevoegen aan een nieuwe map, klikt u op de werkbalk op Nieuwe map om een nieuwe map te maken, typt u een naam voor de nieuwe map en drukt u op ENTER.

  3. Selecteer in het vak Bestandsnaamindex als de standaardnaam van uw introductiepagina en klik vervolgens op Opslaan.

    Index.htm is de standaardselectie. Als u index selecteert als de naam van uw introductiepagina, kan hiertoe makkelijker toegang worden verkregen en wordt voorkomen dat gebruikers een lijst weergeven met de bestanden waaruit de website bestaat.

In Windows XP

  1. Klik in het menu Bestand op Publiceren op het web.

  2. In de lijst Opslaan in klikt u op het station voor de schijf waarop u uw website wilt publiceren, zoals D:\mijnwebsite.

    Als u de website wilt toevoegen aan een nieuwe map, klikt u met de rechtermuisknop op de plek waar u de nieuwe map wilt toevoegen, selecteert u Nieuw en klikt u op Map om een nieuwe map te maken. Typ vervolgens een naam voor de nieuwe map in het vak Naam en klik op Openen.

  3. Selecteer in het vak Bestandsnaamindex als de standaardnaam van uw introductiepagina en klik vervolgens op Opslaan.

    Index.htm is de standaardselectie. Als u index selecteert als de naam van uw introductiepagina, kan hiertoe makkelijker toegang worden verkregen en wordt voorkomen dat gebruikers een lijst weergeven met de bestanden waaruit de website bestaat.

Een hyperlink repareren die niet wordt weergegeven

Dit kan een van de volgende oorzaken hebben:

  • De hyperlink bevindt zich in een geroteerd tekstvak of geroteerde AutoVorm    Hyperlinks werken niet goed als ze zich bevinden in geroteerde tekstvakken of AutoVormen. Ze werken echter wel in de webpublicatie als u op Ctrl drukt en op de koppeling klikt, en ze zien er goed uit maar werken niet in Webweergave of wanneer u de publicatie naar het web publiceert. U kunt de hyperlinks in uw webpublicatie herstellen door de geroteerde tekstvakken of AutoVormen waarin hyperlinks staan, op hun oorspronkelijke positie terug te zetten.

  • De hyperlink bevindt zich in een tekstvak of AutoVorm met Randillustratie    Hyperlinks werken niet goed in een webpublicatie als ze zich in een tekstvak of AutoVorm met Randillustratie bevinden. U kunt de hyperlinks in uw webpublicatie herstellen door Randillustraties te verwijderen uit de tekstvakken of AutoVormen waarin hyperlinks staan.

Naar boven

Opmerking : Disclaimer voor automatische vertaling: Dit artikel is vertaald door een computersysteem zonder menselijke tussenkomst. Microsoft biedt deze automatische vertalingen aan om niet-Engels sprekende gebruikers te helpen de inhoud over producten, services en technologieën van Microsoft te raadplegen. Omdat het artikel automatisch is vertaald, bevat het mogelijk fouten in grammatica, woordenschat en syntaxis.

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×