Het argument tabelmatrix gebruiken in een zoekfunctie

Opmerking:  We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

Wanneer u een formule met de functies VERT.zoeken of HORIZ.zoeken maakt, kunt u een argument tabelmatrix, dat wil een bereik van cellen, zoals D2:F39 zeggen invoeren. De functie Hiermee wordt gezocht in dat bereik voor de gegevens die u probeert te zoeken.

Het argument tabelmatrix is altijd het tweede argument in de functie VERT.ZOEKEN of HORIZ.ZOEKEN (het eerste argument is de waarde die u zoekt). Zonder het argument tabelmatrix werken deze functies niet.

Uw eerste argument kan een specifieke waarde zijn, bijvoorbeeld '41' of 'smit’, of kan een celverwijzing zijn, bijvoorbeeld F2. Het eerste argument kan er bijvoorbeeld zo uit zien:

=VERT.ZOEKEN(F2,...

Het argument tabelmatrix volgt altijd na de zoekwaarde, zoals:

=VERT.ZOEKEN(F2,B4:D39, ...

Voor het celbereik in het argument tabelmatrix kunt u relatieve of absolute celverwijzingen gebruiken. Als u de formule naar andere cellen wilt kopiëren, moet u absolute celverwijzingen gebruiken (let op de $-tekens), zoals hieronder:

=VERT.ZOEKEN(F2,$B$2:BD$39, ...

Als de cellen in het argument tabelmatrix zich in een ander werkblad van de werkmap bevinden, moet het argument de bladnaam, gevolgd door een uitroepteken bevatten. De syntaxis ziet er dan als volgt uit:

=VERT.ZOEKEN(F2,Blad2!$C$14:E$42, ...

De kolom die de waarden bevat die u zoekt, is het derde argument dat u invoert. Dit wordt de zoekkolom genoemd. Stel dat de waarden die u wilt weergeven, zich in kolom D bevinden, de derde kolom in de tabelmatrix, dan is het laatste argument een 3.

=VERT.ZOEKEN(F2;B4:D39;3)

Hoewel het optioneel is, wordt geadviseerd om een vierde argument te gebruiken, Onwaar of Waar. Gebruik Onwaar als u naar een exacte overeenkomst zoekt.

=VERT.ZOEKEN(F2,B4:D39,3,Onwaar)

Als u Waar gebruikt of het vierde argument leeg laat, resulteert de functie in een benadering van de waarde in het eerste argument. Dus als het eerste argument 'smit' is en u Waar gebruikt, levert de functie VERT.ZOEKEN 'Smit', 'Smits' enzovoort op. Als u echter Onwaar gebruikt, levert de functie alleen 'Smit' op, wat de meeste mensen willen.

En om het gebruik van Waar nog lastiger te maken, kan deze functie het verkeerde resultaat opleveren als de opzoekkolom, de kolom die u hebt opgegeven in het derde argument, niet in oplopende volgorde is gesorteerd (van A tot en met Z of van het laagste tot en met het hoogste getal).

Zie functies van zoek- en verwijzingsfuncties (overzicht)voor meer informatie over de functies VERT.zoeken en HORIZ.zoeken.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×