Getallen of datums op basis van een voorwaarde tellen

Opmerking:  We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

Gebruik de functie aantal.Als om te tellen, getallen of datums die voldoen aan één voorwaarde (zoals gelijk aan, groter is dan, kleiner dan groter is dan of gelijk aan, of kleiner dan of gelijk aan). Als u wilt tellen getallen of datums die binnen een bereik (zoals groter dan 9000 en tegelijk tijd kleiner is dan 22500 vallen), kunt u de functie aantallen.Als . U kunt ook SOMPRODUCT te gebruiken.

Voorbeeld

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

A

B

Verkoper

Factuur

Blaauboer

15.000

Blaauboer

9.000

Beekman

8.000

Beekman

20.000

Blaauboer

5.000

M. Lakowski

22.500

Formule

Beschrijving (resultaat)

=AANTAL.ALS(B2:B7;">9000")

De functie AANTAL.ALS telt het aantal cellen in het bereik B2:B7 dat een getal bevat dat groter is dan 9000 (4).

=AANTAL.ALS(B2:B7;"<=9000")

De functie AANTAL.ALS telt het aantal cellen in het bereik B2:B7 dat een getal bevat dat kleiner is dan 9000 (4).

=AANTALLEN.ALS(B2:B7;">=9000";B2:B7;"<=22500")

De functie AANTALLEN.ALS (beschikbaar in Excel 2007 en hoger) telt het aantal cellen in het bereik B2:B7 dat groter is dan of gelijk is aan 9000 en kleiner is dan of gelijk is aan 22500 (4).

=SOMPRODUCT((B2:B7>=9000)*(B2:B7<=22500))

De functie SOMPRODUCT telt het aantal cellen in het bereik B2:B7 dat een getal bevat dat groter is dan of gelijk is aan 9000 en kleiner is dan of gelijk is aan 22500 (4). Deze functie kunt u gebruiken in Excel 2003 en lager, waarin AANTALLEN.ALS niet beschikbaar is.

Datum

11-3-2011

1-1-2010

31-12-2010

30-6-2010

Formule

Beschrijving (resultaat)

=AANTAL.ALS(B14:B17;">1-3-2010")

Telt het aantal cellen in het bereik B14:B17 met een datum die groter is dan 1-3-2010 (3).

=AANTAL.ALS(B14:B17;"31-12-2010")

Telt het aantal cellen in het bereik B14:B17 dat gelijk is aan 31-12-2010 (1). Het gelijkteken is niet nodig in de criteria en is hier dan ook niet opgegeven. De formule werkt ook als u het gelijkteken wel opgeeft ("=31-12-2010").

=AANTALLEN.ALS(B14:B17;">=1-1-2010";B14:B17;"<=31-12-2010")

Telt het aantallen cellen in het bereik B14:B17 tussen en met inbegrip van 1-1-2010 en 31-12-2010 (3).

=SOMPRODUCT((B14:B17>=DATUMWAARDE("1-1-2010"))*(B14:B17<=DATUMWAARDE("31-12-2010")))

Telt het aantallen cellen in het bereik B14:B17 tussen en met inbegrip van 1-1-2010 en 31-12-2010 (3). Dit voorbeeld dient als vervanging voor de functie AANTALLEN.ALS, die in Excel 2007 werd geïntroduceerd. De functie DATUMWAARDE converteert de datums naar numerieke waarden waarmee de functie SOMPRODUCT kan werken.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×